Community discussions

 
rizwanshahzad
just joined
Topic Author
Posts: 15
Joined: Sat Oct 01, 2011 8:57 pm

Need Help on Balance the speed

Sun Nov 18, 2012 8:27 am

i have a 2 mb connection,share this with 5 clients,need help on speed balance when one person start downloading other browsing is stopped,how can limit the user who start download and others browsing disturbed.
 
rizwanshahzad
just joined
Topic Author
Posts: 15
Joined: Sat Oct 01, 2011 8:57 pm

Re: Need Help on Balance the speed

Mon Nov 19, 2012 2:48 pm

Any senior member here for help me please
 
User avatar
nickshore
Member
Member
Posts: 473
Joined: Thu Mar 03, 2005 4:14 pm
Location: Suffolk, UK.
Contact:

Re: Need Help on Balance the speed

Mon Nov 19, 2012 3:35 pm

Add a simple queue using a PCQ to share the bandwidth fairly.
/queue type
set 6 kind=pcq name=pcq-upload-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=\
    src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
    pcq-src-address6-mask=128 pcq-total-limit=2000
set 7 kind=pcq name=pcq-download-default pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=\
    dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 \
    pcq-src-address6-mask=128 pcq-total-limit=2000

/queue simple add max-limit=384k/2M name="fair share" queue=pcq-upload-default/pcq-download-default
This assumes your uplink is 384k, and uses the latest default pcq queues.

Hope that helps
Nick.
Nick Shore MTCNA MTCWE MTCRE MTCINE MTCTCE
LinITX.com - MultiThread Consultants
Get your MikroTik RBs and Training: http://linitx.com/brand/mikrotik
Official UK MikroTik Distributor
IRC chan: #routerboard on irc.z.je (IPv4 and IPv6)
 
rizwanshahzad
just joined
Topic Author
Posts: 15
Joined: Sat Oct 01, 2011 8:57 pm

Re: Need Help on Balance the speed

Tue Nov 20, 2012 4:07 pm

Thanks sir
 
aymoon22
just joined
Posts: 11
Joined: Sun Jun 17, 2012 1:26 am

Re: Need Help on Balance the speed

Tue Dec 04, 2012 11:56 am

may i ask if that script can work for 10 users or 20 users with line 512k/2048k

Who is online

Users browsing this forum: No registered users and 75 guests