Community discussions

MUM Europe 2020
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

5.22 released!

Fri Nov 23, 2012 2:24 pm

What's new in 5.22 (2012-Nov-23 09:28):

*) userman - fix PayPal "bad HTTP response";
*) kvm - fixed possible ROS guest incomplete package installation;
*) l2tp server - added keepalive-timeout setting;
*) wireless - fixed RADIUS mac-caching;
*) wireless - fixed rare nv2 link stall;
*) metarouter - fixed system occasional lockup for 12s on RB4xx and RB7xx;
*) metarouter - fixed crash when FPU exception was raised in one of powerpc metarouters;
*) quickset - added HomeAP mode;
*) fixed "export compact" in "ip proxy";

http://www.mikrotik.com/download
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: 5.22 released!

Fri Nov 23, 2012 2:57 pm

sergejs
Where I can download "ROS for all Devices" as it was before ?
sorry for my english
 
duvi
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Fri Jun 05, 2009 12:32 pm
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 2:59 pm

sergejs
Where I can download "ROS for all Devices" as it was before ?
http://www.mikrotik.com/download/router ... 22.torrent
 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1065
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 3:00 pm

The link "all stable files" at the download page still points at ROS 5.21. Need to correct the link manually.
-Toni-
Don't crash the ambulance, whatever you do
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 3:06 pm

Link is fixed, thank you very much for the report.
 
nosovk
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jan 25, 2012 11:25 am
Location: Ukraine
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 4:45 pm

RB-433UAH died after update. Netinstall doesnt help :(
Аренда Програмного обеспечения
https://www.CloudZZ.com
Микротики на Украине оптом
mikrotik.kharkov.ua
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 4:51 pm

Please attach Null Modem cable to COM port of your router.
Get the output from console and send it to support@mikrotik.com
 
nosovk
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Wed Jan 25, 2012 11:25 am
Location: Ukraine
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 4:53 pm

Netinstall stops on "sending offer step"
Аренда Програмного обеспечения
https://www.CloudZZ.com
Микротики на Украине оптом
mikrotik.kharkov.ua
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: 5.22 released!

Fri Nov 23, 2012 6:44 pm

Caci99,
The link "all stable files" at the download page

Where did you find this link ?
sorry for my english
 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1065
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: 5.22 released!

Fri Nov 23, 2012 6:54 pm

Caci99,
The link "all stable files" at the download page

Where did you find this link ?

at the "Useful tools and utilities" section, below the normal download packages section

Image
-Toni-
Don't crash the ambulance, whatever you do
 
User avatar
shade
newbie
Posts: 31
Joined: Fri Jan 14, 2011 7:40 pm
Location: Russia,Maykop

Re: 5.22 released!

Fri Nov 23, 2012 8:23 pm

Caci99,
The link "all stable files" at the download page

Where did you find this link ?

at the "Useful tools and utilities" section, below the normal download packages section

Image


it is not obviously =)
Нерешаемых проблем нет — есть проблемы, которые никто не решает
 
marekm
Member Candidate
Member Candidate
Posts: 213
Joined: Tue Feb 01, 2011 11:27 pm

Re: 5.22 released!

Sat Nov 24, 2012 12:44 am

What's new in 5.22 (2012-Nov-23 09:28):

*) userman - fix PayPal "bad HTTP response";
*) kvm - fixed possible ROS guest incomplete package installation;
*) l2tp server - added keepalive-timeout setting;
*) wireless - fixed RADIUS mac-caching;
*) wireless - fixed rare nv2 link stall;
*) metarouter - fixed system occasional lockup for 12s on RB4xx and RB7xx;
*) metarouter - fixed crash when FPU exception was raised in one of powerpc metarouters;
*) quickset - added HomeAP mode;
*) fixed "export compact" in "ip proxy";

http://www.mikrotik.com/download
*) PoE firmware version 2.1

why not mentioned, and what was fixed? One RB750UP upgraded from 5.21 (PoE firmware 2.0) so far, not bricked yet.
 
Paetur
just joined
Posts: 18
Joined: Sat Jan 21, 2012 3:00 pm

5.22 released!

Sat Nov 24, 2012 1:16 am

What's new in 5.22 (2012-Nov-23 09:28):

*) userman - fix PayPal "bad HTTP response";
*) kvm - fixed possible ROS guest incomplete package installation;
*) l2tp server - added keepalive-timeout setting;
*) wireless - fixed RADIUS mac-caching;
*) wireless - fixed rare nv2 link stall;
*) metarouter - fixed system occasional lockup for 12s on RB4xx and RB7xx;
*) metarouter - fixed crash when FPU exception was raised in one of powerpc metarouters;
*) quickset - added HomeAP mode;
*) fixed "export compact" in "ip proxy";

http://www.mikrotik.com/download
*) PoE firmware version 2.1

why not mentioned, and what was fixed? One RB750UP upgraded from 5.21 (PoE firmware 2.0) so far, not bricked yet.
From this thread:
My latest update from support:
new changed poe-controller firmware will be included into RouterOS 5.22. It will
address "crazy lights" when in auto-on mode, weirdness with ether5 port. However
it will not address issues with forced-on mode.


/Paetur
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 5.22 released!

Sat Nov 24, 2012 2:10 am

What's new in 5.22 (2012-Nov-23 09:28):


*) wireless - fixed rare nv2 link stall;
So, how serious is this? Every links goes down now and than. Should I now upgrade or not? (I just finished upgrading to 5.21...)

Did the links stall under certain conditions? Or in general.
In the first case I would like to know what these conditions/configs where.... In the second case I probably need to update again soon.... (after not too many issues are being reported here...)
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: 5.22 released!

Sat Nov 24, 2012 2:47 am

in my x86 it uses less memory....
so far my rb800 with nv2 links are working nice... keep it going
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.22 released!

Sat Nov 24, 2012 3:17 am

The link "all stable files" at the download page still points at ROS 5.21. Need to correct the link manually.
Has anyone considered that having so many different torrent files means far less effective seeding? Someone who downloads the mipsle torrent, can only peer with someone else who downloaded the mipsle torrent--in particular, they cannot peer with somebody who downloaded the "all files" torrent. And vice-versa. For each of the platforms. Rather than all ROS torrent downloaders sharing files in one group, there are now five disjoint sub-groups. Bad Idea™!

It would surprise me if most BT clients did not have the ability to select a subset of files to download. It would be much better to leave that to the BT clients, and keep everyone using the same torrent file that includes everything.
Last edited by Hotz1 on Sun Nov 25, 2012 2:57 pm, edited 1 time in total.
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 5.22 released!

Sat Nov 24, 2012 12:30 pm

What's new in 5.22 (2012-Nov-23 09:28):

*) userman - fix PayPal "bad HTTP response";
*) kvm - fixed possible ROS guest incomplete package installation;
*) l2tp server - added keepalive-timeout setting;
*) wireless - fixed RADIUS mac-caching;
*) wireless - fixed rare nv2 link stall;
*) metarouter - fixed system occasional lockup for 12s on RB4xx and RB7xx;
*) metarouter - fixed crash when FPU exception was raised in one of powerpc metarouters;
*) quickset - added HomeAP mode;
*) fixed "export compact" in "ip proxy";

http://www.mikrotik.com/download
*) PoE firmware version 2.1

why not mentioned, and what was fixed? One RB750UP upgraded from 5.21 (PoE firmware 2.0) so far, not bricked yet.
Very BAD, so mikrotik dont write FULL changelog :( :(
LAN, FTTx, Wireless. ISP operator
 
jcem
Member Candidate
Member Candidate
Posts: 137
Joined: Sun May 24, 2009 4:41 pm
Location: Grebbestad, Sweden

Re: 5.22 released!

Sat Nov 24, 2012 10:46 pm

50 units upgraded without any problem
RB411, RB411AR, RB411AH, RB433, RB433AH, RB435, RB800, RB711, RB2011, SEXANT, SXT

All units had 5.19- 5.21 with firmware upgraded before upgrade.
Rebooted units that had uptime more then 20 days before upgrade

RGDS

Jorgen
 
gluetea
just joined
Posts: 15
Joined: Tue Dec 21, 2010 8:19 am

Re: 5.22 released!

Sat Nov 24, 2012 11:30 pm

*) kvm - fixed possible ROS guest incomplete package installation;

OMG, this is soooo dammm good, RB450G and RB493AH fine upgrade and running smooth.

No more downgrade, no more missing configuration, no more missing packages, no more pain :lol:
 
kosztyua
Frequent Visitor
Frequent Visitor
Posts: 73
Joined: Wed Jul 06, 2011 8:00 pm

Re: 5.22 released!

Sun Nov 25, 2012 1:21 pm

I thought this change with KVM meant that the "failed to copy files to image" bug is finally fixed. Seems it is not, still getting after upgrade.
 
User avatar
bambangs2komputer
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Tue Oct 04, 2011 4:22 pm
Location: Kota Malang-Indonesia
Contact:

Re: 5.22 released!

Sun Nov 25, 2012 3:34 pm

My RB1200 normal again with ROS 5.22,thanks :)
 
dragon2611
Member Candidate
Member Candidate
Posts: 152
Joined: Fri Sep 25, 2009 12:06 am

5.22 released!

Sun Nov 25, 2012 5:22 pm

My RB1200 normal again with ROS 5.22,thanks :)
What problems were you having before?


Sent from my Phone using Tapatalk
 
bzip
just joined
Posts: 5
Joined: Fri Dec 05, 2008 1:31 pm

Re: 5.22 released!

Sun Nov 25, 2012 7:45 pm

Hardware: rb450g
System version: V5.21
Exception: SERIAL RS232 open CPU usage becomes 100%
Require a reboot before they can "return to normal"






















新! 按一下上方的文字,即可編
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 5.22 released!

Sun Nov 25, 2012 8:19 pm

but your screnshot shows v5.21, not v5.22!
No answer to your question? How to write posts
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.22 released!

Sun Nov 25, 2012 8:40 pm

RB433UAH power 24V 2A

system error critical System rebooted because of kernel failure
system error critical router was rebooted without proper shutdown by watchdog timer

5.22 3x restart/48h
5.21 uptime >10days
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: 5.22 released!

Mon Nov 26, 2012 10:47 am

Мissing options on AP side...
AP.jpg
NV2 options on AP side missing too.
You do not have the required permissions to view the files attached to this post.
Last edited by erebusodora on Mon Nov 26, 2012 10:55 am, edited 1 time in total.
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: 5.22 released!

Mon Nov 26, 2012 10:49 am

PoE controller firmware somehow did not qualify as RouterOS change as they are separate entities within RouterBOARD :)
 
Jivo
newbie
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: 5.22 released!

Mon Nov 26, 2012 10:59 am

Guys, what's up?

I have upgraded one RB750G (remotely).
On first reboot nothing happened.
After second reboot I've lost connectivity to the router, because ChangeIP script stopped working.

On closer examination I have found out that half of the /tool commands are missing (compared to 5.16), among others dns-update !!! That's why changeip script was not working.

Is this some kind of error during upgrade, or is it "by design"?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: 5.22 released!

Mon Nov 26, 2012 11:24 am

check if package advanced-tools is properly installed as most of stuff in there comes from it.
 
Jivo
newbie
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: 5.22 released!

Mon Nov 26, 2012 12:03 pm

Right on target - it's NOT installed !!!

How come? It never happened before.

I am not an expert, and have no experience with such problems - could someone please give me instructions how to check if advanced tools are present in NPK served for download, and how to install it separately?
 
Jivo
newbie
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: 5.22 released!

Mon Nov 26, 2012 12:05 pm

security and advanced tools is missing ......
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: 5.22 released!

Mon Nov 26, 2012 12:29 pm

advanced-tools and security is part of the combined package. You can attempt to upload it again and reboot the router. Or, download all packages.zip and there are separate packages available.
 
Jivo
newbie
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: 5.22 released!

Mon Nov 26, 2012 12:47 pm

Yes, I downloaded .ZIP package, extracted those two missing packages, uploaded them to RB750G and rebooted.

The question is:
* were those packages integrated in routeros-mipsbe-5.22.npk
* how could I check (peek into) NPK before reboot
* if packages were there, what went wrong the first time

It never EVER happened to me in 4 or 5 years of using and upgrading Mikrotik RBs - that's why I am a bit puzzled and certainly worried.
 
Jivo
newbie
Posts: 34
Joined: Wed Jun 08, 2011 11:44 pm

Re: 5.22 released!

Mon Nov 26, 2012 1:16 pm

Suceeded ....

But I still wonder if those packages were inside .....
Before.GIF
After.GIF
You do not have the required permissions to view the files attached to this post.
 
m0lod0y
just joined
Posts: 2
Joined: Fri Apr 16, 2010 8:42 am

Re: 5.22 released!

Mon Nov 26, 2012 2:36 pm

I have the same BUG in 5.22, no options in Advanced menu. Packages advanced-tools and security are installed. Upgrade was made by file routeros-mipsbe-5.22. There were no options in Advanced menu in 5.21.
You do not have the required permissions to view the files attached to this post.
 
dadaniel
Member Candidate
Member Candidate
Posts: 160
Joined: Fri May 14, 2010 11:51 pm

Re: 5.22 released!

Mon Nov 26, 2012 5:25 pm

 
wildbill442
Forum Guru
Forum Guru
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Re: 5.22 released!

Mon Nov 26, 2012 8:09 pm

What's new in 5.22 (2012-Nov-23 09:28):


*) wireless - fixed rare nv2 link stall;
So, how serious is this? Every links goes down now and than. Should I now upgrade or not? (I just finished upgrading to 5.21...)

Did the links stall under certain conditions? Or in general.
In the first case I would like to know what these conditions/configs where.... In the second case I probably need to update again soon.... (after not too many issues are being reported here...)

I'd like some additional information on this as well. I've noticed a problem where some NV2 configured access points would just stop sending/receiving data and would not start again until the interface was disabled and then re-enabled.

Does this fix that issue? Is there a detailed bug report we can see?
William Burnett
Network Engineer
 
jonmansey
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sat Sep 18, 2004 3:43 am

Re: 5.22 released!

Mon Nov 26, 2012 9:11 pm

Glad to see the nv2 stalling bug reported as fixed, need to ask if it depends on only bridge/AP side, or also stations need upgrade?
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 5.22 released!

Mon Nov 26, 2012 11:57 pm

Glad to see the nv2 stalling bug reported as fixed, need to ask if it depends on only bridge/AP side, or also stations need upgrade?
Several of us would like to see more info on this anyway.... MT?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.22 released!

Tue Nov 27, 2012 1:05 am

RB433UAH
CPU 100% 7,5h no view tools/profile, samba+proxy+watchdog not work 8)
metarouter work :shock:

update:
CPU 100% 14h
power off on > metarouter not exist :?
You do not have the required permissions to view the files attached to this post.
Last edited by napismizpravu on Tue Nov 27, 2012 8:45 am, edited 1 time in total.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 5.22 released!

Tue Nov 27, 2012 8:34 am

napismizpravu, what do you see at /tool profiler?

dadaniel, I put the same configuration to my RB751 board. /export output provides me with correct result at 5.22,
/interface ethernet
set 0 name=ether1-modem
set 1 name=ether2-wan1
set 2 name=ether3-wan
set 3 name=ether4-wan4
set 4 name=ether5-lan

m0lod0y,
what wireless card model do you use?
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.22 released!

Tue Nov 27, 2012 8:56 am

[quote="sergejs"]napismizpravu, what do you see at /tool profiler?

There's nothing to see an empty window without data

RB433UAH power 24V 2A

from time to restart 1h

system error critical System rebooted because of kernel failure
system error critical router was rebooted without proper shutdown by watchdog timer

8x restart/3,5days

downgrade 5.21(almost stable)? upgrade 6.0rc4?

====Google translate====
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: 5.22 released!

Tue Nov 27, 2012 10:46 am

For everyone that says there is no options in Advanced tab it was already discussed in another topic.
The options that are shown are the only relevant for the currently selected wireless mode. For example there is no ack setting in nstreme. That is why it is not shown in Advanced. Switch to a protocol that uses the option and you will see it.
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 5.22 released!

Tue Nov 27, 2012 3:56 pm

When removing an UPS, or changing the serial port of an UPS, the previous serial port is still assigned to the UPS and unable to be reused by any other process.
 
m0lod0y
just joined
Posts: 2
Joined: Fri Apr 16, 2010 8:42 am

Re: 5.22 released!

Tue Nov 27, 2012 9:57 pm

sergejs, RouterBoard RB433AH + R52Hn
 
Segir
just joined
Posts: 4
Joined: Thu Nov 08, 2012 12:54 am

Re: 5.22 released!

Wed Nov 28, 2012 7:19 am

Same bug in v5.22 and 5.21 (on v5.19 didn't met such problem):
can't log in through web-interface (more often from Safari browser, iPhone), there is a following message: "Internal server error".
As I read changelog, similar problem has already been solved in version 5.7, but now it seems to appear again in 5.21 and 5.22
Please fix this problem.
 
brandonrossl
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Wed Jun 08, 2011 10:09 pm

Re: 5.22 released!

Wed Nov 28, 2012 3:28 pm

Same bug in v5.22 and 5.21 (on v5.19 didn't met such problem):
can't log in through web-interface (more often from Safari browser, iPhone), there is a following message: "Internal server error".
As I read changelog, similar problem has already been solved in version 5.7, but now it seems to appear again in 5.21 and 5.22
Please fix this problem.
In either 5.21 or 5.22 my iPad1 works great. That's weird. I'm on a 433ah
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: 5.22 released!

Wed Nov 28, 2012 3:30 pm

what wireless and wireless security-profile settings you are using, maybe problem is caused by, say, use of TKIP?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Wed Nov 28, 2012 6:27 pm

Same bug in v5.22 and 5.21 (on v5.19 didn't met such problem):
can't log in through web-interface (more often from Safari browser, iPhone), there is a following message: "Internal server error".
As I read changelog, similar problem has already been solved in version 5.7, but now it seems to appear again in 5.21 and 5.22
Please fix this problem.
how often does it happen?
What happens if you manually open the IP address of the hotspot router - does it allow to login?
Please make a support output file right after you see that error message and send it to support@mikrotik.com
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: 5.22 released!

Wed Nov 28, 2012 6:54 pm

For everyone that says there is no options in Advanced tab it was already discussed in another topic.
The options that are shown are the only relevant for the currently selected wireless mode. For example there is no ack setting in nstreme. That is why it is not shown in Advanced. Switch to a protocol that uses the option and you will see it.
:shock: correct
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: 5.22 released!

Wed Nov 28, 2012 9:36 pm

Hello folks!

All our routers and accesspoints plus cpe:s successfully upgraded to ros5.22.
RB150, RB333, RB411, RB450G, RB600, RB750, SXT, SEXTANT
No problems observed, all working as stable as before, we use nv2 in wireless network for distribution and 802.11abgn in offices and some hotspots.

Thanks MT!
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.22 released!

Thu Nov 29, 2012 10:58 pm

napismizpravu, what do you see at /tool profiler?
again error:
proxy KO! uptime 1d
You do not have the required permissions to view the files attached to this post.
 
Segir
just joined
Posts: 4
Joined: Thu Nov 08, 2012 12:54 am

Re: 5.22 released!

Fri Nov 30, 2012 7:09 am

Same bug in v5.22 and 5.21 (on v5.19 didn't met such problem):
can't log in through web-interface (more often from Safari browser, iPhone), there is a following message: "Internal server error".
As I read changelog, similar problem has already been solved in version 5.7, but now it seems to appear again in 5.21 and 5.22
Please fix this problem.
how often does it happen?
What happens if you manually open the IP address of the hotspot router - does it allow to login?
Please make a support output file right after you see that error message and send it to support@mikrotik.com
It happens almost every time I try to log in throuh web-interface (Safari) on iPhone. What do you mean by asking "What happens if you manually open the IP address of the hotspot router- does it allow to login?"? In address bar of Safari I enter IP-address of my RB750G, on logon screen I enter password (user "admin" automatically filled in) and press logon - after a few seconds I see the same logon screen with message "Internal Server Error" below password field.
Will try to send supout.rif soon.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Fri Nov 30, 2012 12:54 pm

Segir, have you tried to install a Chrome on IOS device, does it work with it?
With RouterOS v5.20 you didn't have such problem?
 
torjon
just joined
Posts: 10
Joined: Tue Dec 07, 2010 6:13 pm

Re: 5.22 released!

Fri Nov 30, 2012 5:37 pm

ROS: 5.22
00:00:13 system,error,critical System rebooted because of kernel failure
00:00:16 system,error,critical router was rebooted without proper shutdown
00:00:19 interface,info ether1 link up (speed 100M, full duplex)

RB433AH

After few hours again "rebooted because of kernel failure" and CPU 100% and 100MHz !!!

ROS 5.22 looks like early beta...
Last edited by torjon on Sat Dec 01, 2012 12:45 pm, edited 3 times in total.
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.22 released!

Fri Nov 30, 2012 9:52 pm

Beginning on Nov 12, several devices on our network are having their (static) DHCP addresses deassigned and immediately reassigned every few hours, intermittently, despite the standard 3-day lease length. Here is the log of the most recent incident (MAC addresses changed, obviously):
Nov 30 08:47:56 33Comm LAN-DHCP deassigned 192.168.151.244 from aa:aa:aa:aa:aa:aa
Nov 30 08:47:56 33Comm LAN-DHCP assigned 192.168.151.244 to aa:aa:aa:aa:aa:aa
Nov 30 08:48:00 33Comm LAN-DHCP deassigned 192.168.151.247 from dd:dd:dd:dd:dd:dd
Nov 30 08:48:00 33Comm LAN-DHCP assigned 192.168.151.247 to dd:dd:dd:dd:dd:dd
Nov 30 08:48:00 33Comm LAN-DHCP deassigned 192.168.151.245 from bb:bb:bb:bb:bb:bb
Nov 30 08:48:00 33Comm LAN-DHCP assigned 192.168.151.245 to bb:bb:bb:bb:bb:bb
Nov 30 08:48:00 33Comm LAN-DHCP deassigned 192.168.151.246 from cc:cc:cc:cc:cc:cc
Nov 30 08:48:00 33Comm LAN-DHCP assigned 192.168.151.246 to cc:cc:cc:cc:cc:cc
...
Nov 30 12:48:56 33Comm LAN-DHCP deassigned 192.168.151.244 from aa:aa:aa:aa:aa:aa
Nov 30 12:48:56 33Comm LAN-DHCP assigned 192.168.151.244 to aa:aa:aa:aa:aa:aa
Nov 30 12:49:00 33Comm LAN-DHCP deassigned 192.168.151.246 from cc:cc:cc:cc:cc:cc
Nov 30 12:49:00 33Comm LAN-DHCP assigned 192.168.151.246 to cc:cc:cc:cc:cc:cc
Nov 30 12:49:00 33Comm LAN-DHCP deassigned 192.168.151.247 from dd:dd:dd:dd:dd:dd
Nov 30 12:49:00 33Comm LAN-DHCP assigned 192.168.151.247 to dd:dd:dd:dd:dd:dd
Nov 30 12:49:01 33Comm LAN-DHCP deassigned 192.168.151.245 from bb:bb:bb:bb:bb:bb
Nov 30 12:49:01 33Comm LAN-DHCP assigned 192.168.151.245 to bb:bb:bb:bb:bb:bb
At the same time that this occurs, current connections (e.g., VoIP, Skype) on these devices drop.

Relevant settings (export compact):
/ip pool
add name=LAN-pool ranges=192.168.150.100-192.168.151.249

/ip dhcp-server
add add-arp=yes address-pool=LAN-pool authoritative=yes disabled=no interface=\
    ether1-LAN name=LAN-DHCP

/ip dhcp-server network
add address=192.168.150.0/23 dns-server=192.168.150.1 gateway=192.168.150.1 \
    netmask=23 ntp-server=10.0.1.13

/ip dhcp-server lease
add address=192.168.151.244 client-id=1:c0:3f:e:10:21:7b mac-address=aa:aa:aa:aa:aa:aa server=LAN-DHCP
add address=192.168.151.245 client-id=1:0:e:8:d9:a9:11 mac-address=bb:bb:bb:bb:bb:bb server=LAN-DHCP
add address=192.168.151.246 client-id=1:0:e:8:d7:60:34 mac-address=cc:cc:cc:cc:cc:cc server=LAN-DHCP
add address=192.168.151.247 client-id=1:0:e:8:d8:4c:fb mac-address=dd:dd:dd:dd:dd:dd server=LAN-DHCP
Pretty straightforward, I think. I am not sure if this is caused by the dhcp-server system (e.g., changes made for 5.21) or something else; Hopefully, this will help someone track down the problem. If anyone has any insight into this, or this issue has been seen before, please let me know!

Since I am on the verge of losing a customer due to this behavior, I am going to try giving these devices static IPs (manually, not using dhcp-server) and see if that eliminates the drops. Since this will suggest whether the problem is within the dhcp-server system or elsewhere, I will follow up with my own results next week.

EDIT: This is on a RB750UP, currently running ROS 5.22. Upon further perusal of the logs, this deassign-reassign pattern goes back years--but this is the first time I have noticed it happening with static leases, and with devices for which it causes the user a real inconvenience.
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: 5.22 released!

Fri Nov 30, 2012 10:51 pm

Hello Folks!

PROBLEM!!

Suddenly one by one our CPE:s stop working, no traffic on eth1 at all, DHCP offer we see only, nothing more.

Known affected devices so far RB411

Rollback to 5.20 solved the problem.
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: 5.22 released!

Sat Dec 01, 2012 10:17 pm

The scenario is Sextant AP ----> Sextant station bridge (protocol nv2) ... after 1 day trafic stoping. Enable disable wireless interface traffic comes. When ptotocol is nstream no problem. Downgrade to 5.18 NO problem too.
 
Halfeez92
newbie
Posts: 36
Joined: Tue Oct 30, 2012 12:58 pm
Contact:

Re: 5.22 released!

Sun Dec 02, 2012 5:23 am

I've installed NTP client before upgrade, but after upgraded the package was gone, and I tried to check the time thru logs, and it put the right time. I don't know what happen, but before this it need NTP client to syncronize time from the internet right? Do I need to reinstall NTP client package back?

BTW this version still not solve bug on SSL redirect address when using hotspot.
 
User avatar
samotoka
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Fri Aug 18, 2006 2:18 pm
Location: Hot Water Beach, New Zealand

Re: 5.22 released!

Sun Dec 02, 2012 11:25 am

Yes, You need
It is quite easy
Proud owner of a RB2011UAS-2HnD-IN with ROS 6.19,
pc i586 2004 Mhz Athlon XP with ROS 3.30,
pc i586 330 Mhz Pentium II with ROS 3.30,
old pc 233 Mhz Cirix with ROS 2.9.27
 
Lakis
Forum Veteran
Forum Veteran
Posts: 701
Joined: Wed Sep 23, 2009 7:52 pm

Re: 5.22 released!

Sun Dec 02, 2012 2:48 pm

The scenario is Sextant AP ----> Sextant station bridge (protocol nv2) ... after 1 day trafic stoping. Enable disable wireless interface traffic comes. When ptotocol is nstream no problem. Downgrade to 5.18 NO problem too.
Do u still have this problem with 5.22 because I have this problem with previous version
but now 2-3 days with 5.22 seam fine
 
bminish
just joined
Posts: 8
Joined: Wed Mar 09, 2011 5:47 am

Re: 5.22 released!

Sun Dec 02, 2012 3:45 pm

There's an issue with 'export compact' feature

It does not include the SSID if the radio is in NV2 mode AP/bridge

This is from a 711GA-5HnD

/interface wireless
set 0 band=5ghz-a/n country=ireland default-forwarding=no disabled=no \
frequency=5660 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge \
nv2-preshared-key=xxxxxxxxxxxxxxxxxxxx nv2-security=enabled \
security-profile=CPE wireless-protocol=nv2
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: 5.22 released!

Sun Dec 02, 2012 10:03 pm

I came across memory usage reporting error using v.5.22 with web proxy enabled caching to RAM. "System -> Resources" claim to have 4GiB free memory on my RB450G, while graphs say for example "Max: 345.17MiB (137.4%); Average: 124.61MiB (49.6%); Current: 66.73MiB (26.5%);". When I clean out the proxy cache stored in RAM all goes back to normal. I've 50% of RAM allocated for proxy cache.
 
Ham
just joined
Posts: 18
Joined: Thu Oct 27, 2011 1:27 am

Re: 5.22 released!

Mon Dec 03, 2012 12:44 am

Am I missing something in 5.22 but in Winbox, wireless settings, NV2 Tab a heap of settings missing, TDMA Period Cell radius etc only field there now is the security check box and entry..

Only accessible by terminal now ?
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: 5.22 released!

Mon Dec 03, 2012 8:29 am

I came across memory usage reporting error using v.5.22 with web proxy enabled caching to RAM. "System -> Resources" claim to have 4GiB free memory on my RB450G, while graphs say for example "Max: 345.17MiB (137.4%); Average: 124.61MiB (49.6%); Current: 66.73MiB (26.5%);". When I clean out the proxy cache stored in RAM all goes back to normal. I've 50% of RAM allocated for proxy cache.
So here's how it looks from terminal:

> /system resource print
uptime: 1w13h59m17s
version: 5.22
free-memory: 4294958956KiB
total-memory: 257108KiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 680MHz
cpu-load: 0%
free-hdd-space: 435532KiB
total-hdd-space: 520192KiB
write-sect-since-reboot: 1117527
write-sect-total: 47863782
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB450G
platform: MikroTik

and screenshot from winbox:
winbox522.png
You do not have the required permissions to view the files attached to this post.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Mon Dec 03, 2012 9:54 am

The scenario is Sextant AP ----> Sextant station bridge (protocol nv2) ... after 1 day trafic stoping. Enable disable wireless interface traffic comes. When ptotocol is nstream no problem. Downgrade to 5.18 NO problem too.
do you have 5.22 on both sides?
Please make support output file at the time when it is happening. Also if it is possible make support output file from the remote location.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Mon Dec 03, 2012 9:56 am

Am I missing something in 5.22 but in Winbox, wireless settings, NV2 Tab a heap of settings missing, TDMA Period Cell radius etc only field there now is the security check box and entry..

Only accessible by terminal now ?
most likely you are configuring the Nv2 station end. For Nv2 station you only need to check if you willl use security or not as all the other Nv2 settings are sent and configured by AP.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Mon Dec 03, 2012 10:01 am

There's an issue with 'export compact' feature

It does not include the SSID if the radio is in NV2 mode AP/bridge

This is from a 711GA-5HnD

/interface wireless
set 0 band=5ghz-a/n country=ireland default-forwarding=no disabled=no \
frequency=5660 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge \
nv2-preshared-key=xxxxxxxxxxxxxxxxxxxx nv2-security=enabled \
security-profile=CPE wireless-protocol=nv2
Maybe you have the default ssid=MikroTik?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Mon Dec 03, 2012 10:02 am

Hello Folks!

PROBLEM!!

Suddenly one by one our CPE:s stop working, no traffic on eth1 at all, DHCP offer we see only, nothing more.

Known affected devices so far RB411

Rollback to 5.20 solved the problem.
we need support output file from that situation so we could understand what is causing that.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 5.22 released!

Mon Dec 03, 2012 10:03 am

ROS: 5.22
00:00:13 system,error,critical System rebooted because of kernel failure
00:00:16 system,error,critical router was rebooted without proper shutdown
00:00:19 interface,info ether1 link up (speed 100M, full duplex)

RB433AH

After few hours again "rebooted because of kernel failure" and CPU 100% and 100MHz !!!

ROS 5.22 looks like early beta...
please make a support output file from that router and send to support@mikrotik.com
What RouterOS version you were using before v5.22?
 
Beeski
newbie
Posts: 34
Joined: Sat Apr 02, 2005 4:42 pm

Re: 5.22 released!

Mon Dec 03, 2012 2:17 pm

Day 4 of 5.22 testing = no problems.
3 RB800 AP's with R52Hn wireless cards
1 RB493 switch
10 RB711 CPE's

Waiting for more feedback before we roll-out 5.22 to hundreds of AP's and thousands of CPE's.
 
Segir
just joined
Posts: 4
Joined: Thu Nov 08, 2012 12:54 am

Re: 5.22 released!

Tue Dec 04, 2012 7:40 am

Segir, have you tried to install a Chrome on IOS device, does it work with it?
With RouterOS v5.20 you didn't have such problem?
Installed Chrome browser on iPhone - no problem with log in (tried several times - every time successfully). But with v5.19 and earlier versions - I have never met such problem with Safari browser on iOS.
As for v5.20 - didn't test this version (upgraded from v5.19 to v5.21, and later upgraded to v5.22 - on both 5.21 and 5.22 I met problem with "Internal Server Error" when trying to log in).
Yesterday I sent supout.rif to support@mikrotik.com (Ticket#2012120366000531)
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.22 released!

Wed Dec 05, 2012 9:31 am

RB433UAH power 24V 2A

system error critical System rebooted because of kernel failure
system error critical router was rebooted without proper shutdown by watchdog timer

a waste (lost,does not exist)) of active meterouteru

RB433UAH home router (NAT,samba,MetaRouter -opendchub,webserver) max uptime 3d
RB133 (bridge) currently 11d 18h


===Google translator===
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 5.22 released!

Wed Dec 05, 2012 2:24 pm

When removing an UPS, or changing the serial port of an UPS, the previous serial port is still assigned to the UPS and unable to be reused by any other process.
Am I the only one with this problem?
 
User avatar
samotoka
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Fri Aug 18, 2006 2:18 pm
Location: Hot Water Beach, New Zealand

Re: 5.22 released!

Wed Dec 05, 2012 2:30 pm

No!
Proud owner of a RB2011UAS-2HnD-IN with ROS 6.19,
pc i586 2004 Mhz Athlon XP with ROS 3.30,
pc i586 330 Mhz Pentium II with ROS 3.30,
old pc 233 Mhz Cirix with ROS 2.9.27
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 5.22 released!

Wed Dec 05, 2012 3:22 pm

When removing an UPS, or changing the serial port of an UPS, the previous serial port is still assigned to the UPS and unable to be reused by any other process.
Am I the only one with this problem?
what do you mean by "changing the port"? how many serial ports does your device have, and why are you changing them?
No answer to your question? How to write posts
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 5.22 released!

Thu Dec 06, 2012 12:54 pm

RB433UAH again error v.5.22 uptime 1d max. 3d (supout.rif Unable to create)

demo2.mt.lv RB433UAH - turn on the services proxy, samba, MetaROUTER
You do not have the required permissions to view the files attached to this post.
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 5.22 released!

Fri Dec 07, 2012 3:34 am

When removing an UPS, or changing the serial port of an UPS, the previous serial port is still assigned to the UPS and unable to be reused by any other process.
Am I the only one with this problem?
what do you mean by "changing the port"? how many serial ports does your device have, and why are you changing them?
RB1100AH.
I had an issue with an UPS that doesnt want to be recognized after a reboot. I tried to assign the UPS to the second port, but the first serial port is still show in used by the UPS. Even after removing all UPS from the setup, I can't even use the terminal to serial as I get an error that the port is still assigned to the UPS even when there is no more UPS in the setup.
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: 5.22 released!

Sat Dec 08, 2012 11:14 am

I came across memory usage reporting error using v.5.22 with web proxy enabled caching to RAM. "System -> Resources" claim to have 4GiB free memory on my RB450G, while graphs say for example "Max: 345.17MiB (137.4%); Average: 124.61MiB (49.6%); Current: 66.73MiB (26.5%);". When I clean out the proxy cache stored in RAM all goes back to normal. I've 50% of RAM allocated for proxy cache.
So here's how it looks from terminal:

> /system resource print
uptime: 1w13h59m17s
version: 5.22
free-memory: 4294958956KiB
total-memory: 257108KiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 680MHz
cpu-load: 0%
free-hdd-space: 435532KiB
total-hdd-space: 520192KiB
write-sect-since-reboot: 1117527
write-sect-total: 47863782
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB450G
platform: MikroTik

and screenshot from winbox:
winbox522.png
I now have also problems with creating backup on 5.22. Backup file gets partially created and the router logs:
Dec  8 10:11:27 router error creating backup file: could not read all configuration files
I can do
/export file=filename
though with no problems.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 5.22 released!

Sat Dec 08, 2012 12:02 pm

802.11N + NV2. Cpu goes to 100%. Reboot did not help. With 5.21 no CPU problem. Supout.rif send to support
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
Lakis
Forum Veteran
Forum Veteran
Posts: 701
Joined: Wed Sep 23, 2009 7:52 pm

Re: 5.22 released!

Sat Dec 08, 2012 2:18 pm

The scenario is Sextant AP ----> Sextant station bridge (protocol nv2) ... after 1 day trafic stoping. Enable disable wireless interface traffic comes. When ptotocol is nstream no problem. Downgrade to 5.18 NO problem too.
Do u still have this problem with 5.22 because I have this problem with previous version
but now 2-3 days with 5.22 seam fine
I confirm this problem still occur.
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: 5.22 released!

Mon Dec 10, 2012 9:45 am

The scenario is Sextant AP ----> Sextant station bridge (protocol nv2) ... after 1 day trafic stoping. Enable disable wireless interface traffic comes. When ptotocol is nstream no problem. Downgrade to 5.18 NO problem too.
Do u still have this problem with 5.22 because I have this problem with previous version
but now 2-3 days with 5.22 seam fine
I confirm this problem still occur.
I have this problem after 5.18 version. With 5.18 no problem. (upgraded new versions (5.19-5.20-5.21-5.22 on both sides but same problems)
 
guille4
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Tue Sep 29, 2009 9:23 pm

Re: 5.22 released!

Tue Dec 11, 2012 7:02 pm

Hi... RB450G in bridge mode, ports 1 y 2 bridged, rstp, fw on, when traffic comes through the bridge, the rb reboot all the time... like in loop... I diconnect from the lan the port 1 and rb becomes stable... BUT with no traffic at all... same config with 5.21 and earlier firmwares works fine... I probe it in 3 diferentes segments of my lan, in 3 differents RB with the same results. I'm going back to 5.21 and problem solved. It is a BUG ?
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 5.22 released!

Sun Dec 16, 2012 5:34 pm

When removing an UPS, or changing the serial port of an UPS, the previous serial port is still assigned to the UPS and unable to be reused by any other process.
Am I the only one with this problem?
what do you mean by "changing the port"? how many serial ports does your device have, and why are you changing them?

You can just make the following try:

add a UPS to serial0.
In port, you will see that serial0 is now used by UPS.
Delete the UPS.

Do a system serial-terminal serial0 and you will have the following error: failure: port's channel is already in use
If you go to port, you will see that serial0 is still used by UPS even if you don't have any UPS in the system.


My problem is that once a port has been used by a UPS, you can't reeuse that port for anything else until reboot.
I call that a bug.
 
mangust
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Jun 14, 2007 11:14 am

Re: 5.22 released!

Mon Dec 17, 2012 9:14 pm

HI
Occasionally, i have almost 90% cpu load on my RB1200 v 5.22 for the short period of time.
This is not related traffic, a number of connections, because everything stays constant.
Did anybody faced same issue?
I'm thinking about snmp issue , but Normis told that it was fixed several version ago.

http://forum.mikrotik.com/viewtopic.php ... management
THX.
P.S
Read in another post about someone who had a similar problem so i changed my dude settings on the specific device and unchecked the Router OS checkbox in the general tab in the dude. It seems to have solved the problem. :lol:
This helps me as well. So, it's dude or snmp issue? :)
 
bminish
just joined
Posts: 8
Joined: Wed Mar 09, 2011 5:47 am

Re: 5.22 released!

Tue Dec 18, 2012 7:18 pm

Maybe you have the default ssid=MikroTik?
Definitely not. These are configured sites upgraded to 5.22 where we see this
 
5CardBaka
just joined
Posts: 9
Joined: Fri Oct 26, 2012 2:19 am

Re: 5.22 released!

Thu Dec 20, 2012 7:17 pm

Is there a valid link to a non torrent DL? Work doesn't let me use torrents and the 5.22 file in the downloads section is missing a bunch of things and the upgrade fails. I have 15 or so client that all got caught with the firmware upgrade bringing their devices down and now I'm going to have them ship em all back so I can fix them.

I confirmed the file is not working my side as well and have a now useless device sitting on my desk.

http://download2.mikrotik.com/routeros/ ... e-5.22.zip

DOES NOT WORK unless repaired your side already.

james [Teksavvy Biz services]
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 5.22 released!

Fri Dec 21, 2012 11:37 pm

The scenario is Sextant AP ----> Sextant station bridge (protocol nv2) ... after 1 day trafic stoping. Enable disable wireless interface traffic comes. When ptotocol is nstream no problem. Downgrade to 5.18 NO problem too.
The same probem. Configuration is AP BRIDGE with nv2. No trafic, no ping. Reboot solved problem.
Reported to support
LAN, FTTx, Wireless. ISP operator
 
coffeecoco
Member Candidate
Member Candidate
Posts: 175
Joined: Wed Oct 12, 2005 1:17 pm

Re: 5.22 released!

Wed Dec 26, 2012 3:07 am

Hi i have problem with KVM on x86
for bench testing I loaded 20 Ros KVM into a Dell Routeros Host

occasionally a kvm crash and get stuck and wont respond.

And more importantly i am able to crash the entire routeros host ( dell box )

if i start and stop the Traffic generator many times off and on in a short period

result the server does not recover and i must walk into the server room and manually reboot it.


p.s is there a know stable version of ROS kvm? I want to generate my lab with out these failures
 
tiggda
newbie
Posts: 29
Joined: Fri Mar 04, 2011 11:07 am

Re: 5.22 released!

Thu Jan 03, 2013 7:32 pm

I came across memory usage reporting error using v.5.22 with web proxy enabled caching to RAM. "System -> Resources" claim to have 4GiB free memory on my RB450G, while graphs say for example "Max: 345.17MiB (137.4%); Average: 124.61MiB (49.6%); Current: 66.73MiB (26.5%);". When I clean out the proxy cache stored in RAM all goes back to normal. I've 50% of RAM allocated for proxy cache.
So here's how it looks from terminal:

> /system resource print
uptime: 1w13h59m17s
version: 5.22
free-memory: 4294958956KiB
total-memory: 257108KiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 680MHz
cpu-load: 0%
free-hdd-space: 435532KiB
total-hdd-space: 520192KiB
write-sect-since-reboot: 1117527
write-sect-total: 47863782
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB450G
platform: MikroTik

and screenshot from winbox:
winbox522.png
I now have also problems with creating backup on 5.22. Backup file gets partially created and the router logs:
Dec  8 10:11:27 router error creating backup file: could not read all configuration files
I can do
/export file=filename
though with no problems.
Anyone else came across faulty memory usage reporting and broken configuration backup?
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.22 released!

Thu Jan 10, 2013 8:09 am

Beginning on Nov 12, several devices on our network are having their (static) DHCP addresses deassigned and immediately reassigned every few hours, intermittently, despite the standard 3-day lease length... At the same time that this occurs, current connections (e.g., VoIP, Skype) on these devices drop... I am not sure if this is caused by the dhcp-server system (e.g., changes made for 5.21) or something else; Hopefully, this will help someone track down the problem. If anyone has any insight into this, or this issue has been seen before, please let me know!

EDIT: This is on a RB750UP, currently running ROS 5.22. Upon further perusal of the logs, this deassign-reassign pattern goes back years--but this is the first time I have noticed it happening with static leases, and with devices for which it causes the user a real inconvenience.
NO COMMENT on dhcp-server deassigning and reassigning leases at odd times?! This isn't happening to anyone else?

Since the last time I reported this issue, I have replaced the RB750UP with an RB2011UAS-2HnD and created an all-new configuration, but this problem still happens. VoIP calls are disconnecting, remotely-mounted file systems are disconnecting, it's a mess.

Just today, the log shows DHCP being deassigned and reassigned to the same device twice: first at 11:24am, and again at 4:04pm:
Jan  9 11:24:05 33Comm LAN2-DHCP deassigned 192.168.152.20 from [hh:hh:hh:hh:hh:hh]
Jan  9 11:24:06 33Comm LAN2-DHCP assigned 192.168.152.20 to [hh:hh:hh:hh:hh:hh]
...
Jan  9 16:04:14 33Comm LAN2-DHCP deassigned 192.168.152.20 from [hh:hh:hh:hh:hh:hh]
Jan  9 16:04:15 33Comm LAN2-DHCP assigned 192.168.152.20 to [hh:hh:hh:hh:hh:hh]

Config:
/ip pool
add name=LAN2-Pool ranges=192.168.152.10-192.168.152.250

/ip dhcp-server
add add-arp=yes address-pool=LAN2-Pool authoritative=yes disabled=no interface=ether2-LAN lease-time=3d name=LAN2-DHCP

/ip dhcp-server network
add address=192.168.152.0/24 dhcp-option="" dns-server=192.168.152.1 gateway=192.168.152.1 ntp-server=10.0.1.13 wins-server=""
At the very least, I would expect these events to occur three days apart; i.e., the duration of the lease. And I certainly would not expect a DHCP renewal to cause connections to drop. Insights, anyone?
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: 5.22 released!

Thu Jan 10, 2013 12:41 pm

At the very least, I would expect these events to occur three days apart; i.e., the duration of the lease. And I certainly would not expect a DHCP renewal to cause connections to drop. Insights, anyone?
This is probably normal behaviour. A DHCP client should renew its IP adress at half leasetime. Most clients do it more often in my expreience.
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.22 released!

Thu Jan 10, 2013 1:51 pm

At the very least, I would expect these events to occur three days apart; i.e., the duration of the lease. And I certainly would not expect a DHCP renewal to cause connections to drop. Insights, anyone?
This is probably normal behaviour. A DHCP client should renew its IP adress at half leasetime. Most clients do it more often in my expreience.
Renewing the lease might be normal behavior, but not dropping connections as a result! I found these deassign/reassign events because they coincide with the client reporting that an application's remote database connection closed unexpectedly. It has been happening several times a day. Not all of them trace back to one of these DHCP events, but the fact that two of them do makes me suspicious.

How would I go about confirming whether this is initiated by the client, rather than a bug in the dhcp server? What packet-sniffer settings will capture a DHCP release/renew from the client, and little else?
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.22 released!

Fri Jan 11, 2013 3:29 pm

This cannot be normal dhcp-server behavior, nor can this many different clients (owned by various individuals working in different organizations) be misconfigured in the same way. This isn't even the complete list for one day, just the more egregious examples:

DHCP deassigns/reassigns the same IP to the same MAC three times within fifteen seconds:
  • Jan 10 10:12:48 33Comm Hotspot-DHCP deassigned 10.1.150.82 from [mac1]
    Jan 10 10:12:48 33Comm Hotspot-DHCP assigned 10.1.150.82 to [mac1]
    Jan 10 10:12:57 33Comm Hotspot-DHCP deassigned 10.1.150.82 from [mac1]
    Jan 10 10:12:57 33Comm Hotspot-DHCP assigned 10.1.150.82 to [mac1]
    Jan 10 10:13:01 33Comm Hotspot-DHCP deassigned 10.1.150.82 from [mac1]
    Jan 10 10:13:02 33Comm Hotspot-DHCP assigned 10.1.150.82 to [mac1]
Assigned, then 7 minutes later (de)assigned 4 times over the course of ~6 minutes:
  • Jan 10 14:23:06 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:30:38 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:30:38 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:32:23 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:32:23 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:33:15 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:33:15 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:37:00 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:37:00 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
(de)assigned only 30 seconds after the initial assignment:
  • Jan 10 16:29:32 33Comm Hotspot-DHCP assigned 10.1.150.86 to [mac3]
    Jan 10 16:30:04 33Comm Hotspot-DHCP deassigned 10.1.150.86 from [mac3]
    Jan 10 16:30:05 33Comm Hotspot-DHCP assigned 10.1.150.86 to [mac3]
...and then half an hour later, most disturbingly, the same device is deassigned, and then reassigned a different IP:
  • Jan 10 17:02:27 33Comm Hotspot-DHCP deassigned 10.1.150.86 from [mac3]
    Jan 10 17:02:30 33Comm Hotspot-DHCP assigned 10.1.150.66 to [mac3]
When would that ever be desired behavior?!

Assigned and deassigned twice over the course of one second--and left deassigned?!
  • Jan 10 23:40:46 33Comm Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    Jan 10 23:40:46 33Comm Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    Jan 10 23:40:46 33Comm Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    Jan 10 23:40:46 33Comm Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
Interestingly, in this last case, the log file on the board itself shows this (de)assignment happening seven times in one second, and leaves it assigned. The above is taken from its remote log. On the board, the log file reads:
  • jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
Clearly something is broken!
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
frankie
Member Candidate
Member Candidate
Posts: 116
Joined: Thu May 08, 2008 9:45 pm

Re: 5.22 released!

Fri Jan 11, 2013 9:53 pm

Still same problem on RB951-2n as with ROS 5.21, frequency dropped to 360MHz. Tested on two RB951-2n with Bootloader 2.41 and 3.0. Under v5.20 same boards shows 400MHz.
You do not have the required permissions to view the files attached to this post.
 
ste
Forum Guru
Forum Guru
Posts: 1816
Joined: Sun Feb 13, 2005 11:21 pm

Re: 5.22 released!

Wed Jan 16, 2013 1:09 am

NV2 is much better with 5.22. Some problematic links now run very smooth for a week. Good work MT!
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: 5.22 released!

Thu Jan 24, 2013 10:56 pm

This cannot be normal dhcp-server behavior, nor can this many different clients (owned by various individuals working in different organizations) be misconfigured in the same way. This isn't even the complete list for one day, just the more egregious examples:

DHCP deassigns/reassigns the same IP to the same MAC three times within fifteen seconds:
  • Jan 10 10:12:48 33Comm Hotspot-DHCP deassigned 10.1.150.82 from [mac1]
    Jan 10 10:12:48 33Comm Hotspot-DHCP assigned 10.1.150.82 to [mac1]
    Jan 10 10:12:57 33Comm Hotspot-DHCP deassigned 10.1.150.82 from [mac1]
    Jan 10 10:12:57 33Comm Hotspot-DHCP assigned 10.1.150.82 to [mac1]
    Jan 10 10:13:01 33Comm Hotspot-DHCP deassigned 10.1.150.82 from [mac1]
    Jan 10 10:13:02 33Comm Hotspot-DHCP assigned 10.1.150.82 to [mac1]
Assigned, then 7 minutes later (de)assigned 4 times over the course of ~6 minutes:
  • Jan 10 14:23:06 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:30:38 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:30:38 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:32:23 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:32:23 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:33:15 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:33:15 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
    Jan 10 14:37:00 33Comm Hotspot-DHCP deassigned 10.1.150.60 from [mac2]
    Jan 10 14:37:00 33Comm Hotspot-DHCP assigned 10.1.150.60 to [mac2]
(de)assigned only 30 seconds after the initial assignment:
  • Jan 10 16:29:32 33Comm Hotspot-DHCP assigned 10.1.150.86 to [mac3]
    Jan 10 16:30:04 33Comm Hotspot-DHCP deassigned 10.1.150.86 from [mac3]
    Jan 10 16:30:05 33Comm Hotspot-DHCP assigned 10.1.150.86 to [mac3]
...and then half an hour later, most disturbingly, the same device is deassigned, and then reassigned a different IP:
  • Jan 10 17:02:27 33Comm Hotspot-DHCP deassigned 10.1.150.86 from [mac3]
    Jan 10 17:02:30 33Comm Hotspot-DHCP assigned 10.1.150.66 to [mac3]
When would that ever be desired behavior?!

Assigned and deassigned twice over the course of one second--and left deassigned?!
  • Jan 10 23:40:46 33Comm Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    Jan 10 23:40:46 33Comm Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    Jan 10 23:40:46 33Comm Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    Jan 10 23:40:46 33Comm Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
Interestingly, in this last case, the log file on the board itself shows this (de)assignment happening seven times in one second, and leaves it assigned. The above is taken from its remote log. On the board, the log file reads:
  • jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP deassigned 10.1.150.46 from [mac4]
    jan/10 23:40:46 dhcp,info Hotspot-DHCP assigned 10.1.150.46 to [mac4]
Clearly something is broken!
I have the same problem with many customers on 5.22 and DHCP leases, Yes there is something wrong with 5.22 DHCP
N21roadie,
Network 100% MT for Now?
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: 5.22 released!

Thu Jan 24, 2013 11:39 pm

This cannot be normal dhcp-server behavior, nor can this many different clients (owned by various individuals working in different organizations) be misconfigured in the same way... Clearly something is broken!
I have the same problem with many customers on 5.22 and DHCP leases, Yes there is something wrong with 5.22 DHCP
I'm glad to know it isn't just me or something flaky about our configuration. Are you also experiencing the breaking of persistent connections (VoIP, RDP) when this happens? Do you suppose downgrading to 5.21 might improve the situation?
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: 5.22 released!

Fri Jan 25, 2013 2:10 am

I'm glad to know it isn't just me or something flaky about our configuration. Are you also experiencing the breaking of persistent connections (VoIP, RDP) when this happens? Do you suppose downgrading to 5.21 might improve the situation?
I have downgraded some CPE's to 5.20 because the logs on cpe's running that version did not have dhcp issues and i needed a quick if temporary fix for this, on the AP's and a lot of cpe's which are still 5.22 until i downgrade is to remove any IP Services not being used for me i use only Winbox + Telnet the rest API,ftp,ssh,www-ssh and especially www are not used so i disabled not sure it will help.
N21roadie,
Network 100% MT for Now?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6618
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 5.22 released!

Fri Jan 25, 2013 12:43 pm

Hotz1
we are interested in your problem about DHCP-server leases reassignments.

1) Please run /tool sniffer on DHCP-server interface, during assignment/deassigment;
2) Make support output file after clicking stop on /tool sniffer;
3) Send both files for us, we will research where could be the problem (I assume local network works fine and there is no problem with wireless disconnects, bad switch, etc.).
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: 5.22 released!

Fri Jan 25, 2013 9:37 pm

Hotz1
we are interested in your problem about DHCP-server leases reassignments.

1) Please run /tool sniffer on DHCP-server interface, during assignment/deassigment;
2) Make support output file after clicking stop on /tool sniffer;
3) Send both files for us, we will research where could be the problem (I assume local network works fine and there is no problem with wireless disconnects, bad switch, etc.).
@Sergis I have the same issue and will follow your instructions, in response to question about local network works fine and there is no problem with wireless disconnects, bad switch, etc.
Usually I check wireless registration and when it says uptime in days and customer says they have disconnects several times daily I had assumed it was being caused by some other device on the customers LAN and did find with one customer a rouge DHCP server which was taken down but then another customer asks are we having network issues and another then checking at random many customers CPE logs and DHCP leases reassignments - alarm bells rings? on checking customers with 5.20 they did not have these DHCP leases reassignments so i used DUDE to force upgrade to 5.20 ("force upgrade" which should be titled "force install"?) and I have disabled ports not used to access the routers and in my case i use only Telnet,winbox,
I will forward the support output file and /tool sniffer files to support

Below is just from one customer



Jan/08/2013 18:59:43 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/08/2013 18:59:45 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/08/2013 19:11:47 dhcp,info dhcp1 deassigned 192.168.1.96 from 04:0C:CE:4C:95:2A
Jan/08/2013 19:11:49 dhcp,info dhcp1 assigned 192.168.1.96 to 04:0C:CE:4C:95:2A
Jan/08/2013 20:06:08 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/08/2013 20:06:09 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/08/2013 21:54:51 dhcp,info dhcp1 assigned 192.168.1.33 to 60:67:20:AB:E8:4C
Jan/09/2013 11:33:58 dhcp,info dhcp1 deassigned 192.168.1.29 from 00:1B:B1:8B:2E:40
Jan/09/2013 18:18:40 dhcp,info dhcp1 deassigned 192.168.1.96 from 04:0C:CE:4C:95:2A
Jan/09/2013 18:18:42 dhcp,info dhcp1 assigned 192.168.1.96 to 04:0C:CE:4C:95:2A
Jan/09/2013 18:26:31 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/09/2013 18:26:32 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/09/2013 21:32:10 interface,info ether1 link down
Jan/09/2013 21:32:34 interface,info ether1 link up (speed 100M, full duplex)
Jan/09/2013 21:32:43 interface,info ether1 link down
Jan/09/2013 21:32:44 interface,info ether1 link up (speed 100M, full duplex)
Jan/09/2013 21:32:51 interface,info ether1 link down
Jan/09/2013 21:32:53 dhcp,info dhcp1 deassigned 192.168.1.93 from 00:19:FB:24:BA:11
Jan/09/2013 21:32:53 dhcp,info dhcp1 assigned 192.168.1.93 to 00:19:FB:24:BA:11
Jan/09/2013 21:32:53 interface,info ether1 link up (speed 100M, full duplex)
Jan/10/2013 18:59:43 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/10/2013 19:00:02 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/10/2013 19:01:30 dhcp,info dhcp1 deassigned 192.168.1.96 from 04:0C:CE:4C:95:2A
Jan/10/2013 19:01:31 dhcp,info dhcp1 assigned 192.168.1.96 to 04:0C:CE:4C:95:2A
Jan/10/2013 20:03:38 dhcp,info dhcp1 deassigned 192.168.1.33 from 60:67:20:AB:E8:4C
Jan/10/2013 20:03:39 dhcp,info dhcp1 assigned 192.168.1.33 to 60:67:20:AB:E8:4C
Jan/10/2013 20:44:25 dhcp,info dhcp1 deassigned 192.168.1.35 from 00:0C:43:CE:19:D6
Jan/10/2013 20:44:34 dhcp,info dhcp1 assigned 192.168.1.35 to 00:0C:43:CE:19:D6
Jan/10/2013 21:02:28 interface,info ether1 link down
Jan/10/2013 21:02:48 interface,info ether1 link up (speed 100M, full duplex)
Jan/10/2013 21:02:57 interface,info ether1 link down
Jan/10/2013 21:02:59 interface,info ether1 link up (speed 100M, full duplex)
Jan/10/2013 21:03:05 interface,info ether1 link down
Jan/10/2013 21:03:06 dhcp,info dhcp1 deassigned 192.168.1.93 from 00:19:FB:24:BA:11
Jan/10/2013 21:03:07 interface,info ether1 link up (speed 100M, full duplex)
Jan/10/2013 21:03:12 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/10/2013 21:03:12 dhcp,info dhcp1 assigned 192.168.1.93 to 00:19:FB:24:BA:11
Jan/10/2013 21:03:13 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/11/2013 15:39:32 dhcp,info dhcp1 deassigned 192.168.1.96 from 04:0C:CE:4C:95:2A
Jan/11/2013 15:39:34 dhcp,info dhcp1 assigned 192.168.1.96 to 04:0C:CE:4C:95:2A
Jan/11/2013 21:13:11 dhcp,info dhcp1 deassigned 192.168.1.96 from 04:0C:CE:4C:95:2A
Jan/11/2013 21:13:13 dhcp,info dhcp1 assigned 192.168.1.96 to 04:0C:CE:4C:95:2A
Jan/12/2013 17:59:17 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/12/2013 17:59:19 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/12/2013 18:11:42 dhcp,info dhcp1 deassigned 192.168.1.96 from 04:0C:CE:4C:95:2A
Jan/12/2013 18:11:46 dhcp,info dhcp1 assigned 192.168.1.96 to 04:0C:CE:4C:95:2A
Jan/12/2013 18:32:50 dhcp,info dhcp1 deassigned 192.168.1.37 from 00:0C:E7:01:62:4C
Jan/12/2013 18:33:24 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/12/2013 18:35:24 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/12/2013 18:35:41 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/12/2013 19:39:11 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/12/2013 19:39:15 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/13/2013 13:23:27 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/13/2013 13:23:30 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/13/2013 13:24:38 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/13/2013 13:30:25 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/13/2013 13:30:31 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/13/2013 13:30:36 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/13/2013 13:42:46 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/13/2013 13:42:46 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/13/2013 17:32:01 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/13/2013 17:32:52 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/14/2013 13:50:11 dhcp,info dhcp1 deassigned 192.168.1.30 from 08:60:6E:27:07:C9
Jan/14/2013 13:50:11 dhcp,info dhcp1 assigned 192.168.1.30 to 08:60:6E:27:07:C9
Jan/14/2013 19:45:31 dhcp,info dhcp1 deassigned 192.168.1.198 from 8C:FA:BA:5D:39:97
Jan/14/2013 19:45:38 dhcp,info dhcp1 assigned 192.168.1.198 to 8C:FA:BA:5D:39:97
Jan/14/2013 20:40:25 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/14/2013 20:40:42 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/14/2013 21:37:38 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/14/2013 21:37:50 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/14/2013 21:38:19 dhcp,info dhcp1 deassigned 192.168.1.31 from 00:0C:E7:01:62:4C
Jan/14/2013 21:38:29 dhcp,info dhcp1 assigned 192.168.1.31 to 00:0C:E7:01:62:4C
Jan/14/2013 23:16:31 dhcp,info dhcp1 deassigned 192.168.1.30 from 08:60:6E:27:07:C9
Jan/14/2013 23:16:31 dhcp,info dhcp1 assigned 192.168.1.30 to 08:60:6E:27:07:C9
Jan/14/2013 23:18:32 dhcp,info dhcp1 deassigned 192.168.1.30 from 08:60:6E:27:07:C9
Jan/14/2013 23:18:32 dhcp,info dhcp1 assigned 192.168.1.30 to 08:60:6E:27:07:C9
Jan/14/2013 23:20:09 dhcp,info dhcp1 deassigned 192.168.1.30 from 08:60:6E:27:07:C9
Jan/14/2013 23:20:09 dhcp,info dhcp1 assigned 192.168.1.30 to 08:60:6E:27:07:C9

N21roadie,
Network 100% MT for Now?
 
User avatar
Alessio Garavano
Member
Member
Posts: 304
Joined: Sat May 29, 2004 12:49 am
Location: Corrientes, Argentina
Contact:

Re: 5.22 released!

Tue May 21, 2013 1:28 am

I have this DHCP problem a lot of time and never can fix!

Many times the reassigned IP is different of the deassigned and the client figure like connected in the hotspot with the old IP and not allowed more sessions to the client and we need to remove the client manually to allow reconnect again!

In the last v6.0 of May 17th the problem persist...

Any help?
Alessio Garavano
http://www.isparg.com.ar
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: 5.22 released!

Mon Nov 04, 2013 1:08 pm

RB1100AH.
I had an issue with an UPS that doesnt want to be recognized after a reboot. I tried to assign the UPS to the second port, but the first serial port is still show in used by the UPS. Even after removing all UPS from the setup, I can't even use the terminal to serial as I get an error that the port is still assigned to the UPS even when there is no more UPS in the setup.
Did you ever get a resolution to this? Couldn't see anything acknowledging the bug in the v5 changelogs so guessing it's still an issue with v5.26?
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: 5.22 released!

Mon Nov 04, 2013 1:32 pm

I did note that this only seems to occur if you disable the UPS before removing. If you just remove then its seems to clear the "used by" state. We needed to access the UPS directly to update battery count at a couple of sites to give a more accurate run time.
 
asimko
just joined
Posts: 22
Joined: Wed Nov 13, 2013 9:55 am

Re: 5.22 released!

Wed Nov 13, 2013 10:03 am

What's new in 5.22 (2012-Nov-23 09:28):


*) wireless - fixed rare nv2 link stall;
So, how serious is this? Every links goes down now and than. Should I now upgrade or not? (I just finished upgrading to 5.21...)

Did the links stall under certain conditions? Or in general.
In the first case I would like to know what these conditions/configs where.... In the second case I probably need to update again soon.... (after not too many issues are being reported here...)

I'd like some additional information on this as well. I've noticed a problem where some NV2 configured access points would just stop sending/receiving data and would not start again until the interface was disabled and then re-enabled.

Does this fix that issue? Is there a detailed bug report we can see?

We have still this issue on several APs! We have everywhere version 5.26 with newest firmware, APs are mostly RB433L or AH with SXT or RB711 all upgraded to 5.26. Is there a solution for this issue?

Who is online

Users browsing this forum: No registered users and 70 guests