Page 1 of 1

ARP problems after setting up the HotSpot

Posted: Mon Dec 10, 2012 6:34 pm
by psymax
Hello!

I have a basic setup based on RB750GL with ROS V6.04 with the Hotspot activated and used behind a NAT.
The router is sharing the internet connection for aprox. 30 users.
In the network I also have one Digital Video Recording system. For those, i've used the "IP Bindings".

When I attempt to connect at the binded IP of DVR, first I get a timeout. After I retry several times, the DVR page apears.

After some research I noticed that after activating the HotSpot function, I recieve ARP response(with the router MAC address) from all the IP's of the lan subnet, except those assigned by DHCP. I guess that this behavior is a kind of ARP spoof protection or something... I don't need this feature. How do I disable it or how I prevent this behavior for the "IP Bindings" list?

Re: ARP problems after setting up the HotSpot

Posted: Mon Dec 10, 2012 7:37 pm
by guilhermeramires
Actually it looks like a wrong entry in ip binding menu. Go to IP -> HotSpot -> Hosts and check if the DVR IP its with "P" flag .

Re: ARP problems after setting up the HotSpot

Posted: Mon Dec 10, 2012 8:29 pm
by psymax
Yes, it is.

Actually I think that I did a mistake. The subnet of the LAN is 10.0.0.0/24, but in the dhcp pool, i have alocated only IP's from 10 to 250. The DVR is out of the dhcp pool ( 10.0.0.9 ). Soon as I get at the location, I will set the network of the DVR to DHCP and give it a static lease.... maybe this will solve the problem.
Thanks for the quick response