Community discussions

MikroTik App
 
asuz
just joined
Topic Author
Posts: 22
Joined: Sat Apr 16, 2011 5:03 pm

mac authenicated hotspot login

Fri Dec 21, 2012 11:21 am

Hello all, I make a hotspot with my mikrotik and its working very well with user name and passwords. But right not trying to log-in users with mac addresses. I mean that, I know users mac addresses and register to mikrotik then I want them log in without user name and password. I edit hotspot login page, I disable username and password field and I set hotspot server profile window with logging by mac but cannot succeed. Can anybody help me step by step.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: mac authenicated hotspot login

Fri Dec 21, 2012 1:49 pm

What are you using for authentication? Are you using the local user database or a RADIUS server like User Manager or FreeRADIUS?
 
asuz
just joined
Topic Author
Posts: 22
Joined: Sat Apr 16, 2011 5:03 pm

Re: mac authenicated hotspot login

Fri Dec 21, 2012 3:04 pm

Good question :) I think local user database
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: mac authenicated hotspot login

Fri Dec 21, 2012 4:14 pm

Do you have the mac address in the local database? Does it have a password?

Enable hotspot verbose logging. Maybe the log will help you see what is happening.
/system logging
add topics=hotspot,debug action=memory
Try a login and check the log.
 
asuz
just joined
Topic Author
Posts: 22
Joined: Sat Apr 16, 2011 5:03 pm

Re: mac authenicated hotspot login

Fri Dec 21, 2012 6:48 pm

Do you have the mac address in the local database? Does it have a password?

Enable hotspot verbose logging. Maybe the log will help you see what is happening.
/system logging
add topics=hotspot,debug action=memory
Try a login and check the log.
Logs are here
You do not have the required permissions to view the files attached to this post.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: mac authenicated hotspot login

Fri Dec 21, 2012 10:18 pm

That looks like that mac address is not in the database or the format is incorrect. Looks like it is also checking a RADIUS database with the same result: "User not found".
However it displays the mac address in the log is the format. Should be
XXXXXXXXXXXX
or
XX:XX:XX:XX:XX:XX
 
asuz
just joined
Topic Author
Posts: 22
Joined: Sat Apr 16, 2011 5:03 pm

Re: mac authenicated hotspot login

Fri Dec 21, 2012 10:22 pm

That looks like that mac address is not in the database or the format is incorrect. Looks like it is also checking a RADIUS database with the same result: "User not found".
However it displays the mac address in the log is the format. Should be
XXXXXXXXXXXX
or
XX:XX:XX:XX:XX:XX
Is there any idea what to do from beginning to end, I am newbee at mikrotik.
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: mac authenicated hotspot login

Fri Dec 21, 2012 10:49 pm

It is simple. I just checked it.
/ip hotspot profile
set X login-by="mac,http-chap"

/ip hotspot user
add name=XX:XX:XX:XX:XX:XX
Insure you change the correct hotspot profile. Mine has more than one.

That is the format my hotspot uses for the username. Leave the password blank.
I restarted the router to insure the hotspot was starting clean with the new login setting.

I opened my web browser and went to Google. It came right up and the mac address showed in
/ip hotspot active

Who is online

Users browsing this forum: accarda, almdandi, Google [Bot], MSN [Bot], saibarker, truefriendcz, usovalx5 and 190 guests