Page 1 of 1

mac authenicated hotspot login

Posted: Fri Dec 21, 2012 11:21 am
by asuz
Hello all, I make a hotspot with my mikrotik and its working very well with user name and passwords. But right not trying to log-in users with mac addresses. I mean that, I know users mac addresses and register to mikrotik then I want them log in without user name and password. I edit hotspot login page, I disable username and password field and I set hotspot server profile window with logging by mac but cannot succeed. Can anybody help me step by step.

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 1:49 pm
by SurferTim
What are you using for authentication? Are you using the local user database or a RADIUS server like User Manager or FreeRADIUS?

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 3:04 pm
by asuz
Good question :) I think local user database

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 4:14 pm
by SurferTim
Do you have the mac address in the local database? Does it have a password?

Enable hotspot verbose logging. Maybe the log will help you see what is happening.
/system logging
add topics=hotspot,debug action=memory
Try a login and check the log.

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 6:48 pm
by asuz
Do you have the mac address in the local database? Does it have a password?

Enable hotspot verbose logging. Maybe the log will help you see what is happening.
/system logging
add topics=hotspot,debug action=memory
Try a login and check the log.
Logs are here

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 10:18 pm
by SurferTim
That looks like that mac address is not in the database or the format is incorrect. Looks like it is also checking a RADIUS database with the same result: "User not found".
However it displays the mac address in the log is the format. Should be
XXXXXXXXXXXX
or
XX:XX:XX:XX:XX:XX

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 10:22 pm
by asuz
That looks like that mac address is not in the database or the format is incorrect. Looks like it is also checking a RADIUS database with the same result: "User not found".
However it displays the mac address in the log is the format. Should be
XXXXXXXXXXXX
or
XX:XX:XX:XX:XX:XX
Is there any idea what to do from beginning to end, I am newbee at mikrotik.

Re: mac authenicated hotspot login

Posted: Fri Dec 21, 2012 10:49 pm
by SurferTim
It is simple. I just checked it.
/ip hotspot profile
set X login-by="mac,http-chap"

/ip hotspot user
add name=XX:XX:XX:XX:XX:XX
Insure you change the correct hotspot profile. Mine has more than one.

That is the format my hotspot uses for the username. Leave the password blank.
I restarted the router to insure the hotspot was starting clean with the new login setting.

I opened my web browser and went to Google. It came right up and the mac address showed in
/ip hotspot active