Community discussions

 
estdata
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Mon Feb 20, 2012 9:05 pm
Contact:

v6 rc7 released

Fri Jan 18, 2013 8:59 pm

What's new in 6.0rc7 (2013-Jan-18 13:04):

*) dhcp relay - possibility to add relay agent information option;
*) lcd - options current-interface, time-interval and all-interface-mode
no longer get reset after reboot;
*) fix reboot in virtualized enviroment;
*) lcd - improve slideshow screen;
*) console - file print now shows file size as small number with suffix;
*) dhcp v4 - fix problem when sometimes client or server failed to send packets
most likely it happened on vlan interfaces;
*) ipv6 - added setting to disable forwarding;
*) added "/ip neighbor discovery settings" menu with "default=yes/no" setting;
Last edited by estdata on Sat Jan 19, 2013 1:20 pm, edited 2 times in total.
don't forget to give me karma if got help
....
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: V6 RC 7.0 released

Fri Jan 18, 2013 10:02 pm

No fix to vrf? (not tested)
 
estdata
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Mon Feb 20, 2012 9:05 pm
Contact:

Re: V6 RC 7.0 released

Fri Jan 18, 2013 10:57 pm

No fix to vrf? (not tested)
I think that this version has been tested
don't forget to give me karma if got help
....
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: V6 RC 7.0 released

Fri Jan 18, 2013 11:33 pm

Now on to RC8
 
slech
Long time Member
Long time Member
Posts: 533
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: V6 RC 7.0 released

Fri Jan 18, 2013 11:42 pm

/interface print
ether1-wan-primary ether 1500 1526 00:0C:42:41:6A:85
ether2-lan ether 1500 1522 1522 00:0C:42:41:6A:86
/ip neighbor print
0 ether2... 192.168.2.1 00:0C:42:41:6A:86 MikroTik 6.0rc7 RB433UAH
1 ether1... 99.99.99.99 00:0C:42:41:6A:85 MikroTik 6.0rc7 RB433UAH
Why it show me itself, or this is normal ?

On demo2.mt.lv all is ok.
On demo.mt.lv is double.
sorry for my english
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: V6 RC 7.0 released

Sat Jan 19, 2013 12:26 am

I downloaded new version of Winbox.exe from router and saved it on my desktop (as I always do) and after running Winbox, files listed below were created on my desktop:
advtool.crc, advtool.dll, dhcp.crc, dhcp.dll, hotspot.crc, hotspot.dll, mpls.crc, mpls.dll, ppp.crc, ppp.dll, roteros.crc, roteros.dll, roting4.crc, roting4.dll, secure.crc, secure.dll, system.crc, system.dll, wlan4.crc, wlan4.dll.

After I delete these files, Winbox creates files on desktop every time I start it.
 
lambert
Long time Member
Long time Member
Posts: 532
Joined: Fri Jul 23, 2010 1:09 am

Re: V6 RC 7.0 released

Sat Jan 19, 2013 1:16 am

Why it show me itself, or this is normal ?

On demo2.mt.lv all is ok.
On demo.mt.lv is double.
I think it is normal if the mikrotik is the only one doing discovery protocol on the interface.

If there are other devices participating in discover, I don't see the current RouterOS device listed on the interface. It's been that way from 5.x for me anyway.
 
marcin21
Member Candidate
Member Candidate
Posts: 188
Joined: Tue May 04, 2010 4:50 pm

Re: V6 RC 7.0 released

Sat Jan 19, 2013 3:40 am

I discovered that after upgrade from 5.18,5.20,5.22 to 6.0rc7
interfaces/bridges just dissapears. So far i've upgraded four x86 units
and three of them got up without bridges at all. Therefore Ip adresses
are binded to "unknown" interface. Mess...
First I thought that it was only 5.22>6,0rc7 path that introduces a problem.
But, few minutes ago I encountered the same situation upgrading 5.18>6.0rc7.
 
TonyJr
Member Candidate
Member Candidate
Posts: 201
Joined: Sat Nov 12, 2011 1:30 am
Location: UK
Contact:

Re: V6 RC 7.0 released

Sat Jan 19, 2013 4:21 am

it is weekend wait for the official forum post on monday, otherwise this thread will be ignored. they have done a good job this time :) please. patience!
 
TerAnYu
newbie
Posts: 25
Joined: Sun Jun 20, 2010 1:46 pm
Location: Russia, Novosibirsk

Re: V6 RC 7.0 released

Sat Jan 19, 2013 10:23 am

After installing the problems started:
1. Decreased the frequency to 100 MHz
2. Constant rebooting and not revert back, if not to use RS232
RouterBOOT booter 3.02

RouterBoard 450G

CPU frequency: 100 MHz
  Memory size: 256 MiB
    NAND size: 512 MiB

------

RouterBOOT booter 3.02

RouterBoard 450G

CPU frequency: 680 MHz
  Memory size: 256 MiB
    NAND size: 512 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
MikroTik 6.0rc7
MikroTik Login: Oops[#1]:
Cpu 0
$ 0   : 00000000 00000001 00000000 fffffffe
$ 4   : cec3d500 00000000 00000000 c02d2410
$ 8   : 0000003c c02391d4 0000cc34 cd0acb40
$12   : cdd7f42c 00000003 ffffffff 000086dd
$16   : cdc8f540 cec3d500 00000000 00000000
$20   : c0391fcc 00000001 00000000 00000000
$24   : 0000000c 134f4c7a
$28   : cf6d0000 cf6d1c58 cec3d500 c029cc50
Hi    : 00000064
Lo    : 000006ca
epc   : cf59ca68 udpv6_queue_rcv_skb+0x5c/0x77c [ipv6@0xcf580000]
    Not tainted
ra    : c029cc50 release_sock+0x94/0x108
Status: 1000d203    KERNEL EXL IE
Cause : 00800008
BadVA : 00000030
PrId  : 00019374 (MIPS 24Kc)
Process net (pid: 219, threadinfo=cf6d0000, task=cf5fde30, tls=7766d770)
Stack : cdc8f180 cd25c050 cd25c050 00000000 cec3d500 cdc8f540 c0420000 c029cc50
        000000a4 ffffffff cec3d70c cec3d70c 00000000 cec3d70c 00000000 cf6d1ee0
        cdfafea0 00000000 00000074 cf59df00 0000007c c02deb00 cf6d1efc cf6d1d30
        00000008 00000001 00000000 00000000 cf6d1cd8 cdfafea0 00000000 00000000
        0000000c 00000000 00000000 00001104 00000000 ff020000 00000000 00000000
        ...
Call Trace:
[<cf59ca68>] udpv6_queue_rcv_skb+0x5c/0x77c [ipv6@0xcf580000]
[<c029cc50>] release_sock+0x94/0x108
[<cf59df00>] udpv6_sendmsg+0x80c/0x980 [ipv6@0xcf580000]
[<c0298e34>] sock_sendmsg+0x84/0x9c
[<c029b424>] sys_sendto+0xcc/0x10c
[<c010dd10>] stack_done+0x20/0x44


Code: 8e020048  2403fffe  00621024 <8c420030> 30420004  14400008  32420004  02202021  00002821
---[ end trace df72217082fc4575 ]---
Kernel panic - not syncing: Fatal exception in interrupt

panicSaver: dumping panic to flash
flash: erase f
flash: prg f
spi_program_sector 0000000f
Rebooting in 1 seconds..

RouterBOOT booter 3.02

RouterBoard 450G

CPU frequency: 680 MHz
  Memory size: 256 MiB
    NAND size: 512 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
MikroTik 6.0rc7
MikroTik Login: Oops[#1]:
Cpu 0
$ 0   : 00000000 00000001 00000000 fffffffe
$ 4   : ceca2fc0 00000000 00000000 c02d2410
$ 8   : 0000003c c02391d4 000037c2 cd6a7660
$12   : ffffffff 00000003 ffffffff 000086dd
$16   : cf7bf6c0 ceca2fc0 00000000 00000000
$20   : c0391fcc 00000001 00000000 00000000
$24   : 00000000 00000000
$28   : cf6d2000 cf6d3c58 ceca2fc0 c029cc50
Hi    : 00000020
Lo    : 69a36992
epc   : cf59ca68 udpv6_queue_rcv_skb+0x5c/0x77c [ipv6@0xcf580000]
    Not tainted
ra    : c029cc50 release_sock+0x94/0x108
Status: 1000d203    KERNEL EXL IE
Cause : 00800008
BadVA : 00000030
PrId  : 00019374 (MIPS 24Kc)
Process net (pid: 219, threadinfo=cf6d2000, task=cf5fa280, tls=770d7770)
Stack : cdfba3c0 cf7e9a50 cf7e9a50 00000000 ceca2fc0 cf7bf6c0 c0420000 c029cc50
        0000009f ffffffff ceca31cc ceca31cc 00000000 ceca31cc 00000000 cf6d3ee0
        cdfcd680 00000000 0000006f cf59df00 00000077 c02deb00 cf6d3efc cf6d3d30
        00000008 00000001 00000000 00000000 cf6d3cd8 cdfcd680 00000000 00000000
        00000004 00000000 00000000 00001104 00000000 ff020000 00000000 00000000
        ...
Call Trace:
[<cf59ca68>] udpv6_queue_rcv_skb+0x5c/0x77c [ipv6@0xcf580000]
[<c029cc50>] release_sock+0x94/0x108
[<cf59df00>] udpv6_sendmsg+0x80c/0x980 [ipv6@0xcf580000]
[<c0298e34>] sock_sendmsg+0x84/0x9c
[<c029b424>] sys_sendto+0xcc/0x10c
[<c010dd10>] stack_done+0x20/0x44


Code: 8e020048  2403fffe  00621024 <8c420030> 30420004  14400008  32420004  02202021  00002821
---[ end trace 14a0ee4ef2829e9f ]---
Kernel panic - not syncing: Fatal exception in interrupt

panicSaver: dumping panic to flash
flash: erase f
flash: prg f
spi_program_sector 0000000f
Rebooting in 1 seconds..

RouterBOOT booter 3.02

RouterBoard 450G

CPU frequency: 680 MHz
  Memory size: 256 MiB
    NAND size: 512 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
MikroTik 6.0rc7
MikroTik Login:
I had to return to rc6.
ROS: 6.[latest]
 
tkgit
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Sun Dec 23, 2012 8:32 am
Location: Dunedin, NZ
Contact:

Re: v6 rc7 released

Sat Jan 19, 2013 2:05 pm

can mikrotik team add find & replace feature in winbox?
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

6.0rc7

Sat Jan 19, 2013 3:30 pm

RB433UAH

RouterOS + enable MetaROUTER >>> random crash RouterOS
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6 rc7 released

Sat Jan 19, 2013 8:00 pm

and routing marks don't work... reverted to rc6 -> all ok.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
mattsawatzky
newbie
Posts: 41
Joined: Wed Oct 27, 2010 12:43 am

Re: 6.0rc7

Mon Jan 21, 2013 7:46 am

RB433UAH

RouterOS + enable MetaROUTER >>> random crash RouterOS
Had this back in RC5 at least. Using a 750. Had to manually go out and recycle the router.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: V6 RC 7.0 released

Mon Jan 21, 2013 12:24 pm

I discovered that after upgrade from 5.18,5.20,5.22 to 6.0rc7
interfaces/bridges just dissapears. So far i've upgraded four x86 units
and three of them got up without bridges at all. Therefore Ip adresses
are binded to "unknown" interface. Mess...
First I thought that it was only 5.22>6,0rc7 path that introduces a problem.
But, few minutes ago I encountered the same situation upgrading 5.18>6.0rc7.
we checked two systems, x86. they both upgraded fine from v5.18 and v5.22 and kept all their bridge configuration. could you send us your complete config to support? maybe some other problem caused this. supout.rif files from v5 and v6 would be appreciated
No answer to your question? How to write posts
 
hci
Long time Member
Long time Member
Posts: 597
Joined: Fri May 28, 2004 5:10 pm

Re: V6 RC 7.0 released

Mon Jan 21, 2013 5:41 pm

I discovered that after upgrade from 5.18,5.20,5.22 to 6.0rc7
interfaces/bridges just dissapears. So far i've upgraded four x86 units
and three of them got up without bridges at all. Therefore Ip adresses
are binded to "unknown" interface. Mess...
First I thought that it was only 5.22>6,0rc7 path that introduces a problem.
But, few minutes ago I encountered the same situation upgrading 5.18>6.0rc7.
Upgraded some MIPSBE and PPC based routers with a few bridge interfaces and did encounter any issues. Perhaps this is just a x86 issue? Anyone else see this?
 
blingblouw
Member Candidate
Member Candidate
Posts: 273
Joined: Wed Aug 25, 2010 9:43 am

Re: v6 rc7 released

Mon Jan 21, 2013 8:37 pm

My bridges were fine after upgrading to rc7 but I am seeing lots of random reboots - think it has to do with KVM, sent support a mail
 
tetecko
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sun Jun 11, 2006 7:44 pm

Re: v6 rc7 released

Mon Jan 21, 2013 11:20 pm

ipv6 - added setting to disable forwarding;

how exactly is working this feature, how can I get my IPv6 address on box? I set up ipv6/setting/forward: no , but how I can get my IPv6 address now?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: V6 RC 7.0 released

Tue Jan 22, 2013 1:12 pm

I downloaded new version of Winbox.exe from router and saved it on my desktop (as I always do) and after running Winbox, files listed below were created on my desktop:
advtool.crc, advtool.dll, dhcp.crc, dhcp.dll, hotspot.crc, hotspot.dll, mpls.crc, mpls.dll, ppp.crc, ppp.dll, roteros.crc, roteros.dll, roting4.crc, roting4.dll, secure.crc, secure.dll, system.crc, system.dll, wlan4.crc, wlan4.dll.

After I delete these files, Winbox creates files on desktop every time I start it.
What version of Windows are you using? What other software is running? Maybe some antivirus programs?
No answer to your question? How to write posts
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: V6 RC 7.0 released

Tue Jan 22, 2013 7:31 pm

I downloaded new version of Winbox.exe from router and saved it on my desktop (as I always do) and after running Winbox, files listed below were created on my desktop:
advtool.crc, advtool.dll, dhcp.crc, dhcp.dll, hotspot.crc, hotspot.dll, mpls.crc, mpls.dll, ppp.crc, ppp.dll, roteros.crc, roteros.dll, roting4.crc, roting4.dll, secure.crc, secure.dll, system.crc, system.dll, wlan4.crc, wlan4.dll.
After I delete these files, Winbox creates files on desktop every time I start it.
What version of Windows are you using? What other software is running? Maybe some antivirus programs?
It's funny, but I have just checked once again and it does not happen anymore. Did You fixed it telepathically? ;)
I guess that Winbox couldn't access some path and downloaded its files to current directory.
Anyway, everything is OK now, thank You. :)
 
doush
Long time Member
Long time Member
Posts: 625
Joined: Thu Jun 04, 2009 3:11 pm

Re: v6 rc7 released

Tue Jan 22, 2013 7:38 pm

normis,
Why you dont make this post a universal sticky in all forum so people can see easily and test more ?
 
tetecko
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Sun Jun 11, 2006 7:44 pm

Re: v6 rc7 released

Tue Jan 22, 2013 7:39 pm

ipv6 - added setting to disable forwarding;

how exactly is working this feature, how can I get my IPv6 address on box? I set up ipv6/setting/forward: no , but how I can get my IPv6 address now?
I answer my self, its working, but you don't have chance see it :) there is nothing in ipv6/address nor in ipv6/routes but you get and adress and google is pingable .. :) miracle :)))
 
krakenant
Member Candidate
Member Candidate
Posts: 136
Joined: Sat Feb 06, 2010 6:32 am

Re: v6 rc7 released

Tue Jan 22, 2013 8:07 pm

I try not to bust your chops too much on beta and release candidate bugs, but the bugs I have come across with the CloudCore Router and DHCP are borderline reprehensible. The config we are using works everywhere on every piece of equipment on 5.22. On the latest RC7, DHCP doesn't work with a src address set, last night when I went from a pre-release RC7 to the officially released RC7, I had to wipe the configuration from the device and reconfigure it to get the DHCP server working, when rebooting the CCR today the DHCP failed to work until I disabled and and enabled it. Aside from that the CCR produced 200ms pings on a link that is normally 50ms, and only passed 100Mbps on a hotspot network that usually passes 160Mbps plus of traffic (edit: figured this one out, the firewall code isn't optimized to use all of the cores, not sure what the point in letting it go out was given the firewall is generally one of the biggest consumers of the CPU and a fix is at least two weeks out).

Needless to say we are back on an x86 box on 5.22 this morning. I submitted a ticket this morning as well with the above issues. Posting this as more of a heads up for other users.
 
andrijco
just joined
Posts: 17
Joined: Mon Aug 23, 2010 3:45 am

Re: v6 rc7 released

Wed Jan 23, 2013 12:31 pm

routeros rc7 tilegx
when 3 fullview bgp instances are processed simultaneosly
router crashes and rebooted
but when i enable one instance after another giving each of them time proccess routes it works great until bgp flap
is this known issue ?
or i need to submit support.rif ?

same problem i noticed on rc4 x86 platform
 
marcin21
Member Candidate
Member Candidate
Posts: 188
Joined: Tue May 04, 2010 4:50 pm

Re: v6 rc7 released

Wed Jan 23, 2013 12:52 pm

Regarding these dissapearing bridges, I did some further investigations, and what I see,
is that those bridges don't dissapear but after full boot up of my
Intel D945G sejt, bridge appears after about 2 minutes! First I thought maybe because
i had admin managed mac adress and automac=no set on this bridge. But it's not the issue.
Time after boot up needed to bridge to appear made my hardwre watchdog rebooted
router. on 5.x problem doesn't exist.
As a proof I did manage to log into router "without" bridge1 and added it manually, then after
some time ( about 2min ) the bridge appears again so I've got two bridges called
"bridge1" and afaik it shouldn't be possible.
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Wed Jan 23, 2013 1:02 pm

Regarding these dissapearing bridges, I did some further investigations, and what I see,
is that those bridges don't dissapear but after full boot up of my
Intel D945G sejt, bridge appears after about 2 minutes! First I thought maybe because
i had admin managed mac adress and automac=no set on this bridge. But it's not the issue.
Time after boot up needed to bridge to appear made my hardwre watchdog rebooted
router. on 5.x problem doesn't exist.
As a proof I did manage to log into router "without" bridge1 and added it manually, then after
some time ( about 2min ) the bridge appears again so I've got two bridges called
"bridge1" and afaik it shouldn't be possible.
You are using MAC address to connect. This is a very bad idea. Items will appear slowly, and this is not a bug. MAC address is for debug/extreme uses. Not for normal configuration.
No answer to your question? How to write posts
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6 rc7 released

Wed Jan 23, 2013 2:29 pm

and this is not a bug
identical interface names are not a bug?.. Normis, are you kidding? :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Wed Jan 23, 2013 2:41 pm

and this is not a bug
identical interface names are not a bug?.. Normis, are you kidding? :)
Connect to IP and then check. From MAC connection you can expect all kinds of wonders if the connection is slow.
No answer to your question? How to write posts
 
fourroses
just joined
Posts: 1
Joined: Tue Jan 15, 2013 2:45 pm

Re: v6 rc7 released

Wed Jan 23, 2013 5:08 pm

and this is not a bug
identical interface names are not a bug?.. Normis, are you kidding? :)
Connect to IP and then check. From MAC connection you can expect all kinds of wonders if the connection is slow.
Same here on D645G SEJT, and I am not connected via winbox - I am on board directly, with kbd and LCD.
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6 rc7 released

Wed Jan 23, 2013 8:39 pm

On RB951-2n (but I suppose it affects all the other routerboards) there is a problem setting the /ip dns cache-size parameter:

> /ip dns set cache-size=

CacheSize ::= Num[KiB]
Num ::= 512..4294967295 (integer number)

----------------------------

/ip dns set cache-size=2048KiB
value of cache-size contains invalid trailing characters

----------------------------

/ip dns set cache-size=2048K
/ip dns export
# jan/02/1970 00:10:02 by RouterOS 6.0rc7
# software id = ITFF-9NIU
#
/ip dns
set allow-remote-requests=yes cache-size=2048000KiB max-udp-packet-size=512

-----------------------------

/ip dns set cache-size=2048
/ip dns export verbose
# jan/02/1970 00:11:06 by RouterOS 6.0rc7
# software id = ITFF-9NIU
#
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 \
query-server-timeout=2s query-total-timeout=10s servers=""

------------------------------

I hope it's clear enough.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6 rc7 released

Wed Jan 23, 2013 10:33 pm

it's as it was designed.
you set this value as a number in kibibytes, you shouldn't add 'KiB'
'k', 'M', etc. are standard Terminal suffixes, they just add necessary number of zeroes (like in Queues, you set max-limit in bits per second as '1000000', '1000k' or '1M', but not '1000kbps' - that's wrong)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6 rc7 released

Wed Jan 23, 2013 11:57 pm

it's as it was designed.
you set this value as a number in kibibytes, you shouldn't add 'KiB'
'k', 'M', etc. are standard Terminal suffixes, they just add necessary number of zeroes (like in Queues, you set max-limit in bits per second as '1000000', '1000k' or '1M', but not '1000kbps' - that's wrong)
So why "/ip dns export verbose" outputs the following?
/ip dns export verbose 
# jan/23/2013 22:54:44 by RouterOS 6.0rc7
# software id = 1FXC-EL87
#
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 query-server-timeout=2s query-total-timeout=10s servers=x.x.x.x,y.y.y.y
If you feed the same code on 6.0rc7 it won't be accepted.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6 rc7 released

Thu Jan 24, 2013 2:35 pm

I see...

at least rc4 accepts "set cache-size=2048KiB" format - so it was broken somewhere later. rc8 says 'invalid trailing characters' too
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
SoKaR
newbie
Posts: 47
Joined: Fri Dec 03, 2010 11:15 pm

Re: v6 rc7 released

Thu Jan 24, 2013 4:33 pm

L2TP-Client default-encryption is crashing the Router. First i tried RC7 now RC6 but same result.
1.jpg
2.jpg
You do not have the required permissions to view the files attached to this post.
 
krakenant
Member Candidate
Member Candidate
Posts: 136
Joined: Sat Feb 06, 2010 6:32 am

Re: v6 rc7 released

Thu Jan 24, 2013 4:56 pm

Duplicate or delayed bridges would explain some of the DHCP server issues I ran into.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6 rc7 released

Thu Jan 24, 2013 9:58 pm

routeros rc7 tilegx
when 3 fullview bgp instances are processed simultaneosly
router crashes and rebooted
but when i enable one instance after another giving each of them time proccess routes it works great until bgp flap
is this known issue ?
or i need to submit support.rif ?

same problem i noticed on rc4 x86 platform
This is due to the current routing implementation being single threaded.

A new routing engine is meant to be coming soon that will resolve this.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
LookinGooder
just joined
Posts: 3
Joined: Tue Jan 22, 2013 9:59 pm

Re: v6 rc7 released

Thu Jan 24, 2013 10:46 pm

Little bug on RB751G with 6rc7:

In Winbox (Windows7x64):
-open "Files"
-select any file in window "File list"
-press button "copy"
-then move mouse cursor to my desktop
-right click, select "paste"
-the selected file is copied to the desktop.

Then if I move mouse cursor to the window "File list" again and try to repeat the operation - nothing happened.

Solved by closing and re-opening the "File List" or copy-paste something from/to the desktop.

P.S. On WinXP this causes error message: "Cannot read from the source file or disk".
 
wispwest
Member
Member
Posts: 477
Joined: Tue May 19, 2009 3:48 am

Re: v6 rc7 released

Fri Jan 25, 2013 6:16 pm

RC7 is STILL broke!!! RB1100AH locks up when logging into it. Same problem with my 433AH I replaced it with. CPU was only 20%. Was fine for one day. Then when we log in to change queues or firewall rules, it locks up and reboots.

LOG = Router rebooted from improper shutdown
SUPOUT = Can't create one because it locks up before it makes it file
DOWNGRADE BACK TO 5.22 = Fixes the lockup problem
 
el berto
Member Candidate
Member Candidate
Posts: 197
Joined: Wed Sep 26, 2007 10:53 am

Re: v6 rc7 released

Fri Jan 25, 2013 7:15 pm

Where is ppp-client menu gone?
 
mik0s
just joined
Posts: 7
Joined: Fri Jan 25, 2013 7:27 pm

Re: v6 rc7 released

Fri Jan 25, 2013 7:35 pm

Troubles with v6 rc7 and Cloud Core. Need help http://forum.mikrotik.com/viewtopic.php?f=1&t=68771
 
User avatar
apteixeira
Trainer
Trainer
Posts: 50
Joined: Fri Oct 05, 2012 5:54 pm

Re: v6 rc7 released

Fri Jan 25, 2013 7:42 pm

Hello.

I am having problems with v6 rc7.
This is the second time that the router lost connectivity.

I can only access using MAC from another router with the same version and when I try to ping any ip this is the result:

132 (No buffer space available)

Has anyone experienced this issue?

Bye.

Image
 
wispwest
Member
Member
Posts: 477
Joined: Tue May 19, 2009 3:48 am

Re: v6 rc7 released

Sat Jan 26, 2013 4:15 am

ANOTHER RB100AH just locked up when I was logging in to change the speed on a simple queue. 2hr drive up to a mountain tower. NOT COOL MIKROTIK!!!!!

I know its my fault for testing beta, but this is RC7 shouldn't it be at least somewhat stable?!?!? Really getting tired of this, this is the 3rd router now doing the same thing.
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: v6 rc7 released

Sun Jan 27, 2013 3:33 am

ANOTHER RB100AH just locked up when I was logging in to change the speed on a simple queue. 2hr drive up to a mountain tower. NOT COOL MIKROTIK!!!!!

I know its my fault for testing beta, but this is RC7 shouldn't it be at least somewhat stable?!?!? Really getting tired of this, this is the 3rd router now doing the same thing.
"I know its my fault for testing beta" + "NOT COOL MIKROTIK!!!!!" = You are funny. :)

BTW: Watchdog didn't do it's job?
 
wispwest
Member
Member
Posts: 477
Joined: Tue May 19, 2009 3:48 am

Re: v6 rc7 released

Sun Jan 27, 2013 3:53 am

ANOTHER RB100AH just locked up when I was logging in to change the speed on a simple queue. 2hr drive up to a mountain tower. NOT COOL MIKROTIK!!!!!

I know its my fault for testing beta, but this is RC7 shouldn't it be at least somewhat stable?!?!? Really getting tired of this, this is the 3rd router now doing the same thing.
"I know its my fault for testing beta" + "NOT COOL MIKROTIK!!!!!" = You are funny. :)

BTW: Watchdog didn't do it's job?

my fault for testing beta, but this is RC7 shouldn't it be at least somewhat stable?!?!?

I would enable watchdog if I could log into long enough before it locks up!!!!!!
 
ste
Forum Guru
Forum Guru
Posts: 1813
Joined: Sun Feb 13, 2005 11:21 pm

AW: v6 rc7 released

Sun Jan 27, 2013 8:05 am

You missed a "!" ;-))
 
wispwest
Member
Member
Posts: 477
Joined: Tue May 19, 2009 3:48 am

Re: AW: v6 rc7 released

Sun Jan 27, 2013 8:12 pm

You missed a "!" ;-))
but this is RC7 shouldn't it be at least somewhat stable?!?!?

RC7 not SOMEWHAT stable!!!!!!!!!!!
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6 rc7 released

Sun Jan 27, 2013 10:09 pm

This conversion should help when dealing with RouterOS:

Beta = Alpha
RC though x.16 = Beta
.16 and higher = Stable

I never deploy a new RouterOS release unless I absolutely have to, and always test the features I use on VM's before deploying it.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6 rc7 released

Mon Jan 28, 2013 3:18 am

rc8 says 'invalid trailing characters' too
[admin@demo.mt.lv] > /ip dns export
# jan/28/2013 03:18:47 by RouterOS 6.0rc8
# software id = 0TLY-48W5
#
/ip dns
set cache-size=3048KiB max-udp-packet-size=512 servers=10.10.2.2


[admin@demo.mt.lv] > /ip dns set cache-size=3048KiB
value of cache-size contains invalid trailing characters

Yes, still not fixed.

How should I manage it in my script? Should I remove "KiB" after the size, or should I wait for Mikrotik to fix it?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6 rc7 released

Mon Jan 28, 2013 8:51 am

wispwest
Please attach Null Modem cable to your RouterBOARD 1100AH (during the lockup), is it possible to run any command on it?
Is there any response or output?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Mon Jan 28, 2013 9:10 am

RC7 is STILL broke!!! RB1100AH locks up when logging into it. Same problem with my 433AH I replaced it with. CPU was only 20%. Was fine for one day. Then when we log in to change queues or firewall rules, it locks up and reboots.

LOG = Router rebooted from improper shutdown
SUPOUT = Can't create one because it locks up before it makes it file
DOWNGRADE BACK TO 5.22 = Fixes the lockup problem
Connect serial cable and copy full output of the problem. If any crash happens, it will be visible on the serial output.
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Mon Jan 28, 2013 9:10 am

RC7 is STILL broke!!! RB1100AH locks up when logging into it. Same problem with my 433AH I replaced it with. CPU was only 20%. Was fine for one day. Then when we log in to change queues or firewall rules, it locks up and reboots.

LOG = Router rebooted from improper shutdown
SUPOUT = Can't create one because it locks up before it makes it file
DOWNGRADE BACK TO 5.22 = Fixes the lockup problem
Connect serial cable and copy full output of the problem. If any crash happens, it will be visible on the serial output.
No answer to your question? How to write posts
 
doush
Long time Member
Long time Member
Posts: 625
Joined: Thu Jun 04, 2009 3:11 pm

Re: v6 rc7 released

Mon Jan 28, 2013 4:40 pm

Ticket#2013011266000104

Still unreplied.

CCR is acting up when we export compact the configuration exactly like our x86 box that we would like to replace with it. x86 is also running RC7.
 
kgninfos
Member
Member
Posts: 387
Joined: Thu Jun 21, 2012 7:34 pm
Location: Earth
Contact:

Re: v6 rc7 released

Mon Jan 28, 2013 7:13 pm

i am getting 50-75% cpu uses(RB2011UAS-RM) with just about 7-8 hotspot users and 3-4Mbps bandwidth max
i am using layer7 based traffic prioritization
http://wiki.mikrotik.com/wiki/Basic_tra ... _protocols
and simple queues for bandwidth management

is this normal
 
Surtpp
just joined
Posts: 3
Joined: Thu Nov 29, 2012 11:10 pm

Re: v6 rc7 released

Tue Jan 29, 2013 12:26 am

Can I give a positive remark?

Using PPPoE client to run a VDSL2 modem I used to get 45ms pings (to XYZ server) on 5.22 and 6RC6. Nothing has changed except that now I put 6RC7 on the RB2011UAS-2HnD, and now I'm getting 30ms pings.

Maybe its the full moon? Who knows. But anyway, its nice!

Thanks MT.
 
SMARTNETT
just joined
Posts: 3
Joined: Mon Jan 28, 2013 6:04 pm

Re: V6 RC 7.0 released

Tue Jan 29, 2013 3:19 am

I discovered that after upgrade from 5.18,5.20,5.22 to 6.0rc7
interfaces/bridges just dissapears. So far i've upgraded four x86 units
and three of them got up without bridges at all. Therefore Ip adresses
are binded to "unknown" interface. Mess...
First I thought that it was only 5.22>6,0rc7 path that introduces a problem.
But, few minutes ago I encountered the same situation upgrading 5.18>6.0rc7.
we checked two systems, x86. they both upgraded fine from v5.18 and v5.22 and kept all their bridge configuration. could you send us your complete config to support? maybe some other problem caused this. supout.rif files from v5 and v6 would be appreciated

I HAVE THE SAME PROBLEM WITH X86 SYSTEM, 5.14 TO 6RC7 AND ALL THE INTERFACES CANT VIW VIA IP AL THE SYSTEM IS FINE BUT NEVER VIA IP
 
User avatar
erebusodora
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Mon Jan 23, 2012 3:46 pm
Location: Bulgaria

Re: v6 rc7 released

Tue Jan 29, 2013 8:29 am

ANOTHER RB100AH just locked up when I was logging in to change the speed on a simple queue. 2hr drive up to a mountain tower. NOT COOL MIKROTIK!!!!!

I know its my fault for testing beta, but this is RC7 shouldn't it be at least somewhat stable?!?!? Really getting tired of this, this is the 3rd router now doing the same thing.
This is because the bugs from the previous version unmade starting a new ..... With the new version like driving in the dark .. Surely they do not want to fix bugs in previous versions (5.21 or 6 RC6) and rush to version 7 or 8 or 9.
Rule one:If it works do not touch it or upgrades!
 
estdata
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Mon Feb 20, 2012 9:05 pm
Contact:

Re: v6 rc7 released

Tue Jan 29, 2013 11:11 am

6.0 RC7 is not possible to use an external hard disk drive is the problem, not connecting and are not visible from the outside. Routerboard OS disc that filesysteems uses?

2. fix please rstp and stp protokol, highly volatile Internet speed
don't forget to give me karma if got help
....
 
kgninfos
Member
Member
Posts: 387
Joined: Thu Jun 21, 2012 7:34 pm
Location: Earth
Contact:

Re: v6 rc7 released

Tue Jan 29, 2013 6:17 pm

i got my second random reboot
i the device was up for last 2 days and suddenly it got restarted and in log there is nothing(log cleared)
what's going on??
 
mtmx80
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Wed Mar 16, 2011 11:12 pm

Re: v6 rc7 released

Tue Jan 29, 2013 8:58 pm

I experience the same. Router is up for 2-3 days and reboots while there shouldn't be any load on it (after midnight).

One more think:
[] > /system routerboard print
       routerboard: yes
             model: 2011UAS
     serial-number: 374702DC2387
  current-firmware: 
  upgrade-firmware: 3.02
Where is current-firmware version? It was there in version 6.0rc6 and it was up to date.
[] > /system resource print 
                   uptime: 19h48m6s
                  version: 6.0rc7
               build-time: Jan/18/2013 13:04:05
              free-memory: 101.2MiB
             total-memory: 128.0MiB
                      cpu: MIPS 74Kc V4.12
                cpu-count: 1
            cpu-frequency: 600MHz
                 cpu-load: 1%
           free-hdd-space: 46.9MiB
          total-hdd-space: 64.0MiB
  write-sect-since-reboot: 3329
         write-sect-total: 367793
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: RB2011UAS
                 platform: MikroTik



i got my second random reboot
i the device was up for last 2 days and suddenly it got restarted and in log there is nothing(log cleared)
what's going on??
 
LAQ
just joined
Posts: 7
Joined: Tue Jan 29, 2013 11:40 pm

Re: v6 rc7 released

Wed Jan 30, 2013 12:19 am

Hi,

Several Issue's..

We use XENServer to virtualize our routers the DC and testing v6 RC7..

In HVM Mode we cannot run the installer and does not get to the initial module selection page.

If we Install 5.22 and upgrade to v6 RC7 on rebooting we end up with a kernel panic on rebooting the vm after the module upgrades.

Regards

Lee
 
User avatar
jhheider
newbie
Posts: 48
Joined: Fri Sep 30, 2011 5:04 pm

Re: v6 rc7 released

Wed Jan 30, 2013 1:48 am

Insane number of reboots on a 750 with 6.0rc7:
Jan 28 12:11:13 RB750 router was rebooted without proper shutdown
Jan 28 16:18:52 RB750 router was rebooted without proper shutdown
Jan 28 17:08:49 RB750 router was rebooted without proper shutdown
Jan 28 21:28:27 RB750 router was rebooted without proper shutdown
Jan 28 22:18:28 RB750 router was rebooted without proper shutdown
Jan 28 22:38:30 RB750 router was rebooted without proper shutdown
Jan 28 23:38:27 RB750 router was rebooted without proper shutdown
Jan 29 03:08:29 RB750 router was rebooted without proper shutdown
Jan 29 03:58:30 RB750 router was rebooted without proper shutdown
Jan 29 05:08:27 RB750 router was rebooted without proper shutdown
Jan 29 05:38:27 RB750 router was rebooted without proper shutdown
Jan 29 06:58:27 RB750 System rebooted because of kernel failure
Jan 29 06:58:27 RB750 router was rebooted without proper shutdown
Jan 29 09:38:27 RB750 router was rebooted without proper shutdown
Jan 29 10:08:29 RB750 System rebooted because of kernel failure
Jan 29 10:08:29 RB750 router was rebooted without proper shutdown
Jan 29 11:28:28 RB750 System rebooted because of kernel failure
Jan 29 11:28:28 RB750 router was rebooted without proper shutdown
Jan 29 11:48:29 RB750 router was rebooted without proper shutdown
Jan 29 13:38:34 RB750 router was rebooted without proper shutdown
Jan 29 14:18:27 RB750 router was rebooted without proper shutdown
Jan 29 16:28:30 RB750 router was rebooted without proper shutdown
Jan 29 16:48:28 RB750 router was rebooted without proper shutdown
Jan 29 17:28:27 RB750 router was rebooted without proper shutdown
Jan 29 18:08:27 RB750 router was rebooted without proper shutdown
Ticket #2013013066000026. Two auto-sups and a manual.
 
kgninfos
Member
Member
Posts: 387
Joined: Thu Jun 21, 2012 7:34 pm
Location: Earth
Contact:

Re: v6 rc7 released

Wed Jan 30, 2013 6:25 am

i think my cpu uses is 100% due to ddos
in connection log i can see an ip 69.171.248.16 and port 80 in list but when the site is opened it shows
for (;;); {"t":"refresh","reason":120,"seq":0}
also am getting a lots of connection to a specific ip can any one tell is there any issue(screenshot attached)
You do not have the required permissions to view the files attached to this post.
 
User avatar
meschaninovn
just joined
Posts: 22
Joined: Thu Aug 09, 2012 11:23 pm
Contact:

Re: v6 rc7 released

Thu Jan 31, 2013 9:09 pm

In the menu "ip - neighbor list" all dynamic interfaces are available for the detection... i can`t disable this...
You do not have the required permissions to view the files attached to this post.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8318
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6 rc7 released

Thu Jan 31, 2013 11:19 pm

In the menu "ip - neighbor list" all dynamic interfaces are available for the detection... i can`t disable this...
try

ros code

/ip neighbor discovery settings set default=no
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
meschaninovn
just joined
Posts: 22
Joined: Thu Aug 09, 2012 11:23 pm
Contact:

Re: v6 rc7 released

Fri Feb 01, 2013 12:17 am

In the menu "ip - neighbor list" all dynamic interfaces are available for the detection... i can`t disable this...
try

ros code

/ip neighbor discovery settings set default=no
Thanks)
 
estdata
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Mon Feb 20, 2012 9:05 pm
Contact:

Re: v6 rc7 released

Fri Feb 01, 2013 7:20 am

i am getting 50-75% cpu uses(RB2011UAS-RM) with just about 7-8 hotspot users and 3-4Mbps bandwidth max
i am using layer7 based traffic prioritization
http://wiki.mikrotik.com/wiki/Basic_tra ... _protocols
and simple queues for bandwidth management

is this normal

Why you are using a Layer-7. And if you look at the cpu so high up, over your log,
or/interface port1 torch

I will rise 20-40% of cpu if you throw things or big traffic
Steady even if someone DDoS attack to you
don't forget to give me karma if got help
....
 
kgninfos
Member
Member
Posts: 387
Joined: Thu Jun 21, 2012 7:34 pm
Location: Earth
Contact:

Re: v6 rc7 released

Fri Feb 01, 2013 6:37 pm

i figured out the issue
it was due to the layer 7 prioritization
disabled that and CPU load is not 4-5%
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6 rc7 released

Sun Feb 03, 2013 3:51 am

[admin@demo.mt.lv] > /system resource print
uptime: 6h34m47s
version: 6.0rc8
build-time: Feb/01/2013 14:37:45
free-memory: 32.7MiB
total-memory: 64.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 300MHz
cpu-load: 38%
free-hdd-space: 49.7MiB
total-hdd-space: 64.0MiB
write-sect-since-reboot: 11435
write-sect-total: 2255972
bad-blocks: 0.1%
architecture-name: mipsbe
board-name: RB433
platform: MikroTik
[admin@demo.mt.lv] > /ip dns export
# feb/03/2013 03:46:58 by RouterOS 6.0rc8
# software id = 0TLY-48W5
#
/ip dns
set cache-size=3048KiB max-udp-packet-size=512 servers=10.10.2.2

[admin@demo.mt.lv] > /ip dns set cache-size=3048KiB
value of cache-size contains invalid trailing characters
Please, fix this... I think it's really simple! The resulting export script should be compatible...

I don't think I need to open a ticket and/or send a supout.rif... do I?

Thanks!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Mon Feb 04, 2013 11:07 am

Hm, sorry but can't repeat it yet.

ros code

[admin@MikroTik] /ip dns> set cache-size=30000    
[admin@MikroTik] /ip dns> print 
                servers: 
        dynamic-servers: 192.168.88.1,10.5.8.1
  allow-remote-requests: yes
    max-udp-packet-size: 4096
   query-server-timeout: 2s
    query-total-timeout: 10s
             cache-size: 30000KiB
          cache-max-ttl: 1w
             cache-used: 10KiB
[admin@MikroTik] /ip dns> export
# jan/07/1970 21:28:30 by RouterOS 6.0rc7
# software id = LB6Y-8QAY
#
/ip dns
set allow-remote-requests=yes cache-size=30000KiB
/ip dns static
add address=192.168.88.1 name=router
[admin@MikroTik] /ip dns> /ip dns
[admin@MikroTik] /ip dns> set allow-remote-requests=yes cache-size=30000KiB
[admin@MikroTik] /ip dns>
No answer to your question? How to write posts
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6 rc7 released

Tue Feb 05, 2013 12:18 am

Hm, sorry but can't repeat it yet.
On what ROS version are you trying it? This behaviour appeared only in 6.0rc7 (tested on RB951-2n and RB1200), and it's still like this in 6.0rc8 (build-time: Feb/04/2013 13:25:4) found on demo.mt.lv.

To reproduce this, just log into demo.mt.lv and issue the command:
[admin@demo.mt.lv] > /ip dns
[admin@demo.mt.lv] /ip dns> set allow-remote-requests=yes cache-size=30000KiB
value of cache-size contains invalid trailing characters

P.S.: about build time: I don't tink that seconds lack the leading 0 intentionally (13:25:4).
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v6 rc7 released

Tue Feb 05, 2013 2:02 am

ros code

[admin@dydyrydy14780554] /ip dns> set cache-size=8192KiB
value of cache-size contains invalid trailing characters
[admin@dydyrydy14780554] /ip dns> /
[admin@dydyrydy14780554] > /system resource 
[admin@dydyrydy14780554] /system resource> print 
                   uptime: 5h26m41s
                  version: 6.0rc8
               build-time: Feb/04/2013 13:25:46
               board-name: RB751U-2HnD
As paoloaga wrote, this problem appeared in ver. 6.0rc7 and still exists.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Tue Feb 05, 2013 8:54 am

I have latest rc8 and CCR router. I don't see this issue. Try this on som other router, no DEMO router where you have no write permissions.
No answer to your question? How to write posts
 
incubusru
just joined
Posts: 4
Joined: Tue Feb 05, 2013 11:38 am

Re: v6 rc7 released

Tue Feb 05, 2013 11:55 am

Image
ether3, ether4 - 10gb
Dropping tx packets on vlan193. How it fix?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Tue Feb 05, 2013 12:06 pm

you don't need to fix that. those are invalid packets that are being ignored in the router. RC8 and above will not show them
No answer to your question? How to write posts
 
incubusru
just joined
Posts: 4
Joined: Tue Feb 05, 2013 11:38 am

Re: v6 rc7 released

Tue Feb 05, 2013 12:28 pm

you don't need to fix that. those are invalid packets that are being ignored in the router. RC8 and above will not show them
Did it normal, when tx drops +50~+150 per second, but rx drops always zero?

ps

drops invalid ip packets or ethernet frames?
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6 rc7 released

Tue Feb 05, 2013 6:33 pm

I have latest rc8 and CCR router. I don't see this issue. Try this on som other router, no DEMO router where you have no write permissions.
This is ROS 6.0rc7 on a RB2011UAS:
[admin@AgalandGW] > /system resource print
uptime: 2w3d20h2m17s
version: 6.0rc7
build-time: Jan/18/2013 13:04:05
free-memory: 97.9MiB
total-memory: 128.0MiB
cpu: MIPS 74Kc V4.12
cpu-count: 1
cpu-frequency: 600MHz
cpu-load: 14%
free-hdd-space: 110.8MiB
total-hdd-space: 128.0MiB
write-sect-since-reboot: 8169
write-sect-total: 45721
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB2011UAS
platform: MikroTik


[admin@AgalandGW] > /ip dns set cache-size=2048KiB
value of cache-size contains invalid trailing characters
I don't have an RC6.0rc8 at hand, right now, I will try to download it later.

Anyway, on the demo router, the error appears at the command parsing level, before reaching the user write permission deny.
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: v6 rc7 released

Wed Feb 06, 2013 12:33 am

I have latest rc8 and CCR router. I don't see this issue.
paoloaga and me made tests on 'mipsbe' platform, maybe 'tile' is not affected with this issue?
Demo routers are also 'mipsbe'.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
pyfgcrl
just joined
Posts: 2
Joined: Tue Nov 20, 2012 11:26 pm

Re: v6 rc7 released

Thu Feb 07, 2013 5:19 am

Any chance that 6rd is going to find its way into RouterOS v6? at&t and many large ISPs like it are now using 6rd to deploy IPv6. Not having it in RouterOS is a big issue for our clients that use RouterOS on the edge.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Thu Feb 07, 2013 9:14 am

you are right, this only affects MIPS-BE platform
No answer to your question? How to write posts
 
heviejob
Member Candidate
Member Candidate
Posts: 168
Joined: Mon Nov 30, 2009 4:54 pm

Re: v6 rc7 released

Thu Feb 07, 2013 7:58 pm

I upgraded a RB450G not its bricked. I can't access it via winbox
nor reset the unit. How can I recover it.
It had 5.23 the upgraded to v6rc7.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Fri Feb 08, 2013 7:58 am

I upgraded a RB450G not its bricked. I can't access it via winbox
nor reset the unit. How can I recover it.
It had 5.23 the upgraded to v6rc7.
connect serial console, and see what it says. netinstall will probably recover it: http://wiki.mikrotik.com/wiki/Manual:Netinstall
No answer to your question? How to write posts
 
alexjhart
Member Candidate
Member Candidate
Posts: 192
Joined: Thu Jan 20, 2011 8:03 pm

Re: v6 rc7 released

Fri Feb 08, 2013 10:05 am

I am dealing with random reboots on rc7 with CCR1036.
-----
Alex Hart

The Brothers WISP
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Fri Feb 08, 2013 12:28 pm

I am dealing with random reboots on rc7 with CCR1036.
Please try the version with fixes for this problem: http://www.mikrotik.com/download/share/ ... 6.0rc9.npk
No answer to your question? How to write posts
 
heviejob
Member Candidate
Member Candidate
Posts: 168
Joined: Mon Nov 30, 2009 4:54 pm

Re: v6 rc7 released

Mon Feb 18, 2013 8:20 pm

I upgraded a RB450G not its bricked. I can't access it via winbox
nor reset the unit. How can I recover it.
It had 5.23 the upgraded to v6rc7.
connect serial console, and see what it says. netinstall will probably recover it: http://wiki.mikrotik.com/wiki/Manual:Netinstall
Netinstall recovered it. Am waiting for the stable version now.
 
alexjhart
Member Candidate
Member Candidate
Posts: 192
Joined: Thu Jan 20, 2011 8:03 pm

Re: v6 rc7 released

Sat Feb 23, 2013 6:32 am

I am dealing with random reboots on rc7 with CCR1036.
Please try the version with fixes for this problem: http://www.mikrotik.com/download/share/ ... 6.0rc9.npk
I haven't had any issues with reboots while on rc9 (13 days uptime so far). Many thanks! :)
-----
Alex Hart

The Brothers WISP
 
User avatar
ConnectiviaSrl
just joined
Posts: 7
Joined: Sat May 19, 2012 11:04 am
Location: Naples Area / Italy
Contact:

Re: v6 rc7 released

Mon Mar 18, 2013 8:08 am

and this is not a bug
identical interface names are not a bug?.. Normis, are you kidding? :)
Connect to IP and then check. From MAC connection you can expect all kinds of wonders if the connection is slow.

We had the same problem. The bridges disappear after reboot in both cases : connected trough MAC or IP. moreover the local connection used to manage the router is with 0.1ms so no slow connection issue can be involved.

Th sub thread started by marcin21 apparently has no final solved answer so I do not know if it was solved or less.

please whenever solution or workaraoud where found , show them to us.
Networking - R&D Team @ Connectivia Srl
http://www.connectivia.it
 
rower
newbie
Posts: 25
Joined: Wed Feb 25, 2009 2:39 pm

Re: v6 rc7 released

Thu Mar 21, 2013 4:23 pm

This conversion should help when dealing with RouterOS:

Beta = Alpha
RC though x.16 = Beta
.16 and higher = Stable

I never deploy a new RouterOS release unless I absolutely have to, and always test the features I use on VM's before deploying it.
i just wander, if you do feel that it is right ?
 
User avatar
ConnectiviaSrl
just joined
Posts: 7
Joined: Sat May 19, 2012 11:04 am
Location: Naples Area / Italy
Contact:

Re: v6 rc7 released

Thu Mar 21, 2013 4:51 pm

not 100% because on other x86 nodes it 's working like a charme. so?
Networking - R&D Team @ Connectivia Srl
http://www.connectivia.it
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24264
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6 rc7 released

Fri Mar 22, 2013 9:07 am

This thread is about an old version. Please upgrade to rc11 or rc12 and if problem repeats, post in the relevant topics.
No answer to your question? How to write posts

Who is online

Users browsing this forum: Google [Bot] and 126 guests