Community discussions

MikroTik App
 
omidh
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 54
Joined: Tue Oct 27, 2009 4:00 pm
Location: Iran
Contact:

Cisco VPN Client with Mikrotik as vpn server

Wed Jan 30, 2013 2:19 pm

Hi all.
Is it possible to configure Mikrotik as vpn server to work with Cisco VPN client?
or cisco vpn client use proprietary protocol that only works with Cisco devices?
if yes How?
 
omidh
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 54
Joined: Tue Oct 27, 2009 4:00 pm
Location: Iran
Contact:

Re: Cisco VPN Client with Mikrotik as vpn server

Sat Feb 02, 2013 10:17 am

is there anybody to help me on this?
 
onyx3821
just joined
Posts: 7
Joined: Wed Mar 12, 2014 9:28 pm

Re: Cisco VPN Client with Mikrotik as vpn server

Mon Mar 24, 2014 9:01 pm

I saw someone in another thread reply that this is impossible because Cisco (in their "Cisco way") uses vpnc instead of l2tp or pptp to make the connection, and Mikrotik doesn't support it. Since linux DOES, there was a way to do it in Metarouter, but that is faulty since after a reboot the bridge ports disappear.

Waiting for Mikrotik to figure out that this is actually the Cisco buster - if we could replace ASA's that are currently acting as VPN gateways, and have the client side never know the difference, that'd be awesome !

Rick
www.navitend.com
Thanks,

Rick Smith, Network Engineer
rsmith@navitend.com | www.navitend.com
P (973) 448 0070 | F (973) 448 0264
23 US Highway 206 Byram Twp. NJ 07874
 
carlosfrosario
just joined
Posts: 4
Joined: Fri Jul 21, 2017 3:03 am

Re: Cisco VPN Client with Mikrotik as vpn server

Fri Feb 23, 2018 1:02 am

Hi,
Managed to connect successfully to a cisco router as a vpnc client.
here's my config:
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=md5 enc-algorithms=des pfs-group=none
add auth-algorithms=md5 enc-algorithms=des lifetime=5m name=cisco pfs-group=none
/ip ipsec peer
add address=x.x.x.x auth-method=pre-shared-key-xauth dh-group=modp1024 dpd-interval=disable-dpd enc-algorithm=\
    aes-128,3des,des exchange-mode=aggressive generate-policy=port-override lifetime=5m local-address=y.y.y.y \
    mode-config=request-only my-id=key-id:{groupid} notrack-chain=prerouting secret={group passw} xauth-login={username} xauth-password=\
    {password}
/ip ipsec policy
add dst-address=0.0.0.0/0 level=unique proposal=cisco sa-dst-address=x.x.x.x sa-src-address=y.y.y.y \
    src-address=192.168.1.2/32 tunnel=yes

 
yiucsw
just joined
Posts: 11
Joined: Mon Mar 27, 2017 4:03 am

Re: Cisco VPN Client with Mikrotik as vpn server

Fri Feb 01, 2019 9:33 am

are you use Metarouter? my CISCO Any connect need a VIP access key? will it pop up for input the dyamic key?

Who is online

Users browsing this forum: Google Feedfetcher, krisjanisj, Znevna and 190 guests