Community discussions

 
mdaitc
newbie
Topic Author
Posts: 34
Joined: Mon Mar 22, 2010 5:18 am

VPN (l2tp/ipsec) for Mac OSX 10.8 clients

Mon Mar 11, 2013 5:42 pm

Hi,

i seen to have gone round and round in circles trying to get some OSX 10.8 clients to have a VPN (l2tp/ipsec/whatever) to a RB1100.

Does anyone have a working configuration they'd be able to share?

thanks,
 
nmaton
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Fri Feb 18, 2011 12:31 am

Re: VPN (l2tp/ipsec) for Mac OSX 10.8 clients

Mon Mar 11, 2013 10:18 pm

Easiest is to configure pptp:


/interface pptp-server server
set authentication=pap,chap,mschap1,mschap2 enabled=yes


/ppp secret
add local-address=192.168.1.1 name=test password=test remote-address=192.168.1.2 service=pptp


That should do the trick.
Nicolas Maton
nicolasmaton@gmail.com

CCNA/ CCDA
MTCNA / MTCTCE

Available for Mikrotik Consulting
 
mdaitc
newbie
Topic Author
Posts: 34
Joined: Mon Mar 22, 2010 5:18 am

Re: VPN (l2tp/ipsec) for Mac OSX 10.8 clients

Tue Mar 12, 2013 1:28 am

thanks, that seems to work...

how much more complex would ipsec be?

this is where i'm at - but it doesn't work, alas..

/interface l2tp-server
add disabled=no name=l2tp-myuser user=myuser
/interface l2tp-server server
set authentication=chap,mschap1,mschap2 default-profile=default-encryption enabled=yes \
keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha1 disabled=no enc-algorithms=aes-256 lifetime=30m \
name=default pfs-group=modp1024
/ip ipsec peer
add address=0.0.0.0/0 auth-method=pre-shared-key dh-group=modp1024 disabled=no dpd-interval=\
disable-dpd dpd-maximum-failures=1 enc-algorithm=aes-256 exchange-mode=main-l2tp \
generate-policy=no hash-algorithm=sha1 lifetime=1d my-id-user-fqdn="" nat-traversal=no port=\
500 secret=123456789 send-initial-contact=yes
/ppp secret
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 local-address=192.168.12.254 \
name=testuser password=testuserpass profile=default remote-address=192.168.12.223 routes="" service=\
any


here's the output from the Mac:
Mar 11 19:06:22 configd[17]: SCNC: start, triggered by SystemUIServer, type L2TP, status 0
Mar 11 19:06:22 pppd[21560]: pppd 2.4.2 (Apple version 596.13) started by testuser, uid 501
Mar 11 19:06:22 pppd[21560]: L2TP connecting to server 'rb1100' (192.168.13.102)...
Mar 11 19:06:22 pppd[21560]: IPSec connection started
Mar 11 19:06:22 racoon[21561]: Connecting.
Mar 11 19:06:22 racoon[21561]: IPSec Phase1 started (Initiated by me).
Mar 11 19:06:22 racoon[21561]: IKE Packet: transmit success. (Initiator, Main-Mode message 1).
Mar 11 19:06:22 racoon[21561]: IKE Packet: receive success. (Initiator, Main-Mode message 2).
Mar 11 19:06:22 racoon[21561]: IKE Packet: transmit success. (Initiator, Main-Mode message 3).
Mar 11 19:06:22 racoon[21561]: IKE Packet: receive success. (Initiator, Main-Mode message 4).
Mar 11 19:06:22 racoon[21561]: IKE Packet: transmit success. (Initiator, Main-Mode message 5).
Mar 11 19:06:22 racoon[21561]: IKEv1 Phase1 AUTH: success. (Initiator, Main-Mode Message 6).
Mar 11 19:06:22 racoon[21561]: IKE Packet: receive success. (Initiator, Main-Mode message 6).
Mar 11 19:06:22 racoon[21561]: IKEv1 Phase1 Initiator: success. (Initiator, Main-Mode).
Mar 11 19:06:22 racoon[21561]: IPSec Phase1 established (Initiated by me).
Mar 11 19:06:23 racoon[21561]: IPSec Phase2 started (Initiated by me).
Mar 11 19:06:23 racoon[21561]: IKE Packet: transmit success. (Initiator, Quick-Mode message 1).
Mar 11 19:06:23 racoon[21561]: IKE Packet: receive success. (Initiator, Quick-Mode message 2).
Mar 11 19:06:23 racoon[21561]: IKE Packet: transmit success. (Initiator, Quick-Mode message 3).
Mar 11 19:06:23 racoon[21561]: IKEv1 Phase2 Initiator: success. (Initiator, Quick-Mode).
Mar 11 19:06:23 racoon[21561]: IPSec Phase2 established (Initiated by me).
Mar 11 19:06:23 pppd[21560]: IPSec connection established
Mar 11 19:06:43 pppd[21560]: L2TP cannot connect to the server
Mar 11 19:06:43 racoon[21561]: IPSec disconnecting from server 192.168.13.102
Mar 11 19:06:43 racoon[21561]: IKE Packet: transmit success. (Information message).
Mar 11 19:06:43 racoon[21561]: IKEv1 Information-Notice: transmit success. (Delete IPSEC-SA).
Mar 11 19:06:43 racoon[21561]: IKE Packet: transmit success. (Information message).
Mar 11 19:06:43 racoon[21561]: IKEv1 Information-Notice: transmit success. (Delete ISAKMP-SA).



here's the rb1100 output:
19:07:46 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:07:46 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:07:46 l2tp,debug,packet (M) Message-Type=SCCRQ
19:07:46 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:46 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:07:46 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:07:46 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:07:46 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:07:46 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:46 l2tp,info first L2TP UDP packet received from 192.168.15.101
19:07:46 l2tp,debug tunnel 17 entering state: wait-ctl-conn
19:07:46 l2tp,debug,packet sent control message to 192.168.15.101:51229
19:07:46 l2tp,debug,packet tunnel-id=42, session-id=0, ns=0, nr=1
19:07:46 l2tp,debug,packet (M) Message-Type=SCCRP
19:07:46 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:46 l2tp,debug,packet (M) Framing-Capabilities=0x1
19:07:46 l2tp,debug,packet (M) Bearer-Capabilities=0x0
19:07:46 l2tp,debug,packet Firmware-Revision=0x1
19:07:46 l2tp,debug,packet (M) Host-Name="rb1100"
19:07:46 l2tp,debug,packet Vendor-Name="MikroTik"
19:07:46 l2tp,debug,packet (M) Assigned-Tunnel-ID=17
19:07:46 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:47 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:07:47 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:07:47 l2tp,debug,packet (M) Message-Type=SCCRQ
19:07:47 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:47 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:07:47 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:07:47 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:07:47 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:07:47 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:47 l2tp,debug,packet sent control message (ack) to 192.168.15.101:51229
19:07:47 l2tp,debug,packet tunnel-id=42, session-id=0, ns=1, nr=1
19:07:47 l2tp,debug,packet sent control message to 192.168.15.101:51229
19:07:47 l2tp,debug,packet tunnel-id=42, session-id=0, ns=0, nr=1
19:07:47 l2tp,debug,packet (M) Message-Type=SCCRP
19:07:47 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:47 l2tp,debug,packet (M) Framing-Capabilities=0x1
19:07:47 l2tp,debug,packet (M) Bearer-Capabilities=0x0
19:07:47 l2tp,debug,packet Firmware-Revision=0x1
19:07:47 l2tp,debug,packet (M) Host-Name="rb1100"
19:07:47 l2tp,debug,packet Vendor-Name="MikroTik"
19:07:47 l2tp,debug,packet (M) Assigned-Tunnel-ID=17
19:07:47 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:48 l2tp,debug,packet sent control message to 192.168.15.101:51229
19:07:48 l2tp,debug,packet tunnel-id=42, session-id=0, ns=0, nr=1
19:07:48 l2tp,debug,packet (M) Message-Type=SCCRP
19:07:48 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:48 l2tp,debug,packet (M) Framing-Capabilities=0x1
19:07:48 l2tp,debug,packet (M) Bearer-Capabilities=0x0
19:07:48 l2tp,debug,packet Firmware-Revision=0x1
19:07:48 l2tp,debug,packet (M) Host-Name="rb1100"
19:07:48 l2tp,debug,packet Vendor-Name="MikroTik"
19:07:48 l2tp,debug,packet (M) Assigned-Tunnel-ID=17
19:07:48 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:49 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:07:49 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:07:49 l2tp,debug,packet (M) Message-Type=SCCRQ
19:07:49 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:49 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:07:49 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:07:49 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:07:49 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:07:49 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:49 l2tp,debug,packet sent control message (ack) to 192.168.15.101:51229
19:07:49 l2tp,debug,packet tunnel-id=42, session-id=0, ns=1, nr=1
19:07:50 l2tp,debug,packet sent control message to 192.168.15.101:51229
19:07:50 l2tp,debug,packet tunnel-id=42, session-id=0, ns=0, nr=1
19:07:50 l2tp,debug,packet (M) Message-Type=SCCRP
19:07:50 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:50 l2tp,debug,packet (M) Framing-Capabilities=0x1
19:07:50 l2tp,debug,packet (M) Bearer-Capabilities=0x0
19:07:50 l2tp,debug,packet Firmware-Revision=0x1
19:07:50 l2tp,debug,packet (M) Host-Name="rb1100"
19:07:50 l2tp,debug,packet Vendor-Name="MikroTik"
19:07:50 l2tp,debug,packet (M) Assigned-Tunnel-ID=17
19:07:50 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:53 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:07:53 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:07:53 l2tp,debug,packet (M) Message-Type=SCCRQ
19:07:53 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:53 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:07:53 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:07:53 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:07:53 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:07:53 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:53 l2tp,debug,packet sent control message (ack) to 192.168.15.101:51229
19:07:53 l2tp,debug,packet tunnel-id=42, session-id=0, ns=1, nr=1
19:07:54 l2tp,debug,packet sent control message to 192.168.15.101:51229
19:07:54 l2tp,debug,packet tunnel-id=42, session-id=0, ns=0, nr=1
19:07:54 l2tp,debug,packet (M) Message-Type=SCCRP
19:07:54 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:54 l2tp,debug,packet (M) Framing-Capabilities=0x1
19:07:54 l2tp,debug,packet (M) Bearer-Capabilities=0x0
19:07:54 l2tp,debug,packet Firmware-Revision=0x1
19:07:54 l2tp,debug,packet (M) Host-Name="rb1100"
19:07:54 l2tp,debug,packet Vendor-Name="MikroTik"
19:07:54 l2tp,debug,packet (M) Assigned-Tunnel-ID=17
19:07:54 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:57 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:07:57 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:07:57 l2tp,debug,packet (M) Message-Type=SCCRQ
19:07:57 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:07:57 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:07:57 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:07:57 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:07:57 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:07:57 l2tp,debug,packet (M) Receive-Window-Size=4
19:07:57 l2tp,debug,packet sent control message (ack) to 192.168.15.101:51229
19:07:57 l2tp,debug,packet tunnel-id=42, session-id=0, ns=1, nr=1
19:08:01 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:08:01 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:08:01 l2tp,debug,packet (M) Message-Type=SCCRQ
19:08:01 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:08:01 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:08:01 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:08:01 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:08:01 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:08:01 l2tp,debug,packet (M) Receive-Window-Size=4
19:08:01 l2tp,debug,packet sent control message (ack) to 192.168.15.101:51229
19:08:01 l2tp,debug,packet tunnel-id=42, session-id=0, ns=1, nr=1
19:08:02 l2tp,debug,packet sent control message to 192.168.15.101:51229
19:08:02 l2tp,debug,packet tunnel-id=42, session-id=0, ns=0, nr=1
19:08:02 l2tp,debug,packet (M) Message-Type=SCCRP
19:08:02 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:08:02 l2tp,debug,packet (M) Framing-Capabilities=0x1
19:08:02 l2tp,debug,packet (M) Bearer-Capabilities=0x0
19:08:02 l2tp,debug,packet Firmware-Revision=0x1
19:08:02 l2tp,debug,packet (M) Host-Name="rb1100"
19:08:02 l2tp,debug,packet Vendor-Name="MikroTik"
19:08:02 l2tp,debug,packet (M) Assigned-Tunnel-ID=17
19:08:02 l2tp,debug,packet (M) Receive-Window-Size=4
19:08:05 l2tp,debug,packet rcvd control message from 192.168.15.101:51229
19:08:05 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0
19:08:05 l2tp,debug,packet (M) Message-Type=SCCRQ
19:08:05 l2tp,debug,packet (M) Protocol-Version=0x01:00
19:08:05 l2tp,debug,packet (M) Framing-Capabilities=0x3
19:08:05 l2tp,debug,packet (M) Host-Name=0x68:61:77:6b:32:2e:69:6e:74:65:72:6e:61:6c:2e:6d
19:08:05 l2tp,debug,packet 61:74:74:64:2e:6f:72:67:00
19:08:05 l2tp,debug,packet (M) Assigned-Tunnel-ID=42
19:08:05 l2tp,debug,packet (M) Receive-Window-Size=4
19:08:05 l2tp,debug,packet sent control message (ack) to 192.168.15.101:51229
19:08:05 l2tp,debug,packet tunnel-id=42, session-id=0, ns=1, nr=1
19:08:05 l2tp,debug tunnel 17 received no replies, disconnecting
19:08:05 l2tp,debug tunnel 17 entering state: dead

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 84 guests