Community discussions

MikroTik App
 
oook
just joined
Topic Author
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Ospf distance in 2.9

Wed Mar 01, 2006 12:30 am

Hi I just tried to configure redistribution from ospf to BGP.

It looks like 2.9 hasn't configured ospf distance correctly. It may be 110 and I see nothing (means 0). Same situation in static and connected routes. eBGP writes "20" there.

So I can't redistribute BGP to ospf (because my router preferes ospf routes instead of BGP).

In 2.8 the distance on ospf routes looks fine.

May I missed anything in configuration? Or another bug in 2.9 line?
 
airnet
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Thu Feb 09, 2006 12:46 pm

Thu Mar 02, 2006 2:03 pm

You need to use inbound filters with routing-test package eg:

/routing filter chain=ospf-in set-distance=110

/ routing ospf area set backbone area-id=0.0.0.0 authentication=none prefix-list-import=ospf-in prefix-list-export="" disabled=no

BEWARE - the last (at least 2) versions of routing-test (up to 2.9.14 so far) are very broken. wait until about 2.9.73 and it might be closer to stable.
 
oook
just joined
Topic Author
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Thu Mar 02, 2006 6:26 pm

You need to use inbound filters with routing-test package eg:

/routing filter chain=ospf-in set-distance=110

/ routing ospf area set backbone area-id=0.0.0.0 authentication=none prefix-list-import=ospf-in prefix-list-export="" disabled=no

BEWARE - the last (at least 2) versions of routing-test (up to 2.9.14 so far) are very broken. wait until about 2.9.73 and it might be closer to stable.
where to get 2.9.10 routing-test? :idea:

found it :-)
 
oook
just joined
Topic Author
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Thu Mar 02, 2006 6:41 pm

You need to use inbound filters with routing-test package eg:

/routing filter chain=ospf-in set-distance=110

/ routing ospf area set backbone area-id=0.0.0.0 authentication=none prefix-list-import=ospf-in prefix-list-export="" disabled=no

BEWARE - the last (at least 2) versions of routing-test (up to 2.9.14 so far) are very broken. wait until about 2.9.73 and it might be closer to stable.
I've installed 2.9.10 routing-test and ospf stopped to work (same configuration).

I've disabled routing-test and waiting for new version of OS.
 
oook
just joined
Topic Author
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Fri Mar 10, 2006 12:14 am

You need to use inbound filters with routing-test package eg:

/routing filter chain=ospf-in set-distance=110

/ routing ospf area set backbone area-id=0.0.0.0 authentication=none prefix-list-import=ospf-in prefix-list-export="" disabled=no

BEWARE - the last (at least 2) versions of routing-test (up to 2.9.14 so far) are very broken. wait until about 2.9.73 and it might be closer to stable.
I've installed 2.9.10 routing-test and ospf stopped to work (same configuration).

I've disabled routing-test and waiting for new version of OS.
Just now upgraded to 2.9.16 and ospf routes are still not marked by default. I'm not so brave to load routing-test this version. Can anybody fix the problem? It must be definitelly one line in the code.
 
User avatar
Eugene
Forum Veteran
Forum Veteran
Posts: 993
Joined: Mon May 31, 2004 5:06 pm
Location: Cranfield, UK

Fri Mar 10, 2006 8:07 pm

Routing-test in the 2.9.16 is known to work.

Eugene
Tout individu a droit à la vie, à la liberté et à la sûreté de sa personne.
 
oook
just joined
Topic Author
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Sun Mar 12, 2006 10:43 pm

Routing-test in the 2.9.16 is known to work.

Eugene
I've found it and testing. Distance is set, but it seems like there is still no redistribution to my ospf process ... Have to look more deeply into routing tables in my area ...

Who is online

Users browsing this forum: Google [Bot], jvanhambelgium and 184 guests