Community discussions

 
almustaness
just joined
Topic Author
Posts: 19
Joined: Thu Feb 14, 2013 12:38 pm

How can we backup to Google Drive ?

Wed Mar 27, 2013 8:04 pm

Who can create an idea to upload "server backup" to "cloud computing service" such as dropbox or google drive ?
 
User avatar
ohara
Member
Member
Posts: 371
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: How can we backup to Google Drive ?

Wed Mar 27, 2013 8:57 pm

Here are some simple steps which should help you to set up backup to Google Drive:

1) Open your Google disk drive
2) Replace the disk letter in the path with the IP of your workstation, for example:
C:\Users\Admin\Dysk Google
change into: \\192.168.1.100\Users\Admin\Dysk Google


3) Install Filezilla Server
4) Set up a FTP account in Filezilla and point it to \\192.168.1.100\Users\Admin\Dysk Google
5) In RouterOS set up a script that will upload the configuration to the created ftp account

You may need to enable sharing on your Google disk drive folder in your OS as well, but I am not sure.
 
almustaness
just joined
Topic Author
Posts: 19
Joined: Thu Feb 14, 2013 12:38 pm

Re: How can we backup to Google Drive ?

Thu Mar 28, 2013 12:16 pm

Could you please tell the script. I want it to work each hour to backup config.
 
User avatar
ohara
Member
Member
Posts: 371
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: How can we backup to Google Drive ?

Thu Mar 28, 2013 10:05 pm

Here you go. Replace XXX.XXX.XXX.XXX with the address of your ftp server. If you need help how to set it up in RouterOS task scheduler, then let me know.
log info "Starting Backup Script"
:global thisdate [/system clock get date]
:global datetimestring ([:pick $thisdate 4 6] ."-" . [:pick $thisdate 0 3] ."-" . [:pick $thisdate 7 11])
/system backup save name="$[/system identity get name]_$datetimestring" 
:delay 5s
:log info "Sending Backup File"
/tool fetch address=XXX.XXX.XXX.XXX src-path="$[/system identity get name]_$datetimestring.backup" user=mikrotik password=mikrotik port=21 upload=yes mode=ftp dst-path="$[/system identity get name]_$datetimestring.backup"
:delay 1
:log info "Finished Backup Script"
 
almustaness
just joined
Topic Author
Posts: 19
Joined: Thu Feb 14, 2013 12:38 pm

Re: How can we backup to Google Drive ?

Fri Mar 29, 2013 9:46 am

Thank you very much for the script !

I have mapped dropbox by using a software (visual subset) and I have created FTP server by using filezilla.

Just I want you to tell me what is the option to let FTP server to point to my machine 192.168.1.2

Also how to change Drive letter to \\192.168.1.2 in windows 7


I hope this script replace the old backup.


Waiting for your reply
 
almustaness
just joined
Topic Author
Posts: 19
Joined: Thu Feb 14, 2013 12:38 pm

Re: How can we backup to Google Drive ?

Fri Mar 29, 2013 10:16 am

Better to explain how to map google drive or dropbox because you can't share the drive when you use (visual subset)
 
User avatar
ohara
Member
Member
Posts: 371
Joined: Mon Jun 13, 2011 11:30 pm
Location: Warsaw

Re: How can we backup to Google Drive ?

Sun Mar 31, 2013 9:26 pm

Just I want you to tell me what is the option to let FTP server to point to my machine 192.168.1.2
Please check the attached picture which shows how to set up shared folders. Feel free to experiment around with Filezilla, for example try to set up any folder on your PC to work with Filezilla. Once you figure it out, you can check if it will work with Google Drive/Dropbox. Please remember, this is a Mikrotik forum and not a Filezilla forum.
Also how to change Drive letter to \\192.168.1.2 in windows 7
If you are looking for a way how to map a network location as a disk drive, then please follow this tutorial: http://www.7tutorials.com/print/how-map ... -windows-7
You do not have the required permissions to view the files attached to this post.
 
almustaness
just joined
Topic Author
Posts: 19
Joined: Thu Feb 14, 2013 12:38 pm

Re: How can we backup to Google Drive ?

Wed Apr 03, 2013 11:06 pm

Just I want you to tell me what is the option to let FTP server to point to my machine 192.168.1.2
Please check the attached picture which shows how to set up shared folders. Feel free to experiment around with Filezilla, for example try to set up any folder on your PC to work with Filezilla. Once you figure it out, you can check if it will work with Google Drive/Dropbox. Please remember, this is a Mikrotik forum and not a Filezilla forum.
Also how to change Drive letter to \\192.168.1.2 in windows 7
If you are looking for a way how to map a network location as a disk drive, then please follow this tutorial: http://www.7tutorials.com/print/how-map ... -windows-7
Unfortunately, Dropbox folde and also Mybox folder can't be shared. Do you know any solution to upload to the cloud. Or I to TFTP server then I can let it point to my dropbox folder.

Who is online

Users browsing this forum: Google [Bot] and 107 guests