Community discussions

MUM Europe 2020
 
User avatar
ViREnG
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Drop all communication except PPPoE Connections

Sun Mar 31, 2013 12:03 pm

Hello friends
I have some MikroTik Access point they provide a bridged PPPoE Server .
I want to Limit communication to just PPPoE Connections , clients just connect to my accesspoint via PPPoE Protocol and drop all other protocols .
how can i do this ? for example drop all other procotols on ether 2
 
krajnalic
newbie
Posts: 34
Joined: Wed Nov 30, 2011 1:39 am

Re: Drop all communication except PPPoE Connections

Sun Mar 31, 2013 2:04 pm

Hi. The solution is simple. You have to put three rules into Interface/Bridge/Filters :

add action=accept chain=forward comment="" disabled=no mac-protocol=pppoe-discovery
add action=accept chain=forward comment="" disabled=no mac-protocol=pppoe
add action=drop chain=forward comment="" disabled=no

This will allow only pppoe connections to pass through bridge.

dont forget to give karma....
 
User avatar
ViREnG
Member Candidate
Member Candidate
Topic Author
Posts: 220
Joined: Tue Aug 11, 2009 4:01 pm
Location: Yekaterinburg

Re: Drop all communication except PPPoE Connections

Mon Apr 08, 2013 4:41 pm

Thanks krajnalic
what I must to do if I want to access 192.168.20.0/24 with ICMP Protocol ?
I'm now using below rules but I can't access to bridged devices with ICMP Ping :
/interface bridge filter
add action=accept chain=forward disabled=no mac-protocol=pppoe
add action=accept chain=forward disabled=no mac-protocol=pppoe-discovery
add action=accept chain=forward disabled=no ip-protocol=icmp mac-protocol=ip
add action=drop chain=forward comment="DROP Communication" disabled=no


where's problem ?
 
krajnalic
newbie
Posts: 34
Joined: Wed Nov 30, 2011 1:39 am

Re: Drop all communication except PPPoE Connections

Sun Jun 23, 2013 1:34 am

you can add out-interface=ether2 in those rules

Who is online

Users browsing this forum: astons2, crosswind, lastovsky, MSN [Bot], OlofL and 131 guests