Community discussions

MikroTik App
 
AnaG
just joined
Topic Author
Posts: 22
Joined: Mon Feb 20, 2006 3:15 am

Link Public IP to Local IP's

Fri Mar 03, 2006 3:41 am

I have 32 public IP I want to link same public to local 3-4 IP's like this

This is 1 of my 32 public IP's
/ip address add address=10.20.0.101/32 interface=Public

/ip firewall nat add chain=dstnat dst-address=10.20.0.101 action=dst-nat \
to-addresses=192.168.0.41
/ip firewall nat add chain=srcnat src-address=192.168.0.41 action=src-nat \
to-addresses=10.20.0.101

Ok now I'd like to link same public IP 10.20.0.101 to local ip's 192.168.0.42
and 192.168.0.43
what shold I do
Thx
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1730
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Fri Mar 03, 2006 8:27 am

It is much more simplier

place 1 public IP to the Public interface (like 10.20.0.101/24 i quess /32 is incorrect)
place 1 private IP to the Local interface (like 192.168.0.254/24)

/ ip firewall nat add chain=srcnat out-interface=Public action=masquerade


Add to your PCs gateway: 192.168.0.254
And you need to specify gateway for your router to (it will be 10.20.0.<something>)
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1730
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Fri Mar 03, 2006 8:30 am

With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
AnaG
just joined
Topic Author
Posts: 22
Joined: Mon Feb 20, 2006 3:15 am

Fri Mar 17, 2006 2:23 pm

Ok I yesterday I recive Public ip's and by
http://www.mikrotik.com/docs/ros/2.9/ip/nat
I did it
but I have anader problem
when I enable web proxy when I do http://www.whatismyip.com/
it gives IP of router not IP assinged to client
i m not a expert there is something with nat rule if some one had same problem and resolved it pls past me the key for using webproxy with public ip's
Thx
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Fri Mar 17, 2006 2:33 pm

Router IP address will be shown, when you are using proxy (router as a proxy).
 
User avatar
fatonk
Member
Member
Posts: 439
Joined: Tue Feb 22, 2005 11:06 am
Location: Mitrovica/Kosova

Fri Mar 17, 2006 3:44 pm

Do you need to connect from Public network (Internet) to these local IPs ?
 
AnaG
just joined
Topic Author
Posts: 22
Joined: Mon Feb 20, 2006 3:15 am

Sat Mar 18, 2006 5:08 am

Do you need to connect from Public network (Internet) to these local IPs ?
Yes i did this but when I enable web proxy Router IP address will be shown, you are right sergejs about (router as a proxy) is there a any way to fix this
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6621
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Sat Mar 18, 2006 8:29 pm

I suppose, one way access public networks without proxy.

Who is online

Users browsing this forum: arm920t and 214 guests