Community discussions

 
User avatar
eugenevdm
Member Candidate
Member Candidate
Topic Author
Posts: 208
Joined: Tue Jun 01, 2004 12:23 pm
Location: Stellenbosch, South Africa
Contact:

100% CPU Utilization SNMP and Management RB750G

Thu Apr 18, 2013 1:13 pm

See attached graph. This router works for months on end and then goes into a 100% CPU loop. We do
/tool profile
and see that the following services are spiking:

SNMP and Management.
NAME                    CPU        USAGE
ppp                     all           0%
p2p-matcher             all         0.5%
snmp                    all        31.5%
ethernet                all           8%
console                 all           0%
traffic-flow            all         1.5%
firewall                all           3%
logging                 all           0%
management              all        47.5%
idle                    all           2%
queuing                 all           6%
unclassified            all           0%
Our conclusion:

1. SNMP server is broken
2. Management (what does this entail?) is broken
3. SNMP client is broken

As for option 3, this only happens on MikroTik, as far as we know.

Solution: Stop using SNMP on RB750G with RouterOS :-(

Other specs:

RouterOS v5.24
Firmware: 3.02
At 12:05 we turned off SNMP and CPU is back to normal.

Advice welcome.

Maybe install SNMP and Management watchdog? How?
You do not have the required permissions to view the files attached to this post.
The Snowball Effect
Superior Internet Solutions
 
tyronzn
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Thu May 24, 2007 4:55 pm
Location: Durban,South Africa
Contact:

Re: 100% CPU Utilization SNMP and Management RB750G

Thu Jun 20, 2013 8:45 pm

Hi Eugene,

do you use pppoe authentication?i have stumbled across same issue every now and again although i replicate the problem by disconnecting pppoe sessions and once they connected again the cpu usage goes up even though no traffic is passing through pppoe connection,almost as if its a broadcast storm of some sort.i know in my case that its not snmp as the issue was present before we implemented a snmp server,its puzzling though that you and i have the same issue but different causes.This issue is only present on highsites using rb750g
 
chipper43
just joined
Posts: 7
Joined: Wed Apr 24, 2013 5:08 am

Re: 100% CPU Utilization SNMP and Management RB750G

Tue Mar 24, 2015 1:07 am

I am seeing similar issues with Cacti watching these devices using SNMPv3. When enabled CPU is excessive upwards of 90% however when I disable SNMP it goes down by 9%.

Nothing crazy running, a couple static routes as well and three or 4 internal BGP routes and this is a CCR-1016

Open for suggestions.

Who is online

Users browsing this forum: No registered users and 35 guests