Community discussions

MikroTik App
 
iamjahid
just joined
Topic Author
Posts: 4
Joined: Tue Apr 23, 2013 5:00 pm

How to Block Hotspot Shield

Tue Apr 23, 2013 5:16 pm

i am using Mikrotik RB450G. I can't block hotspot shield. Plz help.
or
layer 7 protocols hotspot shield?
 
kraker
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Thu Aug 02, 2012 9:34 am

Re: How to Block Hotspot Shield

Tue Apr 23, 2013 7:14 pm

 
iamjahid
just joined
Topic Author
Posts: 4
Joined: Tue Apr 23, 2013 5:00 pm

Re: How to Block Hotspot Shield

Tue Apr 23, 2013 7:19 pm

 
kraker
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Thu Aug 02, 2012 9:34 am

Re: How to Block Hotspot Shield

Tue Apr 23, 2013 9:54 pm

search in wiki page...
 
iamjahid
just joined
Topic Author
Posts: 4
Joined: Tue Apr 23, 2013 5:00 pm

Re: How to Block Hotspot Shield

Thu Apr 25, 2013 3:56 pm

Dear I search in wiki but its too old for hotspot shield. The program dev. day by day. can any help layer7 block.
 
User avatar
dotnet
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Tue Feb 26, 2013 11:41 am
Location: Chittagong, Bangladesh.

Re: How to Block Hotspot Shield

Fri Apr 26, 2013 10:03 am

please try this link. i hope you have got something.

http://wiki.mikrotik.com/wiki/How_to_De ... ication%29



best regards
Suman

Dotnet
(Mini ISP)
 
komailov
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Sat May 19, 2012 9:52 am
Location: Lebanon

Re: How to Block Hotspot Shield

Fri Apr 26, 2013 3:41 pm

iamjahid Hello,

try to block Hotspot Shield Ports Number,

usually it works on 5345,5938,5245,3398,3451,5265,1755,5050,5396,10000-10010,9000,3211,15000-15010,1935,5231,800,989

you can block this list through ur firewall.

Thank You.
Think Smart & Act Quiet
 
iamjahid
just joined
Topic Author
Posts: 4
Joined: Tue Apr 23, 2013 5:00 pm

Re: How to Block Hotspot Shield

Sun Apr 28, 2013 2:41 pm

komailov Hello,
i already block this port but it wont work. ....5345,5938,5245,3398,3451,5265,1755,5050,5396,10000-10010,9000,3211,15000-15010,1935,5231,800,989.

Dotnet hello,
http://wiki.mikrotik.com/wiki/How_to_De ... ication%29
the Article publish 2011 but now 2013.

Thank You.
You do not have the required permissions to view the files attached to this post.
 
User avatar
Stillhard
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Sun Jun 10, 2012 11:18 am
Location: Banten, Indonesia
Contact:

Re: How to Block Hotspot Shield

Mon Apr 29, 2013 5:07 am

Have you ever do a search? :lol:

Use this, it works for me, well THE ONLY one that works:
http://forum.mikrotik.com/viewtopic.php?f=2&t=70849
 
User avatar
dotnet
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Tue Feb 26, 2013 11:41 am
Location: Chittagong, Bangladesh.

Re: How to Block Hotspot Shield

Mon Apr 29, 2013 6:50 am

ok. Actually you have to need more customization in firewall rules.

Here is the solution.

Detect and Block Hotspot Shield program traffic (vpn application)

/ip firewall mangle
add action=add-dst-to-address-list address-list=WhiteList \
address-list-timeout=4d4h chain=prerouting comment=WhiteList content=\
!127.0.0.1:895 disabled=no dst-port=80 protocol=tcp
add action=add-src-to-address-list address-list=HotSpotShieldUsers \
address-list-timeout=1h chain=prerouting comment=HotSpotShieldUsers \
content=127.0.0.1:895 disabled=no dst-port=80 protocol=tcp
add action=add-dst-to-address-list address-list=WhiteList \
address-list-timeout=4d4h chain=prerouting comment=WhiteList content=\
!127.0.0.1:895 disabled=no dst-port=443 protocol=tcp

/ip firewall filter
add action=drop chain=forward comment="\"Block HotSpot Shield\"" disabled=no \
src-address-list=HotSpotShieldUsers

---------------------------------------------------------------
Detect and Block UltraSurf program traffic

/ip firewall filter
add action=drop chain=forward comment="Block UltraSurf" disabled=no dst-port=\
443 protocol=tcp src-address-list=UltraSurfUsers

/ip firewall mangle
add action=add-src-to-address-list address-list=UltraSurfUsers \
address-list-timeout=5m chain=prerouting comment=UltraSurfUsers disabled=\
no dst-address-list=UltraSurfServers dst-port=443 protocol=tcp

/ip firewall address-list
add address=65.49.0.0/17 comment="" disabled=no list=UltraSurfServers
add address=204.107.140.0/24 comment="" disabled=no list=UltraSurfServers

------------------------------------------------
Block DNS

/ip firewall filter
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=tcp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=udp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=tcp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=udp
add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=tcp
add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=udp


It has work with 5.20. please try this way, may be it will be done.


best regards
Suman

Dotnet
(Mini ISP)
 
bnjmnjf
just joined
Posts: 1
Joined: Thu Jan 16, 2014 12:27 am

Re: How to Block Hotspot Shield

Thu Jan 16, 2014 12:46 am

ok. Actually you have to need more customization in firewall rules.

Here is the solution.

Detect and Block Hotspot Shield program traffic (vpn application)

/ip firewall mangle
add action=add-dst-to-address-list address-list=WhiteList \
address-list-timeout=4d4h chain=prerouting comment=WhiteList content=\
!127.0.0.1:895 disabled=no dst-port=80 protocol=tcp
add action=add-src-to-address-list address-list=HotSpotShieldUsers \
address-list-timeout=1h chain=prerouting comment=HotSpotShieldUsers \
content=127.0.0.1:895 disabled=no dst-port=80 protocol=tcp
add action=add-dst-to-address-list address-list=WhiteList \
address-list-timeout=4d4h chain=prerouting comment=WhiteList content=\
!127.0.0.1:895 disabled=no dst-port=443 protocol=tcp

/ip firewall filter
add action=drop chain=forward comment="\"Block HotSpot Shield\"" disabled=no \
src-address-list=HotSpotShieldUsers

---------------------------------------------------------------
Detect and Block UltraSurf program traffic

/ip firewall filter
add action=drop chain=forward comment="Block UltraSurf" disabled=no dst-port=\
443 protocol=tcp src-address-list=UltraSurfUsers

/ip firewall mangle
add action=add-src-to-address-list address-list=UltraSurfUsers \
address-list-timeout=5m chain=prerouting comment=UltraSurfUsers disabled=\
no dst-address-list=UltraSurfServers dst-port=443 protocol=tcp

/ip firewall address-list
add address=65.49.0.0/17 comment="" disabled=no list=UltraSurfServers
add address=204.107.140.0/24 comment="" disabled=no list=UltraSurfServers

------------------------------------------------
Block DNS

/ip firewall filter
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=tcp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.194.50 dst-port=53 protocol=udp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=tcp
add action=accept chain=forward comment=DNS disabled=no dst-address=198.153.192.50 dst-port=53 protocol=udp
add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=tcp
add action=drop chain=forward comment=DNS disabled=no dst-port=53 protocol=udp


It has work with 5.20. please try this way, may be it will be done.


best regards

Who is online

Users browsing this forum: boxxed, Voisanats, yuridee and 39 guests