Community discussions

MikroTik App
 
imadghassir
just joined
Topic Author
Posts: 4
Joined: Tue Apr 30, 2013 1:26 am

Problem with PCC LoadBalancing

Wed May 01, 2013 1:57 am

Greetings everybody, i’m new user in this mikrotik routerOS, i met a verry persisting problem concerning pcc load balancing, briefly my hardware and software features are :

Hardware
Pc containes INTEL 3Ghz of CPU ,2 GB of RAM, 750 GB of HDD…

Operating System

Mikrotik routerOS v 5.18

Network

-The main internet connexion shared by 45 users in LAN
- 5 wan links with 8 Mbits/s for each ,2 out of 5 are Ethernet links and the 3 others are Wireless ATHEROS AR 9 links coming from modems.

Method used

I used the method of PCC LoadBalancing.

Persisting Problem

I already used this method, everything is well setted and users are well connecting but I have noticed that when I open the WINBOX i find the interfaces never reach the maximum debit expected,as for interface WAN1 with 8 Mbits/s that normally recieves the same as 8 Mbits/s or less a bit, doesn’t seize the maximum of its real debit and it is the same as for the 4 remaining WANS which normally gives the total 40 Mbits/s of transmitted to all users thus this problem affects the users while surfing or dowloading , I have to tell you also that this 40 mbts/s doesn’t even reach 24 Mbits/s, hereby I seek from you a practical solution to this persisting problem which I need to understand whether on the level of hardware that lacks a good physical setting that needed to be changed or is there any trick that I must add to PCC loadbalancing that will allow each interface to seize its maximum debit.

Ex : while downloading a video from youtube using internet download manager, the rate of transffering doesn’t exceed the rate of 3.2 Mo/s using the same previosuly setting already mentioned.

Waiting for your prompt answer
My best regards
 
ronix
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Nov 17, 2011 6:51 pm

Re: Problem with PCC LoadBalancing

Wed May 01, 2013 7:43 pm

please if you post your config ...
 
imadghassir
just joined
Topic Author
Posts: 4
Joined: Tue Apr 30, 2013 1:26 am

Re: Problem with PCC LoadBalancing

Thu May 02, 2013 2:46 am

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
add address=192.168.3.2/24 network=192.168.3.0 broadcast=192.168.3.255 interface=WAN3
add address=192.168.4.2/24 network=192.168.4.0 broadcast=192.168.4.255 interface=WAN4
add address=192.168.5.2/24 network=192.168.5.0 broadcast=192.168.5.255 interface=WAN5
 
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
add chain=input in-interface=WAN4 action=mark-connection new-connection-mark=WAN4_conn
add chain=input in-interface=WAN5 action=mark-connection new-connection-mark=WAN5_conn
	 
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
add chain=output connection-mark=WAN4_conn action=mark-routing new-routing-mark=to_WAN4
add chain=output connection-mark=WAN5_conn action=mark-routing new-routing-mark=to_WAN5
 
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.4.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.5.0/24 action=accept in-interface=Local
	 
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/2 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/3 action=mark-connection new-connection-mark=WAN4_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:5/4 action=mark-connection new-connection-mark=WAN5_conn passthrough=yes
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
add chain=prerouting connection-mark=WAN3_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN3
add chain=prerouting connection-mark=WAN4_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN4
add chain=prerouting connection-mark=WAN5_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN5
 
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_WAN3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_WAN4 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.5.1 routing-mark=to_WAN5 check-gateway=ping
	 
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 distance=3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 distance=4 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.5.1 distance=5 check-gateway=ping
	 
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
add chain=srcnat out-interface=WAN3 action=masquerade
add chain=srcnat out-interface=WAN4 action=masquerade
add chain=srcnat out-interface=WAN5 action=masquerade
 
gtpro
newbie
Posts: 36
Joined: Thu Jun 03, 2010 9:05 pm

Re: Problem with PCC LoadBalancing

Thu May 02, 2013 3:40 am

Hi, I have the same problem, I have 8 dsl lines coming into a RB493AH, each DSL line is 10Mb, total bandwtidh never reachs above 30Mb. Maybe thats how PCC works.
 
User avatar
aacable
Member
Member
Posts: 433
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: Problem with PCC LoadBalancing

Thu May 02, 2013 9:28 am

Have you verified you DSL line quality separately by putting it directly to PC and then do some test downloads and check the results?
If the lines are ok and you are able to download at full capacity on each WAN in testing, then do this for testing. Install IDM in your test PC, and download multiple 5-10 big files (Like ISO files , ubuntu images etc from reliable sources) using IDM and then post the WAN output result.
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
imadghassir
just joined
Topic Author
Posts: 4
Joined: Tue Apr 30, 2013 1:26 am

Re: Problem with PCC LoadBalancing

Fri May 03, 2013 2:16 pm

greetings,
I have done tests for each line seperately, i found the bandwith is good 8 Mbit/s, for the second stage I have replug them in the Mikrotik router and I have let multiple downloads from good resources (youtube....ect) I found that the total rate of download doesn't exceed 3 Mo/s with internet download manager, so it is still the same problem which persists so I doubt that the PCC is not well functioning, I wish this problem will be solved soon.
 
ronix
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Nov 17, 2011 6:51 pm

Re: Problem with PCC LoadBalancing

Fri May 03, 2013 7:50 pm

please do the following :

1) test it with 2 WANs ... if the same problem then:
2) try to upgrade your router to 5.25...if the same problem then:
3) try version 6.0rc14...

please feed us about the result ...

you can test it in another pc to prevent any crash of your system...

Who is online

Users browsing this forum: arjanwixx, awbl, erlinden, jebz and 128 guests