Community discussions

MUM Europe 2020
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Problem with connection tracking - need advice!

Wed May 15, 2013 9:58 pm

We have some 40 SXT-Lites installed lately and several of these have speed problems.
We can make a tcp bandwith test from a laptop to the SXT-L and we are getting high download speeds (TO the laptop) but only some 8-12Mb upload.)
A bandwith test performed from the SXT-L to its AP gives 20-40Mb depending on network and link parameters.

But bandwith tests performed from a laptop OVER the SXT-L's are not even reaching 1Mb!

There are hardly firewall rules in place, little mangle and only one src-nat.
No queues are set. (Traffic is limited at the endpoint of my network, several routers away.)

What I now found out is that when I disable the connection tracking, speeds suddenly run up OVER de router (and towards and from) as to be expected. The cpu of the laptop or the SXT-L is maxing out.

But, in disabling connection tracking, surfing on the internet is not longer possible.
SXT's are all in routing mode. WLAN (WAN side) is dhcp-client and Ethernet interface is LAN with a dhcp-server.
Firewall nat has one rule to translate all traffic from lan (/24) the masquerade of the IP of the Wlan side.

What to do?

It only is the case on 4 of these units now. How come? Where to look for possible issues and/or solutions...
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Problem with connection tracking - need advice!

Wed May 15, 2013 10:08 pm

Like always on issues like this.. change ros version. :D
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Problem with connection tracking - need advice!

Wed May 15, 2013 10:26 pm

Into what? Running v5.24 with fw3.04

This is about the latest version, and running fine on about 400+ other units with same config...
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Problem with connection tracking - need advice!

Wed May 15, 2013 10:35 pm

I have no idea about the lite (I don't think our supplier even would bring it to market), but in my opinion, 5.x and 6.x have really wired issues from versions to versions. It was an issue earlier to, but not in the same way like now.

If there are 400 lite boxes with no problem, at same firmware and ros, the issue is probably regarded to the hardware it self? IF you only have issue at lite boxes, and its possible to reproduce, just try some other releases of ros. I used 5.x for a long time. but the rc 6.13 is stable for my setup. (6.14 is not)
 
samsung172
Forum Guru
Forum Guru
Posts: 1186
Joined: Sat Apr 04, 2009 3:45 am
Location: Østfold - Norway
Contact:

Re: Problem with connection tracking - need advice!

Wed May 15, 2013 10:39 pm

just to say. I have had the following verions stable:

2.9.42, 2.9.50(51), 3.20, 3.30, 4.17 , 5.20 , 5.24 and or 6.13. I newer use any other ros than this.

Who is online

Users browsing this forum: MSN [Bot] and 82 guests