Community discussions

MikroTik App
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

netwatch is not working on 2.9.17

Sat Mar 11, 2006 1:17 pm

I have hoped so much that version 2.9.17 will be a stable one, however it looks that it's not. Last night I experienced lots of problems after upgrading core routers to 2.9.17. For example after trying to setup OSPF one of the routers get loaded up to 100% (3.3 Ghz Intel). There were problems and wtih RIP - all rip routes were with metric of 16. There was no such a problem with version 2.8.26/2.8.28. Well I'm not 100% certain about my OSPF config and RIP is working now (after some reboots) :(. I think there are still problems with these routing protocols.

Moreover netwatch is not working for sure. There are hosts that are up and pingable , however their status is down. If I disable/enable a host it is correctly reported the first time. After elapsing the configured interval - the host is again repored as down (It is really up). This problem is not regarding only one host.

Is there someone who does not have any problems with 2.9.17?
 
meister
newbie
Posts: 48
Joined: Wed Jul 07, 2004 12:28 pm
Location: Canada

Sun Mar 12, 2006 2:33 am

I upgraded our spare from 2.8.28 to 2.9.17. Everything seems to be working. I have tested netwatch for sure. Can you ping the netwatch host manually from the box?

On another box OSPF is running trouble free at 2.9.17 whereas 2.9.11 was giving a little grief.
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

Sun Mar 12, 2006 4:03 pm

Yes, I can ping manualy the netwatch host.

I'll read again the documentation about OSPF more carefully than before and I'll try to set it up again. I suspicious thing about my current ospf config is that I have two networks on the interfaces that are sending ospf messages to each other. I have 192.168.1.1/24 and 192.168.2.1/24 on my eth interface, for example, and I'm adding 192.168.1.0/24 and 192.168.2.0/24 networks in the ospf config. Is it possible to be a misconfiguration?
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Sun Mar 12, 2006 5:22 pm

netwatch is working for me. (only 4 mt-boxes with 2.9.17 so far )
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

Sun Mar 12, 2006 8:50 pm

Netwatch is not working for me for sure. What interval and timeout are you using? I've tested with:
timeout / interval
2s 30s
2s 1m
1s 30s
1s 1m

I have almost 100 monitored hosts.
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Sun Mar 12, 2006 9:16 pm

one example:
/ tool netwatch 
add host=x.y.8.158 timeout=1s interval=1m up-script="" down-script="" comment="rt-wil-hs041" disabled=no 
add host=x.y.8.160 timeout=1s interval=1m up-script="" down-script="" comment="rt-wdn-hm014" disabled=no 
add host=10.10.1.70 timeout=1s interval=5m up-script="" down-script="" comment="VPN Weidenau" disabled=no 
add host=10.10.1.71 timeout=1s interval=5m up-script="" down-script="" comment="VPN Wilnsdorf" disabled=no 
but with 100 devices i would go for some real network-management. i use netwatch only for a few devices and mostly without scripts.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1735
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Mon Mar 13, 2006 9:47 am

Netwatch is working for me too.

Did you upgradet from 2.8.xx???? Maybe try to recreate the setup manualy from the the beggining on 2.9!!!
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

Mon Mar 13, 2006 10:09 am

I upgraded from 2.9.12 in which everithing was working.

Now I will test if it will be working with less than 60 monitored hosts. There are about 90 hosts with interval 2m20s and timeout 1s - it is still not working properly. There are hosts that are marked with down and in the same time they are fully pingable.
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

Tue Mar 14, 2006 3:03 am

I tried on a second box with 2.9.17 installed and the same netwatch rules installed - the same problems occured.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1735
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Tue Mar 14, 2006 8:20 am

So how many hosts it can handle now?
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
gottin
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 62
Joined: Fri Feb 25, 2005 8:33 am
Location: Bulgaria
Contact:

Tue Mar 14, 2006 11:06 am

Well it looks it's not problem conserning the number of hosts, because with 50 hosts the situation was same :(.
 
sergis
just joined
Posts: 16
Joined: Tue Apr 05, 2005 5:09 pm

Tue Mar 14, 2006 12:16 pm

I have 50 monitoring hosts and similar problems with netwatch,they going up and down and if there is configured sms notification this is nightmare, but all hosts in this time are up and running with no problems..
 
vklimovs
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Fri Dec 16, 2005 5:37 pm

Tue Mar 14, 2006 5:41 pm

Yes, same problem here. Could easily ping from linux box desired host, but netwatch shows it as down. I though is was a router pretty high load issue, but after your posts it seems that it is not. I wrote a little script as a workaround for that.
:local time
:local mailsent
:set time [/system clock get time]
:set mailsent false
:while ([/ping HOST IP ADDRESS count=1] = 0) do={
  :if ( !( $mailsent ) ) do={    
    :if ( [/system clock get time] - $time >= 1m ) do={
      /tool e-mail send to="MY_EMAIL" subject="host is down"
      :set mailsent true
      }      
    }
  :delay 10s
  }
:if ($mailsent) do={  
  /tool e-mail send to="MY_EMAIL" subject="host is up"
  }

E-mail and sms sending is what personally I need from netwatch, but you may substitute actions with any other. The thing is that script sends an e-mail only if host is down for a certain amount of time, 1 minute here, but checks the host status every 10 sec. So long outage (1 min) never happens due to netwatch.

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Sanalturkey, sindy and 99 guests