Page 1 of 2

Re: v6.0 released

Posted: Sat Jun 08, 2013 10:18 am
by Stillhard
:shock: i'm gonna try this new v6.1 released

Edit:
tested 6.1 released (Jun/06/2013 16:11:56)
- NOT FIXED, error in usermanager web-ui (web-ui ignoring timezone setting)
- FIXED, ip > hotspot > active - Bytes Out, Packets Out, Tx Rate, Tx Rate stays in 0 bps :)
- NEW ERROR, on boot, there's an error about xxx...fastpath.ko not loading or something (can't afford to test that version again to see the msg again since alot of ppls will angry at me)

Back to 6.0rc14 again now (with error in usermanager web-ui (web-ui ignoring timezone setting) only)

Re: v6.0 released

Posted: Sat Jun 08, 2013 2:28 pm
by coffeecoco
the problem with disapearing bridge interfaces and randomly dissapearing WLAN interfaces is still there

FYI this has been happening since day 1 of the rc6.0 beta, i reported it many times but no one gave a crap......

6.1 did not resolve the issue.!
Just be patient, we'll get a reward someday as a reporter :)
lol ok i want fkn cookies

Re: v6.0 released

Posted: Sun Jun 09, 2013 10:01 am
by coffeecoco
I give up on Ros6, dear mikrotik, no offence but you release software way too early,
I'm a network corporate administrator
And a Linux server administrator, I manage the servers behind the development farms and Staging farms AND the Live production Farms.

You make have so many flaws in how you release software, I dont think you could fathorm the amount of detail we go though to make sure software is worthy, Frankly my personal opinion is i feel its careless.

I will give you credit, that you dont charge astronomical prices, and you might limit your staff, or have difficulty with getting enough staff, so okay credits to you.

but honestly, probably early days when mikrtik was released you had a alot of us consumers to help you test as the software was Very early, but your OVER the that Line, for what is accepted as early development, you have from a company that needs community support to selling production hardware/software

Your first thing was how many people Ranted at you for selling that CCR thing, and not telling people its a development type product, ive read the posts and read the comments.

So, here is the part where i stop ranting and try help, I have been a member for a long time, like 8 years now...
So please dont think this is another rant of someone who just wants to cry....

You need to be accepting that your running very low on the community that is willing to BETA test your software
this in turn makes it difficult for you to get response's before you " release "
This is why we see you guys say all the time " not one person reported this issue "
Also I have reported issues that went ignored, One of a few of my issues i reported you said you will fix, but it just never happened.

I dont know what else to say, I like you guys alot, I just want you to try redesign your testing platforms


I have to go back to version 5 because a problem i reported on the very first day you released the beta rc 6 has not been resolved.

Also Alot of companys are heading into PCI compliancy, I in fact am banned from using your product in anything i touch at work because of a survey, that went though some of our network guys, that it lacks support, and it full of bugs.....

The last time i spoke like this i tried to help you in setting up a Bug Ticketing System Like Source forge... ( downloadable)


Yours Truely
Mikrotik Fan.

Re: v6.0 released

Posted: Sun Jun 09, 2013 10:19 am
by coffeecoco
This is what i got when i downgraded, from ros6 to ros5

In the pictures below From bottom to TOP
you can see 3 x Local Bridges AND 2 x Bridge1

they mysteriously appeared after vanishing on ros6 every time i rebooted, HENCE why there are so many an indictation of how many times i had to re add the bridge interfaces, on this box alone.

On top of that, mikrotik there was issues with your static routes and metrics

I set a manage rule to mark routing, IE dual load balancer Nth Method, I know its setup correctly, Because I was involved in the creation of the first Load balancer scripts in 2005
Basicly when you set the static route with the route mark even or odd, it would not use it, just stayed "blue"
Screen Shot 2013-06-09 at 5.14.44 PM.png
Screen Shot 2013-06-09 at 5.14.08 PM.png

Re: v6.0 released

Posted: Sun Jun 09, 2013 10:31 am
by Diamond
Good day!
I wrote above about router rebooting on rc12. So.
I have installed Dude4.0beta3 package on the device (rc11). Updating to rc12 brought to reboots. Router worked on rc11 before today.
Today I tried to upgrade to ROS6.0 release and the router began reboots again :D Next, router has netinstalled again for ROS6.0 - and all stayed ok! After this Dude4.0beta3 has installed and all work!
These all say that the dude package brought to reboots after upgrading a release, or the updating process goes wrongly=)

P.S. This post is also in rc12 thread, just in case.

Re: v6.0 released

Posted: Sun Jun 09, 2013 9:26 pm
by jezekus
Hello I have upgraded 2x RB750GL from v5.25 and v5.19 to v6.0 and after upgrade everything was OK. Now I tried reset to default using reset button/reset hole and I'm unable to connect to these routers. They seems to not have IP of any kind (both were default 192.168.88.1).
Can somebody help me please?

Re: v6.0 released

Posted: Sun Jun 09, 2013 10:07 pm
by andriys
Hello I have upgraded 2x RB750GL from v5.25 and v5.19 to v6.0 and after upgrade everything was OK. Now I tried reset to default using reset button/reset hole and I'm unable to connect to these routers. They seems to not have IP of any kind (both were default 192.168.88.1).
Can somebody help me please?
I've seen the same issue on RB751U-2Hnd and RB951-2n. On v6.0 there seem to be no such thing as default configuration, at least on these devices. On v6.1 rc1 (that rc1 that was available to downloaded on the day I was trying it, which is... probably nobody knows what exact version of v6.1 rc1 it was :? ) there already were such thing as default configuration, but it was "slightly" different from what we all used to see on the previous ROS versions:

Image

So. I guess your device has no IP address at the moment. Try connecting to your device using WinBox by MAC address.

Re: v6.0 released

Posted: Mon Jun 10, 2013 9:41 am
by heavyd
Anyone else have disabled wlan when the RB has been shutdown ? I have 3 sites and all 3 have donr this to me ..

Come on Mikrotik how can you release V6 when this is happening

Re: v6.0 released

Posted: Mon Jun 10, 2013 8:10 pm
by reapster
RouterOS 6.0 upgrade on RB532A goes something like:

Welcome to MikroTik Router Software remote installation
Press Ctrl-Alt-Delete to abort

<Usual netinstall stuff, key etc...>

Formatting disk.....

installed system-6.0
installed advanced-tools-6.0
installed dhcp-6.0
installed ipv6-6.0
installed mpls-6.0
installed multicast-6.0
installed ntp-6.0
installed openflow-6.0
installed ppp-6.0
installed routing-6.0
installed security-6.0
installed wireless-6.0
Writing configuration...

Software installed.
Press ENTER to reboot

... reboot ...

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
opendir: No such file or directory
opendir: No such file or directory
ERROR: no system package found!
Kernel panic - not syncing: Attempted to kill init!


This happened when upgrading from 5.19, and when doing a fresh Netinstall with RouterOS 6. I'm guessing this isn't the expected result. Went back to 5.25 and all is fine.

Could this have something to do with some RB532As having 128MB flash, but RouterOS usually only using 64MB? (The boot loader is 2.18)

Re: v6.0 released

Posted: Mon Jun 10, 2013 11:10 pm
by Diamond
Good day!
I wrote above about router rebooting on rc12. So.
I have installed Dude4.0beta3 package on the device (rc11). Updating to rc12 brought to reboots. Router worked on rc11 before today.
Today I tried to upgrade to ROS6.0 release and the router began reboots again :D Next, router has netinstalled again for ROS6.0 - and all stayed ok! After this Dude4.0beta3 has installed and all work!
These all say that the dude package brought to reboots after upgrading a release, or the updating process goes wrongly=)

P.S. This post is also in rc12 thread, just in case.
I forgot to install ntp packet on previous state "all work" system. Did it, and RB951 began reboot. So this dude package damages the install manager? Don't uderstand.
Now I don't want install the dude because each upgrade of the system will occur rebooting...

Re: v6.0 released

Posted: Tue Jun 11, 2013 12:41 am
by ricky011
btw, another problem: facebook over ipv6 hanging, lagging, downgrade to 5.25 and problem solved... this is starting to be boring, please someone notify me when a usable ROSv6 arrives...

Re: v6.0 released

Posted: Tue Jun 11, 2013 2:27 am
by duvi
btw, another problem: facebook over ipv6 hanging, lagging, downgrade to 5.25 and problem solved... this is starting to be boring, please someone notify me when a usable ROSv6 arrives...
Actually I've been experiencing the same with facebook over ipv6 in the last couple of days at multiple locations.
But I'm using openwrt on my home router, so I rather think this has to do something with facebook.
However, it started to work yesterday normally again, maybe you should give it another try.

Re: v6.0 released

Posted: Tue Jun 11, 2013 7:37 am
by alexanders
Hello, i'm facing with webfig problem. Webfig can't start in opera, just showing 'loading'.
rb750up, ros v.6.0, Opera 12.15 (build 1748), java v7 (update 21).

Re: v6.0 released

Posted: Tue Jun 11, 2013 9:52 am
by normis
alexanders - it works fine in the newest Opera version (the silver icon in your start bar)

Re: v6.0 released

Posted: Tue Jun 11, 2013 10:24 am
by omidkosari
After upgrade from 5.25 to 6.0 PPPoE client disconected after 3 hours on x86. System reboot PPPoE client conect again. Back to 5.25 all is OK.
Same problem with RB7xx . Manual disconnect and reconnect PPPoE client solves problem for few hours .

Re: v6.0 released

Posted: Tue Jun 11, 2013 10:51 am
by normis
[quote="coffeecoco"][/quote]

Did you contact support with supout.rif file from v6.0 ? Tell me your ticket number, I will check what was found in this case.

Re: v6.0 released

Posted: Tue Jun 11, 2013 11:38 am
by normis
:shock: i'm gonna try this new v6.1 released

Edit:
tested 6.1 released (Jun/06/2013 16:11:56)
- NOT FIXED, error in usermanager web-ui (web-ui ignoring timezone setting)
- FIXED, ip > hotspot > active - Bytes Out, Packets Out, Tx Rate, Tx Rate stays in 0 bps :)
- NEW ERROR, on boot, there's an error about xxx...fastpath.ko not loading or something (can't afford to test that version again to see the msg again since alot of ppls will angry at me)

Back to 6.0rc14 again now (with error in usermanager web-ui (web-ui ignoring timezone setting) only)

Both of the above issues are fixed in v6.1 todays build

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:22 pm
by pmaster
link to full package of build 6.1 for mipsbe (with userman)

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:24 pm
by normis
link to full package of build 6.1 for mipsbe (with userman)
http://www.mikrotik.com/download/share/ ... es_6.1.zip

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:27 pm
by kapnos
Any news about the missing graphs(cpu, memory, disk) on 6.0?

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:33 pm
by normis
Any news about the missing graphs(cpu, memory, disk) on 6.0?
yes, but you need to reinstall with netinstall for the fix to take effect

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:39 pm
by Attila
Dear Normis!

CCR1036 multicast routing (PIM-SM) same source to different interface is solved in 6.1 ?

Attila

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:45 pm
by normis
Dear Normis!

CCR1036 multicast routing (PIM-SM) same source to different interface is solved in 6.1 ?

Attila
What do you mean? Have you contacted support ?

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:51 pm
by doush
V6.0 RC14 (CCR 1036-12G-4S)

Bonding 2xGiga interfaces (802.3ad, L3 and L4 Hashing). Remote side is an Alcatel Metro Router.

Our transmit is flowing through only 1 interface instead of 2 interfaces and it is also suffering from low throuhput (only tx).
Although Alcatel is properly utilizing both channels while transmitting without any throuhput issues.

Mikrotik, this is serious. Could you please try to replicate ?

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:54 pm
by Attila
Dear Normis!

Ticket#2013020566000411

Multicast routing (PIM-SM) same source to different interface doesn't work in CCR1036.
Same ROS version and same configuration (1. RP, 3. Interface) work like a charm in RB2011.

The problem exist with all RC ROS version and final 6.0 and CCR1036 firmware version (3.04,3.05).


Attila

Re: v6.0 released

Posted: Tue Jun 11, 2013 1:54 pm
by normis
V6.0 RC14 (CCR 1036-12G-4S)

Bonding 2xGiga interfaces (802.3ad, L3 and L4 Hashing). Remote side is an Alcatel Metro Router.

Our transmit is flowing through only 1 interface instead of 2 interfaces and it is also suffering from low throuhput (only tx).
Although Alcatel is properly utilizing both channels while transmitting without any throuhput issues.

Mikrotik, this is serious. Could you please try to replicate ?
This topic is about v6.0 and v6.1, yet your report is about an RC version. Please upgrade to v6.1 (link is above) and see if the problem is still there.

Re: v6.0 released

Posted: Tue Jun 11, 2013 2:09 pm
by doush
There is over 1250mbit passing through this router.

Are you sure that is it safe to try this pre-release version ?

Re: v6.0 released

Posted: Tue Jun 11, 2013 2:10 pm
by normis
There is over 1250mbit passing through this router.

Are you sure that is it safe to try this pre-release version ?

You are currently on a RC version. Version posted here is a stable version. Yes, it is much better than yours.

Re: v6.0 released

Posted: Tue Jun 11, 2013 2:13 pm
by doush
http://www.mikrotik.com/download/share/ ... le-6.1.npk


Above is the link ? or something else ?

Re: v6.0 released

Posted: Tue Jun 11, 2013 2:19 pm
by Attila
Dear Normis!

CCR1036 multicast routing (PIM-SM) same source to different interface is solved in 6.1 ?

Attila
What do you mean? Have you contacted support ?
Dear Normis!

Ticket#2013020566000411

Multicast routing (PIM-SM) same source to different interface doesn't work in CCR1036.
Same ROS version and same configuration (1. RP, 3. Interface) work like a charm in RB2011.

i.e.: Same IPTV channel routed to different interface at the same time only 1 of the clients is getting same stream.

CCR1036 multicast routing (PIM) configured (1.RP and 3. Interface). When the client watching Music Television (same multicast IP source) another client (set-top box) via different VLAN interface in CCR1036 (another network segment) can not watch Music Television at the same time and vice versa. Which client (set-top box) is watching Music Television for first... win...

So this is a big problem in IPTV environment with CCR1036.

The RB2011 in same network and same configuration works well with all ROS(5)(6) version.


Attila

Re: v6.0 released

Posted: Tue Jun 11, 2013 2:57 pm
by kapnos
Any news about the missing graphs(cpu, memory, disk) on 6.0?
yes, but you need to reinstall with netinstall for the fix to take effect

Reinstall 6.0 or 6.1? Does the configuration get reseted?

Re: v6.0 released

Posted: Tue Jun 11, 2013 4:01 pm
by Rudios
Any news about the missing graphs(cpu, memory, disk) on 6.0?
yes, but you need to reinstall with netinstall for the fix to take effect
Nice there is a solution, bit am a little dissapointed I don't get any reply on my mails.
Have been given access to my device but did not get any feedback nor answers on my mail.
I will try to reinstall 6.0 on my affected device.

Re: v6.0 released

Posted: Tue Jun 11, 2013 6:04 pm
by Stillhard
:shock: i'm gonna try this new v6.1 released

Edit:
tested 6.1 released (Jun/06/2013 16:11:56)
- NOT FIXED, error in usermanager web-ui (web-ui ignoring timezone setting)
- FIXED, ip > hotspot > active - Bytes Out, Packets Out, Tx Rate, Tx Rate stays in 0 bps :)
- NEW ERROR, on boot, there's an error about xxx...fastpath.ko not loading or something (can't afford to test that version again to see the msg again since alot of ppls will angry at me)

Back to 6.0rc14 again now (with error in usermanager web-ui (web-ui ignoring timezone setting) only)

Both of the above issues are fixed in v6.1 todays build
:-D GREAT JOB normis and all MT team!!!

tested 6.1 released (Jun/10/2013 16:26:01)
- FIXED, error in usermanager web-ui (web-ui ignoring timezone setting)
- FIXED, ip > hotspot > active - Bytes Out, Packets Out, Tx Rate, Tx Rate stays in 0 bps :)
- FIXED, on boot, there's an error about xxx...fastpath.ko not loading or something

Re: v6.0 released

Posted: Tue Jun 11, 2013 7:56 pm
by wa4zlw
I upgraded from 5.25 --> 6.0 on an RB450G that I manage and all hell broke loose. whole network went down on the inside. Turns out IP addresses weren't being leased or if they were the ACKs weren't coming back. Total disaster. Had to downgrade to 5.25 to get things back to normal.

Anyone have any ideas what went on here?

I successfully upgraded from 5.25 --> 6.0 on my watchguard x86 platforms.

Is 6.0 ok in the CCR?

THanks leon

Re: v6.0 released

Posted: Tue Jun 11, 2013 8:17 pm
by Stillhard
I upgraded from 5.25 --> 6.0 on an RB450G that I manage and all hell broke loose. whole network went down on the inside. Turns out IP addresses weren't being leased or if they were the ACKs weren't coming back. Total disaster. Had to downgrade to 5.25 to get things back to normal.

Anyone have any ideas what went on here?

I successfully upgraded from 5.25 --> 6.0 on my watchguard x86 platforms.

Is 6.0 ok in the CCR?

THanks leon
Use v6.1
- for CCR from http://www.mikrotik.com/download/share/ ... le-6.1.npk
- for x86 from http://www.mikrotik.com/download/share/ ... 86_6.1.npk
or from http://www.mikrotik.com/download/share/ ... es_6.1.zip

Edited typo: User to Use, thx chupa :lol:

Re: v6.0 released

Posted: Tue Jun 11, 2013 8:19 pm
by honzam

:-D GREAT JOB normis and all MT team!!!

tested 6.1 released (Jun/10/2013 16:26:01)
- FIXED, error in usermanager web-ui (web-ui ignoring timezone setting)
- FIXED, ip > hotspot > active - Bytes Out, Packets Out, Tx Rate, Tx Rate stays in 0 bps :)
- FIXED, on boot, there's an error about xxx...fastpath.ko not loading or something
Bug tracker would be very useful. It is complicated to read all topics and search bugs... Fixed bugs, etc...
Please make official BUG TRACKER

Something like this http://bugs.mikrotik-routeros.com/view_all_bug_page.php
Thanks

Re: v6.0 released

Posted: Tue Jun 11, 2013 8:54 pm
by wa4zlw
how does the user package have anything to do with ip address/dhcp???

Re: v6.0 released

Posted: Tue Jun 11, 2013 9:50 pm
by Chupaka
how does the user package have anything to do with ip address/dhcp???
he meant not 'user' but 'use' =)

Re: v6.0 released

Posted: Tue Jun 11, 2013 11:44 pm
by przent
+1 for BugTracker!

Posted: Tue Jun 11, 2013 11:55 pm
by pvidal
Another +1 for Bugtracker!

Enviado desde mi GT-P5110 usando Tapatalk 2

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:33 am
by manson
Hello,

There is a issue with DNS instance. I have added about 15000 static entries in /ip dns static to make DNS blackholing and dns is stopping to respond on dns query. CCR is responding for icmp echo, winbox is active etc... but DNS server crashes every once in a while.

I'm using CCR1036-12G-4S with RouterOS 6.1, same problem was on v6.0.

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:43 am
by warn1ng

Re: v6.0 released

Posted: Wed Jun 12, 2013 4:39 am
by jandafields
The link is misspelled.

It should be:

http://www.mikrotik.com/download/share/ ... 6.1rc1.npk

Re: v6.0 released

Posted: Wed Jun 12, 2013 5:09 am
by lunchboxrts
Hello,

There is a issue with DNS instance. I have added about 15000 static entries in /ip dns static to make DNS blackholing and dns is stopping to respond on dns query. CCR is responding for icmp echo, winbox is active etc... but DNS server crashes every once in a while.

I'm using CCR1036-12G-4S with RouterOS 6.1, same problem was on v6.0.
Don't do that, DNS on MikroTik is very basic. If you really need that many static entries use an external dns(bind etc).

Re: v6.0 released

Posted: Wed Jun 12, 2013 7:50 am
by Stillhard
The link is misspelled.

It should be:

http://www.mikrotik.com/download/share/ ... 6.1rc1.npk
No. don't use the rc, rc is for old release, it's 6.1 released, sorry if the link is not there, i guess MT team hasn't compiled it yet :D

Re: v6.0 released

Posted: Wed Jun 12, 2013 9:33 am
by normis
this is the correct link

X86 http://www.mikrotik.com/download/share/ ... 86-6.1.npk
CCR http://www.mikrotik.com/download/share/ ... le-6.1.npk
PPC http://www.mikrotik.com/download/share/ ... pc-6.1.npk
MBE http://www.mikrotik.com/download/share/ ... be-6.1.npk
MLE http://www.mikrotik.com/download/share/ ... le-6.1.npk
ALL http://www.mikrotik.com/download/share/ ... es_6.1.zip

new build today includes a memory leak fix

changes:

What's new in 6.1 (2013-Jun-12 08:56):

*) pptp, l2tp - fixed crash when tunnel mru was too big and fragmented ip packet
was received;
*) hotspot - fixed problem when after upgrade hotspot html directory was empty;
*) ipv6 nd - dns dynamic-servers were not included in router advertisements;
*) winbox - fixed problem Switch menu disappeared on RB2011;
*) fixed memory amount issue on RB1100AHx2;
*) console - '/import' prints each command that is executed;
*) console - 'import' has new argument 'from-line' that starts executing
commands after specified line;
*) secure api - fixed problem when wrong client ip address was reported;
*) hotspot - fixed universal client;
*) api - added support for API over TLS (SSL);
*) api - api service is now enabled by default;
*) ppp - do not show R flag for locally authenticated users;
*) vrrp - fixed ah authentication;
*) webfig - added support for RADIUS authentication (via MS-CHAPv2);
*) ipsec - for peers with full IP address specified system will
autostart ISAKMP SA negotiation;
*) trafficgen - added inject-pcap command for replaying pcap files into network;
*) dns - retry queries with tcp if truncated results received;
*) improved queue statistics updating;
*) fix 1G linking with some Cisco devices (affects RB7xx, RB9xx, RB1100, RB2011, CCR);

Re: v6.0 released

Posted: Wed Jun 12, 2013 9:44 am
by manson
Hello,

There is a issue with DNS instance. I have added about 15000 static entries in /ip dns static to make DNS blackholing and dns is stopping to respond on dns query. CCR is responding for icmp echo, winbox is active etc... but DNS server crashes every once in a while.

I'm using CCR1036-12G-4S with RouterOS 6.1, same problem was on v6.0.
Don't do that, DNS on MikroTik is very basic. If you really need that many static entries use an external dns(bind etc).
I bought two CCR1036 to make dns cache with vrrp redundancy. Don't tell me this will not work. I think there is a issue in dns daemon. Without loaded static entries it's working flawless. So i think there has been an error of some kind.

Re: v6.0 released

Posted: Wed Jun 12, 2013 11:45 am
by ela002
The latest version does it fix anything related to nat/pppoe connections? It seems pppoe over adsl modem bridge just hang.

The download links are too slow!!! 2 hours to download a small file?

Re: v6.0 released

Posted: Wed Jun 12, 2013 11:58 am
by manson
Hello,

There is a issue with DNS instance. I have added about 15000 static entries in /ip dns static to make DNS blackholing and dns is stopping to respond on dns query. CCR is responding for icmp echo, winbox is active etc... but DNS server crashes every once in a while.

I'm using CCR1036-12G-4S with RouterOS 6.1, same problem was on v6.0.
Don't do that, DNS on MikroTik is very basic. If you really need that many static entries use an external dns(bind etc).
I bought two CCR1036 to make dns cache with vrrp redundancy. Don't tell me this will not work. I think there is a issue in dns daemon. Without loaded static entries it's working flawless. So i think there has been an error of some kind.
I've tested it's performance... BIND on single core machine is faster cache server then CCR. It's worst spent 2.000 $ ever.
Any plans to make it any less useless?

Re: v6.0 released

Posted: Wed Jun 12, 2013 12:02 pm
by normis
First of all, I wish to thank the Mikrotik team for their good work. You guys are awesome!

I have a question regarding this release. I've upgraded few days ago and now my router experiences a new memory consumption phenomenon (see the attachment). I would consider it as a memory leak bug, but since it is a major version upgrade prior reporting I'm just wondering are there any new caching services enabled in this particular release? If so, then I would like to know what exactly are those in order to disable them.

My configuration is:
x86 Router OS on a multicore CPU
two virtual machines on KVM (their normal memory consumption is visible on the left of the pic)
Web Proxy was always disabled and I also checked it first, when I saw the memory graphic.
Hotspot normally for 60-90 clients

The only thing I've changed in my config right after upgrade was enabling the mac-cookie option (which was my reason for upgrading, otherwise I never upgrade if everything is stable). Normis, if you will consider this issue as a bug, then I will send the supout.
drusha, did you contact support with supout.rif file before reboot and after reboot? please send those files

Re: v6.0 released

Posted: Wed Jun 12, 2013 12:45 pm
by Stillhard
The download links are too slow!!! 2 hours to download a small file?
:lol: true true...

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:01 pm
by mistry7
Hi,


does anyone use Bonding Interface with EOIP?
there is a issue in the actual 6.1 Build from 10.06.2013 16:26.
New in 6.0 is that Bonding Interface MTU interference EOIP MTU.
After Reboot MTU on EOIP and Bonding are different an Bondung Interface is not working.
After disable Bonding, the disable EOIP Interface, an the enable all ok.

mistry7

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:21 pm
by manson
Ok, my problem with DNS is caused by fact that DNS on CCR is not multithreading and it's reaching 100% single core load.

My question to Mikrotik Support, are there plans to make RouterOS and daemons within multithreading? Cause what's the point to have 36 cores if any service can only use one?

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:53 pm
by normis
Ok, my problem with DNS is caused by fact that DNS on CCR is not multithreading and it's reaching 100% single core load.

My question to Mikrotik Support, are there plans to make RouterOS and daemons within multithreading? Cause what's the point to have 36 cores if any service can only use one?
usually each one uses a different core :)

but of course you are right, we are working to make all services use multithreading. software updates will improve this.

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:54 pm
by HaPe
When are you going to release ros with wireless controller?

Re: v6.0 released

Posted: Wed Jun 12, 2013 1:56 pm
by normis
When are you going to release ros with wireless controller?
working on many big projects right now. can't do them all at the same time. step by step.

Re: v6.0 released

Posted: Wed Jun 12, 2013 2:09 pm
by manson
Ok, my problem with DNS is caused by fact that DNS on CCR is not multithreading and it's reaching 100% single core load.

My question to Mikrotik Support, are there plans to make RouterOS and daemons within multithreading? Cause what's the point to have 36 cores if any service can only use one?
usually each one uses a different core :)

but of course you are right, we are working to make all services use multithreading. software updates will improve this.
Thank you for your answer. When approximately can we expect any of those updates? Month? Few months? I know that you have much work right now, but we'd like to know what to do with this problem for now.

Re: v6.0 released

Posted: Wed Jun 12, 2013 2:16 pm
by normis
I suggest opening a ticket with the support department and describe the exact issue with DNS that you are having. maybe the problem is elsewhere. support technicians will find and report any found bugs.

Re: v6.0 released

Posted: Wed Jun 12, 2013 2:22 pm
by wa4zlw
the release notes don't mention the issues I had with the RB450G.

BUGTRACKER is needed. Is this officially released now? If so I dont see it on the website.

Leon

Re: v6.0 released

Posted: Wed Jun 12, 2013 2:25 pm
by jandafields
the release notes don't mention the issues I had with the RB450G.

BUGTRACKER is needed. Is this officially released now? If so I dont see it on the website.

Leon
It's not officially released until it shows up on the download page. Currently, it is only available to testers and people on this forum.

Re: v6.0 released

Posted: Thu Jun 13, 2013 11:44 am
by fkayser
Hi,

I'm no sure if this is the right place for my post, but I'll give it a try ;)
I've installed 6.1 on an 2011L with Firmware 3.08 to try the new feature:

webfig - added support for RADIUS authentication (via MS-CHAPv2)

The RADIUS authentication via the console is working, but for the webfig I get an error:

ERROR: router has been disconnected.

In the log of the RB I get the following message:

01:09:50 system,info,account user fkayser logged in from 10.115.192.96 via web

I tried with different browsers (Chrome, Firefox, IE). For Chrome and Firefox I've got the same message and for IE only "ERROR:" was shown.

Do I miss something in the config or is there a bug?

RADIUS config:
/user
add comment="system default user" group=full name=admin
add group=full name=user1
/user aaa
set default-group=full use-radius=yes
/radius
add address=XXX.XXX.XXX.XXX secret=testlab service=login src-address=192.168.254.71
/ip address
add address=192.168.254.71/24 interface=ether3 network=192.168.254.0

Thanks for any reply

Re: v6.0 released

Posted: Thu Jun 13, 2013 11:52 pm
by regardtv
Ok, my problem with DNS is caused by fact that DNS on CCR is not multithreading and it's reaching 100% single core load.
Manson, While I agree it would be great for all daemons to be fully multi-threaded I must concur with one of the previous posters - making the CCR your network's main DNS recursors/resolvers is really a crappy idea.

We have a rather large DNS infrastructure and dealing with DNS attacks (DDOS and other), query rate-limiting, DNSSEC and other issues are just not practical on a product designed as a ROUTER.

The DNS offered by Mikrotik is good enough for the basics - but really won't suit your needs in the long term.

Just my 2c worth ...

And sorry for going off v6 topic ;-)

Re: v6.0 released

Posted: Fri Jun 14, 2013 8:41 am
by normis
the release notes don't mention the issues I had with the RB450G.

BUGTRACKER is needed. Is this officially released now? If so I dont see it on the website.

Leon
If this issue was introduced during pre-release, and fixed during pre-release, it doesn't affect normal users, hence it is not in the changelog.

Re: v6.0 released

Posted: Thu Jun 20, 2013 2:19 pm
by alphil
We updated ROS from 5.14 to 6.1 on a x86 platform and we have a problem with ARP table now. The Mikrotik's ARP table is dynamic and DHCP server is a Windows 2k3 Server. When a PC change its IP address (release, renew), - the Mikrotik's ARP table maintains the old MAC address. Then, the PC haven't access to Internet.

Re: v6.0 released

Posted: Mon Jun 24, 2013 12:45 pm
by scampbell
I saw this on one site. Check the lease time on the W2K server. My site was set to expire its leases every 1h and changing it to 3d made a big difference. (ROS 6.1 CCR 1016)

Having said that the ARP table should have refreshed with the 1 hour settings but sometimes workarounds are useful :-)

Re: v6.0 released

Posted: Thu Jun 27, 2013 2:26 am
by alphil
This situation isn't normal. ROS 6.1 (x86) doesn't erase MAC addresses from its ARP table. I think, that the ARP table must be updated every 20 minutes at most. At night, all PC's are off, but ARP table is maintains all records for all night.

Re: v6.0 released

Posted: Thu Jun 27, 2013 4:46 pm
by Chupaka
check
:put [/ip settings get arp-timeout]

Re: v6.0 released

Posted: Thu Jun 27, 2013 6:52 pm
by wildbill442
Manson, While I agree it would be great for all daemons to be fully multi-threaded I must concur with one of the previous posters - making the CCR your network's main DNS recursors/resolvers is really a crappy idea.

We have a rather large DNS infrastructure and dealing with DNS attacks (DDOS and other), query rate-limiting, DNSSEC and other issues are just not practical on a product designed as a ROUTER.

The DNS offered by Mikrotik is good enough for the basics - but really won't suit your needs in the long term.

Just my 2c worth ...

And sorry for going off v6 topic ;-)
I concur... If you're maxing CPU cycles on DNS requests then you should have a dedicated DNS Cache and separate servers for forward and reverse zones.

Re: v6.0 released

Posted: Fri Jun 28, 2013 11:45 am
by alphil
check
:put [/ip settings get arp-timeout]
checked, 00:00:30

Arp table not clearing dynamic entries.

Posted: Sat Aug 17, 2013 8:32 pm
by bney
I also have had this problem. Caused some of my customers a lot of heartburn.
We changed a router in our core. Didnt notice that the arp entries never expired.
When I checked the arp table 30 hours after the change, the old entries were still
there. I left one in place just to see what happens and its still there 2 days later.
Once I delete the old entry the proper entry appears but this is a definite bug in version 6.

Re: v6.0 released

Posted: Sat Dec 23, 2017 5:35 pm
by abhishake
Hi team i have Mikrotik CCR 300 installed at my location
i want startup wifi zone in my area through APs pls suuggest
is router support wif controller and how can enable free usage for exisitng broadband customer and 20 min free fro new customer

Re: v6.0 released

Posted: Sat Dec 23, 2017 11:13 pm
by mistry7
Please Open new topic