Page 1 of 1

Traffic prioritizing on interfaces, need crazy help

Posted: Sun Jun 09, 2013 4:30 pm
by Ehman
Hi,

I need some help here, I've got a routerboard 750 and want to use it to prioritize ether2 with the highest and ether5 with the lowest and the internet goes in on ether1

can this be done, I've got no idea how to make it work, the speed is variable, so I cant say 1MB for that, I just want to give something a higher priority

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 2:15 am
by webpagetech
You want to look into /ip firewall mangle to identify the traffic going to and from you lan interfaces. You can use queues to prioritize and shape your traffic using the identification tags that you set up in you mangle rules.

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 2:48 am
by Ehman
You want to look into /ip firewall mangle to identify the traffic going to and from you lan interfaces. You can use queues to prioritize and shape your traffic using the identification tags that you set up in you mangle rules.
Hi, thx for reply, do you have a example for me, I have no idea how to setup that stuff

Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 4:03 am
by cbrown
You would be better off to use simple queues, they are much easier for the beginner and just as effective for what you are trying to achieve.

http://wiki.mikrotik.com/wiki/Manual:Qu ... ple_Queues

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 4:12 am
by Ehman
So with simple queues, I can set one interface with a priory of 8 and the other one to 1 without needing to set a max upload and download speed on the queue?

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 4:25 pm
by Ehman
Ok, simple queues is working on speed throttling but thats not want I want, I have no luck with the interface priority part :(

Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 6:59 pm
by cbrown
Create a parent queue for the two queues u created and set the max limit on the parent queue.

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Mon Jun 10, 2013 9:21 pm
by Ehman
nah not working

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Thu Jun 27, 2013 10:18 am
by webpagetech
Are ether2 and ether5 bridged? do they have different subnets? what is the lan set up?

I set a little test up but I'm on a bridge so I used src address instead of interface.

you could try having your wan as the parent target and eth2 and eth5 as your child targets. You will need to follow a couple rules.

1)The parent queue needs to have a max-limit set(setting it to high is not desirable try and be close to what the connection can actually handle).
2)The parent queue should not have a limit-at set and the priority does not mater.
3)Both child queues need to have a limit-at set so that when added together they add to the max-limit of the parent.
4) priority will only help distribute parent bandwidth so it only works in the child(leaf) queues

I don't have a test router on me right this sec to test interface priority but since I'm not to familiar with simple queue priority(mangle->queue-tree still seems simpler to me) I set up a test on my lan.
I'm running 6.1 currently and Allot has changed in simple queue in the new release so I hope this will still work if you haven't upgraded yet. I also suggest changing your default-small queue in queue types to sfq as it will limit on a per user basis cleaner than fifo.

lets say you have a bridge called bridge-lan that you have a /24 allocated. You want to prioritize and give more bandwidth to the first half of the subnet then the other.
/queue simple
add max-limit=0/9M name=parent-download target=bridge-lan
add limit-at=0/6M max-limit=0/9M name=priority-down parent=parent-download priority=7/7 target=192.168.1.0/25 total-priority=7
add limit-at=0/3M max-limit=0/9M name=regular-down parent=parent-download target=192.168.1.128/25
add max-limit=0/3M name=parent-upload target=1-wan
notice that the upload needs to have the wan as the parent instead of the lan and that the upload can't prioritize the two groups.

I'm still kind of confused why the parent queue can't be set to global. I think that would allow us to capture up and down traffic. As is, in the example above the queues can only limit traffic that is going out of their target interface.

as of right now there are not many examples on simple queues in version 6. Most of them have to do with using a /32 src address in a pcq situation and work just fine for the upload and download.

This example works great for the download prioritization but upload is just limited on a all user basis(bandage work around for now i hope).

I hope this helps. I can get a test router and try in 5.25 with your interface situation if this does not help you come to a resolution.

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Thu Jun 27, 2013 12:46 pm
by Ehman
Are ether2 and ether5 bridged? do they have different subnets? what is the lan set up?

I set a little test up but I'm on a bridge so I used src address instead of interface.

you could try having your wan as the parent target and eth2 and eth5 as your child targets. You will need to follow a couple rules.

1)The parent queue needs to have a max-limit set(setting it to high is not desirable try and be close to what the connection can actually handle).
2)The parent queue should not have a limit-at set and the priority does not mater.
3)Both child queues need to have a limit-at set so that when added together they add to the max-limit of the parent.
4) priority will only help distribute parent bandwidth so it only works in the child(leaf) queues

I don't have a test router on me right this sec to test interface priority but since I'm not to familiar with simple queue priority(mangle->queue-tree still seems simpler to me) I set up a test on my lan.
I'm running 6.1 currently and Allot has changed in simple queue in the new release so I hope this will still work if you haven't upgraded yet. I also suggest changing your default-small queue in queue types to sfq as it will limit on a per user basis cleaner than fifo.

lets say you have a bridge called bridge-lan that you have a /24 allocated. You want to prioritize and give more bandwidth to the first half of the subnet then the other.
/queue simple
add max-limit=0/9M name=parent-download target=bridge-lan
add limit-at=0/6M max-limit=0/9M name=priority-down parent=parent-download priority=7/7 target=192.168.1.0/25 total-priority=7
add limit-at=0/3M max-limit=0/9M name=regular-down parent=parent-download target=192.168.1.128/25
add max-limit=0/3M name=parent-upload target=1-wan
notice that the upload needs to have the wan as the parent instead of the lan and that the upload can't prioritize the two groups.

I'm still kind of confused why the parent queue can't be set to global. I think that would allow us to capture up and down traffic. As is, in the example above the queues can only limit traffic that is going out of their target interface.

as of right now there are not many examples on simple queues in version 6. Most of them have to do with using a /32 src address in a pcc situation and work just fine for the upload and download.

This example works great for the download prioritization but upload is just limited on a all user basis(bandage work around for now i hope).

I hope this helps. I can get a test router and try in 5.25 with your interface situation if this does not help you come to a resolution.
Hi, yea its all bridged to act as a simple switch, ether1 is WAN (internet)

ether2 is for CEO's, and ether5 is for facebook guys and random traffic that not really important, but I want them all to have the same speed, but just a different priority

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Thu Jun 27, 2013 4:27 pm
by webpagetech
OK so what are the bandwidth limitations of the wan port?

Are they both on the same subnet? If so is there any differences in the addresses that users on port two would have vs users on port five?

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Thu Jun 27, 2013 5:11 pm
by Ehman
OK so what are the bandwidth limitations of the wan port?

Are they both on the same subnet? If so is there any differences in the addresses that users on port two would have vs users on port five?
All same subnet, its like a transparent shaper
bandwidth limitations should be the same for everyone, just ether2 must have first priority over everything they want to access, bandwidth wise

Re: Traffic prioritizing on interfaces, need crazy help

Posted: Thu Jun 27, 2013 6:11 pm
by webpagetech
What is your actual internet speeds? you need to set this as parent max limit.

It would help if you ran an export so we could see what is going on.

/interface export compact
and then past your results.

I think the problem might be that logically they are on the same port (bridge or switch chip). ether2 and ether5 are probably slaves to this bridge.

If this is the case you might need to separate the two groups logically. An address lists from dhcp would do it.