Page 1 of 1

Why can't I ping thru?

Posted: Fri Mar 17, 2006 3:35 pm
by pekr
Hi,

yesterday I installed following test configs, as I am struggling with establishing static routes, but that will come probably with another post :-)

So here we go: http://www.xidys.com/test-config.jpg

The trouble is, PC2 and PC3 can ping out of the box! But PC1 is NOT reachable. I do not know why - no firewall. I even disabled default route and masquarading, as then it pings, but I want clean routing. Why PC1 is not visible, only its nearest eth1 interface (10.0.1.1) is visible from the point of view of PC2 and PC3.

Could switch make a difference? I even deplugged switch and connected PC1 directly to eth1, but still no ping - I was confused (well, but now as I think about it, RB could remember some ARP entries, so not sure what is going on).

I even enabled arp-proxy on eth1 for a while, but still no ping to PC1 (or whatever on 10.01.0/24 network).

I don't understand the difference - do I have to define static route somehow, if there is switch involved in-between? How do I define it, please? I tried all possible combinations as:

for pc3:
destination - 10.0.1.0/24
gateway - 10.0.1.1
preferred source - 10.0.3.1

but still no ping. Btw - with such defined route, the route entry stays in blue color, has only S mark (not AS) it says interface unknown (whereas in terminal mode it shows interface - a winbox bug ;-)

So, how do I define proper static route? What is a destination (imo a destination network, but can it be even a concrete IP?), what is a gateway (imo outmost interface reachable from the router directly?) and what is preferred source and do I need to use it at all?

Please show me an example of static route defined for my test set-up, I would like to finally know how to do it, as I am struggling this small issue for quite a bit of a time already :-)

OK, any help appreciated,

thank you very much,
Petr

Posted: Sat Mar 18, 2006 8:22 pm
by pekr
Hi,

so here I am with my own findings. Maybe some novices, as we, would find following interesting.

If you look into picture (link in previous post), I had following problem - from PC2 or PC3 I could NOT ping to PC1.

As one folk pointed to me on czech forum, the cause was, that on PC1, I had gateway set to 10.0.1.254, simply to wan! So when I changed it to 10.0.1.1, I was able to ping from PC 2/3 to PC1.
---------------------------------------------

But that was not all - I played with gateways on PC1. I wanted them have both. So I had two gateways on PC1:

10.0.1.254 (wan - internet), 10.0.1.1, to be able to reply to PC2/3. But that did not work once again ...

Then I looked into PC1 Windows settings and found, that both have metrics of "automatic" set. In that case, imo Windows is using gateways as they are listed. As both are on the same network, the first one (pointing to wan), was used, and once again I could not ping. So I played with metrics and when 10.0.1.1 has lower metrics, it worked once again - well, because it was listed first ...

I did not find the way, how to define in Windows gui, gateway, based upon source address/network. So I just got to console (cmd), looked into 'route table and tried:

route add 10.0.2.0/24 mask 255.255.255.0 10.0.1.1

and voila, I was able to get my pings once again ....

Heh, do you know the feeling, when you finally find out something, what seems so obvious afterwards? :-)

cheers,
-pekr-