Community discussions

MikroTik App
 
servizioaudiovideo
just joined
Topic Author
Posts: 3
Joined: Tue Jul 16, 2013 12:30 pm

3G UMTS ONDA/ HUAWEI USB Modem disconnect and not reconnect

Thu Aug 22, 2013 11:53 am

Hi,
I have a trouble with some USB 3G modem (different models/brands). After many days (in which the router is power on /off many times from and operator) the 3G USB modem go in "disconnect" state and it doesn't reconnect also if I reboot the device nor if I power on/off the device (RB751U-2hnD).

I have tried many methods for to unlock the modem (AT commands of reset / disable RF circuit / disable cdrom mode ) but none of this is working .

The only method for to restart the 3g connection is to go into the web interface >ppp-client , select the ppp connection, disable > apply > enable > apply. Another method is to insert the USB 3G modem into a laptop/pc and start the operator connection software.

I have thinking "I write a script that if there is not connection, execute the operation automatically". But I have tried to enable/disable the connection from ssh console, but here is not working. My question is: Someone know the difference of the enable/disable command from the web interface and the ssh console? What happen to the router or modem when I press enable/disable into the web interface that is different from ssh console?

Thanks.


22/08/2013 NEWS

I have many other devices, with same configuration, with this issue.
I have seen that the issue happens when the user don't use the 3g connection for 1 week or more (!?!).
I confirm that the only manner for to unlock the 3G connection is from web interface --> ppp-client --> configuration --> disable ---> enable ---> APPLY.

This is a section of ssh-console, at the first connection after the issue:
[admin@alterinibus] /interface ppp-client> disable 0
[admin@alterinibus] /interface ppp-client> enable 0
[admin@alterinibus] /interface ppp-client> monitor 0
  status: disconnected
[admin@alterinibus] /interface ppp-client> print
Flags: X - disabled, R - running 
 0    name="3G_ADSL" max-mtu=1500 max-mru=1500 mrru=disabled port=(unknown)
      data-channel=1 info-channel=2 apn="ibox.tim.it" pin="" user="" 
      password="" profile=default phone="*99#" dial-command="ATDT" 
      modem-init="ATZ" null-modem=no dial-on-demand=no add-default-route=yes 
      use-peer-dns=yes keepalive-timeout=0 allow=pap,chap,mschap1,mschap2

[admin@alterinibus] /interface ppp-client> enable 0 
[admin@alterinibus] /interface ppp-client> disable 0
[admin@alterinibus] /interface ppp-client> enable 0 
[admin@alterinibus] /interface ppp-client> disable 0
[admin@alterinibus] /interface ppp-client> enable 0
[admin@alterinibus] /interface ppp-client> disable 0
[admin@alterinibus] /interface ppp-client> info 0   
failure: Unable to acquire port!
I see "port=(unknown)" and finally "failure: Unable to acquire port!"
Then, after I press enable --> disable --> APPLY, from web interface
[admin@alterinibus] /interface ppp-client> info 0
             status: call in progress
         pin-status: no password required
      functionality: full
       manufacturer: ONDA COMMUNICATION
              model: MT689DC
           revision: MT68xDC.TIM.FW.B06
      serial-number: 358729040499941
   current-operator: Telecom Italia Mobile
  access-technology: 3G
     signal-strengh: -65 dBm
   frame-error-rate: n/a
All is OK now.

My question is: What happens when I press "APPLY", that the ssh-console doesn't do? Which commands send to router the APPLY key?

Please someone reply this post.... is very important for the customer credibility of my businness/company.

Regards to all.


Last bumped by servizioaudiovideo on Thu Aug 22, 2013 11:53 am.

Who is online

Users browsing this forum: Bing [Bot], kakaxa, reman6110 and 54 guests