Community discussions

 
ners
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Tue Mar 12, 2013 4:30 pm

ROS 6.x how to stop simple queues mess with queue tree

Thu Jul 25, 2013 1:19 pm

I am testing a PPPoE NAS on Mikrotik 1100AHx2, ROS 6.1

Radius sends Mikrotik-Rate-Limit attribute for each newly connected user.

A dynamic simple queue is created like this:
0 D name="<pppoe-mikrotik_4m>" target=<pppoe-mikrotik_4m> parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=4096k/4096k max-limit=4096k/4096k
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
However I want to define a list of networks from where my users would get unlimited bandwidth.

ros code

/ip firewall mangle
add action=mark-packet chain=forward dst-address-list=city_nets new-packet-mark=CITY_UPLOAD
add action=mark-packet chain=forward new-packet-mark=CITY_DOWNLOAD src-address-list=city_nets

ros code

/queue type
add kind=pcq name=city_up pcq-classifier=src-address
add kind=pcq name=city_down pcq-classifier=dst-address

ros code

/queue tree
add name=citynov_up packet-mark=CITY_UPLOAD parent=global queue=city_up
add name=citynov_down packet-mark=CITY_DOWNLOAD parent=global queue=city_down

Traffic is correctly captured by the queue in the tree, but it is also captured by the simple queue, so traffic gets limited anyway. I cannot find a way to prevent dynamic simple queues from firing at traffic which was already processed by a tree queue. Is there any?

Who is online

Users browsing this forum: Majestic-12 [Bot] and 107 guests