Community discussions

 
jeraldvimal
just joined
Topic Author
Posts: 23
Joined: Thu Jun 20, 2013 2:17 pm

bandwidth management

Fri Aug 02, 2013 11:40 am

hi can any one help me

how to control the bandwidth in rb 750 by using queues

my need is i want to control the user based on the usage
for instant like bsnl i want to controll my internet user up to 6 gb data download speed is 1mbps after 6gb usage download speed
step down 256 kbps
how to do this stuf plz help me
thanks
jeraldvimal
ooty
 
mistry7
Forum Guru
Forum Guru
Posts: 1326
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: bandwidth management

Sat Aug 03, 2013 12:11 am

You Need a Radius Server with Multi contract Support
I'am Using radius Manager from DMA Softlab

mistry7
 
User avatar
mahnet
Long time Member
Long time Member
Posts: 654
Joined: Tue Jul 07, 2009 9:11 pm

Re: bandwidth management

Mon Aug 05, 2013 4:55 am

i want to do similar stuff with Mikrotik user manager and radius server.
Is it possible??
 
jeraldvimal
just joined
Topic Author
Posts: 23
Joined: Thu Jun 20, 2013 2:17 pm

Re: bandwidth management

Mon Aug 05, 2013 10:00 am

can you explain how to do this
 
User avatar
samir494
Member Candidate
Member Candidate
Posts: 236
Joined: Thu Aug 06, 2009 11:27 am
Location: India

Re: bandwidth management

Mon Aug 05, 2013 10:10 am

if your are using MT userman,

its very easy & quicky too
Mistry Samir
Unique and Different
India
9920670022

Give me more Karma
 
User avatar
mahnet
Long time Member
Long time Member
Posts: 654
Joined: Tue Jul 07, 2009 9:11 pm

Re: bandwidth management

Tue Aug 06, 2013 7:40 am

i have tried several options but it does not work.
I asked mikrotik support and it tells me that we need to have two profiles and write a script to run one profile and switch over to the second when the first(i.e. the data limit) is finished.
I do not know how to write a script.
Pls if forum can help.
 
User avatar
samir494
Member Candidate
Member Candidate
Posts: 236
Joined: Thu Aug 06, 2009 11:27 am
Location: India

Re: bandwidth management

Tue Aug 06, 2013 8:56 am

/queue simple
#name=”Limit 6GB” target-addresses=192.168.1.0/24 dst-address=0.0.0.0/0
interface=<ether-x> parent=none direction=both
max-limit=1M/1M total-queue=default-small

#name=”After 6GB” target-addresses=192.168.1.0/24 dst-address=0.0.0.0/0
interface=<ether-x> parent=none direction=both
max-limit=256k/256k total-queue=default-small

/system script
#name=”Limit 6GB” source=/queue simple enable Limit 6GB; /queue simple disable After 6GB

#name=”After 6GB” source=/queue simple enable After 6GB; /queue simple disable Limit 6GB

now create
system scheduler for your hotspot user profile

else just make a script as below

:local traf;
/queue simple
:for i from=1 to= 254 do = {
:if ([/queue simple find target-addresses=("192.168.1." . $i)] != "") do={
:set traf [get [find target-addresses=("192.168.1." . $i)] total-bytes]
:if ($traf > 104857600(put your 6GB here)) do = {
set [find target-addresses=("192.168.1." . $i)] max-limit= 256000/256000
}
}
}
Mistry Samir
Unique and Different
India
9920670022

Give me more Karma
 
jeraldvimal
just joined
Topic Author
Posts: 23
Joined: Thu Jun 20, 2013 2:17 pm

Re: bandwidth management

Wed Aug 07, 2013 10:11 am

thank u sir i do this
 
jeraldvimal
just joined
Topic Author
Posts: 23
Joined: Thu Jun 20, 2013 2:17 pm

Re: bandwidth management

Wed Aug 07, 2013 10:30 am

if i control the particular address means this script is right



if ([/queue simple find target-addresses=("192.168.1.10)] != "")
 
Ehman
Member
Member
Posts: 363
Joined: Mon Nov 15, 2010 10:49 pm

Re: bandwidth management

Sat Aug 24, 2013 2:32 am

You Need a Radius Server with Multi contract Support
I'am Using radius Manager from DMA Softlab

mistry7
I'm also using radius manager, but lol!, you cant expect a noob to turn into a linux genius and doing the works that involves using Radius manager, because its hard as hell and takes forever to understand + configuring radius manager the way you want it to work and understanding everything aint no joke

Who is online

Users browsing this forum: No registered users and 103 guests