Community discussions

MikroTik App
 
wiyat
newbie
Topic Author
Posts: 45
Joined: Tue Jan 12, 2010 9:38 pm
Contact:

Quality of Service by Vlan Separate Data and VoIP

Mon Aug 05, 2013 12:21 pm

Dear
Mikrotik Users


I need your support maybe someOne can support to me.- The point is: How I can transport my VoIP traffic across the new Vlan20 and the rest of the traffic for the normal way.

I create on my RB1200/PPPoE Server R2, Cisco Switch and Main router R1 a Vlan20, after to do this, I create a /IP Route Rules where I declare that all traffic that going to 84.X.X.209 (asterisk server) mark routing how VoIP, after this I create /IP Route a new route where 0.0.0.0/0 gateway to 10.255.252.1 with routing Mark "VoIP".

Automatically all Traffic that go to my asterisk going to Vlan20, NOW I need to declare on my Router R1 that all traffic that come from 84.X.X.209 mark how VoIP using a /IP ROUTE RULES using the same table.

On My Router R1, I create a /IP ROUTE add a new route where I say it: 0.0.0.0/0 via 10.255.252.2 where have routing mark "VoIp".

The VoIP Traffic from my Router R2 work 100% via VLAN20.

My problem is: The VoIP Traffic that go via OSPF to the Router R3, Router R4, Router R5 not work, because I routing all VoIP traffic via Vlan20 to the router R2.

My question is How I can do for working with my Asterisk Server on my network where 1 Router will be work with Vlan20 for SIP/Traffic and the others Router R3, R4, R5 will be work with OSPF Dynamic for the VoIP/traffic?

Please send me back your comments,
You do not have the required permissions to view the files attached to this post.
 
wiyat
newbie
Topic Author
Posts: 45
Joined: Tue Jan 12, 2010 9:38 pm
Contact:

Re: Quality of Service by Vlan Separate Data and VoIP

Mon Aug 05, 2013 1:01 pm

Dear
All

Remember that my problem is How I can combine the rounting traffic on R1 that come from 84.X.X.209/Asterisk Server to OSPF Dynamic with R3, R4, R5 and Vlan20 on R2

At the moment I setting up on R2 and R2 the following configuration:

/ip route rule
add action=lookup disabled=no dst-address=84.X.X.209/32 interface=ether2 table=voip
/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.255.252.1 routing-mark=voip scope=30 target-scope=10


On Router 1

/ip route rule
add action=lookup comment="" disabled=no interface=vlan20 src-address=84.X.X.209/32 table=voip
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.255.252.2 routing-mark=voip scope=30 \
target-scope=10


But my others Router R3, R4, R5 the VoIP Traffic not work because R1 not send back the traffic It by OSPF at the moment only that work the VoIp Traffic by Vlan20, My question is How I can routing on R1 the income traffic that come from 84X.X.209 via OSPF to R3,R4,R5 and via Vlan20

Who is online

Users browsing this forum: marek263, sindy and 194 guests