Community discussions

 
stranger2904
just joined
Topic Author
Posts: 3
Joined: Thu Jul 25, 2013 10:34 am

BGP based VPLS, help needed

Thu Aug 08, 2013 8:48 pm

Hello everyone, I'm trying to setup this scheme (followed wiki examples):
Image
But for some reason I can get vpls up.
BGP/LDP - seems ok.
All routerboards are updated to 6.2.
192.168.22.0/24 - Net for management.
Doesn't know what else I should check..

PE2-configured to act as route reflector.


PE1 Config:
[admin@PE1] > /export compact 
# jan/02/1970 00:22:21 by RouterOS 6.2

#
/interface bridge
add name=loopback
add name=vpn
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/port
set 0 name=serial0
/routing ospf instance
set [ find default=yes ] router-id=10.13.0.2
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/ip address
add address=192.168.22.130/24 interface=ether10 network=192.168.22.0
add address=10.12.1.17/30 interface=ether2 network=10.12.1.16
add address=10.12.1.2/30 interface=ether3 network=10.12.1.0
add address=10.12.1.6/30 interface=ether1 network=10.12.1.4
add address=10.13.0.2/32 interface=loopback network=10.13.0.2
/ip route vrf
add disabled=yes interfaces=ether1,ether2,ether3,loopback route-distinguisher=1:1 routing-mark=MPLS_VPLS
/lcd interface
set sfp1 interface=sfp1
set ether1 interface=ether1
set ether2 interface=ether2
set ether3 interface=ether3
set ether4 interface=ether4
set ether5 interface=ether5
set ether6 interface=ether6
set ether7 interface=ether7
set ether8 interface=ether8
set ether9 interface=ether9
set ether10 interface=ether10
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.13.0.2 transport-address=10.13.0.2
/mpls ldp interface
add interface=ether1 transport-address=10.13.0.2
add interface=ether2 transport-address=10.13.0.2
add interface=ether3 transport-address=10.13.0.2
/routing bgp peer
add address-families=l2vpn name=pe3 remote-address=10.13.0.1 remote-as=65530 ttl=default update-source=loopback
add address-families=l2vpn name=pe2 remote-address=10.13.0.3 remote-as=65530 ttl=default update-source=loopback
add address-families=l2vpn name=cpe1 remote-address=10.13.0.4 remote-as=65530 ttl=default update-source=loopback
/routing ospf interface
add interface=ether1
add interface=ether2
add interface=ether3
/routing ospf network
add area=backbone network=10.12.1.16/30
add area=backbone network=10.13.0.2/32
add area=backbone network=10.12.1.0/24
add area=backbone network=10.12.1.4/30
/system identity
set name=PE1
PE2:
[admin@PE2] > /export compact 
# jan/02/1970 00:24:54 by RouterOS 6.2
# software id = T6PG-8NKN
#
/interface bridge
add name=loopback
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/routing ospf instance
set [ find default=yes ] router-id=10.13.0.3
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/ip address
add address=10.12.1.10/30 interface=ether2 network=10.12.1.8
add address=10.12.1.5/30 interface=ether10 network=10.12.1.4
add address=192.168.22.132/24 interface=ether9 network=192.168.22.0
add address=10.13.0.3/32 interface=loopback network=10.13.0.3
add address=172.16.0.1/24 interface=ether5 network=172.16.0.0
/ip route vrf
add disabled=yes interfaces=ether2,ether10,loopback route-distinguisher=1:1 routing-mark=MPLS_VPLS
add interfaces=ether5 route-distinguisher=2:2 routing-mark=test
/ip service
set api disabled=yes
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.13.0.3 transport-address=10.13.0.3
/mpls ldp interface
add interface=ether10
add interface=ether2
/routing bgp peer
add address-families=l2vpn name=pe3 remote-address=10.12.1.9 remote-as=65530 route-reflect=yes ttl=default update-source=loopback
add address-families=l2vpn name=pe1 remote-address=10.13.0.2 remote-as=65530 route-reflect=yes ttl=default update-source=loopback
add name=cpe1 remote-address=10.13.0.4 remote-as=65530 route-reflect=yes ttl=default
add name=cpe2 remote-address=10.13.0.5 remote-as=65530 route-reflect=yes ttl=default
/routing ospf interface
add interface=ether10
add interface=ether2
/routing ospf network
add area=backbone network=10.13.0.3/32
add area=backbone network=10.12.1.0/24
/system identity
set name=PE2

PE3:
[admin@PE3] > /export compact 
# jan/02/1970 00:26:01 by RouterOS 6.2
#
/interface bridge
add name=loopback
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/routing ospf instance
set [ find default=yes ] router-id=10.13.0.1
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/ip address
add address=10.12.1.1/30 interface=ether3 network=10.12.1.0
add address=10.12.1.9/30 interface=ether2 network=10.12.1.8
add address=10.12.1.13/30 interface=ether10 network=10.12.1.12
add address=192.168.22.131/24 interface=ether9 network=192.168.22.0
add address=10.13.0.1/32 interface=loopback network=10.13.0.1
add address=172.16.0.2/24 interface=ether5 network=172.16.0.0
/ip route vrf
add disabled=yes interfaces=ether2,ether3,ether10,loopback route-distinguisher=1:1 routing-mark=MPLS_VPLS
add interfaces=ether5 route-distinguisher=2:2 routing-mark=test
/ip service
set api disabled=yes
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.13.0.1 transport-address=10.13.0.1
/mpls ldp interface
add interface=ether2
add interface=ether3
add interface=ether10
/routing bgp peer
add address-families=l2vpn name=pe1 remote-address=10.13.0.2 remote-as=65530 ttl=default update-source=loopback
add address-families=l2vpn name=pe2 remote-address=10.13.0.3 remote-as=65530 ttl=default update-source=loopback
add address-families=l2vpn name=cpe2 remote-address=10.13.0.5 remote-as=65530 ttl=default update-source=loopback
/routing ospf interface
add interface=ether10
add interface=ether2
add interface=ether3
/routing ospf network
add area=backbone network=10.12.1.0/24
add area=backbone network=10.13.0.1/32
add area=backbone network=10.12.1.8/30
add area=backbone network=10.12.1.12/30
/system identity
set name=PE3
[admin@PE3] > 
CPE1:
[admin@CPE1] > /export compact 
# jan/02/1970 00:26:53 by RouterOS 6.2

#
/interface bridge
add name=loopback
add l2mtu=1598 mtu=1526 name=vpnA
/interface wireless
set 0 l2mtu=2290 ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/routing ospf instance
set [ find default=yes ] router-id=10.13.0.4
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/interface bridge port
add bridge=vpnA interface=ether2
/interface vpls bgp-vpls
add bridge=vpnA bridge-cost=5 bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1 name=A pw-mtu=1526 route-distinguisher=1:1 site-id=4
/ip address
add address=10.12.1.18/30 interface=ether1 network=10.12.1.16
add address=192.168.22.133/24 interface=ether5 network=192.168.22.0
add address=10.13.0.4/32 interface=loopback network=10.13.0.4
/ip route vrf
add disabled=yes interfaces="ether1,loopback,(unknown)" route-distinguisher=1:1 routing-mark=MPLS_VPLS
/ip service
set api disabled=yes
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.13.0.4 transport-address=10.13.0.4
/mpls ldp interface
add interface=ether1
/routing bgp peer
add address-families=l2vpn name=pe1 remote-address=10.13.0.2 remote-as=65530 ttl=default update-source=loopback
add address-families=l2vpn name=pe2 remote-address=10.13.0.3 remote-as=65530 ttl=default update-source=loopback
/routing ospf interface
add interface=ether1
/routing ospf network
add area=backbone network=10.12.1.0/24
add area=backbone network=10.13.0.4/32
/system identity
set name=CPE1
/system leds
set 0 interface=wlan1
CPE2:
[admin@CPE2] > /export compact 
# jan/02/1970 00:27:34 by RouterOS 6.2

#
/interface bridge
add name=loopback
add l2mtu=1598 mtu=1526 name=vpnA
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/routing ospf instance
set [ find default=yes ] router-id=10.13.0.5
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/interface bridge port
add bridge=vpnA interface=ether2
/interface vpls bgp-vpls
add bridge=vpnA bridge-cost=5 bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1 name=A pw-mtu=1526 route-distinguisher=1:1 site-id=5
/ip address
add address=10.12.1.14/30 interface=ether1 network=10.12.1.12
add address=192.168.22.134/24 interface=ether5 network=192.168.22.0
add address=10.13.0.5/32 interface=loopback network=10.13.0.5
/ip route vrf
add disabled=yes interfaces="ether1,loopback,(unknown)" route-distinguisher=1:1 routing-mark=MPLS_VPLS
/ip service
set api disabled=yes
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set enabled=yes lsr-id=10.13.0.5 transport-address=10.13.0.5
/mpls ldp interface
add interface=ether1
/routing bgp peer
add address-families=l2vpn name=pe3 remote-address=10.13.0.1 remote-as=65530 ttl=default update-source=loopback
add address-families=l2vpn name=pe2 remote-address=10.13.0.3 remote-as=65530 ttl=default update-source=loopback
/routing ospf interface
add interface=ether1 network-type=broadcast
/routing ospf network
add area=backbone network=10.13.0.5/32
add area=backbone network=10.12.1.0/24
/system identity
set name=CPE2

CPE2 Output:
[admin@CPE2] > /mpls ldp neighbor print 
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES      
 0 DO   10.13.0.1       10.13.0.5       10.13.0.1:0                no            10.12.1.1      
                                                                                 10.12.1.9      
                                                                                 10.12.1.13     
                                                                                 10.13.0.1      
                                                                                 172.16.0.2     
                                                                                 192.168.22.131 
[admin@CPE2] > /interface vpls print    
Flags: X - disabled, R - running, D - dynamic, B - bgp-signaled, C - cisco-bgp-signaled 
[admin@CPE2] > /mpls ldp print          
                       enabled: yes
                        lsr-id: 10.13.0.5
             transport-address: 10.13.0.5
             path-vector-limit: 255
                     hop-limit: 255
                   loop-detect: no
             use-explicit-null: no
  distribute-for-default-route: no
[admin@CPE2] > /mpls ldp neighbor print 
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES      
 0 DO   10.13.0.1       10.13.0.5       10.13.0.1:0                no            10.12.1.1      
                                                                                 10.12.1.9      
                                                                                 10.12.1.13     
                                                                                 10.13.0.1      
                                                                                 172.16.0.2     
                                                                                 192.168.22.131 
[admin@CPE2] > /routing bgp peer print 
Flags: X - disabled, E - established 
 #   INSTANCE                                                                                       REMOTE-ADDRESS                                                                                                                 REMOTE-AS  
 0 E default                                                                                        10.13.0.1                                                                                                                      65530      
 1 E default                                                                                        10.13.0.3                                                                                                                      65530 

CPE1 Output:
[admin@CPE1] >  /interface vpls print     
Flags: X - disabled, R - running, D - dynamic, B - bgp-signaled, C - cisco-bgp-signaled 
[admin@CPE1] >  /mpls ldp print           
                       enabled: yes
                        lsr-id: 10.13.0.4
             transport-address: 10.13.0.4
             path-vector-limit: 255
                     hop-limit: 255
                   loop-detect: no
             use-explicit-null: no
  distribute-for-default-route: no
[admin@CPE1] >  /mpls ldp neighbor print  
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls 
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES      
 0 DO   10.13.0.2       10.13.0.4       10.13.0.2:0                no            10.12.1.2      
                                                                                 10.12.1.6      
                                                                                 10.12.1.17     
                                                                                 10.13.0.2      
                                                                                 192.168.22.130 
[admin@CPE1] >  /routing bgp peer print   
Flags: X - disabled, E - established 
 #   INSTANCE                                                                                       REMOTE-ADDRESS                                                                                                                 REMOTE-AS  
 0 E default                                                                                        10.13.0.2                                                                                                                      65530      
 1 E default                                                                                        10.13.0.3                                                                                                                      65530      
[admin@CPE1] >  /routing ospf route print 
 # DST-ADDRESS        STATE          COST                                                                                        GATEWAY         INTERFACE                                                                                    
 0 10.12.1.0/30       intra-area     20                                                                                          10.12.1.17      ether1                                                                                       
 1 10.12.1.4/30       intra-area     20                                                                                          10.12.1.17      ether1                                                                                       
 2 10.12.1.8/30       intra-area     30                                                                                          10.12.1.17      ether1                                                                                       
 3 10.12.1.12/30      intra-area     30                                                                                          10.12.1.17      ether1                                                                                       
 4 10.12.1.16/30      intra-area     10                                                                                          0.0.0.0         ether1                                                                                       
 5 10.13.0.1/32       intra-area     30                                                                                          10.12.1.17      ether1                                                                                       
 6 10.13.0.2/32       intra-area     20                                                                                          10.12.1.17      ether1                                                                                       
 7 10.13.0.3/32       intra-area     30                                                                                          10.12.1.17      ether1                                                                                       
 8 10.13.0.4/32       intra-area     10                                                                                          0.0.0.0         loopback                                                                                     
 9 10.13.0.5/32       intra-area     40                                                                                          10.12.1.17      ether1                                       
Any ideas are very appreciated :)
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1821
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BGP based VPLS, help needed

Fri Aug 09, 2013 12:27 pm

Can you stand up statically configured VPLS tunnels ?

MPLS/LDP config looks fine, I didnt read all the BGP part, but from what I did read it was correct.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
phendry
Member Candidate
Member Candidate
Posts: 258
Joined: Fri May 28, 2004 4:42 pm

Re: BGP based VPLS, help needed

Mon Oct 07, 2013 12:13 am

If you're expecting PE2 to reflect NLRI's between CPE1 and CPE2, shouldn't you have enabled l2vpn address family to them?

Who is online

Users browsing this forum: No registered users and 130 guests