Community discussions

MikroTik App
 
airnet
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Thu Feb 09, 2006 12:46 pm

cannot redistribute BGP to OSPF in routing-test 2.9.18

Sun Mar 26, 2006 5:22 pm

EDITED WITH UPDATE:
Cannot redistribute any BGP to OSPF, let alone the default route.

I am REALLY losing hair now.

_________________________________________________________

There are 2 border routers. They each face the net and each one runs BGP. Only one of them is operating at one particular time, hence the one that is connected and has the default 0.0.0.0 route via BGP NEEDS to redistribute itself as 0.0.0.0/0 to his friendly neighbours via OSPF on the LAN side....

THIS NEVER WORKS:
routing ospf distribute-default=if-installed-as-type-x

THIS ALWAYS WORKS (but not how I want it to...):
routing ospf distribute-default=always-as-type-x

It was perfect on 2.8.28. It's broken on 2.9.12, 2.9.17 or 2.9.18.
2.9.12 can at least redistribute BGP (but not a default route)

What have I missed? Where are the instructions for routing-test?
 
airnet
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Thu Feb 09, 2006 12:46 pm

Tue Mar 28, 2006 12:03 am

Am I really the ONLY one in the world trying to redistribute BGP to OSPF ?
 
oook
just joined
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Wed Mar 29, 2006 12:42 am

Am I really the ONLY one in the world trying to redistribute BGP to OSPF ?
nope. but still no reliable answer from Mikrotik representatives :-(
 
User avatar
Eugene
Forum Veteran
Forum Veteran
Posts: 993
Joined: Mon May 31, 2004 5:06 pm
Location: Cranfield, UK

Wed Mar 29, 2006 8:02 pm

THIS NEVER WORKS:
routing ospf distribute-default=if-installed-as-type-x
This works fine for me. But the BGP redistribution indeed seems to be not working.

Eugene
Tout individu a droit à la vie, à la liberté et à la sûreté de sa personne.
 
airnet
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Thu Feb 09, 2006 12:46 pm

Sat Apr 01, 2006 6:15 am

Redistribute-default=if-installed-as-type-x will only work if you have also have redistribute-static=yes enabled (and you have a static default route)

It will not redistribute a default BGP route (or any BGP route for that matter)

PLEASE fix in 2.9.19
 
oook
just joined
Posts: 12
Joined: Sun Feb 26, 2006 8:58 pm

Wed Apr 05, 2006 10:29 am

Redistribute-default=if-installed-as-type-x will only work if you have also have redistribute-static=yes enabled (and you have a static default route)

It will not redistribute a default BGP route (or any BGP route for that matter)

PLEASE fix in 2.9.19
Hm ... Unfortunatelly I don't have default on my BGP router :-(

Hope it will be fixed in 2.9.19 ...

Who is online

Users browsing this forum: AndyGs, FurfangosFrigyes, MSN [Bot] and 171 guests