Community discussions

MUM Europe 2020
 
fbslim
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 55
Joined: Wed Feb 22, 2012 12:17 pm

Multiple WAN access to resources behind NAT, HOW-TO... do???

Tue Aug 20, 2013 12:19 pm

Hello everybody!

Have a problem... with two ISPs on my router.

I need to make accessible one resource behind NAT, than in my LAN. And i need to make it accessible from two ISPs simultaneously.

So - two different Internet IPs and one and the same server on it.


I can make accessible the router ports/services itself, such as 21, 22, 80, 8291 from two ISPs.

Looks like this:

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ISP1-pppoe routing-mark=ISP1 scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ISP2-pppoe routing-mark=ISP2 scope=30 target-scope=10

/ip firewall mangle
add chain=input action=mark-connection new-connection-mark=ISP1-input passthrough=no dst-address=1.1.1.1 in-interface=ISP1-pppoe
add chain=output action=mark-routing new-routing-mark=ISP1 passthrough=no connection-mark=ISP1-input
add chain=input action=mark-connection new-connection-mark=ISP2-input passthrough=no dst-address=2.2.2.2 in-interface=ISP2-pppoe
add chain=output action=mark-routing new-routing-mark=ISP2 passthrough=no connection-mark=ISP2-input


But I don't understand how to do the same to resources behind NAT.

Please, can somebody show the working examples, to understand???

Thanks in advance!
Last edited by fbslim on Tue Aug 20, 2013 3:09 pm, edited 1 time in total.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Multiple WAN access to resources behind NAT, HOW-TO... d

Tue Aug 20, 2013 12:33 pm

Look at the first part of this video, it explains how to get dual WAN properly working.
Then just setup NAT like normal.

Ignore the load-balancing part if you are not interested in load-balancing.

http://tiktube.com/video/DofH3iFnjDJomG ... uKlEoLqHq=
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
fbslim
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 55
Joined: Wed Feb 22, 2012 12:17 pm

Re: Multiple WAN access to resources behind NAT, HOW-TO... d

Tue Aug 20, 2013 2:58 pm

Look at the first part of this video, it explains how to get dual WAN properly working.
Then just setup NAT like normal.

Ignore the load-balancing part if you are not interested in load-balancing.

http://tiktube.com/video/DofH3iFnjDJomG ... uKlEoLqHq=
MAN!!! Thank you VERY much! Really working stuff!!!
 
navigowifi
just joined
Posts: 6
Joined: Sun Jul 14, 2013 7:43 am

Re: Multiple WAN access to resources behind NAT, HOW-TO... d

Mon Sep 02, 2013 11:58 am

Hello, I am interested to see if MK can do what the Mushroom can do. Basically if I have two ISP with 10 megs each, when I download something can I have both connections join together to get 20 megs downloads? Thats all I need to ask.


Thanks
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Multiple WAN access to resources behind NAT, HOW-TO... d

Wed Sep 04, 2013 12:48 pm

It is impossible to have a single TCP or UDP connection split across multiple ISPs.

With a multi-connection download (ex. Torrents) you can have full speed.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 966
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Multiple WAN access to resources behind NAT, HOW-TO... d

Wed Sep 04, 2013 5:10 pm

Look at the first part of this video ...
http://tiktube.com/video/DofH3iFnjDJomG ... uKlEoLqHq=
Is this on YouTube somewhere? I can never play anything form tiktube for some reason.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Multiple WAN access to resources behind NAT, HOW-TO... d

Wed Sep 04, 2013 7:09 pm

Is this on YouTube somewhere? I can never play anything form tiktube for some reason.
Use Chrome or Firefox and it should play.

MUM presentations are only on Tiktube, nowhere else that I know of.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!

Who is online

Users browsing this forum: No registered users and 62 guests