Community discussions

MikroTik App
 
Freman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Thu Jul 01, 2004 8:49 am

/ip proxy (not /ip web-proxy) and logging

Fri Mar 31, 2006 7:32 am

G'day folks

I'm running Mikrotik 2.9.18 and I'm trying to get /ip proxy to log

I've done /system logging add topics=web-proxy action=memory for testing
but the /ip proxy doesn't show anything up.

If I disable /ip proxy and enable /ip web-proxy (I have them both on the same port) the logs work fine.

I don't want to use web-proxy because the router is running off a CF card so I don't want any caching.

Does anyone know how to make /ip proxy log?
 
zaherhamiyah
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Thu Mar 23, 2006 12:43 am

Tue Apr 04, 2006 6:04 am

i think you can add a filter rule as follows :

ip firewall filter> add chain=forward protocol=tcp dst-port=8080 action=log log-prefix=ip-proxy_log comment="ip proxy logging"
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1735
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Tue Apr 04, 2006 1:55 pm

So,

There are 2 proxies:
one in the test package "/ip proxy"
other in the normal package "/ip web-proxy"

when web-proxy-test package is enabled logging works fine to me!
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
zaherhamiyah
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Thu Mar 23, 2006 12:43 am

Tue Apr 04, 2006 2:19 pm

yup.
And u can go to this link http://forum.mikrotik.com//viewtopic.php?t=7672 where u can find a conversation between me and other guy.There i posted a question for the purpose of making things clearer as for "ip proxy" and "ip web proxy"
 
Freman
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 76
Joined: Thu Jul 01, 2004 8:49 am

Mon Apr 10, 2006 1:43 am

I don't want to log the packet, I want to log the request

And I still don't want caching, full stop.
 
User avatar
hecklertm
Member Candidate
Member Candidate
Posts: 165
Joined: Fri Jun 24, 2005 5:12 am
Location: US

Mon Apr 10, 2006 6:40 am

If you want it to log web-proxy requests with cache,

/ip proxy set max-disk-cache-size=none
/ip proxy set enabled=yes

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], SiB, tawan and 234 guests