Page 1 of 1

/ip proxy (not /ip web-proxy) and logging

Posted: Fri Mar 31, 2006 7:32 am
by Freman
G'day folks

I'm running Mikrotik 2.9.18 and I'm trying to get /ip proxy to log

I've done /system logging add topics=web-proxy action=memory for testing
but the /ip proxy doesn't show anything up.

If I disable /ip proxy and enable /ip web-proxy (I have them both on the same port) the logs work fine.

I don't want to use web-proxy because the router is running off a CF card so I don't want any caching.

Does anyone know how to make /ip proxy log?

Posted: Tue Apr 04, 2006 6:04 am
by zaherhamiyah
i think you can add a filter rule as follows :

ip firewall filter> add chain=forward protocol=tcp dst-port=8080 action=log log-prefix=ip-proxy_log comment="ip proxy logging"

Posted: Tue Apr 04, 2006 1:55 pm
by macgaiver
So,

There are 2 proxies:
one in the test package "/ip proxy"
other in the normal package "/ip web-proxy"

when web-proxy-test package is enabled logging works fine to me!

Posted: Tue Apr 04, 2006 2:19 pm
by zaherhamiyah
yup.
And u can go to this link http://forum.mikrotik.com//viewtopic.php?t=7672 where u can find a conversation between me and other guy.There i posted a question for the purpose of making things clearer as for "ip proxy" and "ip web proxy"

Posted: Mon Apr 10, 2006 1:43 am
by Freman
I don't want to log the packet, I want to log the request

And I still don't want caching, full stop.

Posted: Mon Apr 10, 2006 6:40 am
by hecklertm
If you want it to log web-proxy requests with cache,

/ip proxy set max-disk-cache-size=none
/ip proxy set enabled=yes