Community discussions

MikroTik App
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

QoS Piorities and PCQ

Mon Sep 09, 2013 10:46 am

Hi!

I've following queues for my WAN interfaces on both routers and it works as excepted. Now I want to add PCQ to make sure that not one session is filling up the connection if there are other sessions. Where to I need to add the PCQ? with each /queue or is it enough if I set it for the parent? Do I need to set a limit-at and max-limit for each queue to make it work? Thx for your help.
/queue tree add limit-at=8M max-limit=8M name="queue__interface_to_other_location" parent=_interface_to_other_location
/queue tree add name="queue__interface_to_other_location_1" packet-mark=prio1 parent="queue__interface_to_other_location" priority=1
/queue tree add name="queue__interface_to_other_location_2" packet-mark=prio2 parent="queue__interface_to_other_location" priority=2
/queue tree add name="queue__interface_to_other_location_3" packet-mark=prio3 parent="queue__interface_to_other_location" priority=3
/queue tree add name="queue__interface_to_other_location_4" packet-mark=prio4 parent="queue__interface_to_other_location" priority=4
/queue tree add name="queue__interface_to_other_location_5" packet-mark=no-mark parent="queue__interface_to_other_location" priority=5
/queue tree add name="queue__interface_to_other_location_6" packet-mark=prio6 parent="queue__interface_to_other_location" priority=6
/queue tree add name="queue__interface_to_other_location_7" packet-mark=prio7 parent="queue__interface_to_other_location" priority=7
/queue tree add name="queue__interface_to_other_location_8" packet-mark=prio8 parent="queue__interface_to_other_location" priority=8
 
derr12
Member
Member
Posts: 411
Joined: Fri May 01, 2009 11:32 pm

Re: QoS Piorities and PCQ

Mon Sep 09, 2013 7:32 pm

just in each of the child queues.

i use this format in my transparent shaper;
Flags: X - disabled, I - invalid 
 0   name="Uploads_Full" parent=ether1 packet-mark="" limit-at=0 queue=default 
     priority=1 max-limit=11M burst-limit=0 burst-threshold=0 burst-time=0s 

 1   name="Downloads_Full" parent=ether2 packet-mark="" limit-at=0 queue=default 
     priority=1 max-limit=38M burst-limit=0 burst-threshold=0 burst-time=0s 

 2   name="DN_priority1" parent=Downloads_Full packet-mark=p1_down limit-at=256k 
     queue=downloads_pcq priority=1 max-limit=38M burst-limit=0 
     burst-threshold=0 burst-time=0s 

 3   name="DN_priority2" parent=Downloads_Full packet-mark=p2_down limit-at=768k 
     queue=downloads_pcq priority=2 max-limit=38M burst-limit=0 
     burst-threshold=0 burst-time=0s 

 4   name="DN_priority3" parent=Downloads_Full packet-mark=p3_down limit-at=23M 
     queue=downloads_pcq priority=3 max-limit=37M burst-limit=0 
     burst-threshold=0 burst-time=0s 

 5   name="DN_priority4" parent=Downloads_Full packet-mark=p4_down limit-at=9M 
     queue=downloads_pcq priority=4 max-limit=37M burst-limit=0 
     burst-threshold=0 burst-time=0s 

 6   name="DN_priority5" parent=Downloads_Full packet-mark=p5_down limit-at=3M 
     queue=downloads_pcq priority=5 max-limit=37M burst-limit=0 
     burst-threshold=0 burst-time=0s 

 7   name="UP_priority1" parent=Uploads_Full packet-mark=p1_up limit-at=256k 
     queue=uploads_pcq priority=1 max-limit=11M burst-limit=0 burst-threshold=0 
     burst-time=0s 

 8   name="UP_priority2" parent=Uploads_Full packet-mark=p2_up limit-at=768k 
     queue=uploads_pcq priority=2 max-limit=11M burst-limit=0 burst-threshold=0 
     burst-time=0s 

 9   name="UP_priority3" parent=Uploads_Full packet-mark=p3_up limit-at=6M 
     queue=uploads_pcq priority=3 max-limit=10M burst-limit=0 burst-threshold=0 
     burst-time=0s 

10   name="UP_priority4" parent=Uploads_Full packet-mark=p4_up limit-at=3M 
     queue=uploads_pcq priority=4 max-limit=10M burst-limit=0 burst-threshold=0 
     burst-time=0s 

11   name="UP_priority5" parent=Uploads_Full packet-mark=p5_up limit-at=1M 
     queue=uploads_pcq priority=5 max-limit=10M burst-limit=0 burst-threshold=0 
     burst-time=0s
 
derr12
Member
Member
Posts: 411
Joined: Fri May 01, 2009 11:32 pm

Re: QoS Piorities and PCQ

Mon Sep 09, 2013 7:33 pm

or if you want to just add my example;
/queue tree
add max-limit=11M name=Uploads_Full parent=ether1 priority=1 queue=default
add max-limit=38M name=Downloads_Full parent=ether2 priority=1 queue=default
add limit-at=256k max-limit=38M name=DN_priority1 packet-mark=p1_down parent=Downloads_Full priority=1 queue=downloads_pcq
add limit-at=768k max-limit=38M name=DN_priority2 packet-mark=p2_down parent=Downloads_Full priority=2 queue=downloads_pcq
add limit-at=23M max-limit=37M name=DN_priority3 packet-mark=p3_down parent=Downloads_Full priority=3 queue=downloads_pcq
add limit-at=9M max-limit=37M name=DN_priority4 packet-mark=p4_down parent=Downloads_Full priority=4 queue=downloads_pcq
add limit-at=3M max-limit=37M name=DN_priority5 packet-mark=p5_down parent=Downloads_Full priority=5 queue=downloads_pcq
add limit-at=256k max-limit=11M name=UP_priority1 packet-mark=p1_up parent=Uploads_Full priority=1 queue=uploads_pcq
add limit-at=768k max-limit=11M name=UP_priority2 packet-mark=p2_up parent=Uploads_Full priority=2 queue=uploads_pcq
add limit-at=6M max-limit=10M name=UP_priority3 packet-mark=p3_up parent=Uploads_Full priority=3 queue=uploads_pcq
add limit-at=3M max-limit=10M name=UP_priority4 packet-mark=p4_up parent=Uploads_Full priority=4 queue=uploads_pcq
add limit-at=1M max-limit=10M name=UP_priority5 packet-mark=p5_up parent=Uploads_Full priority=5 queue=uploads_pcq
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Re: QoS Piorities and PCQ

Tue Sep 10, 2013 12:11 pm

Ok, Thx for your help.

Who is online

Users browsing this forum: eworm, Google [Bot] and 142 guests