Page 1 of 1

v6.4 released

Posted: Thu Sep 12, 2013 4:35 pm
by normis
http://www.mikrotik.com/download
What's new in 6.4 (2013-Sep-12 13:52):

*) wireless - improved 802.11n wireless retransmission (doesn't effect nstreme/nv2)
*) ovpn - allow to specify server via dns name;
*) winbox - fixed problem where ipv6 routes with non local link address gateway
could not be added;
*) fixed watchdog on mipsle boards;
*) traceroute - added count & max-hops parameters;
*) traceroute - added back use-dns parameter;
*) fixed usb Yota LTE modem hangup;
*) console - make newly added item names always immediately available;
*) graphing - make sure that interface graphs gets preserved across reboots;

Re: v6.4 released

Posted: Thu Sep 12, 2013 4:57 pm
by Rudios
Still see an issue with the graphing.
I've created a queue graping rule for my internal network to see.
Nevertheless I can see the entry from anywhere.

Re: v6.4 released

Posted: Thu Sep 12, 2013 5:03 pm
by normis
Still see an issue with the graphing.
I've created a queue graping rule for my internal network to see.
Nevertheless I can see the entry from anywhere.
We will check, meanwhile please make a firewall rule to deny access to port 80 from other networks.

Re: v6.4 released

Posted: Thu Sep 12, 2013 5:48 pm
by honzam
What mean the first change? *) wireless - improved 802.11n wireless retransmission

Re: v6.4 released

Posted: Thu Sep 12, 2013 6:44 pm
by uldis
What mean the first change? *) wireless - improved 802.11n wireless retransmission
When sending traffic over wireless links in some rare cases the N data rate could drop to the lowest value and would not recover so fast. This version has a fix for those rare cases.

Re: v6.4 released

Posted: Thu Sep 12, 2013 6:52 pm
by efaden
What mean the first change? *) wireless - improved 802.11n wireless retransmission
When sending traffic over wireless links in some rare cases the N data rate could drop to the lowest value and would not recover so fast. This version has a fix for those rare cases.
Any IPSec fixes? Particularly for "Unknown" for key names?

Re: v6.4 released

Posted: Thu Sep 12, 2013 6:54 pm
by slech
*) ovpn - allow to specify server via dns name;
ROS 6.4 - RB951G-2HnD - oVPN Server - after upgrade
ROS 6.3 - RB951G-2HnD - oVPN Client - lost connection to ROS 6.4 oVPN Server.

Downgrade Server back to 6.3 and same effect.
Downgrade Server back to 6.2 and it works.

ros code

/ip service disable www-ssl
And it's working.

Re: v6.4 released

Posted: Thu Sep 12, 2013 6:58 pm
by honzam
What mean the first change? *) wireless - improved 802.11n wireless retransmission
When sending traffic over wireless links in some rare cases the N data rate could drop to the lowest value and would not recover so fast. This version has a fix for those rare cases.
Thanks for the explanation.
Have you plans for the next version some NV2 improvements?

Re: v6.4 released

Posted: Thu Sep 12, 2013 8:12 pm
by ohara
Here is something strange. All options are disabled on quickset page. Only after closing it and reopening it the fields become enabled. I've seen this since 6.3 on laptop and workstation. Has anyone else noticed it?

Re: v6.4 released

Posted: Thu Sep 12, 2013 8:18 pm
by sirdir

*) ovpn - allow to specify server via dns name;
I'd like very much to see this in IPSec as well...

Re: v6.4 released

Posted: Thu Sep 12, 2013 10:39 pm
by Lupin
Have you plans for the next version some NV2 improvements?
Hi honzam if you want wireless improvements from Mikrotik please add your opinion, or your interest in this topic

http://forum.mikrotik.com/viewtopic.php?f=7&t=76376

8)

Re: v6.4 released

Posted: Thu Sep 12, 2013 11:48 pm
by elgrandiegote
*) ovpn - allow to specify server via dns name;

thanks! :D

Re: v6.4 released

Posted: Fri Sep 13, 2013 12:08 am
by npero
*) ovpn - allow to specify server via dns name;

thanks! :D
Also thanks :D

Re: v6.4 released

Posted: Fri Sep 13, 2013 12:20 am
by pcunite
Bug in v6.4 ... Using Netinstall or Upgrade package.

When using WinBox only and navigating to several random settings ( IP / DNS, IP / SMB, etc.) the options for these pages (to enable or disable) are grayed out. However, closing the page and going back and forth to it makes it accessible again. Not present in v6.3. WinBox is most likely to blame.

Re: v6.4 released

Posted: Fri Sep 13, 2013 12:51 am
by asaleh75
getting problem in safe mode. I have add a filter rule to drop all input in safe mode, now i can't access router.

Re: v6.4 released

Posted: Fri Sep 13, 2013 6:53 am
by TerAnYu
There are strange errors:
- Do not update via NTP Client (2011UAS-2HnD)
- Do not appear possible to edit anything, all obscured. For the second time of calling this function is activated. (2011UAS-2HnD + 450G)

Image

Re: v6.4 released

Posted: Fri Sep 13, 2013 10:21 am
by BorgMcz
In OS v6.2, v6.3, v6.4 not communicating UPS, connected to serial port. Previous versions of OS everything worked. See the following thread: http://forum.mikrotik.com/viewtopic.php?f=2&t=76652

Newly Identified note (If you restart the system, just before the shutdown occurs shortly to implement the communication with the UPS)

Re: v6.4 released

Posted: Fri Sep 13, 2013 11:07 am
by bysard
There are strange errors:
- Do not update via NTP Client (2011UAS-2HnD)
- Do not appear possible to edit anything, all obscured. For the second time of calling this function is activated. (2011UAS-2HnD + 450G)

Image
I can confirm this.

EDIT: I just closed it and opened NTP client settings again and i can edit. Seems a random bug.
EDIT2: OK, this always happens the first time you start winbox and click on ntp clisnt settings. This also happens on e.g. /ip clock and I assume somewhere else too, but I didn't check yet.

Re: v6.4 released

Posted: Fri Sep 13, 2013 2:15 pm
by vfomkin
6.4 is supports create self-signed CA?
[xxx@yyy] > /certificate ca create-self-signed-ca
bad command name create-self-signed-ca (line 1 column 17)
[xxx@yyy] > /certificate ca                      

.. -- go up to certificate
add -- Create a new item
export-cert -- 
find -- Find items by value
get -- Gets value of item's property
import-to-store -- 
print -- Print values of item properties
rebuild-crl -- 
remove -- Remove item

[xxx@yyy] > /certificate ca 


Re: v6.4 released

Posted: Fri Sep 13, 2013 2:54 pm
by CStrauch
After I upgraded my Access Concentrators I saw a problem with high CPU usage, but only with the PowerPC ones.
The DHCP process was occupying all available CPU. After I disabled the DHCP package, the CPU usage returned to normal.
The problem is I use the DHCP process for the IPv6 PD.

Carlos Strauch

Re: v6.4 released

Posted: Fri Sep 13, 2013 8:31 pm
by drusha
There are strange errors:
- Do not update via NTP Client (2011UAS-2HnD)
- Do not appear possible to edit anything, all obscured. For the second time of calling this function is activated. (2011UAS-2HnD + 450G)
I can confirm this.

EDIT: I just closed it and opened NTP client settings again and i can edit. Seems a random bug.
EDIT2: OK, this always happens the first time you start winbox and click on ntp clisnt settings. This also happens on e.g. /ip clock and I assume somewhere else too, but I didn't check yet.
seems that every text entry box or drop down list is disabled by the very first opening. second time and later - works as usual. (RB750, MT6.4) but is it WinBox problem or OS itself? I guess that supout is meant for OS only without exposing any of winbox bugs (also, web config works just fine)

Re: v6.4 released

Posted: Fri Sep 13, 2013 9:15 pm
by Jaggl
yes i also can see this problem!

Re: v6.4 released

Posted: Fri Sep 13, 2013 10:53 pm
by steen
Hello Folks!

We tried on 6 routers mixture of, rb433, rb333, rb2011uas-2hnd, rb750g

All working fine no real production disturbances, exept things in logs and display:

rb2011uas-2hnd shows running on 245.5V ?!

And in out l2tp router (rb333), very many:
sep/13/2013 21:23:19 ipsec,warning,critical Policy install failed: proposal disabled: ipsec proposal default
sep/13/2013 21:23:56 ipsec,warning,critical Policy install failed: proposal disabled: ipsec proposal default

I did not dare to update our production IPSEC routers, neither the Wireless infrastructure yet.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:54 am
by jandafields
"Allow to specify server via dns name"

Please add this functionality to IPSEC and also to NTP CLIENT.

Thank you!

Re: v6.4 released

Posted: Sat Sep 14, 2013 11:08 am
by ronishil
Wellcome t mikrotik v6.4

Re: v6.4 released

Posted: Sat Sep 14, 2013 12:02 pm
by greek
DNS bug!

DNS menu in winbox is obscured too.

Workaround:
reset dns-servers thru terminal ( /ip dns set servers=8.8.8.8 ) and reopen dns menu (ip - dns)

May be it will be worked in SMTP-client menu too ?

Re: Odp: v6.4 released

Posted: Sat Sep 14, 2013 12:06 pm
by ohara
Hi greek, most of the previous comments in this thread mention the same issue. All winbox windows are affected by this bug. I hope it will be fixed soon because it is inconvenient to reopen the windows all the time.

Re: v6.4 released

Posted: Sat Sep 14, 2013 12:13 pm
by greek
Image
Just reopen this menu.

Re: v6.4 released

Posted: Sat Sep 14, 2013 12:16 pm
by greek
Hi, ohara, you are right. Will be waiting v6.5 soon

Re: v6.4 released

Posted: Sat Sep 14, 2013 12:46 pm
by bysard
Image
Just reopen this menu.
That's what I wrote.

SMNP Bug

Posted: Sat Sep 14, 2013 5:02 pm
by net365
Unable to edit SNMP settings!

Closing the window then opening it again solves the issue.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:11 pm
by dzieva
This proves that the Mikrotik does not test before they release a new version.
Mikrotik leaves that job for us.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:14 pm
by jandafields
This proves that the Mikrotik does not test before they release a new version.
Mikrotik leaves that job for us.
Yup, and so far not a single word about this from Mikrotik!

Imagine if you were a new user today, never used Mikrotik before, and you bought a routerboard, and you did the suggested upgrade to the newest "stable" version 6.4 and then tried to use the router. You would lose all faith in them, as your very first impression of them is that the "stable" version doesn't even work.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:19 pm
by efaden
This proves that the Mikrotik does not test before they release a new version.
Mikrotik leaves that job for us.
+1. I am a relatively new MikroTik user, and after several updates breaking things I am now weary of new upgrades. What also concerns me is how many of the bugs seem to be regressions... I have been a software engineer for a long time. It seems that there is no automated testing (including regression testing) on the platform.

At least as far as I am concerned I am on 6.1, because that seems to work for me. But I am now reading the "6.x released" threads for at least a week or two before I decide to upgrade to see if it is going to break things. I am getting tired of doing restores for releases breaking things I use.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:25 pm
by jandafields
This proves that the Mikrotik does not test before they release a new version.
Mikrotik leaves that job for us.
+1. I am a relatively new MikroTik user, and after several updates breaking things I am now weary of new upgrades. What also concerns me is how many of the bugs seem to be regressions... I have been a software engineer for a long time. It seems that there is no automated testing (including regression testing) on the platform.

At least as far as I am concerned I am on 6.1, because that seems to work for me. But I am now reading the "6.x released" threads for at least a week or two before I decide to upgrade to see if it is going to break things. I am getting tired of doing restores for releases breaking things I use.
The problem is that they don't do public beta testing. You can request access to development versions... but that doesn't work well. With 6.4, they didn't allow time for any testing... it was out almost immediately as the "stable" release and they didn't post ANY changelog to 6.4 in the development portal before it went public. And, to make it worse, they prohibit discussing the beta versions in the forum... so all of the people testing the beta versions cannot even talk to each other about it!

It would be great if they always had a public stable version, and a public beta version. A LOT more people would test the beta version... and it wouldn't be such a big deal if there were problems like this because you could talk about them on the forum. Then, after a certain amount of time and stability, make this the new stable version and start a new beta version.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:30 pm
by efaden
This proves that the Mikrotik does not test before they release a new version.
Mikrotik leaves that job for us.
+1. I am a relatively new MikroTik user, and after several updates breaking things I am now weary of new upgrades. What also concerns me is how many of the bugs seem to be regressions... I have been a software engineer for a long time. It seems that there is no automated testing (including regression testing) on the platform.

At least as far as I am concerned I am on 6.1, because that seems to work for me. But I am now reading the "6.x released" threads for at least a week or two before I decide to upgrade to see if it is going to break things. I am getting tired of doing restores for releases breaking things I use.
The problem is that they don't do public beta testing. You can request access to development versions... but that doesn't work well. With 6.4, they didn't allow time for any testing... it was out almost immediately as the "stable" release and they didn't post ANY changelog to 6.4 in the development portal before it went public. And, to make it worse, they prohibit discussing the beta versions in the forum... so all of the people testing the beta versions cannot even talk to each other about it!

It would be great if they always had a public stable version, and a public beta version. A LOT more people would test the beta version... and it wouldn't be such a big deal if there were problems like this because you could talk about them on the forum. Then, after a certain amount of time and stability, make this the new stable version and start a new beta version.

Don't they have a specific BETA forum?

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:32 pm
by jandafields
Don't they have a specific BETA forum?
Nope, not at all. You can only send bug reports to support@mikrotik.com. There is absolutely no user-to-user contact for beta versions.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:34 pm
by efaden
Don't they have a specific BETA forum?
Nope, not at all. You can only send bug reports to support@mikrotik.com. There is absolutely no user-to-user contact for beta versions.
Interesting. I always thought thats what http://forum.mikrotik.com/viewforum.php?f=1 was.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:37 pm
by jandafields

Interesting. I always thought thats what http://forum.mikrotik.com/viewforum.php?f=1 was.
No, that forum was originally created for the PUBLIC beta of v6 before 6.0 was released. Now, it seems to be randomly used for feature requests and general support.

Look in it, you NEVER see people talking about the next version (like 6.5 now).

People get PM warnings if they talk about beta versions, even in that forum.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:37 pm
by boen_robot
It would be great if they always had a public stable version, and a public beta version. A LOT more people would test the beta version... and it wouldn't be such a big deal if there were problems like this because you could talk about them on the forum. Then, after a certain amount of time and stability, make this the new stable version and start a new beta version.
Keep in mind that when you label a version "beta", you get less people using THAT version compared to a version labeled "stable", which in turn means far less chance of bugs being caught in that period.
It seems that there is no automated testing (including regression testing) on the platform.
And THAT seems to be the root of the problem here.

I'd assume that the MikroTik devs have some tests for the basic functions and compliance for the different protocols... but that's not the same as UI testing and "integration testing" (read: unit testing higher level modules that use the lower level modules), which are the kinds of issues most frequently observed between "stable" versions.

Re: v6.4 released

Posted: Sat Sep 14, 2013 6:41 pm
by jandafields
Keep in mind that when you label a version "beta", you get less people using THAT version compared to a version labeled "stable", which in turn means far less chance of bugs being caught in that period.
Yes, but if it is publically available AND had a forum for discussion, that would increase it a LOT! The way it is now, everyone has to individually report errors, and they can't see what other people have reported, and it gets old reporting every tiny bug because you know that other people have obviously seen them... but no way to confirm that.

Also, people keep reporting the same "stable" bugs over and over because they have no way of knowing that some of those issues are already fixed in the next beta version... because there is often no changelog at all for beta versions and no where to discuss them. If there was a place to discuss beta versions, you could see that "xx" issue is either fixed (and that "xx" bug tested specifically be users) or not yet fixed in the upcoming release.

Like this current Winbox bug in v6.4 for instance, it MIGHT actually already be fixed in the 6.5 beta... but if I tested 6.5 beta for that bug, I would not be allowed to tell you here on the forum if it is fixed or not! So, EVERYONE that has development access would have to test it themselves instead of being able to see that a few people have already confirmed it one way or another, if they wanted to know if it is fixed.... instead of spending time looking for other bugs, all beta testers are spending time testing this one obvious bug.

Re: v6.4 released

Posted: Sat Sep 14, 2013 7:00 pm
by boen_robot
True, true... all of it...

But I guess I can also sympathize with MikroTik devs here - it's hard to keep everyone up to date on development changes, without either having direct access to a VCS (and by extension - the source code, which for obvious reasons MikroTik would never do), or spending time on "bureaucracy"* like updating a change log on every commit, and tracking down all issue IDs where this was reported, updating the status, and notifying the submitters.... and don't get me started on what happens when you later need to revert the change because (through the limited testing that you DO perform) you find out it breaks something else in a bigger way.

Bigger companies (e.g. Microsoft) can only pull this off with an army of testers who test everything internally, so that users don't need to be kept updated between unofficial releases. With MikroTik - forum users are the unpaid army of testers.

* Note: This would be so with or without a public issue tracker... though with a public issue tracker, at least, as you say, we get the ability to see whether this was reported already, and maybe just cast a "me too" vote or whatever.

Re: v6.4 released

Posted: Sat Sep 14, 2013 7:16 pm
by jandafields
True, true... all of it...

But I guess I can also sympathize with MikroTik devs here - it's hard to keep everyone up to date on development changes, without either having direct access to a VCS (and by extension - the source code, which for obvious reasons MikroTik would never do), or spending time on "bureaucracy"* like updating a change log on every commit, and tracking down all issue IDs where this was reported, updating the status, and notifying the submitters.... and don't get me started on what happens when you later need to revert the change because (through the limited testing that you DO perform) you find out it breaks something else in a bigger way.

Bigger companies (e.g. Microsoft) can only pull this off with an army of testers who test everything internally, so that users don't need to be kept updated between unofficial releases. With MikroTik - forum users are the unpaid army of testers.

* Note: This would be so with or without a public issue tracker... though with a public issue tracker, at least, as you say, we get the ability to see whether this was reported already, and maybe just cast a "me too" vote or whatever.

A beta forum would fix this. I and a couple other people could test it and say, "xx problem fixed". Then, we would know. Then we could look for other bugs or fixes as a community instead of individually. As it is now, you are completely on your own... and Mikrotik probably gets 100 emails saying "xx still broken"... talk about having to spend time on "bureaucracy" !

Re: v6.4 released

Posted: Sat Sep 14, 2013 7:47 pm
by pcunite
To be clear, the developers themselves are not the problem, it is the system they're using and a part of. MikroTik is on the brink of another growth period and what does not kill them will make them better. If I was the CTO I would begin to implement some type of change control and automation.

It must still be the wild west around there for this type of a bug to make it out. I understand this and love the products, but what are new people still making comparisons thinking? That's when the increasing popularity can prove harmful.

Re: v6.4 released

Posted: Sun Sep 15, 2013 4:05 am
by tkgit
activate WDS-mesh on more than 1 minipci, wireless performance drop poorly, then DHCP-server always busy

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:15 am
by class889
do i need to reset-configuration if im moving from 6.3 to 6.4 with upgrade?

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:47 am
by bysard
To be clear, the developers themselves are not the problem, it is the system they're using and a part of. MikroTik is on the brink of another growth period and what does not kill them will make them better. If I was the CTO I would begin to implement some type of change control and automation.

It must still be the wild west around there for this type of a bug to make it out. I understand this and love the products, but what are new people still making comparisons thinking? That's when the increasing popularity can prove harmful.
Agreed.

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:58 am
by Rudios
do i need to reset-configuration if im moving from 6.3 to 6.4 with upgrade?
No

Re: v6.4 released

Posted: Sun Sep 15, 2013 10:07 am
by Joe1vm
Hi.
I never noticed it before, so I am not sure if this is related only to 6.4. But when I am running Winbox on any computer (in this case 192.168.88.10) there is still significant packet traffic in LAN - it looks like the winbox is still broadcasting on the winbox port (20561) even if it is already connected. This behaviour is not visible when Webfig is used and became visible when winbox is connected to Mikrotik router.

What do you think - is it common?

Re: v6.4 released

Posted: Sun Sep 15, 2013 12:32 pm
by yogii
dear support.
my RB951-2n, ROS 6.4, cpu load randomly jump to 100% then crashed (when manage via winbox) and router rebooted it self.

open profile, i saw console and management consume cpu load highly. is it normal? why console apeared in profile? :?
this happened 4 times.

thanks..

Re: v6.4 released

Posted: Sun Sep 15, 2013 12:56 pm
by infused
For production gear, just don't upgrade.

I had a CCR and stayed on 6.0 RC13 until 6.3 had been released for awhile. It's stable for me, so I will now stay here until there are significant performance improvements that will make it worthwhile upgrading.

Re: v6.4 released

Posted: Sun Sep 15, 2013 1:04 pm
by kwagga
Hi, all PPP options are also greyed out/obscured once the connection starts...

I'm still able to edit/change the settings via terminal, webfig or right click...

All this started with upgrade to v6.4. I'll provide a suppout if required.

Re: v6.4 released

Posted: Sun Sep 15, 2013 1:19 pm
by yogii
another known bug when using winbox.
first open (i tried dns, routerboard window), the windows are freeze, close and open again all normal.

Re: v6.4 released

Posted: Sun Sep 15, 2013 5:35 pm
by kosztyua
Currently I am overly fed up with Mikrotik and RouterOS.

We are providing a VPN service with PPTP, OVPN and SSTP, using x86 RouterOS.
Yesterday I upgraded from 5.24 to enjoy the new features and kernel. I have waited long enough after 6.x coming to stable version. 6.4 failed me with freezes randomly when a client connected, as well as the earlier mentioned grayed out settings anywhere, randomly. After this, as I have read that 6.2 is more stable, downgraded to see the same freezing issue. Downgraded back to 5.24 to see that SSTP now fails, showing TLS shutdown error when a client tried to connect. Upgraded to 6.3 to see that the server reboots about every hour (no leak in graph) and freeze occasionally.

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:03 pm
by Lakis
Is this
*) wireless - improved 802.11n wireless retransmission (doesn't effect nstreme/nv2)

included in 5.26?

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:12 pm
by neticted
Just upgraded router form 5.26 to 6.4.

Simple queues are all messed up.

First I noticed that Queue Tree was messed up. It seems there is significant change in Queue Tre but upgrade is unable to convert to new format. All Queue Types were set as red and deactivated and Parent set to unknown. That lead to Simple queues also stop working.

I've "fixed" queue tree by setting up parent=global for each item. I do not know if that is correct.

However, Simple Queues still do not work. The only one rule I made to catch some traffic is general rule that covers all traffic, and even that does not catch traffic properly (for example, I have throughput of 8 mbps on interface but this simple queue shows just about 40-50 kbps.
 0    name="queue1" target="" parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=0/0 
      max-limit=100M/100M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s 

If I narrow catching by any way, rule catches nothing.

This is ridiculous that such basic function is messed up this way by upgrade.

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:31 pm
by kwagga
I wish Mikrotik would beta test a little more before releasing these files to the general public, or release it as "beta" and tell people it's for testing. Releasing something as "stable", implies just that.

I'm sure the Mikrotik Dev's are working hard on a fix! :)

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:37 pm
by neticted
When will documentation be updated to reflect IMPORTANT changes in Mikrotik commands?!?!?!?!

Example from Manual:

/queue simple add name=private target-addresses=10.1.1.0/24 max-limit=256K/512K interface=ether2

Until now it worked fine but in the latest Mikrotik this command is invalid!!!!

I guess it is not to much if we ask that we at least get working product with proper documentation that we pay for?

Re: v6.4 released

Posted: Sun Sep 15, 2013 8:40 pm
by neticted
I'm sure the Mikrotik Dev's are working hard on a fix! :)
Right. They are working hard but still cannot fix issues that are noted years ago. But they are very successful to produce more bugs. :)

We should be careful not to go too far as Mikrotik stuff has a habit of banning people just for complaining too much.

Re: v6.4 released

Posted: Sun Sep 15, 2013 9:12 pm
by Ivoshiee
With MT you have to be in waiting mode, not to hurry. Just stick to some earlier version and do not let the PR talk you convince to upgrade.

Re: v6.4 released

Posted: Mon Sep 16, 2013 12:01 am
by hnt
Somewhere since ROS 6.3 SMB performance dropped from about 7.8MB/s to ~4Megs/sec for no particular reason.

Re: v6.4 released

Posted: Mon Sep 16, 2013 5:40 am
by wiltshra
RouterOS6.4, wont accept mesh script… (Groove A-52HPn)

NOTE: Script (with mesh setup) loaded without issue on RouterOS6.2 and mesh system worked fine.

Script below:
/interface mesh port
add interface=wlan1 mesh=mesh1
add interface=wlan2 mesh=mesh1

Now this wont load with a RouterOS6.4 install.

I then rolled back to v6.2 reloaded the script successfully – then upgraded to RouterOS6.4 (using WinBox) - to see what was happening – see attached:

The mesh ports “look configured” for wlan1 and wlan2 – but if you do a print the interfaces are unknown – see terminal window output.

When I export the script I only get this:
/interface mesh port
add mesh=mesh1
add mesh=mesh1
without any reference to wlan1 or 2

If I try to type it in I get this error:
[admin@MSH-PORT-PMP-1] /interface mesh port> add interface=wlan1 mesh=mesh1
input does not match any value of interface


Any suggestions from MirkroTik – have you guys broken something or changed anything in this area?

Re: v6.4 released

Posted: Mon Sep 16, 2013 11:11 am
by uldis
wiltshra, make a support output file and send it to support@mikrotik.com

Re: v6.4 released

Posted: Mon Sep 16, 2013 11:26 am
by mrz
When will documentation be updated to reflect IMPORTANT changes in Mikrotik commands?!?!?!?!

Example from Manual:

/queue simple add name=private target-addresses=10.1.1.0/24 max-limit=256K/512K interface=ether2

Until now it worked fine but in the latest Mikrotik this command is invalid!!!!

I guess it is not to much if we ask that we at least get working product with proper documentation that we pay for?
It is already mentioned in documentation that in v6 taget-address and interface is replaced with target.
http://wiki.mikrotik.com/wiki/Manual:Qu ... dentifiers

Re: v6.4 released

Posted: Mon Sep 16, 2013 11:27 am
by normis
Until now it worked fine
It is already mentioned in documentation that in v6 taget-address and interface is replaced with target.
http://wiki.mikrotik.com/wiki/Manual:Qu ... dentifiers
You say "until now", but this change has been there for several versions already. It's not a v6.4 change.

Re: v6.4 released

Posted: Mon Sep 16, 2013 12:23 pm
by wiltshra
wiltshra, make a support output file and send it to support@mikrotik.com

email sent with support file and details.

Re: v6.4 released

Posted: Mon Sep 16, 2013 2:02 pm
by ghi000
hello, i need to put this to work, any fix for IPSec? shall i try it? :) i didn't even paid for it, it stays here just for testing, nobody wants to buy it, i have it for 3 months already. i could be the only customer for this and the seller is not very happy. nice CCR :)

Re: v6.4 released

Posted: Mon Sep 16, 2013 8:18 pm
by skylaer
No problem, man.
You can always send me PM and i'll buy!

Re: v6.4 released

Posted: Mon Sep 16, 2013 9:50 pm
by Buster2
Hello,

we have several ROS 5.26 installations on XenServer 6.2 in HVM mode running fine (support for xen/vmware/openvm tools would be superior for live migration support). But upgrading to 6.4 or doing a fresh install of 6.4 from ISO image leads to 100% cpu load during boot process and VM's boot process stops. Console only shows
Loading Linux...................
Loading initrd.rgz............
Ready.
In XenCenter we can see cpu load graphs constantly at 100% for 1 vcpu (doesn't matter how many vcpu we put in). Occasionally network traffic goes up to 1.5 kbps but we can't connect to any mac based service to do any initial (ip) configuration. I changed vcpu from 2 down to 1 and ram from 1024 MB down to 128 MB, but hadn't any success.

What may i look for? How to debug this any further?

Re: v6.4 released

Posted: Tue Sep 17, 2013 2:37 am
by verex
Hi Folks,
i get this Bug on v6.3 and 6.4 (mipsbe and ppc) when trying to create a certificate request:

[admin@VX-RB1200] > /certificate create-certificate-request
template:
Script Error: action cancelled

Do I miss something ?

regards,
verex

Re: v6.4 released

Posted: Tue Sep 17, 2013 10:06 am
by dada
What mean the first change? *) wireless - improved 802.11n wireless retransmission
When sending traffic over wireless links in some rare cases the N data rate could drop to the lowest value and would not recover so fast. This version has a fix for those rare cases.
Hi Uldis,

are you really sure that the problem has nothing to do with similar problem in NV2 we are trying to solve long time? Isn't it possible to use this knowledge to solve the NV2 problem? Will the 80211n fix be ported to 5.x ROS line? Or there is no such bug in 5.x 80211n ?

NV2 AP tends to lock modulation for some clients - it can be easily detected by checking the 'age' of RX signal info on a client (wireless registration-table print stats - we use a perl script to check this via API). The locked modulation can be a low one or even the high one (harder to detect unless the client is not working on the high modulation).

Re: v6.4 released

Posted: Tue Sep 17, 2013 9:06 pm
by jaduke
It would be great if they always had a public stable version, and a public beta version. A LOT more people would test the beta version... and it wouldn't be such a big deal if there were problems like this because you could talk about them on the forum. Then, after a certain amount of time and stability, make this the new stable version and start a new beta version.
Keep in mind that when you label a version "beta", you get less people using THAT version compared to a version labeled "stable", which in turn means far less chance of bugs being caught in that period.
It seems that there is no automated testing (including regression testing) on the platform.
And THAT seems to be the root of the problem here.

I'd assume that the MikroTik devs have some tests for the basic functions and compliance for the different protocols... but that's not the same as UI testing and "integration testing" (read: unit testing higher level modules that use the lower level modules), which are the kinds of issues most frequently observed between "stable" versions.
I'd like to see something like what Kerio has where they have a private (by request/invitation) forum for beta versions. There you can discuss the issues with the beta and get input on whether the problem is unique to your installation or common across many. Obviously you can't discuss beta out on the public forum. After a time in private beta, Kerio will also release various milestone versions like release candidates (rc) for the world to test and report back on the public forum any issues found.

You get a much better product that way. And when something doesn't work, it's caught well prior to release.

Cheers,
Jon

Re: v6.4 released

Posted: Tue Sep 17, 2013 11:18 pm
by Chupaka
when I am running Winbox on any computer (in this case 192.168.88.10) there is still significant packet traffic in LAN - it looks like the winbox is still broadcasting on the winbox port (20561) even if it is already connected. This behaviour is not visible when Webfig is used and became visible when winbox is connected to Mikrotik router.

What do you think - is it common?
yes, it is. 20561 is not WinBox, it's MAC WinBox. use IP address to connect to the router. now you're using MAC address
First I noticed that Queue Tree was messed up. It seems there is significant change in Queue Tre but upgrade is unable to convert to new format. All Queue Types were set as red and deactivated and Parent set to unknown.
http://wiki.mikrotik.com/wiki/Manual:Ro ... ews#Queues
That lead to Simple queues also stop working.
Simple Queues and Queue Tree are completely independent in v6, so it doesn't lead
However, Simple Queues still do not work. The only one rule I made to catch some traffic is general rule that covers all traffic, and even that does not catch traffic properly (for example, I have throughput of 8 mbps on interface but this simple queue shows just about 40-50 kbps.
 0    name="queue1" target="" parent=none packet-marks="" priority=8/8 queue=default-small/default-small limit-at=0/0 
      max-limit=100M/100M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s 

'target' in v6 is mandatory parameter, I don't know why your target="" is not invalid :)
This is ridiculous that such basic function is messed up this way by upgrade.
yep, probably MT should put a link for http://wiki.mikrotik.com/wiki/Manual:RouterOS6_news to Downloads page :)

Re: v6.4 released

Posted: Wed Sep 18, 2013 7:17 pm
by Belonogoff
Here is something strange. All options are disabled on quickset page. Only after closing it and reopening it the fields become enabled. I've seen this since 6.3 on laptop and workstation. Has anyone else noticed it?
Yes, i have the same problems on RB951G-2HnD, RB751U-2HnD and on x86-system, but also in some other dialog windows (NTP-client, NTP-server, DNS, Users). Dear developers when will you fix this problem?

Re: v6.4 released

Posted: Fri Sep 20, 2013 2:50 pm
by phuang3
Mine is RB450G. After updated to v6.4, the LAN speed dropped from 100+ MB/sec(gigabit) to merely 7MB/sec(100Mb?)! Restored to V6.2 and everything is back to normal.

Re: v6.4 released

Posted: Fri Sep 20, 2013 3:56 pm
by neticted
When will documentation be updated to reflect IMPORTANT changes in Mikrotik commands?!?!?!?!

Example from Manual:

/queue simple add name=private target-addresses=10.1.1.0/24 max-limit=256K/512K interface=ether2

Until now it worked fine but in the latest Mikrotik this command is invalid!!!!

I guess it is not to much if we ask that we at least get working product with proper documentation that we pay for?
It is already mentioned in documentation that in v6 taget-address and interface is replaced with target.
http://wiki.mikrotik.com/wiki/Manual:Qu ... dentifiers
I found that out and tried bit it does not work anyways.

As upgrade was unable to use previous configuration, backup configuration was unusable too, and even full export of configuration was unusable due to changes in syntax i had to set it all up from scratch.

And then I found out that simple queues actually do not work at all.

Re: v6.4 released

Posted: Fri Sep 20, 2013 4:08 pm
by neticted
Until now it worked fine
It is already mentioned in documentation that in v6 taget-address and interface is replaced with target.
http://wiki.mikrotik.com/wiki/Manual:Qu ... dentifiers
You say "until now", but this change has been there for several versions already. It's not a v6.4 change.
So your point is that change is there for several versions but documentation still instructs us to use syntax that is no more valid and there is no new documentation that shows how to use new syntax?

Well, As I learn from my mistakes I do not update router with all MikrotikOS release as it is notorious on introducing new bugs, changing syntax and other unpolite stuff. I decided to upgrade with this version as it seemed not many complaints followed its publication.

That was another mistake.

If I am not using too much of equipment under Mikrotik Os and switch to other product would be far too expensive, I would do so.

This became ridiculous. How about you start investing in better quality control and producing software that actually works instead introducing more and more hardware that is not needed that much?

Re: v6.4 released

Posted: Fri Sep 20, 2013 5:33 pm
by lorsungcu
Yeah I spent 4 days undoing an upgrade to a router. DHCP was acting weird after the upgrade, although L2TP/IPSEC was better than in 5.26. Also experienced all the issues with winbox and syntax changes. What an unfortunate mess :/

Re: v6.4 released

Posted: Fri Sep 20, 2013 11:02 pm
by dohmniq
RouterOS6.4, wont accept mesh script… (Groove A-52HPn)

NOTE: Script (with mesh setup) loaded without issue on RouterOS6.2 and mesh system worked fine.

Script below:
/interface mesh port
add interface=wlan1 mesh=mesh1
add interface=wlan2 mesh=mesh1

Now this wont load with a RouterOS6.4 install.

I then rolled back to v6.2 reloaded the script successfully – then upgraded to RouterOS6.4 (using WinBox) - to see what was happening – see attached:

The mesh ports “look configured” for wlan1 and wlan2 – but if you do a print the interfaces are unknown – see terminal window output.

When I export the script I only get this:
/interface mesh port
add mesh=mesh1
add mesh=mesh1
without any reference to wlan1 or 2

If I try to type it in I get this error:
[admin@MSH-PORT-PMP-1] /interface mesh port> add interface=wlan1 mesh=mesh1
input does not match any value of interface


Any suggestions from MirkroTik – have you guys broken something or changed anything in this area?

Same problem here but on a RB435G, also running 6.4:
[dom@RB435] > /int print
Flags: D - dynamic, X - disabled, R - running, S - slave
 #     NAME                                TYPE         MTU L2MTU  MAX-L2MTU MAC-ADDRESS
 0  R  ether1                              ether       1500  1520       1520 00:0C:42:BB:A1:C5
 1     ether2                              ether       1500  1520       1520 00:0C:42:BB:A1:C6
 2     ether3                              ether       1500  1520       1520 00:0C:42:BB:A1:C7
 3     beacon                              wlan        1500  2290            D4:CA:6D:11:38:F3
 4  R  wiiiii                              wlan        1500  2290            D4:CA:6D:11:39:15
 5  R  mesh                                mesh        1500                  00:00:00:00:00:00
[dom@RB435] > /int mesh print
Flags: X - disabled, R - running
 0  R name="mesh" mtu=1500 arp=enabled mac-address=00:00:00:00:00:00 auto-mac=yes admin-mac=00:00:00:00:00:00 mesh-portal=yes hwmp-default-hoplimit=32 hwmp-preq-waiting-time=4s hwmp-preq-retries=2
      hwmp-preq-destination-only=yes hwmp-preq-reply-and-forward=yes hwmp-prep-lifetime=5m hwmp-rann-interval=10s hwmp-rann-propagation-delay=0.5 hwmp-rann-lifetime=22s reoptimize-paths=yes
[dom@RB435] > /int mesh port print
Flags: X - disabled, I - inactive, D - dynamic
 #    INTERFACE                                                                                           MESH
[dom@RB435] > /int mesh port add mesh=mesh interface=wiiiii
input does not match any value of interface
[dom@RB435] >

When I typed the last command and was at the "interface=" stage, repeatedly pressing TAB produces no possible values!

About to generate supout and send to support...

Dom

Re: v6.4 released

Posted: Sat Sep 21, 2013 11:09 pm
by payday
Another script stopped working...

The following command does not work anymore:
/interface> print count-only where !comment
0
In previous versions this command returned number of items that not had a comment. Now it always returns 0. This also fails in other contexts.
User "kotsius" also reports this problem: http://forum.mikrotik.com/viewtopic.php?f=9&t=76416
Is it permanent change or a bug that will it be fixed?
This is useful command.

Re: v6.4 released

Posted: Sun Sep 22, 2013 2:22 pm
by idanmik
Hello everybody,

I have just purchased my first routerboard, RB951G-2HnD, which came with ver. 5.24 os and I wonder if this is a right time to upgrade the software.
Looking at this topic found that 6.4 has some issues, and on download page there is also 5.26 version available...
Should I upgrade to 6.x or 5.26, or just wait for some more weeks for a mature release?

Please note that I am newbie in Mikrotik OS, and I use it for basic internet connection via PPPoE from my ISP.

Thanks in advance for any suggestion/answer.

Dan

Re: v6.4 released

Posted: Sun Sep 22, 2013 2:42 pm
by idanmik
Hello everybody,

I have just purchased my first routerboard, RB951G-2HnD, which came with ver. 5.24 os and I wonder if this is a right time to upgrade the software.
Looking at this topic found that 6.4 has some issues, and on download page there is also 5.26 version available...
Should I upgrade to 6.x or 5.26, or just wait for some more weeks for a mature release?

Please note that I am newbie in Mikrotik OS, and I use it for basic internet connection via PPPoE from my ISP.

Thanks in advance for any suggestion/answer.

Dan

Re: v6.4 released

Posted: Mon Sep 23, 2013 2:15 am
by Nighthawke
*Gets up on a soapbox.*

I feel that the ROS is getting into a situation where outstanding bugs and issues are not being fixed, and new features that have even more bugs are being added to the package, compounding the situation to where it is unacceptable.

Take a little advice:

Set up a triage on a whiteboard.

Make three columns.

* What needs fixed immediate:

* What can be resolved in the next few releases:

* What can be shelved BUT it does need to be resolved BEFORE the next full version roll out.

Keep this board updated and moving!

Do NOT add any more features or enhancements until the current package has all known and future bugs resolved.

This is what got CCP, the creators of EVE-Online in the dip early on. They threw an update package out without bothering to resolve outstanding issues with the game play and subsequently got reamed out by the developer community. Even the novice players realized the mistakes they were committing and made notice.

CCP realized their cock-up and the next update resolved nearly EVERY issue in the game and got rave reviews and attaboys from everyone.

Do not continue on this release path you are on now.

Fair advice, please follow it.

Re: v6.4 released

Posted: Mon Sep 23, 2013 3:14 am
by dzieva
*Gets up on a soapbox.*

I feel that the ROS is getting into a situation where outstanding bugs and issues are not being fixed, and new features that have even more bugs are being added to the package, compounding the situation to where it is unacceptable.

Take a little advice:

Set up a triage on a whiteboard.

Make three columns.

* What needs fixed immediate:

* What can be resolved in the next few releases:

* What can be shelved BUT it does need to be resolved BEFORE the next full version roll out.

Keep this board updated and moving!

Do NOT add any more features or enhancements until the current package has all known and future bugs resolved.

This is what got CCP, the creators of EVE-Online in the dip early on. They threw an update package out without bothering to resolve outstanding issues with the game play and subsequently got reamed out by the developer community. Even the novice players realized the mistakes they were committing and made notice.

CCP realized their cock-up and the next update resolved nearly EVERY issue in the game and got rave reviews and attaboys from everyone.

Do not continue on this release path you are on now.

Fair advice, please follow it.
+1

Re: v6.4 released

Posted: Mon Sep 23, 2013 3:19 am
by 0ldman
This proves that the Mikrotik does not test before they release a new version.
Mikrotik leaves that job for us.
+1. I am a relatively new MikroTik user, and after several updates breaking things I am now weary of new upgrades. What also concerns me is how many of the bugs seem to be regressions... I have been a software engineer for a long time. It seems that there is no automated testing (including regression testing) on the platform.

At least as far as I am concerned I am on 6.1, because that seems to work for me. But I am now reading the "6.x released" threads for at least a week or two before I decide to upgrade to see if it is going to break things. I am getting tired of doing restores for releases breaking things I use.
I just upgraded from 3.30 to 5.25. Every time I tried to upgrade to 4.x I had to roll back nearly half of my customers to 3.30 to keep it working.

I had decent results with 5.11 and 802.11n hardware. I finally took a chance and updated my A/G hardware to 5.25 and it finally matches the performance of 3.30 in 95% of my equipment.

Re: v6.4 released

Posted: Mon Sep 23, 2013 8:54 am
by rzirzi
*Gets up on a soapbox.*
I feel that the ROS is getting into a situation where outstanding bugs and issues are not being fixed, and new features that have even more bugs are being added to the package, compounding the situation to where it is unacceptable.
Take a little advice:
Set up a triage on a whiteboard.
Make three columns.
* What needs fixed immediate:
* What can be resolved in the next few releases:
* What can be shelved BUT it does need to be resolved BEFORE the next full version roll out.
Keep this board updated and moving!
Do NOT add any more features or enhancements until the current package has all known and future bugs resolved.
This is what got CCP, the creators of EVE-Online in the dip early on. They threw an update package out without bothering to resolve outstanding issues with the game play and subsequently got reamed out by the developer community. Even the novice players realized the mistakes they were committing and made notice.
CCP realized their cock-up and the next update resolved nearly EVERY issue in the game and got rave reviews and attaboys from everyone.
Do not continue on this release path you are on now.
Fair advice, please follow it.
+1

Re: v6.4 released

Posted: Mon Sep 23, 2013 12:45 pm
by Maggiore81
I have upgraded a RB750GL from 5.26 to 6.4
everything went well, except from the simple queues that needed a little adjustments.

The weird thing is that with 6.4 it doesnt respond to pings, and so all of my CPE's just auto-reboot every 15min... and if I downgrade to 5.26 it responds to pings again.

Even with no firewall rules, just plain routing

Re: v6.4 released

Posted: Mon Sep 23, 2013 1:43 pm
by bysard
*Gets up on a soapbox.*
I feel that the ROS is getting into a situation where outstanding bugs and issues are not being fixed, and new features that have even more bugs are being added to the package, compounding the situation to where it is unacceptable.
Take a little advice:
Set up a triage on a whiteboard.
Make three columns.
* What needs fixed immediate:
* What can be resolved in the next few releases:
* What can be shelved BUT it does need to be resolved BEFORE the next full version roll out.
Keep this board updated and moving!
Do NOT add any more features or enhancements until the current package has all known and future bugs resolved.
This is what got CCP, the creators of EVE-Online in the dip early on. They threw an update package out without bothering to resolve outstanding issues with the game play and subsequently got reamed out by the developer community. Even the novice players realized the mistakes they were committing and made notice.
CCP realized their cock-up and the next update resolved nearly EVERY issue in the game and got rave reviews and attaboys from everyone.
Do not continue on this release path you are on now.
Fair advice, please follow it.
+1
+1

Re: v6.4 released

Posted: Mon Sep 23, 2013 4:42 pm
by andriys
I have just purchased my first routerboard, RB951G-2HnD, which came with ver. 5.24 os and I wonder if this is a right time to upgrade the software.
Looking at this topic found that 6.4 has some issues, and on download page there is also 5.26 version available...
Should I upgrade to 6.x or 5.26, or just wait for some more weeks for a mature release?

Please note that I am newbie in Mikrotik OS, and I use it for basic internet connection via PPPoE from my ISP.
I'd suggest upgrading to 5.26 and then sticking to it until a) you get more familiar with Mikrotik RouterOS and b) 6.x stabilizes.

Re: v6.4 released

Posted: Mon Sep 23, 2013 5:26 pm
by Chrisdewit
Why would this happen on the same type of boards, same routeros. Voip doesnt want to work anymore, If I enable tracking of connections it goes to the normal mode like in working1.jpg. Working2.jpg changes to red even if i disable enable again.

Re: v6.4 released

Posted: Mon Sep 23, 2013 5:41 pm
by honzam
In 6.4 dont work SNTP client? It is not posible enabled checkbox

Re: v6.4 released

Posted: Mon Sep 23, 2013 8:25 pm
by Lakis
fix BTest
no meter u select receive or send test is always in both directions

Re: v6.4 released

Posted: Mon Sep 23, 2013 8:37 pm
by Lakis
In 6.4 dont work SNTP client? It is not posible enabled checkbox
its not just SNTP a lot of options are showing like that (locked like u are login with user with only read policy)

Re: v6.4 released

Posted: Mon Sep 23, 2013 9:53 pm
by posetr
it doesnt handle 250mbit udp flood, there is no other rule except drop udp

Re: v6.4 released

Posted: Tue Sep 24, 2013 3:07 am
by efaden
*Gets up on a soapbox.*
I feel that the ROS is getting into a situation where outstanding bugs and issues are not being fixed, and new features that have even more bugs are being added to the package, compounding the situation to where it is unacceptable.
Take a little advice:
Set up a triage on a whiteboard.
Make three columns.
* What needs fixed immediate:
* What can be resolved in the next few releases:
* What can be shelved BUT it does need to be resolved BEFORE the next full version roll out.
Keep this board updated and moving!
Do NOT add any more features or enhancements until the current package has all known and future bugs resolved.
This is what got CCP, the creators of EVE-Online in the dip early on. They threw an update package out without bothering to resolve outstanding issues with the game play and subsequently got reamed out by the developer community. Even the novice players realized the mistakes they were committing and made notice.
CCP realized their cock-up and the next update resolved nearly EVERY issue in the game and got rave reviews and attaboys from everyone.
Do not continue on this release path you are on now.
Fair advice, please follow it.
+1
+1
+1. Add documentation to the list. A WIKI is great, but the users can't update it and many of the pages are old, outdated, and lacking information. All of the features should have appropriate, correct, and good documentation when they are released.

Re: v6.4 released

Posted: Tue Sep 24, 2013 5:48 am
by wispwest
I"m sure this was already mentioned, but multiple times on all my RB912's I log in and go into interface to change settings and its all grayed out, as if I'm logged in as read-only. I simply close out the window and re-open it, then it allows changes.

Nstreme seems totally worthless starting with v6+ and NV2 has stability issues with latency all over the place. Throughput never was what it used to be. Not sure what's going on with Mikrotik lately, but it seems things are slowly getting worse and worse! We use Mikrotik for all our PtP's, and it seems every firmware has no improvements for Nstreme or NV2. I used to get SOLID 1ms with Nstreme, now its 14-26ms and throughput is complete crap. I remember when my "Pthroughput" used to say 145000, now it never goes above 45000kbps !!

Re: v6.4 released

Posted: Tue Sep 24, 2013 7:54 am
by jandafields
I"m sure this was already mentioned, but multiple times on all my RB912's I log in and go into interface to change settings and its all grayed out, as if I'm logged in as read-only. I simply close out the window and re-open it, then it allows changes.
This problem keeps getting repeated over and over here. It is being fixed in 6.5

Re: v6.4 released

Posted: Tue Sep 24, 2013 7:56 am
by jandafields
I have upgraded a RB750GL from 5.26 to 6.4
everything went well, except from the simple queues that needed a little adjustments.

The weird thing is that with 6.4 it doesnt respond to pings, and so all of my CPE's just auto-reboot every 15min... and if I downgrade to 5.26 it responds to pings again.

Even with no firewall rules, just plain routing
6.4 responds to pings, something may have went wrong during your upgrade.

Re: v6.4 released

Posted: Tue Sep 24, 2013 9:22 am
by bbraem
The new traceroute count option does not stop the traceroute itself, the output is still being refreshed. This is quite annoying when using API calls on traceroute, this just keeps generating output.
Is this a bug or is this expected behaviour (and how should I then use the new traceroute with the API?).

Re: v6.4 released

Posted: Tue Sep 24, 2013 10:25 am
by janisk
at the moment you can try to use duration together with the count, just note, duration will limit time, while count will limit requests sent. So for example
/tool traceroute 8.8.8.8 count=5 duration=10
will stop in CLI and API after duration.

Re: v6.4 released

Posted: Tue Sep 24, 2013 10:28 am
by janisk
In 6.4 dont work SNTP client? It is not posible enabled checkbox
that is winbox problem not SNTP.

try to close SNTP configuration window and re-open again - it should start working in 6.5 it will be fixed.

Re: v6.4 released

Posted: Tue Sep 24, 2013 12:45 pm
by honzam
fix BTest
no meter u select receive or send test is always in both directions
+1

Re: v6.4 released

Posted: Wed Sep 25, 2013 12:56 pm
by Raf
It should be fixed in final 6.3. I've reported it already when 6.3 (or 6.2?) was in development. Support said that 6.3 will have it fixed.
Ticket#2013072566000516

Re: v6.4 released

Posted: Wed Sep 25, 2013 2:47 pm
by mangust
Hello All.
RB2011Ls, ROS 6.4
Ethernet1 is "Master", ether2 & ether3 are setup as slave.
Then I put comment to ehter1 then ether2& and ether3 resets.
Could anybody confirm this ?

Re: v6.4 released

Posted: Wed Sep 25, 2013 3:20 pm
by kwagga
*Gets up on a soapbox.*

I feel that the ROS is getting into a situation where outstanding bugs and issues are not being fixed, and new features that have even more bugs are being added to the package, compounding the situation to where it is unacceptable.

Take a little advice:

Set up a triage on a whiteboard.

Make three columns.

* What needs fixed immediate:

* What can be resolved in the next few releases:

* What can be shelved BUT it does need to be resolved BEFORE the next full version roll out.

Keep this board updated and moving!

Do NOT add any more features or enhancements until the current package has all known and future bugs resolved.

This is what got CCP, the creators of EVE-Online in the dip early on. They threw an update package out without bothering to resolve outstanding issues with the game play and subsequently got reamed out by the developer community. Even the novice players realized the mistakes they were committing and made notice.

CCP realized their cock-up and the next update resolved nearly EVERY issue in the game and got rave reviews and attaboys from everyone.

Do not continue on this release path you are on now.

Fair advice, please follow it.
+1!

I halted our deployment of Mikrotik devices because I feel RouterOS isn't as stable as it once was, and could be. Even the Winbox Read-Only bug should never have reared it's head, and was a easily avoidable bug.

With a company policy in place that says all networking devices must at all times have the latest firmware/OS releases, and with RouterOS' supposedly stable releases causing all kinds of havoc, my job is on the line if a router should misbehave.

Re: v6.4 released

Posted: Wed Sep 25, 2013 4:15 pm
by payday
Hello All.
RB2011Ls, ROS 6.4
Ethernet1 is "Master", ether2 & ether3 are setup as slave.
Then I put comment to ehter1 then ether2& and ether3 resets.
Could anybody confirm this ?
I have noticed the same behavior on RB2011UAS.

Re: v6.4 released

Posted: Wed Sep 25, 2013 4:41 pm
by onnoossendrijver
With a company policy in place that says all networking devices must at all times have the latest firmware/OS releases, and with RouterOS' supposedly stable releases causing all kinds of havoc, my job is on the line if a router should misbehave.
Sorry to be rude, but that is a very stupid policy.
We currently have severe problems with the latest 'stable' software on our Juniper T4000 / TX Matrix and MX480/MX960 routers. We also had severe problems with previous 'stable' IOS software on our ME3400 switches.
You should ALWAYS test the software before rolling out to the devices. You should test all the functionality you are using in the field.

Re: v6.4 released

Posted: Wed Sep 25, 2013 4:53 pm
by kwagga
With a company policy in place that says all networking devices must at all times have the latest firmware/OS releases, and with RouterOS' supposedly stable releases causing all kinds of havoc, my job is on the line if a router should misbehave.
Sorry to be rude, but that is a very stupid policy.
We currently have severe problems with the latest 'stable' software on our Juniper T4000 / TX Matrix and MX480/MX960 routers. We also had severe problems with previous 'stable' IOS software on our ME3400 switches.
You should ALWAYS test the software before rolling out to the devices. You should test all the functionality you are using in the field.

You're not rude. :)

I don't agree with the policy, but then again, I don't get to make company policy. Stupid policies are usually implemented by people whom know nothing -or very little of IT, but are decision makers of IT Infrastructure.

Re: v6.4 released

Posted: Wed Sep 25, 2013 5:02 pm
by bysard
With a company policy in place that says all networking devices must at all times have the latest firmware/OS releases, and with RouterOS' supposedly stable releases causing all kinds of havoc, my job is on the line if a router should misbehave.
Sorry to be rude, but that is a very stupid policy.
We currently have severe problems with the latest 'stable' software on our Juniper T4000 / TX Matrix and MX480/MX960 routers. We also had severe problems with previous 'stable' IOS software on our ME3400 switches.
You should ALWAYS test the software before rolling out to the devices. You should test all the functionality you are using in the field.
You're not rude, you're just saying what evryone else is thinking :)

Re: v6.4 released

Posted: Wed Sep 25, 2013 5:21 pm
by Nighthawke
With a company policy in place that says all networking devices must at all times have the latest firmware/OS releases, and with RouterOS' supposedly stable releases causing all kinds of havoc, my job is on the line if a router should misbehave.
Sorry to be rude, but that is a very stupid policy.
We currently have severe problems with the latest 'stable' software on our Juniper T4000 / TX Matrix and MX480/MX960 routers. We also had severe problems with previous 'stable' IOS software on our ME3400 switches.
You should ALWAYS test the software before rolling out to the devices. You should test all the functionality you are using in the field.
IMO, his policy is as solid as it can get. People working Enterprise networks expect their hardware to be solid, stable and have world-class support. I've seen some of all three from this company, but the support category needs more work, especially when it comes to dealing with bugs and client requests.

The last company I worked for had Juniper MPLS routers but their power supplies kept frying. Despite all assurances and denials, Juniper lost their shirts and asses over the debacle. Over 2 million USD in routers had to be replaced before they got a handle on it. But by that time the company was looking back at CISO and making quotes for another capital purchase.

Re: v6.4 released

Posted: Thu Sep 26, 2013 4:21 am
by Kreacher
With a company policy in place that says all networking devices must at all times have the latest firmware/OS releases, and with RouterOS' supposedly stable releases causing all kinds of havoc, my job is on the line if a router should misbehave.
This is like many others here! They mean it in a good direction and on a fine wise but don´t know
anything about the entire case that with the latest as stable market version more problems can be
putting in likes the used firmware version before! But to coming out of this we all need in my eyes
a more detailed changelog where all points must be named, that we can easier choosing which
firmware we want to install, but than you are running in the next trap, because the most vendors
want to to see the latest firmware version installed on our devices!
You should ALWAYS test the software before rolling out to the devices. You should test all the functionality you are using in the field.
I consider!

Re: v6.4 released

Posted: Thu Sep 26, 2013 7:51 am
by kwagga
With everything said, I believe they should've pulled this 6.4 release from the main page, or at least, move it to the Beta Releases page.

....an apology or at least a formal acknowledgement would also go a long way.

Re: v6.4 released

Posted: Thu Sep 26, 2013 12:43 pm
by bysard
With everything said, I believe they should've pulled this 6.4 release from the main page, or at least, move it to the Beta Releases page.

....an apology or at least a formal acknowledgement would also go a long way.
1. Apology
2. Pull 6.x completelly from page and start over :) - Most of my router are upgradable to 6.x, so it's a real joy to see versions passing by like on highway - you can't really clearly see what's going on around you, but you are moving forward very fast.

Re: v6.4 released

Posted: Thu Sep 26, 2013 12:56 pm
by vik1988
After installing DPK, its still showing Mikrotik on telnet, what is that ??

Re: v6.4 released

Posted: Thu Sep 26, 2013 2:20 pm
by mangust
...so it's a real joy to see versions passing by like on highway - you can't really clearly see what's going on around you, but you are moving forward very fast.
http://demo2.mt.lv/webfig/#System:Packa ... or_Updates
:roll:

Re: v6.4 released

Posted: Thu Sep 26, 2013 4:03 pm
by djdrastic
Eish kwagga feel your pain . I can only assume some braindead auditor or CA thought of that scheme ?


The 6 releases has been pretty poor so far . Barring the boadroom AP's we use there is just no way I would let a 6.XX device touch my network at this point.

Re: v6.4 released

Posted: Thu Sep 26, 2013 5:22 pm
by kwagga
Eish kwagga feel your pain . I can only assume some braindead auditor or CA thought of that scheme ?


The 6 releases has been pretty poor so far . Barring the boadroom AP's we use there is just no way I would let a 6.XX device touch my network at this point.

Eish indeed! :)

Gotta love South African words!

Re: v6.4 released

Posted: Sat Sep 28, 2013 7:22 pm
by ericsooter
Guys, I've been with Mikrotik since the late 1.x versions. So I'm pretty familiar with the ways things go. Every major release usually has some bugs to work out. Yes, it would be nice for them to have a beta testing system, like Cisco and Juniper (giant companies with much more expensive routers). I think I've only seen 1 or 2 releases that had such severe problems where they were pulled from the stable tree (back around the 3.x releases). On your major production routers, you never want to go to a newer release without looking at the forums. I've found this problem with other smaller companies (ie Ubiquiti) also.

I currently run 6.2 and 6.4 on some of my production routers. I've seen the winbox bug on 6.4 (it is a display bug only). For most basic and advance functions (queues, ospf, bgp, L2 MPLS and wireless) its been pretty solid. I did go to the MUM this month and there was mention that L3 MPLS is still broken. Because the CCR router is based on the Tilera processor, there isn't support for version 5.x. This is because 6.x is based on a much newer Linux kernel version and the older kernel doesn't have Tilera support. I've seen some major performance improvements from 5.x to 6.x.

Because the CCR routers are so inexpensive, I "double up" on all my core routers (which should be done anyway). By having two routers with VRRP, you can virtually eliminate downtime.

But I do very much wish they would put a "Known bugs" (including introduced bugs) list somewhere on the website or appended to that releases changelog. It would save a lot of grief.

Re: v6.4 released

Posted: Sat Sep 28, 2013 10:57 pm
by mangust
Every major release usually has some bugs to work out.
+1

BTW
UPnP, Does anybdy test this ? Dynamic firewall rule come up, but doesnt work for some reasone. :(

Re: v6.4 released

Posted: Sat Sep 28, 2013 11:34 pm
by honzam
But I do very much wish they would put a "Known bugs" (including introduced bugs) list somewhere on the website or appended to that releases changelog. It would save a lot of grief.
+1

Re: v6.4 released

Posted: Sun Sep 29, 2013 3:34 am
by Lakis
But I do very much wish they would put a "Known bugs" (including introduced bugs) list somewhere on the website or appended to that releases changelog. It would save a lot of grief.
+1
nice dudes
But Do they read this :)
They need like 64 pages of bugs to fill :) no hard filings MT team u doing just fine
pls dont ban me after this I love Mikrotik and this community :)

Re: v6.4 released

Posted: Sun Sep 29, 2013 6:26 pm
by steen
Hello Folks!

A success story comes here anyway, after reading problems all over RoS6.x we decided to migrate from 5.25 to 6.4 at same time we recieved our first CCR1016 G12 that replaced one RB450G that was overloaded all time, and finally also burned the two green capacitors, they become "fat".

ROS6.4 now on CCR, RB333, RB750 at our site with ipsec tunnels etc. all working fine.

Two things has been noticed, our ddns scripts broke by some unknown reason, will put in a PMR on it later on.
Also noticed some problem in webmin menues, had to open and close, and open again in order to be able entering data inside.

Beside those two issues, nothing else has been discovered.

If it is ok for some days, we will migrate rest of our wireless networks and wba:s to 6.4 as well.

Re: v6.4 released

Posted: Sun Sep 29, 2013 11:13 pm
by payday
But I do very much wish they would put a "Known bugs" (including introduced bugs) list somewhere on the website or appended to that releases changelog. It would save a lot of grief.
+1

Re: v6.4 released

Posted: Mon Sep 30, 2013 2:17 am
by pcunite
Some of the bugs with 6.4 only appear when you try to edit queues and such with the gui tools. Delete all mangles and then reapply with changes makes some things work. This is how you can have one person say it is solid and other say it does not work, etc. In other words, the types of bugs MikroTik creates for itself does the brand no favors.
:-)

Re: v6.4 released

Posted: Mon Sep 30, 2013 7:49 am
by kokpin
Sorry if I post this in the wrong place.

I would like to know whether 6.4 now support ipv6 snmp?

Thanks in advance!

regards
kokpin

Re: v6.4 released

Posted: Mon Sep 30, 2013 12:30 pm
by janisk
Sorry if I post this in the wrong place.

I would like to know whether 6.4 now support ipv6 snmp?

Thanks in advance!

regards
kokpin
http://wiki.mikrotik.com/wiki/SNMP

Re: v6.4 released

Posted: Tue Oct 01, 2013 5:52 am
by wiltshra
[quote="normis"]http://www.mikrotik.com/download

[quote]
What's new in 6.4 (2013-Sep-12 13:52):
*) fixed watchdog on mipsle boards;

Hi Normis (or anyone else) in regards to RouterOSv6.4 release notes "fixed watchdog on mipsle boards" - could you please enlighten me on what the issue was with the watchdog to begin with as I am working with a network issue (Groove A-52HPn, on RouterOSv6.2) and I'd like to know:
- if the watchdog is helping or actually causing the issues I'm seeing.
thankyou.

Re: v6.4 released

Posted: Tue Oct 01, 2013 9:35 am
by janisk
Groove A-52HPn has MIPSBE architecture based CPU. And this entry does not apply to routers using this arch.

All that watchdog does - reboots the software of the router if period of non-responsiveness is detected. On MIPSLE routers it was not possible to enable watchdog, however this was fixed with 6.4 release. On itself watchdog is not causing the issues. If the router is easily accessed, you can try to disable watchdog and see what happens, usually router just becomes unresponsive/some process hangs and uses a lot of CPU resources as this is what watchdog detects.

Re: v6.4 released

Posted: Tue Oct 01, 2013 10:12 am
by wiltshra
Groove A-52HPn has MIPSBE architecture based CPU. And this entry does not apply to routers using this arch.

All that watchdog does - reboots the software of the router if period of non-responsiveness is detected. On MIPSLE routers it was not possible to enable watchdog, however this was fixed with 6.4 release. On itself watchdog is not causing the issues. If the router is easily accessed, you can try to disable watchdog and see what happens, usually router just becomes unresponsive/some process hangs and uses a lot of CPU resources as this is what watchdog detects.

Thanks janisk, my "dyslexia" did not pick up the difference between MIPSBE and MIPSLE!

Re: v6.4 released

Posted: Wed Oct 02, 2013 9:48 am
by itatwork
Is anyone else seeing issues with DHCPv6 client in v6.x?
Immediately after upgrading to 6.0 my RB2011 was unable to obtain a v6 lease, the client just says "searching..."
I've upgraded to 6.4 and still have the same problem.

Looking on the server side it shows the lease has been offered.

Image
Image

Re: v6.4 released

Posted: Wed Oct 02, 2013 6:29 pm
by jozwiak
I have some problem with IPsec Peer and "Generate policy" witch is Not working.
It stopped working from v6.rc14 and is still not working in version 6.4
Downgraded to v6rc13 and it worked again

The config in v6.RC13
proposal
Flags: X - disabled, * - default
0 * name="default" auth-algorithms=sha1 enc-algorithms=3des lifetime=30m
pfs-group=modp1024

peer
Flags: X - disabled
1 address=0.0.0.0/0 port=500 auth-method=pre-shared-key secret="********" generate-policy=port-strict
exchange-mode=main send-initial-contact=yes nat-traversal=no my-id-user-fqdn="GroupVPN" proposal-check=obey
hash-algorithm=sha1 enc-algorithm=3des dh-group=modp1024 lifetime=1d lifebytes=0 dpd-interval=disable-dpd
dpd-maximum-failures=3

Re: v6.4 released

Posted: Sat Oct 05, 2013 8:46 am
by steen
Hello Folks!

I discovered one more oddity with ROS6.4 and The Dude 3.6.

All my links did suddenly all become like the picture below, I waited for over one hour to have it siabilize, but no, they never come back.

How do I fix that ?

Re: v6.4 released

Posted: Sat Oct 05, 2013 10:27 am
by wiltshra
Hello Folks!

I discovered one more oddity with ROS6.4 and The Dude 3.6.

All my links did suddenly all become like the picture below, I waited for over one hour to have it siabilize, but no, they never come back.

How do I fix that ?

Sorry steen, but I'm not seeing this issue.
I have a static mesh setup running (using Groove A-52HPn), that was onRouterOS6.2 which I upgraded to ROS6.4 last week. I'm not having any issues with The Dude 3.6 displaying the data rates.
Have you tried opening the link, checking the interface setting, then Apply, OK?

Re: v6.4 released

Posted: Sat Oct 05, 2013 11:58 am
by steen
Hello Folks!

I discovered one more oddity with ROS6.4 and The Dude 3.6.

All my links did suddenly all become like the picture below, I waited for over one hour to have it siabilize, but no, they never come back.

How do I fix that ?

Sorry steen, but I'm not seeing this issue.
I have a static mesh setup running (using Groove A-52HPn), that was onRouterOS6.2 which I upgraded to ROS6.4 last week. I'm not having any issues with The Dude 3.6 displaying the data rates.
Have you tried opening the link, checking the interface setting, then Apply, OK?
It was all over network map, maybe a dude problem, I did delete and added back the links to every device that was upgraded to from 5.22 to 6.4 .
So now all is back to normal, just fiddly to sit there and delete / add links, but no problem with that, had to sit there anyway monitoring devices coming up after migration anyway, so I had something to do so to say. :-)

Re: v6.4 released

Posted: Sat Oct 05, 2013 12:59 pm
by steen
Hello Folks!

After upgrading RB411 from RoS 5.20 to RoS 6.4 and upgrade the microcode from 4.47 to 3.07 ether1 does not pass any traffic anymore.

I did a rollback to RoS 5.20 but kept the microcode at 3.07, then ether1 started to pass traffic again.

Have anyone seen this before ?

For information, I did also put in a PMR to Microtik for assistance with a supout file as well.

Re: v6.4 released

Posted: Sat Oct 05, 2013 1:13 pm
by steen
Hello Folks!

RoS 6.4 takes much less space on our basestations and cpe:s, nice work MT!

Re: v6.4 released

Posted: Sat Oct 05, 2013 6:06 pm
by autostoper76

Re: v6.4 released

Posted: Mon Oct 07, 2013 9:32 am
by rajo
@Mikrotik

Please add back the ability to retrieve array keys. The capability is now completely missing in 6.4 and makes using arrays difficult, if they key names are unknown.

This capability seems to have regressed starting with 6.2 (i.e. the ability to reference array elements using word keys. The problem with this is that, if you "get" system a configuration "as-value," it returns it as an array of "key=value," which results in the 6.2 change taking over and making it impossible to retrieve "key" itself, as was possible before 6.2. This, of course makes it impossible to retrieve an unknown "key."

I have detailed the issue here: http://forum.mikrotik.com/viewtopic.php ... 91#p389491

Thanks

Re: v6.4 released

Posted: Mon Oct 07, 2013 10:45 am
by steen
Hello Folks!

We have now successfully migrated from RoS5.22 to RoS6.4 in all our network, RB411, RB433, RB333, RB600, CCR, RB2011, RB450G, RB750 etc.

No problems or abnormal has been observed so far.

Only noticed it that in winbox you sometimes has to open and close menus/windows in order to get them "writable".

Regards //
// Peter Steen

Re: v6.4 released

Posted: Mon Oct 07, 2013 10:57 pm
by CStrauch
Is anyone else seeing issues with DHCPv6 client in v6.x?
Immediately after upgrading to 6.0 my RB2011 was unable to obtain a v6 lease, the client just says "searching..."
I've upgraded to 6.4 and still have the same problem.
I didn´t see a problem with the DHCPv6 (PD) client, but the servers had to be disabled because it was taxing the CPU's absurdly.
It worked fine on 6.3 but it's giving me trouble on 6.4.

Carlos Strauch

Re: v6.4 released

Posted: Wed Oct 09, 2013 1:33 am
by tkgit
user manager reset after reboot

Re: v6.4 released

Posted: Thu Oct 10, 2013 7:26 am
by rajo
@MikroTik:

There was a bug that was reported about RouterOS not responding to L2TP connections using the same interface the original request came in on, where there are multiple Internet-bound interfaces. The primary issue being that RouterOS defaults to sending everything out the interface having an IP address that is numerically lowest. By the way, this issue affects not just L2TP but all RouterOS services.

Today, I discovered that this issue also affects SRC-NAT for protocols such as ICMP and UDP. Here is the issue:

We have two interfaces: ISP1 and ISP2. ISP1 has the numerically lower IP address number. We are using PCC (following the WIKI example) for load balancing and availability. What's happening is that SIP phones attempting to register when going through ISP2 never reach the SIP server.

I setup a couple of mangle rules to force one phone and one laptop to go through ISP2 and enabled logging, in RouterOS, to see what interface the packets were going out. According to RouterOS, the packets were being sent out the correct interface (ISP2). Note: this particular issue did not affect web browsing.

I next setup a sniffer between the MikroTik router and the DSL modem and was shocked to discover that RouterOS was sending the SIP registration packets out the correct interface (ISP2) but the packets were NAT'ed to have a source of the address belonging to ISP1. Further investigation showed that, if I performed a traceroute on the laptop, it would not obey the routing mark and would instead take a path through ISP1. However, if I typed "What's my IP" into Google search, it would indicate that my IP address is that of ISP2. And if I did a bandwidth test, the throughput would be consistent with that of ISP2. So, for TCP it was fine, but for non-connection-oriented protocols it was failing -- even though I had no rule distinguishing between the two.

So again, RouterOS is failing to properly tie traffic to the appropriate interface. It should be obvious that if a packet is within the network scope of a particular interface, it should go out that interface and no other. This is frustrating as, until this whole issue of RouterOS not obeying interface IP addressing when sending out packets if fixed, I have to use workarounds the negate that redundancy and failover.

I am using RouterOS 6.4

Re: v6.4 released

Posted: Thu Oct 10, 2013 4:15 pm
by aldoir
@rajo,

Thousands already reported this bug but Mikrotik insist in adding features instead resolving basic bugs like this.

It seems they only will listen to the community and bug reports when they start to lose customers

Re: v6.4 released

Posted: Thu Oct 10, 2013 4:50 pm
by visalink
@rajo,

Thousands already reported this bug but Mikrotik insist in adding features instead resolving basic bugs like this.

It seems they only will listen to the community and bug reports when they start to lose customers
+
Nv2 is problematic in a noisy environment, and still bad since its launch, can only hope to see one day is going to be reliable.

Re: v6.4 released

Posted: Thu Oct 10, 2013 6:59 pm
by steen
Hello Folks!

Problems arrive.... with RoS6.4 and RB5.22, now!

One customer called in after being away a month, their antenna was on RoS5.22 based on RB411.
They told me not traffic passes to internet. Antenna was connected, good signal, I could login from outside and reach internet from their antenna.

Traffic over ether0 was only RX, no traffic sent back to their computers inside.
I could ping their stuff from their antenna and from elsewhere in our network.

However no traffic origin from their computers were returned.
Many other users in same wlan sector as the trouble antenna hand no problems.

I then upgraded the antenna to RoS6.4, but it did not make any difference.

I did then restart the basestation RB600 RoS6.4 and then it suddenly worked.

After just some hours yet another customer called in, same problem, same procedure was repeated and it worked.

It seems like the basestation RoS 6.4 and RoS5.22 does selective lock traffic or something.

Very strange!

Anyone who have seen this.

Re: v6.4 released

Posted: Fri Oct 11, 2013 8:35 pm
by cristiannunes
Beep does not work on RB800

Re: Odp: v6.4 released

Posted: Sat Oct 12, 2013 10:59 am
by ohara
Steen,

It is recommended to have the same ros version on Ap and client.

I have seen similar lockups, eg: http://forum.mikrotik.com/viewtopic.php?t=69064

Re: Odp: v6.4 released

Posted: Sat Oct 12, 2013 2:22 pm
by steen
Steen,

It is recommended to have the same ros version on Ap and client.

I have seen similar lockups, eg: http://forum.mikrotik.com/viewtopic.php?t=69064
Yupp we did upgrade and restart, problem has not been seen anymore after that.

Re: v6.4 released

Posted: Sun Oct 13, 2013 12:10 am
by frankc
I have some problem with IPsec Peer and "Generate policy" witch is Not working.
It stopped working from v6.rc14 and is still not working in version 6.4
Downgraded to v6rc13 and it worked again

The config in v6.RC13
proposal
Flags: X - disabled, * - default
0 * name="default" auth-algorithms=sha1 enc-algorithms=3des lifetime=30m
pfs-group=modp1024

peer
Flags: X - disabled
1 address=0.0.0.0/0 port=500 auth-method=pre-shared-key secret="********" generate-policy=port-strict
exchange-mode=main send-initial-contact=yes nat-traversal=no my-id-user-fqdn="GroupVPN" proposal-check=obey
hash-algorithm=sha1 enc-algorithm=3des dh-group=modp1024 lifetime=1d lifebytes=0 dpd-interval=disable-dpd
dpd-maximum-failures=3
same here AND i get cannot find proposal with 6.4 ipsec... 5.26 was good.. ill revert for lack of reponses from the company
probably will as refund for my 15 routers i bought..

Re: v6.4 released

Posted: Sun Oct 13, 2013 2:30 am
by jandafields

same here AND i get cannot find proposal with 6.4 ipsec... 5.26 was good.. ill revert for lack of reponses from the company
probably will as refund for my 15 routers i bought..

I wonder if this is the same problem you are having:
What's new in 6.5:
*) ipsec - fix peer matching with non byte aligned masks;

Re: v6.4 released

Posted: Sun Oct 13, 2013 3:01 am
by frankc
where is 6.5

Re: v6.4 released

Posted: Sun Oct 13, 2013 3:10 am
by jandafields
where is 6.5
In development, available to pre-release users. It will be publically released soon.

Re: v6.4 released

Posted: Sun Oct 13, 2013 6:31 pm
by Semir
6.4 crached. Not even a watchdog restart. Nothing. Just crached.

I got link to the 6.5 from the support, but it is not working now.

I need quick help as the occassional restarts were bad, but a fully frozen router is much much worse.
Please :(

Re: v6.4 released

Posted: Sun Oct 13, 2013 6:52 pm
by Kreacher
6.4 crached. Not even a watchdog restart. Nothing. Just crached.

I got link to the 6.5 from the support, but it is not working now.

I need quick help as the occassional restarts were bad, but a fully frozen router is much much worse.
Please :(
Please try netinstall to revive the RouterBoard.

Re: v6.4 released

Posted: Sun Oct 13, 2013 6:57 pm
by Semir
Hi, thanks.

power cycling helped.

is it safe to downgrade from 6.4 to 6.3?

Re: v6.4 released

Posted: Sun Oct 13, 2013 7:55 pm
by jandafields
Hi, thanks.

power cycling helped.

is it safe to downgrade from 6.4 to 6.3?
6.4 is stable, the only real problem is that you have to open winbox windows twice to make changes.

Yes, it is safe to downgrade.

Re: v6.4 released

Posted: Sun Oct 13, 2013 8:06 pm
by Semir
That was 6.3.

The router keeps restarting without known causes ever since 6.2.
Sometimes watchdog, sometimes kernel panic.
That is not stabilty.

6.4 freezed completely.

I saw 6.5 changelog:
*) route - fixed crash that could be triggered by change in nexthop
address resolution;

Which seems to me to be implemented in 6.4 as the last log messages before freezing were in the 'route' category.

I'll try to revert to 6.3.

Re: v6.4 released

Posted: Mon Oct 14, 2013 11:32 pm
by 0ldman
I just upgraded an RB433 w/5.25/3.07FW to 6.4 and it reset to defaults.

Luckily it was my office AP so it is an inconvenience rather than a tower climb or minimum of a service call.

Re: v6.4 released

Posted: Tue Oct 15, 2013 8:03 am
by Erastus
another known bug when using winbox.
first open (i tried dns, routerboard window), the windows are freeze, close and open again all normal.

I have same experience

Re: v6.4 released

Posted: Tue Oct 15, 2013 8:05 am
by shayanjameel08
All winbox windows are affected by this bug. I hope it will be fixed soon because it is inconvenient to reopen the windows all the time.

Re: v6.4 released

Posted: Tue Oct 15, 2013 8:28 am
by Erastus
I tried version 6.X
It simply crashes on 386 using PCIe. When I then went back to 5.26 it was a lot better.
With PCI slots becoming less and les PCIe is very important.
I reported it +/- 4 weeks ago and the response on the ticket from Mikrotik is not so good

Re: v6.4 released

Posted: Tue Oct 15, 2013 8:33 am
by Erastus
I have also a very strange scenario with data transfer.
The link seems to be connected the status it indicates data flow yet packets are dropped.
I do not understand how a link stays connected with no data flow
I had very good VOIP and very good video on it.

But suddenly it is turning into a disaster

It appears that if I reboot the system every +/- 24 hours then the software is "more stable"
Looks like a memory leak somewhere.
screen-capture-10.png

Re: v6.4 released

Posted: Tue Oct 15, 2013 8:55 am
by Erastus
Through the years there has been many mishaps and many errors with the software.
It would have been nice if MT would have good communication.

It is like 3 steps forward two steps back.

And then there are no response not on tickets not by email not by forum.
With all the current problems and limited communications it is feeling we are a bunch of mushrooms.

We have e new system but due to PCIe not working it is shelved.

Re: v6.4 released

Posted: Tue Oct 15, 2013 10:12 am
by Erastus
Interesting,

I down graded to ver 5.26.
The signal strength increased
Tx / Rx CCQ improved.
Does not make sense.
screen-capture-12.png

Re: v6.4 released

Posted: Wed Oct 16, 2013 6:08 am
by vipe
Hi, :D
ROS how to set IPID?

iptables -t mangle -A POSTROUTING -o pppoe-wan -j IPID --ipid-pace 1

thx!

Re: v6.4 released

Posted: Wed Oct 16, 2013 1:41 pm
by Adam84
Command:
ip ipsec export compact
doesn't export section ip ipsec user.

Re: v6.4 released

Posted: Wed Oct 16, 2013 10:17 pm
by solelunauno
I experienced today a not clear issue with 6.4 version.
I had a router (RB951) with routerOS 5.22 working well for long time (RouterOS 5.22 is about one year old).
I use it with PPTP BCP vpn client, in a network with other 5 client devices and one server device (RB450G with RouterOS 5.22).
I upgraded this RB951 client and the BCP stopped working: I can't see the correct neighbor in the list and can't ping the internal Bridge ip addresses from this RB951.
The pptp link is up well, but the layer 2 bridging doesn't work.
I tried to enable traking in firewall connections, as I know that in 6.4 it's disabled by default, with no results.
In the neighbor discovery interfaces, all is correct.
I tried with /system package downgrade command to downgrade it to 5.22, and it returned working well into its network, with bcp bridging working well.
So I'm sure it's some 6.4 changes which produces the issue with bcp: does anyone know any change with could affect BCP vpn?
Ttanks.

Re: v6.4 released

Posted: Thu Oct 17, 2013 8:07 am
by Erastus
I ran a spectral scan on wlan ( 386) version and system crashed.
Motherboard is a Foxcon H61 MXP

Re: v6.4 released

Posted: Thu Oct 17, 2013 4:43 pm
by Chupaka
Hi, :D
ROS how to set IPID?

iptables -t mangle -A POSTROUTING -o pppoe-wan -j IPID --ipid-pace 1

thx!
http://forum.mikrotik.com/viewtopic.php?f=2&t=77881

Re: v6.4 released

Posted: Fri Oct 18, 2013 5:55 am
by kss
I upgraded from 5.x on my 493G and uPNP broke. Not sure why. I've tried disabling and re-enabling, and have tried changing the inside interface for UPNP from the wireless-bridge to the inside switch master port. I'd appreciate any pointers. Broken Facetime = murderous wife.

Note the phones connect to a 2.4 ghz WAP connected to eth6.
/interface bridge
add l2mtu=1520 name=wireless-bridge
/interface wireless
set 0 band=5ghz-onlyn channel-width=20/40mhz-ht-above disabled=no \
    ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge ssid=redacted \
    wireless-protocol=unspecified
/interface ethernet
set 0 name=ether1-insideswmaster
set 1 name=ether2-outsideswmaster
set 2 auto-negotiation=no
set 5 master-port=ether1-insideswmaster
set 6 master-port=ether1-insideswmaster
set 7 master-port=ether1-insideswmaster
set 8 master-port=ether1-insideswmaster
/interface ethernet switch
set 0 name=Inside
set 1 name=Outside
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys wpa2-pre-shared-key=redacted
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
    mac-cookie-timeout=3d
/ip pool
add name=DHCP-Pool-inside ranges=172.16.0.100-172.16.0.200
/ip dhcp-server
add address-pool=DHCP-Pool-inside authoritative=yes disabled=no interface=\
    wireless-bridge name=dhcp1
/port
set 0 name=serial0
/interface bridge port
add bridge=wireless-bridge interface=wlan1
add bridge=wireless-bridge interface=ether1-insideswmaster
/ip address
add address=172.16.0.1/24 interface=ether1-insideswmaster network=172.16.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=\
    ether2-outsideswmaster use-peer-dns=no
/ip dhcp-server network
add address=172.16.0.0/24 dns-server=208.67.222.222,208.67.220.220 gateway=\
    172.16.0.1
/ip dns
set allow-remote-requests=yes max-udp-packet-size=2048 servers=\
    208.67.222.222,208.67.220.220
/ip firewall filter
add chain=input connection-state=established
add chain=input connection-state=related
add action=drop chain=input connection-state=invalid
add chain=input in-interface=ether1-insideswmaster
add chain=input in-interface=wireless-bridge
add action=drop chain=input
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether2-outsideswmaster \
    to-addresses=0.0.0.0
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=ether2-outsideswmaster type=external
add interface=wireless-bridge type=internal
/system clock
set time-zone-name=America/Los_Angeles
/system ntp client
set enabled=yes mode=unicast primary-ntp=24.56.178.140 secondary-ntp=\
    131.107.13.100

Re: v6.4 released

Posted: Tue Nov 12, 2013 11:59 am
by Semir
6.4 crached. Not even a watchdog restart. Nothing. Just crached.

I got link to the 6.5 from the support, but it is not working now.

I need quick help as the occassional restarts were bad, but a fully frozen router is much much worse.
Please :(

Hi,
changing CPU settings to 600MHz stabilized the router.
MikroTik told me to return the device.