Community discussions

MUM Europe 2020
 
Lewis
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Fri May 28, 2004 8:58 pm
Location: Thessaloniki, GREECE
Contact:

MT as pptp server

Wed Sep 01, 2004 4:28 pm

hello all,

i'm trying to setup my MT router as pptp server...
The router has a wireless interface, and two ethernet.
the first ethernet is connected to the localnet (where dhcp server runs), and the second is connected to the adsl modem.

first of all, i setup the pptp server...
/ interface pptp-server server 
set enabled=yes mtu=1460 mru=1460 authentication=mschap2,mschap1 keepalive-timeout=30 default-profile=test 
second, i made a ppp profile:
/ ppp profile 
set default name="default" local-address=0.0.0.0 remote-address=0.0.0.0 session-timeout=0s idle-timeout=0s use-compression=no \
    use-vj-compression=no use-encryption=no require-encryption=no only-one=no change-tcp-mss=yes tx-bit-rate=0 rx-bit-rate=0 \
    incoming-filter="" outgoing-filter="" dns-server="" wins-server="" comment="" 
add name="test" local-address=dhcp_pool1 remote-address=dhcp_pool1 session-timeout=0s idle-timeout=0s use-compression=yes \
    use-vj-compression=no use-encryption=yes require-encryption=yes only-one=no change-tcp-mss=no tx-bit-rate=0 rx-bit-rate=0 \
    incoming-filter="" outgoing-filter="" dns-server="" wins-server="" comment="" 
and third i created a test user:
/ ppp secret 
add name="test" service=any caller-id="" password="test" profile=test local-address=0.0.0.0 remote-address=0.0.0.0 routes="" \
    limit-bytes-in=0 limit-bytes-out=0 comment="" disabled=no 
I'm trying to connect from windows XP, log file writes "PPTP connection stablished from xxx.xxx.xxx.xxx", but the connection stops to "verifying username and password"..
After few minutes, winXP reports an error 619.

So, where did i go wrong ?
lewis <at> TWMN.net

Thessaloniki's Wireless Metropolitan Network
http://TWMN.net
 
edzix
Member
Member
Posts: 335
Joined: Thu Jul 01, 2004 3:01 pm
Location: Latvia

Wed Sep 01, 2004 4:33 pm

upgrade the router to the newest RouterOS version (2.8.14).

Make sure that encryption is enabled on WinXP machine (you reqiure it in your router).

Edgars
 
Lewis
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Fri May 28, 2004 8:58 pm
Location: Thessaloniki, GREECE
Contact:

Wed Sep 01, 2004 5:12 pm

upgrade the router to the newest RouterOS version (2.8.14).

Make sure that encryption is enabled on WinXP machine (you reqiure it in your router).

Edgars
I did everything, but no result...

My settings in WinXP client are:
Security/Advanced/MSChap+MSChap2 (require encryption)
Networking/Type of VPN=PPTP/enabled LCP extensions, sw compression
no firewalls...
lewis <at> TWMN.net

Thessaloniki's Wireless Metropolitan Network
http://TWMN.net
 
Bill
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Fri May 28, 2004 4:24 pm
Location: Nevada

Wed Sep 01, 2004 6:22 pm

Change 'Require Encryption' to No. Don't mess with Advanced settings in XP client until you get it working. You need to get a good starting point, and then you can tweak until it breaks. :)
 
Lewis
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Fri May 28, 2004 8:58 pm
Location: Thessaloniki, GREECE
Contact:

Wed Sep 01, 2004 6:51 pm

i tried this also but ...

in winbox ppp/active connections the client is not shown...

the client is natted to the wireles network, is this probably the reason ?
lewis <at> TWMN.net

Thessaloniki's Wireless Metropolitan Network
http://TWMN.net
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Wed Sep 01, 2004 10:38 pm

very simple question: can you ping your pptp-client from the pptp-server?
see also RFC 1925

My posts are written out of personal concern and reflect only personal opinion. Please do not qoute them outside without my permission.
 
User avatar
lastguru
Trainer
Trainer
Posts: 435
Joined: Fri May 28, 2004 9:04 pm
Location: Certified Trainer/Consultant in Riga, Latvia
Contact:

Wed Sep 01, 2004 11:19 pm

Also usually chacking logs helps much.
International MikroTik Certified Trainer and Consultant form Latvia.
I do RouterOS Training and Certification worldwide!

skype: lastguru
 
Lewis
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 65
Joined: Fri May 28, 2004 8:58 pm
Location: Thessaloniki, GREECE
Contact:

Thu Sep 02, 2004 2:11 am

i suppose i made something wrong...

when i deleted everything and made it again from the start, it worked..

My problem is that when i try to use a limit for the user, vpn connection is disconnecting (in log file says something about user-requested disconnection..)
lewis <at> TWMN.net

Thessaloniki's Wireless Metropolitan Network
http://TWMN.net
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Thu Sep 02, 2004 9:55 am

sorry to say, but the mt ppp-log is quite poor :-(

for tracking pptp- or pppoe-connection problems the usual windows- or mac-log gives much more information, even down to lcp- and ipcp- messages.
Also usually chacking logs helps much.
see also RFC 1925

My posts are written out of personal concern and reflect only personal opinion. Please do not qoute them outside without my permission.

Who is online

Users browsing this forum: Kombat1978 and 73 guests