Community discussions

 
Ehman
Member
Member
Topic Author
Posts: 363
Joined: Mon Nov 15, 2010 10:49 pm

huawei e3131 nightmare!

Fri Oct 04, 2013 12:12 am

Hi

I bought a nice huawei e3131 with hilink enabled (the nightmare), this device is fast! but... I can't use it in mikrotik because it doesnt want to work as a modem, I can't make it work, I've tried every guide on the web and none works, can anyone help me with it.

The issue: the device is in hilink mode, some ethernet emulator plug and play driver with web based thing ....there's no windows drivers for the thing available on the web or the device, its awesome for the end user, but not for me, I want to use my 3G dongle with a mikrotik board and give a couple of pc's internet, no luck, I hope someone in future will be able to help me out asap... don't feel like throwing it away, was damn expensive :(


this dodgy guide does not work
http://ubuntuforums.org/showthread.php?t=2076601
 
User avatar
Kreacher
Member
Member
Posts: 359
Joined: Wed Sep 25, 2013 3:58 pm
Location: Hogwarts

Re: huawei e3131 nightmare!

Mon Oct 07, 2013 11:12 am

Hello,

if this modem is in mini PCIe form factor you can try this:
Please go into the System Routerboard USB section and choose the type Mini-pcie and
then the modem should be recognized.

If this is a modem as a USB stick please make a supoutfile.rif and mail it with your question to
support@mikrotik.com they can help you more then we here, because this is only a user to user forum.
Kindly regards
Kreacher ♬

--------------------------------------
Karma points must not be paid by you
 
Ehman
Member
Member
Topic Author
Posts: 363
Joined: Mon Nov 15, 2010 10:49 pm

Re: huawei e3131 nightmare!

Mon Oct 07, 2013 12:35 pm

Hello,

if this modem is in mini PCIe form factor you can try this:
Please go into the System Routerboard USB section and choose the type Mini-pcie and
then the modem should be recognized.

If this is a modem as a USB stick please make a supoutfile.rif and mail it with your question to
support@mikrotik.com they can help you more then we here, because this is only a user to user forum.
System Routerboard USB section you say, I can't find that :(

I can only find a system/routerboard and system/resources/usb

both places, there's no place to set to "mini PCIe form factor "
 
User avatar
Kreacher
Member
Member
Posts: 359
Joined: Wed Sep 25, 2013 3:58 pm
Location: Hogwarts

Re: huawei e3131 nightmare!

Mon Oct 07, 2013 1:49 pm

Hello Ehman,

I was seeing this solution a while before I was telling you that here and it was working very well
for other so I was thinking it should also work at your RouterBoard and also solve your problem!

Here is the original thread I was gaining this solution! mini-PCIe slot not working???

I don´t know your RouterBoard but with the mini PCIe card it should run as with all other mini PCIe modems
I think really.
Kindly regards
Kreacher ♬

--------------------------------------
Karma points must not be paid by you
 
Ehman
Member
Member
Topic Author
Posts: 363
Joined: Mon Nov 15, 2010 10:49 pm

Re: huawei e3131 nightmare!

Mon Oct 07, 2013 11:59 pm

Hello Ehman,

I was seeing this solution a while before I was telling you that here and it was working very well
for other so I was thinking it should also work at your RouterBoard and also solve your problem!

Here is the original thread I was gaining this solution! mini-PCIe slot not working???

I don´t know your RouterBoard but with the mini PCIe card it should run as with all other mini PCIe modems
I think really.
My dongle is USB and not mini PCIe, I does get detected, where just something messedup with it, and mikrotik doesnt support HiLink software, the device can't operate like a normal modem, its a usb device that operates like a hotspot, weird but yea... its nice on a PC, but sux for a router
 
User avatar
Kreacher
Member
Member
Posts: 359
Joined: Wed Sep 25, 2013 3:58 pm
Location: Hogwarts

Re: huawei e3131 nightmare!

Tue Oct 08, 2013 7:22 pm

ahhhhh. my false I was thinking on that you are owning an internal mini PCIe card!!!
Kindly regards
Kreacher ♬

--------------------------------------
Karma points must not be paid by you
 
Ehman
Member
Member
Topic Author
Posts: 363
Joined: Mon Nov 15, 2010 10:49 pm

Re: huawei e3131 nightmare!

Tue Oct 08, 2013 7:54 pm

ahhhhh. my false I was thinking on that you are owning an internal mini PCIe card!!!
hahaha, its ok, I returned the device today and got my money back, I bought a slower device that is compatible
 
Chipicao
just joined
Posts: 2
Joined: Fri Sep 20, 2013 2:11 pm

Re: huawei e3131 nightmare!

Mon Oct 14, 2013 3:41 pm

Sorry for hijacking this thread, but I have a similar problem.

I have a Huawei E3131 USB modem, works fine on my PC, but I'm not sure if my RouterBoard 2011UAS-2HnD-IN detects it.
When I go to System/Resources/USB, I only see RB400 EHCI. From what I understand, that's the Routerboard USB port right?

Shouldn't I also have a row for the USB modem? The modem seems to be getting power because the LED is flashing.

I tried with another modem, Hiawei E352 and I have the same issue, nothign listed under System/Resources/USB.
 
nimbo78
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Tue Jan 14, 2014 9:09 pm

Re: huawei e3131 nightmare!

Tue Jan 14, 2014 9:14 pm

Sorry for hijacking this thread, but I have a similar problem.

I have a Huawei E3131 USB modem, works fine on my PC, but I'm not sure if my RouterBoard 2011UAS-2HnD-IN detects it.
When I go to System/Resources/USB, I only see RB400 EHCI. From what I understand, that's the Routerboard USB port right?

Shouldn't I also have a row for the USB modem? The modem seems to be getting power because the LED is flashing.

I tried with another modem, Hiawei E352 and I have the same issue, nothign listed under System/Resources/USB.
same problem with rb2011 and e352 modem. no any device on usb except this e352 modem.
but in this thread http://forum.mikrotik.com/viewtopic.php?f=2&t=72801 - seems like it works on rb2011.

"what am I doing wrong, doctor?")
 
RouterSurfer
just joined
Posts: 3
Joined: Sat Mar 08, 2014 11:34 am

Re: huawei e3131 nightmare!

Sat Mar 08, 2014 12:28 pm

"Huawei e3131 (Revision e3131-s2 text under SIM card place) IS nightmare :? " -- indeed. But now it works :lol:
I can show you the path but you have to walk it by your self..

Stuff you need to get before:

1)
Search google for " MobilePartnerforwindows.zip " , can be older version also. It´s not very model specific.
Install it and search for file "ewser2k.inf" it should be located at c:\program files\huawei\drivers\x86 (depends are you x32 or x64) etc.

Copy whole c:\program files\huawei\drivers\x86 directory to c:\temp\x86

Open file ewser2k.inf and search for section topic " [QcomSerialPort] "
Add following lines below section topic :

%QcomDevice01% = QportInstall01, USB\VID_12d1&PID_143E&MI_02
%QcomDevice01% = QportInstall01, USB\VID_12d1&PID_1442&MI_00
%QcomDevice00% = QportInstall00, USB\VID_12d1&PID_1442&MI_01
%QcomDevice01% = QportInstall01, USB\VID_12d1&PID_1448&MI_01

2)
Search google for " E3131Update_21.158.00.00.1020.B757.exe " This is the only that i managed to get e3131 working (3.8.2014)
sha1: 7F655C634AD92EF8014365D6E3ABD7491B37EACD
sha2 (256): C9105E7513548E2FE2DAD3FD60214B64703E3540426753FFE639C6AE68CC8D42
sha2 (512): BF5A13C388C06ED4F86A0460FE7DEB93D682DF0383A519DA3D16DB049B6D73AE228F45A98453878EF66331D14C202D2CE414F736BEAAB130C6F38FA8536C68D2

NOTE:
Huawei e3131-s2 device comes with never firmware already inside and I tried also with latest firmware " UTPS23.009.05.02.1020_MAC23.009.05.02.1020.exe ".

RESULTS with original or latest " UTPS23.009.05.02.1020_MAC23.009.05.02.1020.exe " inside:
USB device is detected ok by "miktotik routerboard 915g 2HnD" with fw 6.10.
You can also send AT commands to device via "/system serial-terminal usb1" and everything looks fine.
Even the dongle light will be solid blue and everything looks REALLY GOOD..
BUT that <<< #!¤%¤%!#¤% >> e3131 will always hang with ppp status "link established" and will not never-ever get WAN ip address.

3) com port communication program , for example teraterm "ttermpro.exe"

ok, suppose you now have necessary files. Let´s proceed.

A)
hilink mode is the 1.st problem,
connect e3131 to laptop and get your self "online"

When you open yur browser to http://192.168.1.1/ you should see some huawei connection status information. Good.
Copy paste this: http://192.168.1.1/html/switchProjectMode.html and press enter. NOTE: url IS CaPs sensitive.

Huawei disconnects to offline and windows device manager will start for searching new drivers.
Everytime point driver search manually to c:\temp\x86..
If you edited ewser2k.inf file correctly, drivers will be found ok.

NOTE: you will need to install those 3 device driver files each of 2 times.
First round is for "huawei device" and after it installs second time for device like "a65bd63245.b65d654f"

ok. If everything went ok, you should now see some communications ports devices.
NOTE: http://192.168.1.1/html/switchProjectMode.html is temporary change only.
If you remove/powerdown huawei e3131 device before part B) , it will go back to hilink mode.


B)
Thanks for "nimbo78" tip, confirmed that below link for cyrillic version of "3G_Modem_Mode_Switcher_1.0\3gsw.exe" works ok and fast after clicking couple times "1.st button on the left"
sha1: 0499DBA3D083DA0A0E29521060FA20E4DD47C07B
sha2 (256): BEBEB359F0F1839614FDA34BA6CFB17A9965A0FA0BE12E6068BBF9F742A9D8B9
sha2 (512): E70933BE251BCA5B4483D5D842CAD358D215498544814B64D6793F8A0097D4C565990228E66F83E727116D5203982AEAF2EB1D28363E637CD888DAD16E8C1C60

Another slower way is connect to huawei e3131 usb dongle via teraterm "ttermpro.exe"
Point to device manager com port which has "user gui" description.
You can confirm that you are connected correctly by giving command AT and you should get instant reply OK.

Give command AT^U2DIAG=0 and you should get reply OK
This will change e3131 device default to modem mode instead of hilink mode
( If you need to change it back, command for hilink default mode is AT^U2DIAG=119 )

Remove and re-insert e3131 device.
If you get com ports again and are able to connect via teraterm "ttermpro.exe" everything went ok.


C)
Install firmware executing " E3131Update_21.158.00.00.1020.B757.exe "
NOTE: during my fw "downgrade" device manager found new devices in the middle of fw update process which was paused..!
I pointed driver search to "c:\temp\x86.." and after drivers were installed ok, firmware update proceed ok.
It´s your device and also risk =)

D)
ok, now you should have got "fimrware update succeed" notice and you are ready to connect huawei e3131-s2 to mikrotik.
Mikrotik init command is
AT+CGDCONT=1,"IP","YourOperatorAPN"
and dial command ATDT to number *99#

After week of 24x7 testing, "huawei e3131-s2" works stable with "miktotik routerboard 915g 2HnD" with fw 6.10"

Sorry bad spelling due hurry, wish you a Good Luck, and remember Sharing Is Caring 8)
Best regards from Finland,

<Some edits and additions for hash checksums etc.>
Last edited by RouterSurfer on Tue Mar 25, 2014 9:21 am, edited 1 time in total.

Who is online

Users browsing this forum: pe1chl and 34 guests