Community discussions

MikroTik App
 
captainproton
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 66
Joined: Sat Jan 12, 2008 3:01 pm

PPPoE: slow downloads, fast upload

Thu Oct 17, 2013 2:42 pm

Hey,

I am using Mikrotik RB1100AHx2 as a PPPoE Server for about 400 Clients. For about 1 year this was all running fine but now something is wrong and I cant figure out what.

Setup:

eth1: uplink to provider, Gigabit
eth2: PPPoE Server, connected to a switch with all customers (ubiquiti toughswitch pro)
eth10: our Server
static routes between the 3 ports.


We used to see Internetspeeds like 50/30 MBit (dl/ul) on customers with unlimited speeds.

But since some weeks it changed:

For customers:
- the download is significantly slower ~10MBit
- uploads do not seem to be affected

For our Server:
- downloads quite slow (~16 MBit/s)
- uploads very fast (> 100 MBit)

Transfer from our Server to Custormer:
- ~12 MBit

Transfer from a Customer to Server
- not affected, ~60 MBit


That meens, obviously our uplink is not the limiting factor since even internal transfers are not working properly. Somehow it seems like some connections that have to go through the mikrotik are alot slower then they should be. This mainly happens on the download from the users point of view.


I can not remember having changed anything fundamentally in the past weeks.

I already bought a cloud core router, configured it new from scratch, changed with the RB1100AHx2 but it is just the same.

It also has nothing to do with being a PPPoE client or having a dedicated IP configuration on the customers' side.

Yes we have seen customer growth!
Have we reached the limit of a switched network? I will take down have the network tomorrow night to see if this has an effect to the speeds.


I hope (!) someone is having an inspiration for me!
 
CStrauch
just joined
Posts: 14
Joined: Sat Nov 27, 2010 3:39 am

Re: PPPoE: slow downloads, fast upload

Thu Oct 17, 2013 3:39 pm

Have we reached the limit of a switched network? I will take down have the network tomorrow night to see if this has an effect to the speeds.
My suggestion is exactly this. You should test with fewer users.

400+ users behind 1 switch is kind a stretch, don't you think? :lol:

Carlos Strauch
 
captainproton
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 66
Joined: Sat Jan 12, 2008 3:01 pm

Re: PPPoE: slow downloads, fast upload

Thu Oct 17, 2013 4:19 pm

well... I think so too, but this is something that grows and grows and you dont know when exactly its time to split the network.

on the other hand: our server is not part of the switched network and when it communicates with the internet the download is slow and the upload great. ...just like on the users side. This makes me believe that splitting the network will not solve the issue.
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: PPPoE: slow downloads, fast upload

Fri Oct 18, 2013 1:22 pm

Hi!

looks like MTU problem, it can well be possible that your provider has changed something in their network that causes the MTU to change.

There are topics regarding MTU/MRRU issues using PPPoE and how to troubleshoot.

Most likely you'll end up making a MANGLE rule in the router that is running the PPPoE service :D

Have fun!

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
captainproton
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 66
Joined: Sat Jan 12, 2008 3:01 pm

Re: PPPoE: slow downloads, fast upload

Fri Oct 18, 2013 8:39 pm

I have done alot of testing. Taking the big switched network off does not make any difference.

I took another Router and configured new with a very basic setup.
AND I SEE THE SAME ISSUE!! :( :( :(

Since this is all a little different then my original post, I started a new post:
http://forum.mikrotik.com/viewtopic.php?f=2&t=77985

Who is online

Users browsing this forum: Google [Bot], keithy, UpRunTech and 86 guests