Page 1 of 1

Changelog RouterOS 6.6

Posted: Sat Nov 02, 2013 6:27 pm
by Stillhard
  • What's new in 6.6 (2013-Nov-01 15:16):
    *) winbox - fixed problem where all previous session opened windows were read only;
    *) certificate - no more 'reset-certificate-cache' and 'decrypt' commands,
    private keys can be decrypted only on 'import', use 'decrypt' before upgrade if needed;
    *) fixed arp-reply only with more than one ip address on interface;
    *) fixed RB400 not to reboot by watchdog during micro-sd format;
    *) web proxy - fix SPDY server push handling;
    *) certificate - merged '/certificate ca issued', '/certificate scep client' and
    '/certificate templates' into '/certificate';
    *) added support for new Intel 10Gb ethernet cards (82599);
    *) certificates - fixed certificate import;
    *) wireless - fixed crash when dfs was enabled on pre-n wireless cards;
MT team, can you tell me if the problem here fixed or not?

Thank you

Re: Changelog RouterOS 6.6

Posted: Sat Nov 02, 2013 11:31 pm
by napismizpravu
Stillhard poor description of the discussion


development build Nov/01/2013 10:03:38 stop work script (no sound) RB433UAH

where the error? correct script humans :D
:local InterfaceName wlan3;
:local RunningTime 300;


:delay 5;local id;local f;for a from=1 to=($RunningTime*2) step=1 do={set id "";foreach i in=[/interface wireless registration-table find interface=$InterfaceName] do={set id $i};if ([:len $id] > 0) do={set f ([/interface wireless registration-table get $id signal-to-noise]*10);beep length=0.4 frequency=$f};delay 0.5}

Re: Changelog RouterOS 6.6

Posted: Mon Nov 04, 2013 4:06 am
by Rivera
Still no TLS update :(

Re: Changelog RouterOS 6.6

Posted: Tue Nov 05, 2013 2:37 pm
by napismizpravu
RouterOS 6.6 build Nov/05/2013 13:07:33 >> script work, again makes noises (Google Translator)

Re: Changelog RouterOS 6.6

Posted: Tue Nov 05, 2013 2:56 pm
by hapi
add support for new intel nic.

Re: Changelog RouterOS 6.6

Posted: Wed Nov 06, 2013 4:09 am
by Stillhard
  • What's new in 6.6 (2013-Nov-05 16:15):
    *) winbox - fixed problem where all previous session opened windows were read only;
    *) certificate - no more 'reset-certificate-cache' and 'decrypt' commands,
    private keys can be decrypted only on 'import', use 'decrypt' before upgrade if needed;
    *) fixed arp-reply only with more than one ip address on interface;
    *) fixed RB400 not to reboot by watchdog during micro-sd format;
    *) web proxy - fix SPDY server push handling;
    *) certificate - merged '/certificate ca issued', '/certificate scep client' and
    '/certificate templates' into '/certificate';
    *) console - :foreach command can iterate over keys and values in an array,
    by specifying two counter variables, e.g.:
    :foreach k,v in=[/system clock get] do={:put "$k is $v"};
    *) added support for new Intel 10Gb ethernet cards (82599);
    *) certificates - fixed certificate import;
    *) wireless - fixed crash when dfs was enabled on pre-n wireless cards;

Re: Changelog RouterOS 6.6

Posted: Wed Nov 06, 2013 8:27 am
by ATROX
  • What's new in 6.6 (2013-Nov-01 15:16):
    ...
    *) fixed arp-reply only with more than one ip address on interface;
    ...
MT team, can you tell me if the problem here fixed or not?

Thank you
Thank you!!!
And more...
Thank you!!!

Re: Changelog RouterOS 6.6

Posted: Wed Nov 06, 2013 8:50 am
by macgaiver
And one from this morning...

What's new in 6.6 (2013-Nov-05 16:15):

*) winbox - fixed problem where all previous session opened windows were read only;
*) certificate - no more 'reset-certificate-cache' and 'decrypt' commands,
private keys can be decrypted only on 'import', use 'decrypt' before upgrade if needed;
*) fixed arp-reply only with more than one ip address on interface;
*) fixed RB400 not to reboot by watchdog during micro-sd format;
*) web proxy - fix SPDY server push handling;
*) certificate - merged '/certificate ca issued', '/certificate scep client' and
'/certificate templates' into '/certificate';
*) console - :foreach command can iterate over keys and values in an array,
by specifying two counter variables, e.g.:
:foreach k,v in=[/system clock get] do={:put "$k is $v"};
*) added support for new Intel 10Gb ethernet cards (82599);
*) certificates - fixed certificate import;
*) wireless - fixed crash when dfs was enabled on pre-n wireless cards;
*) fixed port flapping on CCR;

Re: Changelog RouterOS 6.6

Posted: Wed Nov 06, 2013 8:58 am
by nz_monkey
What about the bug with fixed speed/duplex on CCR ?

Has it been fixed ?

Re: Changelog RouterOS 6.6

Posted: Wed Nov 06, 2013 4:32 pm
by Stillhard
  • What's new in 6.6 (2013-Nov-06 10:23):
    *) winbox - fixed problem where all previous session opened windows were read only;
    *) certificate - no more 'reset-certificate-cache' and 'decrypt' commands,
    private keys can be decrypted only on 'import', use 'decrypt' before upgrade if needed;
    *) fixed arp-reply only with more than one ip address on interface;
    *) fixed RB400 not to reboot by watchdog during micro-sd format;
    *) web proxy - fix SPDY server push handling;
    *) certificate - merged '/certificate ca issued', '/certificate scep client' and
    '/certificate templates' into '/certificate';
    *) console - :foreach command can iterate over keys and values in an array,
    by specifying two counter variables, e.g.:
    :foreach k,v in=[/system clock get] do={:put "$k is $v"};
    *) added support for new Intel 10Gb ethernet cards (82599);
    *) certificates - fixed certificate import;
    *) wireless - fixed crash when dfs was enabled on pre-n wireless cards;
    *) fixed port flapping on CCR;
I guess this is will be the final version for 6.6 :(

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 9:10 am
by normis
Why the long face, Stillhard?

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 9:41 am
by Stillhard
Why the long face, Stillhard?
The problem i asked here http://forum.mikrotik.com/viewtopic.php ... =1#p391476 not fixed
I'm using 2013-Nov-06 10:23 version now, and it's not fixed yet...

Other than that, it's working good :wink:

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 9:56 am
by normis
Why the long face, Stillhard?
The problem i asked here http://forum.mikrotik.com/viewtopic.php ... =1#p391476 not fixed
I'm using 2013-Nov-06 10:23 version now, and it's not fixed yet...

Other than that, it's working good :wink:
It's just not in changelog

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 10:00 am
by hapi
*) added support for new Intel 10Gb ethernet cards (82599);
Chip is produced five years. After this time was no support?

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 10:13 am
by Stillhard
Why the long face, Stillhard?
The problem i asked here http://forum.mikrotik.com/viewtopic.php ... =1#p391476 not fixed
I'm using 2013-Nov-06 10:23 version now, and it's not fixed yet...

Other than that, it's working good :wink:
It's just not in changelog
oh, i'll try the (2013-Nov-06 17:09) now and send the feedback here...

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 10:15 am
by normis
Your fix is not built yet.

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 10:17 am
by Stillhard
Your fix is not built yet.
Thx for the quick info normis, i'll wait then... (abort mission) :D

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 2:32 pm
by nkourtzis
I know this has been asked before, but I cannot find a definitive answer, so let me ask again: Mikrotik, are you working on NV2 tweaking and/or optimization, especially towards reducing jitter and improving throughput in PtMP scenarios?

Also, are you looking into the much-reported low TCP throughput issues? Can we expect a relevant upgrade in the 6.x series?

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 2:44 pm
by normis
I know this has been asked before, but I cannot find a definitive answer, so let me ask again: Mikrotik, are you working on NV2 tweaking and/or optimization, especially towards reducing jitter and improving throughput in PtMP scenarios?

Also, are you looking into the much-reported low TCP throughput issues? Can we expect a relevant upgrade in the 6.x series?
v6.6 has a much improved wireless driver and program, which also includes nv2 improvements.

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 2:45 pm
by normis
Your fix is not built yet.
Thx for the quick info normis, i'll wait then... (abort mission) :D
have you specified the timezone in the correct places? you know, the timezone can be specified for the router, the customer and the user - all separate places.

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 3:17 pm
by tomaskir
v6.6 has a much improved wireless driver and program, which also includes nv2 improvements.
I am REALLY looking forward to testing that, lets hope for good results!

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 4:09 pm
by honzam
v6.6 has a much improved wireless driver and program, which also includes nv2 improvements.
Hello. I solve the ticket (NV2) with Uldis. He donĀ“t say me this information, but he answered ticket today...
If there are really changes is this reflected in changelog 6.6?
I'm going to test nv2 with 6.6. Thanks

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 5:56 pm
by hapi
reply to a ticket? I wrote to you four times and no one answered.
[Ticket # 2013101466000236]
Very important.

Re: Changelog RouterOS 6.6

Posted: Thu Nov 07, 2013 6:15 pm
by Stillhard
have you specified the timezone in the correct places? you know, the timezone can be specified for the router, the customer and the user - all separate places.
I did normis, and it came from a long way before this, see this for an example: http://forum.mikrotik.com/viewtopic.php ... 13#p372713

Re: Changelog RouterOS 6.6

Posted: Fri Nov 08, 2013 6:36 am
by CarulloS
Nov 6 10:23 build we loaded on cloud core this morning and it kernel panic and reboot after a couple of hours. Prior to that 6.2 ran since it was released until today FYI. Don't have any more details my coworker sent in sip out to support. After the one reboot I think it's been ok.

A hope 6.6 final is a keeper.... Thanks

Re: Changelog RouterOS 6.6

Posted: Fri Nov 08, 2013 9:06 am
by normis
Nov 6 10:23 build we loaded on cloud core this morning and it kernel panic and reboot after a couple of hours. Prior to that 6.2 ran since it was released until today FYI. Don't have any more details my coworker sent in sip out to support. After the one reboot I think it's been ok.

A hope 6.6 final is a keeper.... Thanks
We had several other builds after that, it should be fixed now.

Re: Changelog RouterOS 6.6

Posted: Fri Nov 08, 2013 11:09 am
by tomaskir
v6.6 has a much improved wireless driver and program, which also includes nv2 improvements.
Did this make it into the final v6.6?

There is nothing in the change log...

Re: Changelog RouterOS 6.6

Posted: Fri Nov 08, 2013 7:30 pm
by semenko
v6.6 has a much improved wireless driver and program, which also includes nv2 improvements.
I'd also like to know if this made it into 6.6.

Does this improve 802.11bgn too (not just nv2)? (I've always had high jitter on the RB2011UAS-2HnD-IN).

Re: Changelog RouterOS 6.6

Posted: Fri Nov 08, 2013 7:39 pm
by honzam
v6.6 has a much improved wireless driver and program, which also includes nv2 improvements.
Did this make it into the final v6.6?

There is nothing in the change log...

I do not understand why it is not mentioned in the changelog

Re: Changelog RouterOS 6.6

Posted: Fri Nov 08, 2013 9:13 pm
by ejansson
Do both the client and the AP need to be upgrade in order to wireless improvment?

Re: Changelog RouterOS 6.6

Posted: Sat Nov 09, 2013 3:50 am
by Stillhard
Your fix is not built yet.
And it's true :D

It's still not fixed in final 6.6 too :)

Re: Changelog RouterOS 6.6

Posted: Sat Nov 09, 2013 11:16 am
by wahiedi
How to stop user changing their mac address (in trial user mode)

Re: Changelog RouterOS 6.6

Posted: Mon Nov 11, 2013 8:40 am
by normis
Your fix is not built yet.
And it's true :D

It's still not fixed in final 6.6 too :)
I wrote you last Friday, please write back when you can. We haven't been able to repeat the issue.
Please check that your timezones are correct in all places -- customers, routers, users?

Re: Changelog RouterOS 6.6

Posted: Mon Nov 11, 2013 8:53 am
by normis
This topic was about RC version. Let us move the discussion to the Release version topic:
http://forum.mikrotik.com/viewtopic.php?f=1&t=78684