Community discussions

 
artsmolkin
just joined
Topic Author
Posts: 19
Joined: Mon May 13, 2013 12:56 pm
Location: Russia

OVPN in ROS 6.6

Tue Nov 12, 2013 3:24 pm

Hello everybody.
Because of so many changes in Certificates from version 6.4, I want to know how I can make OVPN work in ROS 6.6?
In WinBox->System->Certificates I've added certificate, but nothing good... when I trying to connect to OVPN server from other Mikrotik, that says to me "terminating..." and it's all. If choose Certificate:none in OVPN Server setting, I have the same problem. Firewall disabled, secrets checked... and it worked on 6.3, but not on 6.6.

Could somebody help me find my mistake?

Thanks.
Arthur.

UPD: Well, I shoud correct something: ovpn doesn't work on two simple Mikrotik's with 6.6 ROS.
See screens.
You do not have the required permissions to view the files attached to this post.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OVPN in ROS 6.6

Tue Nov 12, 2013 3:44 pm

You do not have any certificates, in ovpn config certificate is set to none.

You can follow this guide to create certificates on RouterOS
http://wiki.mikrotik.com/wiki/Manual:IP ... rtificates

or import any externally created certificates
 
artsmolkin
just joined
Topic Author
Posts: 19
Joined: Mon May 13, 2013 12:56 pm
Location: Russia

Re: OVPN in ROS 6.6

Tue Nov 12, 2013 3:54 pm

You do not have any certificates, in ovpn config certificate is set to none.

You can follow this guide to create certificates on RouterOS
http://wiki.mikrotik.com/wiki/Manual:IP ... rtificates

or import any externally created certificates
Thanks, mrz.
Done.
But ovpn-client is still "terminating..."
You do not have the required permissions to view the files attached to this post.
 
artsmolkin
just joined
Topic Author
Posts: 19
Joined: Mon May 13, 2013 12:56 pm
Location: Russia

Re: OVPN in ROS 6.6

Tue Nov 12, 2013 5:01 pm

Can somebody reproduce my actions?
I'm not shure that I am genious in MikroTik :) but seems to me problem is simple.
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: OVPN in ROS 6.6

Tue Nov 12, 2013 6:01 pm

Add in logging OpenVpn to see what happens.
I use OpenVPN between two MT 6.6 and working also use from Windows client to MT 6.6 is working.
Some time happens OpenVPN server just stop working, client don't what to connect reboot router work again. Try to reset router where is OpenVPN server, I have this situation with couple routers after reset client connect.
 
artsmolkin
just joined
Topic Author
Posts: 19
Joined: Mon May 13, 2013 12:56 pm
Location: Russia

Re: OVPN in ROS 6.6

Wed Nov 13, 2013 6:40 pm

Add in logging OpenVpn to see what happens.
I use OpenVPN between two MT 6.6 and working also use from Windows client to MT 6.6 is working.
Some time happens OpenVPN server just stop working, client don't what to connect reboot router work again. Try to reset router where is OpenVPN server, I have this situation with couple routers after reset client connect.
Thanks a lot, npero!
I've reboot MT with ovpn-server and now it works fine, clients are connected. Thank you!
*feel myself like a fool* :)

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 99 guests