Community discussions

 
ners
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Tue Mar 12, 2013 4:30 pm

Overriding simple queues applied to interfaces?

Sat Nov 23, 2013 5:56 pm

Is it possible to make a simple queue or a mangle rule/tree queue which would override any other simple queues which are dynamically created by Mikrotik-Rate-Limit RADIUS attribute and applied to the user's interface in RouterOS 6.x?

For example RADIUS sends Mikrotik-Rate-Limit 2048k for a user, a dynamic simple queue is created to shape the user's traffic and is applied to his PPPoE interface.

Now I need to let the user access some networks without any shaping, can I make something to bypass the interface queue or override it only for certain network prefixes?
 
ronix
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Nov 17, 2011 6:51 pm

Re: Overriding simple queues applied to interfaces?

Sat Nov 23, 2013 8:47 pm

yes you can...

mark what you need in mangle, create a simple queue for it and put it in the top
 
User avatar
c0d3rSh3ll
Long time Member
Long time Member
Posts: 558
Joined: Mon Jul 25, 2011 9:42 pm
Location: [admin@Chile] >

Re: Overriding simple queues applied to interfaces?

Sat Nov 23, 2013 10:43 pm

yes you can...

mark what you need in mangle, create a simple queue for it and put it in the top
Yes or you can use dst option too.

Send from my mobile phone using Tapatalk.
nothing
 
ners
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 99
Joined: Tue Mar 12, 2013 4:30 pm

Re: Overriding simple queues applied to interfaces?

Sat Nov 23, 2013 10:51 pm

Thanks, I've done that and it seems to be working:
/queue simple
add dst=10.10.10.10/32 name=ftp-unlimited-4nat queue=default/default target=192.168.0.0/16
add dst=10.10.10.10/32 name=ftp-unlimited-4real queue=default/default target=192.0.2.0/24
However I still see queued and even dropped packets:
[adm@rt-nas01] /queue simple> pr stats where name ~"ftp"
Flags: X - disabled, I - invalid, D - dynamic
0 name="ftp-unlimited-4nat" target=192.168.0.0/16 rate=1931.3kbps/110.1Mbps total-rate=0bps packet-rate=4952/9828 total-packet-rate=0 queued-bytes=0/0
total-queued-bytes=0 queued-packets=0/0 total-queued-packets=0 bytes=532050946/29399916871 total-bytes=0 packets=10399647/20919455 total-packets=0
dropped=125/24076 total-dropped=0
Aren't they supposed to just go through and not be placed in a queue and certainly not dropped? The physical link is 1GE and is not even half up to its limit.
 
ronix
Member Candidate
Member Candidate
Posts: 152
Joined: Thu Nov 17, 2011 6:51 pm

Re: Overriding simple queues applied to interfaces?

Mon Nov 25, 2013 1:09 pm

try the mangle and please feed us about the result...

Who is online

Users browsing this forum: Google [Bot], MSN [Bot] and 71 guests