Community discussions

MikroTik App
 
User avatar
adiazm
just joined
Topic Author
Posts: 13
Joined: Sat Aug 15, 2009 11:39 pm

Settings for bonding

Thu Nov 28, 2013 3:30 pm

Hello Everybody!

I have two sites with 2 ISP providers in each one. I am using bonding for load-balance and fault tolerance. It is working fine with every TCP applications, but when I use VoIP (SIP), we have a very important lack of quality in the voice application.

Here is my configuration:

Site A in Ecuador (LAN 192.168.6.0/24):
IP LAN: 192.168.6.1/24
ISP1: 1.1.1.1
ISP2: 2.2.2.1

/interface eoip add name="EI16-ISP1-OBarrio" mtu=1500 l2mtu=65535 mac-address=02:0D:7B:4E:97:A0 arp=enabled local-address=0.0.0.0 remote-address=1.1.1.1 tunnel-id=11
/interface eoip add name="EI16-ISP2-OBarrio" mtu=1500 l2mtu=65535 mac-address=02:0D:7B:4E:97:A0 arp=enabled local-address=0.0.0.0 remote-address=2.2.2.1 tunnel-id=12
/interface bonding add name="B16-OBarrio" mtu=1500 mac-address=02:0D:7B:4E:97:A0 arp=enabled slaves=EI16-ISP1-OBarrio,EI16-ISP2-OBarrio mode=balance-rr primary=none \
      link-monitoring=arp arp-interval=100ms arp-ip-targets=10.1.16.1 mii-interval=100ms down-delay=0ms up-delay=0ms lacp-rate=30secs transmit-hash-policy=layer-3-and-4
/ip address add interface=B16-OBarrio address=10.1.16.2/30
/ip route add dst-address=172.16.16.0/24 gateway=10.1.16.1
Site B in Panamá (LAN 172.16.16.0/24):
IP LAN: 172.16.16.1/24
ISP1: 1.1.1.2
ISP2: 2.2.2.2

/interface eoip add name="EI16-ISP1-OBarrio" mtu=1500 l2mtu=65535 mac-address=02:25:80:B5:E9:66 arp=enabled local-address=0.0.0.0 remote-address=1.1.1.2 tunnel-id=11
/interface eoip add name="EI16-ISP2-OBarrio" mtu=1500 l2mtu=65535 mac-address=02:25:80:B5:E9:66 arp=enabled local-address=0.0.0.0 remote-address=2.2.2.2 tunnel-id=12
/interface bonding add name="B16-OBarrio" mtu=1500 mac-address=02:25:80:B5:E9:66 arp=enabled slaves=EI16-ISP1-OBarrio,EI16-ISP2-OBarrio mode=balance-rr primary=none \
      link-monitoring=arp arp-interval=100ms arp-ip-targets=10.1.16.2 mii-interval=100ms down-delay=0ms up-delay=0ms lacp-rate=30secs transmit-hash-policy=layer-3-and-4
/ip address add interface=B16-OBarrio address=10.1.16.1/30
/ip route add dst-address=192.168.6.0/24 gateway=10.1.16.2
As I said before, everything works fine in TCP Apps, but the VoIP application (uses SIP under UDP) doesn´t.

When I disable one of the eoip tunnels the VoIP application starts to work fine... :shock:

Can you help me... what can I do to achieve a good quality in VoIP application using both eoip tunnels?

Thanks in advance for your comments. Best Regards.

Who is online

Users browsing this forum: Google [Bot], killersoft, omnet, sebus, sindy and 155 guests