Page 1 of 1

Help configuring interfaces WAN

Posted: Mon Dec 02, 2013 3:23 am
by nerdtron
Hi all,
I have a Mikrotik RB951Ui with a total 5 LAN ports in which port 1 is the WAN port. It came with the default configuration. But I want to have dual wan setup so I want port 2 to act as WAN2 port. I can't seem to figure out how to start the configuration.
I can only access the device using the lan ports since it doesn't have any console port and every time I change the settings of interfaces in the WebFig, I get disconnected.

Any suggestions on how to work this out?

Re: Help configuring interfaces WAN

Posted: Tue Dec 03, 2013 2:19 am
by aaronhun22
When playing with the interfaces use winbox and connect using the MAC address or leave your WAN2 interface disabled until you're done making changes to the mangle rules.

Re: Help configuring interfaces WAN

Posted: Tue Dec 03, 2013 3:50 am
by nerdtron
Great, thanks for your reply. I am now using winbox, but I still get disconnected when I disable port 2? I think it's because the master-local port and the other port are dependent on it?
Can you explain the structure of these interfaces and how do I make them independent of each other?

Thank you for your support and sorry for my simple questions, I'm new to this router OS and reading the docs seems to assume that you already want to assign interfaces as wan port although I can't assign them now because there is a default config.

Thank you again. And here's the default interfaces config.

Re: Help configuring interfaces WAN

Posted: Tue Dec 03, 2013 9:42 am
by Rudios
If you would like to have 2 individual WAN ports, you should not set the two desired ports as master port or add them to a bridge.
Seen from the picture ether2 is set master over 3-5. Set 4 and 5 to have ether3 as master and set master-port on ether3 to none.
Then ether 1,2 and 3 are separated with 4 and 5 slaved to 3, which will give you a 3-port switching and 2 dedicated WAN ports.

NB. The things shown in the picture are only names and are not hard related to the config. I suggest you rename the interfaces to reflect their function.
(ether1-gateway, ether2-gateway, ether3-master-local)