Community discussions

 
voxframe
Member Candidate
Member Candidate
Posts: 126
Joined: Thu Dec 16, 2010 2:51 pm

Re: v6.7 released

Mon Dec 16, 2013 2:47 pm

+1

I realize this is not the appropriate thread for Dude talk... But man you guys need to get working on the Dude. You promised you would/are and yet there is no visible progress in years. Solidify ROS, and then please put some serious resources into the Dude.
 
User avatar
bjorncmtec
Frequent Visitor
Frequent Visitor
Posts: 98
Joined: Thu Apr 19, 2012 1:10 pm

Re: v6.7 released

Tue Dec 17, 2013 5:04 pm

+1 voxframe
Certified

* MTCNA
* MTCRE
* MTCTCE
* MTCINE


South Africa
 
ddejager
Member Candidate
Member Candidate
Posts: 109
Joined: Tue Oct 18, 2011 5:13 am

Re: v6.7 released

Wed Dec 18, 2013 2:32 am

Mikrotik Support confirmed the problem below and said they will try to fix it in the next release.
More significantly every time I view the QuickSet screen on the 711-5HnD, CPU immediately goes to 100% with all available CPU being consumed by winbox (according to profile). If I view it by logging in to Webfig, the CPU stays at 100% until reboot. If I view QuickSet via winbox, the CPU goes to 100% and the winbox session is disconnected. Connecting again shows that the CPU consumed by winbox is then at least 30% even if webfig is not opened again. The problem seems to remain until rebooted.

I do not observe the CPU issue on either the STX R2-5nD or the 711GA-5Hnd
Could you please make a support output file at the time when you see that CPU usage at 100% all the time? Send it to support@mikrotik.com
 
jackwing
just joined
Posts: 15
Joined: Tue Nov 19, 2013 12:43 pm

Re: v6.7 released

Wed Dec 18, 2013 8:43 am

V6.7

VLAN still have problem,it can't be work,but if downgrade to V5.26 , it work

/interface vlan
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0023 use-service-tag=no vlan-id=23
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0002 use-service-tag=no vlan-id=2
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0400 use-service-tag=no vlan-id=400


/ip address
add address=192.168.0.248/16 interface=VLAN0023 network=192.168.0.0
add address=1.0.0.254/24 interface=VLAN0400 network=1.0.0.0
add address=10.1.1.248/24 interface=VLAN0002 network=10.1.1.0


This is the first question
Last edited by jackwing on Wed Dec 18, 2013 9:22 am, edited 2 times in total.
 
jackwing
just joined
Posts: 15
Joined: Tue Nov 19, 2013 12:43 pm

Re: v6.7 released

Wed Dec 18, 2013 9:19 am

The second question


ethernet bonding at 802.3ad mode not work so good

ROS configuration at V5.26 :

/interface bonding
add arp=enabled arp-interval=100ms arp-ip-targets="" disabled=no down-delay=0ms lacp-rate=30secs link-monitoring=mii-type2 mii-interval=100ms mode=802.3ad mtu=1500 name=bonding1 primary=none slaves=ether1,ether2 transmit-hash-policy=layer-2-and-3 up-delay=0ms


/interface vlan
add arp=enabled disabled=yes interface=bonding1 mtu=1500 name=VLAN0023 use-service-tag=no vlan-id=23
add arp=enabled disabled=yes interface=bonding1 mtu=1500 name=VLAN0002 use-service-tag=no vlan-id=2
add arp=enabled disabled=yes interface=bonding1 mtu=1500 name=VLAN0400 use-service-tag=no vlan-id=400


( vlan can't work at V6.7 , so i config the ip at bonding1 for ping test )

/ip address
add address=192.168.0.248/16 interface=VLAN0023 network=192.168.0.0
add address=1.0.0.254/24 interface=VLAN0400 network=1.0.0.0
add address=10.1.1.248/24 interface=VLAN0002 network=10.1.1.0




cisco switch configuration:

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,23,400
switchport mode trunk
ip arp inspection trust
ip dhcp snooping trust

interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 1,2,23,400
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
ip arp inspection trust
ip dhcp snooping trust

interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,23,400
switchport mode trunk
ip arp inspection trust
ip dhcp snooping trust



here some test
You do not have the required permissions to view the files attached to this post.
Last edited by jackwing on Wed Dec 18, 2013 10:45 am, edited 1 time in total.
 
iDen
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Wed Sep 15, 2010 2:26 pm
Location: Tbilisi, Georgia

Re: v6.7 released

Wed Dec 18, 2013 9:25 am

+1 for Dude

Especially when Dude is used by person who has nothing to do with Mikrotik devices at all.
Lots of people monitoring their Nets or servers with Dude.
MTCNA
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: v6.7 released

Wed Dec 18, 2013 11:50 am

Heh, now tell me fella, what use is for MT to usar them programmer hours for freeriders pleasure on free product when their flagship product and ROS still runs full of bugs like my ranch neighbor dog ? If anyone asking me, I sure want them to fixar that v6 and CCR issues damn fast instead of fiddling around that advanced pinging toy for "persons who has nothing to do with Mikrotik devices at all". I would sure be pissed to know they develop Dude while latest ROS is in such an unstable condition as it is now.
+1 for Dude

Especially when Dude is used by person who has nothing to do with Mikrotik devices at all.
Lots of people monitoring their Nets or servers with Dude.
 
sankarklm
just joined
Posts: 20
Joined: Fri Aug 13, 2010 7:05 pm
Location: Bangalore,India

Re: v6.7 released

Wed Dec 18, 2013 2:25 pm

Heh, now tell me fella, what use is for MT to usar them programmer hours for freeriders pleasure on free product when their flagship product and ROS still runs full of bugs like my ranch neighbor dog ? If anyone asking me, I sure want them to fixar that v6 and CCR issues damn fast instead of fiddling around that advanced pinging toy for "persons who has nothing to do with Mikrotik devices at all". I would sure be pissed to know they develop Dude while latest ROS is in such an unstable condition as it is now.
+1 for Dude

Especially when Dude is used by person who has nothing to do with Mikrotik devices at all.
Lots of people monitoring their Nets or servers with Dude.
+10 for Jet Rider., my CCR is giving me nightmares all of sudden packet drops appears vanishes within minutes.Overall browsing download experience is poor.
 
iDen
Frequent Visitor
Frequent Visitor
Posts: 96
Joined: Wed Sep 15, 2010 2:26 pm
Location: Tbilisi, Georgia

Re: v6.7 released

Wed Dec 18, 2013 6:26 pm

off course FIRST OF ALL something should be done with RoS especially on CCRs as soon as possible.
But I want to share some of my experince...
I have 3 CCRs serving core net. 2 of them serving my net for 500 users and last one serving separate plain net for 200 users.
in plain i mean that it has no mangle, no special filters, no queue tree, nothing except simple queue and masquerade.
untill 6.7 i was crying like lil girl. very often I had to wake up during midnight coz of some horrors with CCR!

But right now they become lil bit more stable!
Only separate one left with very strange problem. while doing something on router like disabling/enabling address in address list.
it stops queuing, stops accepting or passing through traffic.
Heh, now tell me fella, what use is for MT to usar them programmer hours for freeriders pleasure on free product when their flagship product and ROS still runs full of bugs like my ranch neighbor dog ? If anyone asking me, I sure want them to fixar that v6 and CCR issues damn fast instead of fiddling around that advanced pinging toy for "persons who has nothing to do with Mikrotik devices at all". I would sure be pissed to know they develop Dude while latest ROS is in such an unstable condition as it is now.
+1 for Dude

Especially when Dude is used by person who has nothing to do with Mikrotik devices at all.
Lots of people monitoring their Nets or servers with Dude.
MTCNA
 
PrSliCa
newbie
Posts: 27
Joined: Sun Feb 18, 2007 2:08 pm

Re: v6.7 released

Wed Dec 18, 2013 9:19 pm

To add some strange bug in logs:

Settings:
wlan1: bridge, ssid: link-brdo, 2 x N, nstreme
wlan2: bridge, ssid: link-brdo-2, 2 x N, nstreme

While all interface connected (19:24):

19:24:04 wireless,info link-brdo-2: data from unknown device 00:00:00:15:6D:84, sent deauth
19:42:53 wireless,info 00:15:6D:84:5B:F3@link-brdo: disconnected, too many poll timeouts
19:42:54 wireless,info 00:15:6D:84:5B:F3@link-brdo: connected, wants bridge

There is no disconnection or anything...

Also (second bug):
20:18:39 system,info device changed by halen
20:18:40 wireless,info 00:15:6D:84:5C:06@link-kladovo established connection on 5715000, SSID elite-ptp0

Frequency is 5715... but log shows something else....
 
tkgit
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Sun Dec 23, 2012 8:32 am
Location: Dunedin, NZ
Contact:

Re: v6.7 released

Wed Dec 18, 2013 10:26 pm

in my 450g :
-multi parent can't be implemented in queue simple
-flappy interface if running vlan
 
lima7
just joined
Posts: 12
Joined: Sun Oct 03, 2010 3:47 am

Re: v6.7 released

Thu Dec 19, 2013 8:17 am

All routes with routing mark is down after upgrade from 6.6 to 6.7, remove the routing mark will make route establish
Image
 
igor88
just joined
Posts: 21
Joined: Thu Jan 17, 2013 6:26 pm
Location: Russia, Moscow
Contact:

Re: v6.7 released

Thu Dec 19, 2013 12:18 pm

are there wifi power control in 6x ? i am still on 5x

i am tired that my telephone disconnects every 30 seconds..
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.7 released

Thu Dec 19, 2013 12:38 pm

lima7, please contact support@mikrotik.com and attach a support output file where you have those non working routing-marks.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Posts: 6615
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: v6.7 released

Thu Dec 19, 2013 12:59 pm

V6.7

VLAN still have problem,it can't be work,but if downgrade to V5.26 , it work

/interface vlan
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0023 use-service-tag=no vlan-id=23
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0002 use-service-tag=no vlan-id=2
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0400 use-service-tag=no vlan-id=400


/ip address
add address=192.168.0.248/16 interface=VLAN0023 network=192.168.0.0
add address=1.0.0.254/24 interface=VLAN0400 network=1.0.0.0
add address=10.1.1.248/24 interface=VLAN0002 network=10.1.1.0


This is the first question
Please clarify your question. At your setup above VLANs interfaces are disabled.
 
linek1980
newbie
Posts: 34
Joined: Thu Feb 03, 2011 1:39 pm

Re: v6.7 released

Thu Dec 19, 2013 1:54 pm

quickset is broken in ROS 6.8RC . Even demo.mt.lv not work "ERROR: Internal Server Error"
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24059
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.7 released

Thu Dec 19, 2013 1:56 pm

quickset is broken in ROS 6.8RC . Even demo.mt.lv not work "ERROR: Internal Server Error"
known issue, thanks!
No answer to your question? How to write posts
 
brainy
Member Candidate
Member Candidate
Posts: 149
Joined: Fri Sep 29, 2006 3:08 pm
Location: Unterschleissheim, Germany
Contact:

Re: v6.7 released

Thu Dec 19, 2013 5:27 pm

We have big problems with DHCP Server with 6.7

Today we updated two RB1100AHx2 and one RB2011UAS-RM from 6.1 to 6.7 and notice that the DHCP Server is not working properly.

The server sends IP to the client but without a gateway and nameservers. Also the netmask is wrong (/0!) resulting in clients that do not have internetconnection.

We run the DHCP Server on VLAN and VRRP Interfaces (the vrrp Interfaces are on VLAN interfaces) and the vlan interfaces are on a bonding link.

Anyone else seeing problems with DHCP Server on 6.7?

Regards,
Joerg
 
tkgit
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Sun Dec 23, 2012 8:32 am
Location: Dunedin, NZ
Contact:

Re: v6.7 released

Fri Dec 20, 2013 3:39 am

All routes with routing mark is down after upgrade from 6.6 to 6.7, remove the routing mark will make route establish
Image
do not use ip-firewall-mangle action mark route,
use route rules in ip-route
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: v6.7 released

Fri Dec 20, 2013 8:27 am


Anyone else seeing problems with DHCP Server on 6.7?

Regards,
Joerg
YES YES YES !!! Finally a friend in my misery !
I have CCR gateway, serving around 2k customers and after upgrade this problem hit me right in the face first thing in the morning upon DHCP lease refresh. I notified MT about this problem, they shoved me off as I was unable to send them supout (I am not willing to fiddle around one huge running environment gateway just to provide them supout). Hope YOU can send them that supout so they figure it out, seems noone there bothers to move an arse or replicate situation without them supout file.
 
tkgit
Frequent Visitor
Frequent Visitor
Posts: 59
Joined: Sun Dec 23, 2012 8:32 am
Location: Dunedin, NZ
Contact:

Re: v6.7 released

Fri Dec 20, 2013 8:33 am


Anyone else seeing problems with DHCP Server on 6.7?

Regards,
Joerg
YES YES YES !!! Finally a friend in my misery !
I have CCR gateway, serving around 2k customers and after upgrade this problem hit me right in the face first thing in the morning upon DHCP lease refresh. I notified MT about this problem, they shoved me off as I was unable to send them supout (I am not willing to fiddle around one huge running environment gateway just to provide them supout). Hope YOU can send them that supout so they figure it out, seems noone there bothers to move an arse or replicate situation without them supout file.
do you use vlan in dhcp server interface?
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: v6.7 released

Fri Dec 20, 2013 8:55 am

do you use vlan in dhcp server interface?
Yes.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.7 released

Fri Dec 20, 2013 5:45 pm

do you use vlan in dhcp server interface?
Yes.
after downgrade to v6.6 it works fine?
We need support output file from your current router - even if it is running v6.6 so we could try to check the configuration and try to reproduce it locally.
We have tested that DHCP server works fine on Vlan interface in CCR running RouteROS v6.7.
 
evharten
newbie
Posts: 33
Joined: Mon Apr 30, 2012 8:20 am
Location: Capelle a/d IJssel, The Netherlands
Contact:

Re: v6.7 released

Sat Dec 21, 2013 4:30 am


Anyone else seeing problems with DHCP Server on 6.7?

Regards,
Joerg
YES YES YES !!! Finally a friend in my misery !
I have CCR gateway, serving around 2k customers and after upgrade this problem hit me right in the face first thing in the morning upon DHCP lease refresh. I notified MT about this problem, they shoved me off as I was unable to send them supout (I am not willing to fiddle around one huge running environment gateway just to provide them supout). Hope YOU can send them that supout so they figure it out, seems noone there bothers to move an arse or replicate situation without them supout file.
Creating an supout isnt fiddling, its just an snapshot of all settings and values at that specific time.
I use it quite often myself to view router settings of my customers if they have problems.
https://www.mikroshop.nl - The Dutch Mikrotik Store!
 
Zito
just joined
Posts: 14
Joined: Tue Feb 19, 2013 11:41 pm

Re: v6.7 released

Sun Dec 22, 2013 2:16 pm

The server sends IP to the client but without a gateway and nameservers. Also the netmask is wrong (/0!) resulting in clients that do not have internetconnection
Similar issue here. 10~ dhcp servers on bond interface with 10~vlans physically connected to two HP core switches. Clients got incorrect DHCP ACK only when i enable dhcp-snooping in my network infrastructure(also HP switches). Its not happened in 6.6.
 
brainy
Member Candidate
Member Candidate
Posts: 149
Joined: Fri Sep 29, 2006 3:08 pm
Location: Unterschleissheim, Germany
Contact:

Re: v6.7 released

Sun Dec 22, 2013 6:27 pm

The server sends IP to the client but without a gateway and nameservers. Also the netmask is wrong (/0!) resulting in clients that do not have internetconnection
Similar issue here. 10~ dhcp servers on bond interface with 10~vlans physically connected to two HP core switches. Clients got incorrect DHCP ACK only when i enable dhcp-snooping in my network infrastructure(also HP switches). Its not happened in 6.6.
Hmm, we are using dhcp-snooping also but on Cisco Switches. Maybe this helps MT to find the Problem.

Regards,
Joerg
 
jackwing
just joined
Posts: 15
Joined: Tue Nov 19, 2013 12:43 pm

Re: v6.7 released

Mon Dec 23, 2013 6:08 pm

V6.7

VLAN still have problem,it can't be work,but if downgrade to V5.26 , it work

/interface vlan
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0023 use-service-tag=no vlan-id=23
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0002 use-service-tag=no vlan-id=2
add arp=enabled disabled=yes interface=eth1 mtu=1500 name=VLAN0400 use-service-tag=no vlan-id=400


/ip address
add address=192.168.0.248/16 interface=VLAN0023 network=192.168.0.0
add address=1.0.0.254/24 interface=VLAN0400 network=1.0.0.0
add address=10.1.1.248/24 interface=VLAN0002 network=10.1.1.0


This is the first question
Please clarify your question. At your setup above VLANs interfaces are disabled.


I’am sorry ,not this problem, vlan is OK, the problem is in DHCP server , DHCP server sends IP to the client took a long time,I don't untherstand why, i thought VLAN still can't work .
if downgrade to V5.26 , DHCP server work so well , client get the ip so quick.
 
tambu
just joined
Posts: 9
Joined: Tue Nov 26, 2013 5:06 pm

Re: v6.7 released

Tue Dec 24, 2013 12:03 pm

updated the firmware from 6.5 to 6.7 and there was a problem on the equipment SXT r2 5nd, 2nd.
it is impossible to set the option in wireless: tx-power-mode=card-rates
[root@MikroTik] > interface wireless set tx-power-mode=card-rates 
numbers: 0
failure: tx-power-mode not supported
[root@MikroTik] > system routerboard print
       routerboard: yes
             model: SXT 5nD r2
     serial-number: 46AD02AA943A
  current-firmware: 3.10
  upgrade-firmware: 3.10
 
gizmoss
just joined
Posts: 5
Joined: Tue Feb 21, 2012 12:57 pm

Re: v6.7 released

Wed Dec 25, 2013 1:34 am

Rb 133 ether 1= WAN, bridge ether2 + wlan1, NAT, 10 queue, clasic router setup. wlan1 cenected only to other mt rb 220 in bridge mode, the signal -45/-45 (RB 220 works ok at 5:25 and 6.7)
5:26 OK

6.6 and 6.7 the same configuring rb 133 (tried WDS, station, mpls, rstp on bridge no difference)
Less CPU usage, greater throughput is possible but sometimes crazy flow (continuous ping from 150 to 1500 at all addresses after the bridge in all directions and towards WAN Internet while CPU is normal). Sometimes it happens after a reboot usually happens when the flow in the direction of vlan- ether2 and ether2-WAN (flow through the bridge interface) while in the case of flow vlan-wan (no flow through the bridge interface i guess fastpath) everything works ok. It is the flow rate of 1 mbps to 4.5 mbps and CPU is always normal. It happens often and prevents you from using the Internet because the speed of the net is reduced to 1/10 and lasts until reboot or interruption and the lowest flow of data.

used google translate

Using the DST parameters in simple queues caused this problem in version 6.7. Combination example. dst-ether-1 target IP address led to the collapse of the network while using only the target parameter by IP address works ok but can not be limited by speed particularly ether1 ether2 .... what is possible in the version 5:26 (interface-ether1 dst-ip address).
Last edited by gizmoss on Wed Dec 25, 2013 7:29 am, edited 1 time in total.
 
Begetan
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Mon Jul 11, 2011 11:49 am

Re: v6.7 released

Wed Dec 25, 2013 2:43 am

What's new in 6.7 (2013-Nov-29 13:37):

*) support Android usb tethering interface;
I have a question to mikrotik developers.
Is there any chance to autodetect unknown USB Vendor/type device or it should be specially added by mikrotk developers?
 
mars
Member Candidate
Member Candidate
Posts: 228
Joined: Sun Mar 14, 2010 1:43 pm

Re: v6.7 released

Wed Dec 25, 2013 7:26 am

there is a bug in ros 6.7 causing the tx power setting not to work correctly on the rb911G
card rates can not be set in the tx power
this was working properly in Ros 6.6
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2278
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.7 released

Wed Dec 25, 2013 12:25 pm

there is a bug in ros 6.7 causing the tx power setting not to work correctly on the rb911G
card rates can not be set in the tx power
this was working properly in Ros 6.6
This is not bug. Card rates dont wort on this wireless chipset. You can use All rates fixed
LAN, FTTx, Wireless. ISP operator
 
mars
Member Candidate
Member Candidate
Posts: 228
Joined: Sun Mar 14, 2010 1:43 pm

Re: v6.7 released

Wed Dec 25, 2013 2:15 pm

yes so i found out later
they should replace the chip and replace the Rb911 for the people who bought it
 
Łukasz
Frequent Visitor
Frequent Visitor
Posts: 82
Joined: Mon Mar 05, 2012 6:03 pm

Re: v6.7 released

Thu Dec 26, 2013 4:05 pm

*) poe - new poe controller firmware for RB750UP and OmniTIK UPA;
What gives new controller firmware? Any changelog?
 
User avatar
falestiny
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Sep 10, 2010 3:11 pm
Location: everywhere
Contact:

Re: v6.7 released

Thu Dec 26, 2013 4:06 pm

web proxy is not functioning probably, when it's enabled it does not disabled :(
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: v6.7 released

Fri Dec 27, 2013 11:11 am

after downgrade to v6.6 it works fine?
We need support output file from your current router - even if it is running v6.6 so we could try to check the configuration and try to reproduce it locally.
We have tested that DHCP server works fine on Vlan interface in CCR running RouteROS v6.7.
We are running v6.5 atm, skipped v6.6. You have my supout with Ticket#2013121066000356. Need me to resend ?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.7 released

Fri Dec 27, 2013 11:21 am

after downgrade to v6.6 it works fine?
We need support output file from your current router - even if it is running v6.6 so we could try to check the configuration and try to reproduce it locally.
We have tested that DHCP server works fine on Vlan interface in CCR running RouteROS v6.7.
We are running v6.5 atm, skipped v6.6. You have my supout with Ticket#2013121066000356. Need me to resend ?
Ticket 2013121066000356 is already answered. If you still see this problem, please submit a new ticket with detailed info how to reproduce this problem.
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: v6.7 released

Fri Dec 27, 2013 11:57 pm

There is a problem with ROS 6.x and dude 4.03beta on RB2011. I have tested few times scenario like this:
1. Clean Netinstal routerOS 6.7 (tried with ROS 6.1 too, same result).
2. simple config with NAT and two interfaces.
3. restart.
4. put dude package in to router.
5. restart.
6. It looks that all wokrs fine, NAT working, you can log in to dude as well. But...
7. System->restart - it is ok.
8. System->Shutdown - and you've got error. Your RB2011 is broke now. You can't up your router because it reboots all the time. You need to make Netinstall and start againt.

So you can't run dude package on RB2011 with ROS 6.x :(. I'm not sure if is there any version of ROS working well with dude 4.03beta.

Mikrotik, please update Dude! We love Dude and we need it (propably we need it more than SMB and other features like this).
We need Mikrotik because of your simple interface GUI and great idea.

We need Dude to know that our Mikrotik are working fine :).
To be fair the DUDe is not really at its best on a routerboard. very resorce hungry. Far better to install on some old redundant x86 PC running XP or later.
 
dankunwizard
just joined
Posts: 20
Joined: Thu Sep 30, 2010 1:23 pm

Re: v6.7 released

Sat Dec 28, 2013 8:00 am

CCR router running ROS v6.7 locked up and stopped forwarding packets after running for about two weeks. It also didn't respond to icmp echo packets.
When connected to console, it was up but the log had hundred lines of BGP connection error messages:

RemoteAddress=xxx.xxx.xxx.xxx
Failed to open TCP connection: No buffer space available

It has simple configurations with a simple queue, a few lines of firewall, no mangle rules and BGP sessions.
Is this a known issue? Anyone else having the same issue?
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: v6.7 released

Sat Dec 28, 2013 11:19 am

CCR router running ROS v6.7 locked up and stopped forwarding packets after running for about two weeks. It also didn't respond to icmp echo packets.
When connected to console, it was up but the log had hundred lines of BGP connection error messages:

RemoteAddress=xxx.xxx.xxx.xxx
Failed to open TCP connection: No buffer space available

It has simple configurations with a simple queue, a few lines of firewall, no mangle rules and BGP sessions.
Is this a known issue? Anyone else having the same issue?
Possible Dos attack of somekind maybe?
 
dankunwizard
just joined
Posts: 20
Joined: Thu Sep 30, 2010 1:23 pm

Re: v6.7 released

Sat Dec 28, 2013 1:01 pm

Possible Dos attack of somekind maybe?
CPU load was 0%, traffic was normal but all BGP sessions were down.
It also had firewall rules on input chain filtering tcp port 179 traffic, so only allowed peers could communicate and establish bgp peering.
"/system reboot" fixed the problem.
 
m3gaman
just joined
Posts: 19
Joined: Sun Jun 02, 2013 10:24 pm

Re: v6.7 released

Sun Dec 29, 2013 2:48 am

On x86, dual port intel(E82571EB) card not working properly on version 6.x(traffic and ping very unstable) on 5.x works fine. Intel 82574L works fine too on 6.x. Onboard broadcom BCM5717 previously not working on 5.x now fine with 6.x.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.7 released

Sun Dec 29, 2013 7:12 pm

Hello Folks!

After some weeks in production CRS used as a pure switch with no vlans or routing etc. all packages are disabled exept dhcp, security, system and advanced-tools, start to missbehave, very bad customer impact!
Further IP settings are cleared out, it is a switch!
LCD and touchscreen is disabled, snmp is disabled!
All else are factory defaults.
CRS and CCR uses RoS6.7.

What happens is ethernet ports are suddenly disabled, and then seconds after enabled again, sometimes it is switching from 1000Mbit/s to 100Mbit/s and back again, sometimes it stay on the lowe speed till it happens again. Some ports more than other, the bad thing is that whole switch seems to be affected by disturbance on one port, lockouts and slowness in network is experienced when it arrives. Also very fast lockout with no ports down in log, has been detected, for a few seconds and then all working again. Sometimes DNS and DHCP is not passed through properly through the switch from CCR.... found out by analysis via wireshark seeing DHCP req but no reply and same with DNS for periods of several minutes, most likely due to some internal lockups inside the switch.

Also noted that when logged in to CRS all active switchports show the same traffic load, like 24Mbit on all of them, but there is only two ports engaged, strange. Neither can I torch them.

All network cabling is in prime condition and uses CAT6 through out all details, there are patch panels, patch cables also CAT6 plus RJ45 jacks on walls also CAT6 and TP cables to workstations also CAT6. WOkrstations have Gigabit interfaces. It has been running without problems for 2 years using CISCO and HP switches, but after CRS it went not so good.

We have got support from Mikrotik from before on VLAN stuff that did not work as expected and our CCR who also suddenly locked ports etc. CCR is stable after disabling snmp and LCD and touchscreen not a problem found since, but CRS is still making big problems.

Anyone who have suggestion what to do, looks to me like a full rollback on all switches to Cisco+HP again... :-(
 
balintos
just joined
Posts: 5
Joined: Fri Nov 18, 2011 11:00 am
Location: Hungary, Bekescsaba

Re: v6.7 released

Sun Dec 29, 2013 8:53 pm

Dell 1850 server (Intel PRO/1000): If the IP VLAN is unavailable. Eth's interface is works. ROS 5.xx works, ROS 6.xx does not work. :(
Same config Dell CS24 (Intel PRO/1000 Ethernet) flawless.

Any idea?
Thank's:
Bálint
 
lima7
just joined
Posts: 12
Joined: Sun Oct 03, 2010 3:47 am

Re: v6.7 released

Mon Dec 30, 2013 6:45 am

added /activated ipsec policies will drop all pppoe connection ( mikrotik 6.7)
 
David1234
Forum Guru
Forum Guru
Posts: 1258
Joined: Sun Sep 18, 2011 7:00 pm

Re: v6.7 released

Mon Dec 30, 2013 12:28 pm

*) leds - inverted modem signal trigger, now it will trigger when the signal level rises above the treshold;
so much useful - you can't understand
Thanks for fix it !
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.7 released

Mon Dec 30, 2013 3:29 pm

added /activated ipsec policies will drop all pppoe connection ( mikrotik 6.7)
I tested this, and cant replicate.

If you can reliably reproduce this, please post the steps.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: v6.7 released

Tue Dec 31, 2013 5:40 am

any update for my tickets in regards to ups issues and led's not working for 10mbit connections?
 
ununium
just joined
Posts: 13
Joined: Wed Sep 12, 2012 10:52 pm

Re: v6.7 released

Thu Jan 02, 2014 6:32 am

Can confirm that 6.7 still shows signs of flapping on CCR1016.

The behavior:

All interfaces go down for 2 secs and then back up.
Sometimes watchdog activates sometimes it doesn't.

Image


I verified on the interface stats and I didnt see any tx/rx errors.

Minimal traffic going through CCR (16Mb/5Mb) when the problem presented.
 
User avatar
bysard
Member Candidate
Member Candidate
Posts: 295
Joined: Thu Apr 22, 2010 2:53 pm

Re: v6.7 released

Thu Jan 02, 2014 1:27 pm

Hello Folks!

After some weeks in production CRS used as a pure switch with no vlans or routing etc. all packages are disabled exept dhcp, security, system and advanced-tools, start to missbehave, very bad customer impact!
Further IP settings are cleared out, it is a switch!
LCD and touchscreen is disabled, snmp is disabled!
All else are factory defaults.
CRS and CCR uses RoS6.7.

What happens is ethernet ports are suddenly disabled, and then seconds after enabled again, sometimes it is switching from 1000Mbit/s to 100Mbit/s and back again, sometimes it stay on the lowe speed till it happens again. Some ports more than other, the bad thing is that whole switch seems to be affected by disturbance on one port, lockouts and slowness in network is experienced when it arrives. Also very fast lockout with no ports down in log, has been detected, for a few seconds and then all working again. Sometimes DNS and DHCP is not passed through properly through the switch from CCR.... found out by analysis via wireshark seeing DHCP req but no reply and same with DNS for periods of several minutes, most likely due to some internal lockups inside the switch.

Also noted that when logged in to CRS all active switchports show the same traffic load, like 24Mbit on all of them, but there is only two ports engaged, strange. Neither can I torch them.

All network cabling is in prime condition and uses CAT6 through out all details, there are patch panels, patch cables also CAT6 plus RJ45 jacks on walls also CAT6 and TP cables to workstations also CAT6. WOkrstations have Gigabit interfaces. It has been running without problems for 2 years using CISCO and HP switches, but after CRS it went not so good.

We have got support from Mikrotik from before on VLAN stuff that did not work as expected and our CCR who also suddenly locked ports etc. CCR is stable after disabling snmp and LCD and touchscreen not a problem found since, but CRS is still making big problems.

Anyone who have suggestion what to do, looks to me like a full rollback on all switches to Cisco+HP again... :-(
I've been suggested not to use CCR's in a production enviroment. Yes I know, it's a Mikrotik flagship router. Port flapping has been going on since ros 6.x.

Who is online

Users browsing this forum: No registered users and 57 guests