Community discussions

MUM Europe 2020
 
petterg
Member Candidate
Member Candidate
Topic Author
Posts: 198
Joined: Wed Sep 16, 2009 2:55 pm

Bug in ROS 6.7: simple queue ignores unlimited

Tue Dec 03, 2013 1:26 am

I think I found a bug in CRS125 running ROS 6.5, and it's still there after upgrading to ROS 6.7

I want a bandwidth to/from all destinations except for one particular subnet to be limited

(All local subnets on this box is within 172.27.0.0/16 the range)

According to how I read documentation the following commands would make communication to/from the 213.236.250.0/26 subnet unlimited, while anything else would be limited to 512k.
/queue simple
add dst=213.236.250.0/26 name=queue-office target=172.27.0.0/16
add max-limit=512k/512k name=queue-public target=172.27.0.0/16
However, the 512k limitation seems to apply even to the 213.236.250.0/26 subnet. Monitoring traffic in winbox I see that all packets hits the second rule, no matter where they come from. (Swapping the order of the queues did not make any changes.)

Now, if I delete the queues created above, and rather run these commands:
/queue simple
add max-limit=20M/20M dst=213.236.250.0/26 name=queue-office target=172.27.0.0/16
add max-limit=512k/512k name=queue-pub target=172.27.0.0/16
... the packets to/from 213.236.250.0/26 hits the first rule, and they are not limited by the 512k limitation.

So it seems to me that when a simple queue is created using "unlimited" the queue is ignored.
Workaround: set limit so higher than link speed.

Googleing turned me to this video, which also show that when queue is set unlimited, the queue doesn't hit. http://www.youtube.com/watch?v=VImqaJEbAAk
 
ners
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Tue Mar 12, 2013 4:30 pm

Re: Bug in ROS 6.7: simple queue ignores unlimited

Wed Dec 04, 2013 5:33 pm

A simple queue with default parameters will not work -- it really is not even created. You should change the type of queue from default-small to default, for example, then it will work.

Who is online

Users browsing this forum: chris91, w32pamela and 96 guests