Community discussions

 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Email - error connecting to server

Tue Dec 24, 2013 9:00 pm

Configured email server settings, getting the above when sending a test email.
No Firewall rules to prevent this, and email server is on VLAN connected to my RB750. Other external and internal clients using the mail server normally. Router can ping/traceroute the IP address without an interface specified.
Error is exactly as above - no indication of authentication issues etc although have allowed the LAN IP address of the RB750 as allowed to use mail server as a relay so should bypass authentication process.

Any suggestions? I'd like to get this working for email of log etc.
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
nerdtron
Member Candidate
Member Candidate
Posts: 123
Joined: Sat Nov 30, 2013 7:49 am

Re: Email - error connecting to server

Thu Dec 26, 2013 10:13 am

What is the mail.log of the mail server when mikrotik tries to send email?
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Thu Dec 26, 2013 10:31 am

Nothing at all - doesn't appear to be reaching.it.
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Email - error connecting to server

Thu Dec 26, 2013 1:11 pm

Enable debug logging for email, then try the email send again and check the log.
/system logging
add topics=e-mail,debug action=memory
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Thu Dec 26, 2013 3:03 pm

Tried that, only got the same as per thread summary.
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Email - error connecting to server

Thu Dec 26, 2013 3:15 pm

Can you ping the email server ip from one of the computers that can't connect?
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Thu Dec 26, 2013 3:22 pm

PCs are fine, just ROS is the issue. Can ping IP no problem.
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Email - error connecting to server

Thu Dec 26, 2013 3:30 pm

PCs are fine, just ROS is the issue. Can ping IP no problem.
Does that mean you are trying to send an email from the router? And you added the debug logging to "/system logging" and nothing shows in the router log?
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Thu Dec 26, 2013 3:38 pm

Correct trying to enable ROS email function.
Tried internal mail server and gmail.
With debug level logging all I get is error connecting to server. No further info.
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Email - error connecting to server

Thu Dec 26, 2013 3:44 pm

Then the router is unable to connect. That is usually a firewall problem on the server. Check your settings there to insure it allows your localnet to access that port.
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Thu Dec 26, 2013 3:49 pm

No fw running on server. No issues inside LAN (any VLAN) or from WAN with any other smtp access
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Email - error connecting to server

Thu Dec 26, 2013 10:10 pm

Then check your email setup in the router to insure you are using the correct port and security.
/tool e-mail

How are you trying to send the email? Are you trying from the command line or from a script?
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Fri Dec 27, 2013 1:13 am

Setup is exactly as per working mail clients.
Using System/Email in Winbox and using the sent test message option
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: Email - error connecting to server

Fri Dec 27, 2013 2:13 am

What version RouterOS are you using?

Mine is under tools - email, and my email test was in my inbox first try. I am using ROS V6.5 and Linux with Sendmail as the smtp server. And the same router sends me a voltage readout for the last 24 hours every day.

I have in the past tried sending to my gmail account and it works also.

I tried to send through one of my servers that does not accept port 25 email, and I got a message in my log like this. It took a minute or so to show up in the log:
Dec/26/2013 18:08:07 system,e-mail,error Error sending email <test>: abnormal termination [timeout]
 
User avatar
sjoram
Member Candidate
Member Candidate
Topic Author
Posts: 116
Joined: Sun Feb 10, 2013 8:47 pm
Location: Essex, UK

Re: Email - error connecting to server

Fri Dec 27, 2013 2:06 pm

Edit: Thought I had it sorted, but I haven't.
Getting further than before but still no success. Getting a timeout, but don't understand why as no internal nor external client has any issue connecting to my mail server.

Image
Home user, working in IT. Home network is my lab.
ISP: Uno Communications
Hardware:
RB750 - Draytek Vigor 120v2 ADSL2+ Annex M
RB750Gr3 - Draytek Vigor 130 FTTC (VDSL) & RBD52G-5HacD2HnD

Who is online

Users browsing this forum: No registered users and 84 guests