Community discussions

 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

UPnP does not work with Nomachine's NX

Thu Jan 09, 2014 4:21 pm

So here's the setup:
One RB951G-2HnD connected to my ISP. It's configured as a standard AP that does NAT.
There's another RB951G-2HnD which is connected to the AP and it's configured to work in as a bridge. I use WDS.
Behind the second RB951G-2HnD I have my laptop connected to one of the ports. On my laptop I'm running NoMachine's NX server.
And here's the problem:
the NX server is using UPnP to communicate to the gateway (the first RB951G-2HnD in my case) what is the outside IP address and what port forwarding needs to be done so that the server will be reachable from outside the LAN. It fails!

So, what I did. I went on my Internet router and checked the UPnP configuration - disabled by default. I've enabled the configuration, and now I have:
[admin@MikroTik_main] > /ip upnp export
# jan/09/2014 16:08:49 by RouterOS 6.7
# software id = 2DWW-HXRL
#
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add forced-external-ip=xx.xx.xx.xx interface=ether1-gateway type=external
add interface=bridge-local type=internal

I've got the wifi and the wds interfaces configured under the bridge-local. My understanding is that this configuration should be enough... But, it does not work.
So I've started a Wireshark capture on my server (it's still reachable from the outside, because I've manually created a port forwarding rule). I used the following capture filter:
udp port 1900

And I see that the NX server is indeed sending a request to both the default gateway 192.168.99.1 in this case and to the multicast address 239.255.255.250. But no response. At least not initially. When I capture for a little bit longer... there are responses from the MikroTik router, but after many, many seconds since the initial requests from the server.
Has anyone ever experienced this? Is UPnP working at your side?
Unfortunately I'm not able to attach the capture files to the thread... but I could send them, if anyone is interested.

Who is online

Users browsing this forum: MSN [Bot] and 74 guests