Community discussions

 
jkay1804
just joined
Topic Author
Posts: 2
Joined: Fri Jan 17, 2014 2:49 am

Creating Route for Vlan to switch

Fri Jan 17, 2014 2:52 am

I have a mikrotik router that has it's main interface (default vlan 1)on ether 2. I created a vlan 3 on the mikrotik and set it's interface to ether2 as well. I created an address on the mikrotik 192.168.3.1 and a static route 192.168.3.0/24

btw on the Mikrotik I use the GUI not the CLI

I have a cisco switch that is connected directly to the mikrotik via ether2. and then it has a SFP port 1/0/25 that connects to a hp switch.

from the cisco switch i can ping 192.168.3.1 but from the HP I cannot. I have a interface setup on the HP of 192.168.3.2 and I cannot ping it from the cisco, however if I add a IP to vlan 3 on the cisco I can ping the hp one but then I can no longer ping the mikrotik.



Here is the Cisco config


Building configuration...

Current configuration : 2044 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname TracysSwitch
!
enable secret 5 $1$UHSd$1hQJNmzhLfSJDclfXv7TL0
!
username admin secret 5 $1$Tmh5$UbpBOyKAGmHWP2sv8bz/h0
no aaa new-model
switch 1 provision ws-c3750g-24ps
ip subnet-zero
ip routing
ip domain-name tracys.local
!
ip dhcp pool Voice_DHCP
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
dns-server 192.168.0.1
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
ip address 192.168.0.2 255.255.255.0
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0
ip access-group 1 in
ip access-group 1 out
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.1 permanent
no ip http server
no ip http secure-server
!
!
access-list 1 permit any
!
control-plane
!
!
line con 0
line vty 0 4



Here is the HP config

HP-3500yl-48G# show running-config

Running configuration:

; J8693A Configuration Editor; Created on release #K.15.10.0022
; Ver #05:08.00.63.1f.ef:9e
hostname "HP-3500yl-48G"
module 1 type j86yya
module 2 type j86xxa
power-over-ethernet pre-std-detect
no web-management
ip access-list extended "100"
10 deny ip 0.0.0.0 255.255.255.255 192.168.0.0 0.0.255.255
20 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip access-list extended "110"
10 deny ip 192.168.0.0 0.0.255.255 0.0.0.0 255.255.255.255
20 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
exit
ip access-list standard "allowall"
10 permit 0.0.0.0 255.255.255.255
exit
ip default-gateway 192.168.0.1
ip dns domain-name "tracys.local"
ip dns server-address priority 1 192.168.0.5
ip dns server-address priority 2 192.168.0.6
ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip routing
vlan 1
name "Default"
no untagged 1-18,45-46
untagged 19-44,47-48
ip address 192.168.0.3 255.255.255.0
exit
vlan 3
name "Cameras"
untagged 1-17
tagged 48
ip address 192.168.3.2 255.255.255.0
exit
vlan 15
name "WiFi"
untagged 46
tagged 48
ip address 192.168.15.15 255.255.255.0
exit
vlan 16
name "Cheezies"
untagged 18
tagged 48
ip access-group "100" in
ip access-group "110" out
ip address 192.168.16.1 255.255.255.0
exit
vlan 100
name "Voice"
tagged 40-45,48
no ip address
qos priority 7
voice
exit
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager

I'm assuming I need to fix a static route or if it's possible "tag" vlan 3 on the mikrotik somehow?
 
User avatar
dasiu
Trainer
Trainer
Posts: 232
Joined: Fri Jan 30, 2009 11:41 am
Location: Reading, UK
Contact:

Re: Creating Route for Vlan to switch

Sun Jan 19, 2014 1:08 am

I have a cisco switch that is connected directly to the mikrotik via ether2. and then it has a SFP port 1/0/25 that connects to a hp switch.
[...]
interface GigabitEthernet1/0/25
switchport trunk encapsulation dot1q
switchport mode trunk
What Cisco port is connected to the MikroTik's ether2? And why don't you configure it also with:
switchport trunk encapsulation dot1q
switchport mode trunk
?
btw on the Mikrotik I use the GUI not the CLI
But you can still open "New Terminal" and enter such commands:
/ip address export
/interface vlan export
/interface bridge export
- and paste the results here - the chances that we will be able to diagnose anything will be better :)
 
jkay1804
just joined
Topic Author
Posts: 2
Joined: Fri Jan 17, 2014 2:49 am

Re: Creating Route for Vlan to switch

Sun Jan 19, 2014 2:24 am

I will give that a try and let you know.

Thanks for the help
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: Creating Route for Vlan to switch

Sun Jan 19, 2014 5:20 am

The Cisco config shown doesn't actually show VLAN 3. Is VLAN 3 defined on the Cisco switch? Are both the relevant Cisco ports in trunk mode and is VLAN 3 permitted on both trunks?
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

Who is online

Users browsing this forum: No registered users and 128 guests