Community discussions

 
lsettembri
just joined
Topic Author
Posts: 23
Joined: Tue Jan 14, 2014 10:04 pm

Speedtest.net - How to bypass

Thu Jan 30, 2014 4:08 pm

Hi and thank you for reading!

I'm new at this, I'm at the moment doing Qos via queue tree and simple queues. The problem is that my customers fell under the queue tree when downloading on heavy connections and therefore the same rule applies when they do a speedtest at speedtest.net.

I'm looking into having some rules that would make them bypass the queue tree when doing this test.

Does anyone know how to do this? Please?

Thanks again!
 
hwmonkey
Member Candidate
Member Candidate
Posts: 115
Joined: Wed Feb 08, 2012 9:50 pm

Re: Speedtest.net - How to bypass

Thu Jan 30, 2014 10:05 pm

Queues that would in one way or another incorporate:
/ip firewall layer7-protocol
add comment="Speedtest" name=speedtest-servers regexp="^.*(get|GET).+speedtest.*\%CONTENT%quot;
 
lsettembri
just joined
Topic Author
Posts: 23
Joined: Tue Jan 14, 2014 10:04 pm

Re: Speedtest.net - How to bypass

Thu Jan 30, 2014 10:09 pm

/ip firewall layer7-protocol
add comment="Speedtest" name=speedtest-servers regexp="^.*(get|GET).+speedtest.*\%CONTENT%quot;
Thanks for the reply! Could you please just explain what does the rule do? Thanks again!
 
lsettembri
just joined
Topic Author
Posts: 23
Joined: Tue Jan 14, 2014 10:04 pm

Re: Speedtest.net - How to bypass

Thu Jan 30, 2014 10:17 pm

Thank you hwmonkey!

Would you mind explaining what does this rule do?

Thank you again!
 
hwmonkey
Member Candidate
Member Candidate
Posts: 115
Joined: Wed Feb 08, 2012 9:50 pm

Re: Speedtest.net - How to bypass

Fri Jan 31, 2014 3:47 pm

Read about layer-7 protocol. By itself, the rule will do nothing valuable (and it looks like the end quote got messed up when I posted the code here). What you want to look at doing is tagging packets based on the layer-3 inspection, mangle, and then creating a queue rule that allows these packets (marked with the speedtest tag created by the rule) to go at full-speed.

I have not done this. I have no experience doing this yet for I have not had time to mess with it, but conceptually, this is the right direction to be going.

Hope that is enough to get you going in the right direction. Post a result after you have it worked out and tested!

http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/L7
http://wiki.mikrotik.com/wiki/Manual:Queue
http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Mangle

Who is online

Users browsing this forum: No registered users and 48 guests