Community discussions

MUM Europe 2020
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: 6.9 released!

Mon Feb 03, 2014 9:43 pm

One of my routers is in a colocation 400km away ;-) So I'll wait with upgrading and test it before on my RB750GLs
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Mon Feb 03, 2014 11:01 pm

pptp appears broke, trying to manage winbox while in the tunnel, different sections are blank, then winbox shows disconnected

sstp also does not appear to be working at this point either. it does not, get an error at verifying username and password, then windows times out with error 628......


i downgraded back to 6.7, pptp and sstp back to working flawless and significantly faster


guess i can live for a while without the leds working right.


guys fix ppp, you seem to have broken alot



this is on a 2011
have you checked your max mtu possible through the tunnell i find many pptp linkd need a slight drop to 1400
 
willie2276
just joined
Posts: 7
Joined: Tue Dec 27, 2011 7:19 pm

Re: 6.9 released!

Tue Feb 04, 2014 2:12 am

HELP HELP HELP
After upgradind a RB1100AHx2 to 6.9!!!!!!!!!!!!!!!
L2TP server doesn't work! Clients log off immediately after connection establishing.
 
mediana
just joined
Posts: 10
Joined: Tue Feb 04, 2014 9:03 am

Re: 6.9 released!

Tue Feb 04, 2014 9:13 am

Model: RB450G
Upgrade from 6.7 to 6.9, IPsec (Site-to-Site) is broken.
Downgrade from 6.9 to 6.7, IPsec works as usual.
 
User avatar
TealFrog
just joined
Posts: 23
Joined: Sun Oct 02, 2011 11:56 am

Re: 6.9 released!

Tue Feb 04, 2014 9:21 am

Downloaded RoS upgrade package again and did another reinstall on the RB2011. No issues so far and no high CPU utilization. Odd.
Attempted to upgrade three routers from V6.7 to V6.9
RB493 - Okay
RB493G - Okay
2011UAS-2HnD - Unsuccessful

Attempted twice to upgrade 2011UAS-2HnD router to V6.9, router became unusable running constantly at 100% CPU utilization. I would have liked to have had some diagnostics to post, but router wasn't responding. Both attempts ended with downgrading to V6.7. CPU utilization back to normal (nil) with downgrades.

Regards,
TealFrog
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1825
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: 6.9 released!

Tue Feb 04, 2014 9:29 am

Model: RB450G
Upgrade from 6.7 to 6.9, IPsec (Site-to-Site) is broken.
Downgrade from 6.9 to 6.7, IPsec works as usual.
I also had this problem. When I investigated I found that the IPSEC policies had been disabled by the upgrade (they were red) I simply enabled them and IPSEC works fine on 6.9
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
alx26
just joined
Posts: 1
Joined: Fri Nov 02, 2012 7:39 am

Re: 6.9 released!

Tue Feb 04, 2014 10:00 am

HELP HELP HELP
After upgradind a RB1100AHx2 to 6.9!!!!!!!!!!!!!!!
L2TP server doesn't work! Clients log off immediately after connection establishing.
We observe similar behavior after upgrade, but the problem cause another. There are changes in the log topic "info". In previous versions failed pppoe authentication logging as:
11:27:03 pppoe,info PPPoE connection established from 08:60:6E:62:37:60 
11:27:03 pppoe,ppp,info <pppoe-0>: waiting for call... 
11:27:03 pppoe,ppp,info <pppoe-0>: terminating... - user 002074 authentication failed 
11:27:03 pppoe,ppp,info <pppoe-0>: disconnected 
and now same authentication failure looks not so obvious:
11:32:59 pppoe,info PPPoE connection established from 08:60:6E:62:37:60 
11:32:59 pppoe,ppp,info,account 002074 logged out, 0 0 0 0 0 
Dear Mikrotik Support Team, сan you say, if it changes in the "logging" or just a bug?
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Tue Feb 04, 2014 10:19 am

HELP HELP HELP
After upgradind a RB1100AHx2 to 6.9!!!!!!!!!!!!!!!
L2TP server doesn't work! Clients log off immediately after connection establishing.
We observe similar behavior after upgrade, but the problem cause another. There are changes in the log topic "info". In previous versions failed pppoe authentication logging as:
11:27:03 pppoe,info PPPoE connection established from 08:60:6E:62:37:60 
11:27:03 pppoe,ppp,info <pppoe-0>: waiting for call... 
11:27:03 pppoe,ppp,info <pppoe-0>: terminating... - user 002074 authentication failed 
11:27:03 pppoe,ppp,info <pppoe-0>: disconnected 
and now same authentication failure looks not so obvious:
11:32:59 pppoe,info PPPoE connection established from 08:60:6E:62:37:60 
11:32:59 pppoe,ppp,info,account 002074 logged out, 0 0 0 0 0 
Dear Mikrotik Support Team, сan you say, if it changes in the "logging" or just a bug?
have you tried removing the interface and reconfiguring it. maybe something got changed in the upgrade, have read similar issues with other things eg: something got disabled etc etc
 
JanezFord
Member Candidate
Member Candidate
Posts: 264
Joined: Wed May 23, 2012 10:58 am

Re: 6.9 released!

Tue Feb 04, 2014 11:07 am

Model: RB450G
Upgrade from 6.7 to 6.9, IPsec (Site-to-Site) is broken.
Downgrade from 6.9 to 6.7, IPsec works as usual.
Check your configs ... I'm running ipsec site-to-site on multiple rb450g without issues ... also interconnecting with with ipsec to rb951g, rb751g, rb800 and rb2011 units ... no issues at all (for now, running 3 days), lots of traffic, encryption aes-128+sha1 on all. All units have been upgraded from 6.7 to 6.9.

JF
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: 6.9 released!

Tue Feb 04, 2014 11:18 am

>OpenVPN server doesn't work! Clients log off immediately after connection establishing. Downgrade to 6.7.

Can confirm. Same goes for PPTP.
I can also confirm issue with VPNs:
- SSTP from MK 6.9 -> MK 6.7 (server) is working
- SSTP in other cases = not working
- OVPN = not working

Downgrade back to 6.7, everything is working.

I haven't time to do more deeper tests, but it seems that not only one network topology is having problem.
 
willie2276
just joined
Posts: 7
Joined: Tue Dec 27, 2011 7:19 pm

Re: 6.9 released!

Tue Feb 04, 2014 11:23 am

HELP HELP HELP
After upgradind a RB1100AHx2 to 6.9!!!!!!!!!!!!!!!
L2TP server doesn't work! Clients log off immediately after connection establishing.

---------------------
In my case donwgrade is not enough!!!!

After downgrade to 6.7 the result is the same.
To resolve MUST have a configuration backup of your previous 6.7 configuration and restore it.
:D
 
ilnicchio
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun May 28, 2006 6:11 pm

Re: 6.9 released!

Tue Feb 04, 2014 11:28 am

pptp appears broke, trying to manage winbox while in the tunnel, different sections are blank, then winbox shows disconnected

sstp also does not appear to be working at this point either. it does not, get an error at verifying username and password, then windows times out with error 628......


i downgraded back to 6.7, pptp and sstp back to working flawless and significantly faster


guess i can live for a while without the leds working right.


guys fix ppp, you seem to have broken alot

this is on a 2011
For me the same problem. In ROS 6.7 I can reach my router through a pptp tunnel, in ROS 6.9 not (it freeze after some Kb of plugin transfer) maybe there's some problem with "change MSS"?
I can normally reach winbox with full MTU interface (like ether1). I try out with 3 RB with the same results...
Please fix.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1723
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: 6.9 released!

Tue Feb 04, 2014 12:20 pm

I just notice that MRRU option in previous versions on some routers was set to 512, but now in v6.9 it is 1600.

I suggest to unset this option, it might cause the problem between versions - this option is only necessary when ppp BCP or MLPPP is used.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Tue Feb 04, 2014 1:01 pm

I see a lot of posts concerning various VPN problems. I am not seeing this on my CCR 10-16 Judging by the symptoms reported I suspect its just a config issue. pay particular attention to MTU values, do a packet fragmentation test to discover the true MTU of the tunnel and adjust as required. I found that Some of my VPN's required a small drop of MTU to 1400. especially pptp tunnels.
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Tue Feb 04, 2014 1:08 pm

[/quote]
For me the same problem. In ROS 6.7 I can reach my router through a pptp tunnel, in ROS 6.9 not (it freeze after some Kb of plugin transfer) maybe there's some problem with "change MSS"?
I can normally reach winbox with full MTU interface (like ether1). I try out with 3 RB with the same results...
Please fix.[/quote]

When you create a PPTP interface a mangle rule is automatically created to reduce the MTU of that interface to take into account of the axtra overhead. Using winbox open the interface and on the general tab is a MAX MTU and MAX MRU. I think the default is 1420. try dropping this to 1400
 
roast
just joined
Posts: 4
Joined: Tue Feb 04, 2014 3:13 pm

Re: 6.9 released!

Tue Feb 04, 2014 3:16 pm

Somehow OpenVPN has become unstable with 6.9. It was super stable in 6.7 now I get disconnects every few hours...
V6.6 to V6.9 -> OpenVPN stopped working for me. Switched to SSTP..........
Last edited by roast on Tue Feb 04, 2014 4:52 pm, edited 1 time in total.
 
roast
just joined
Posts: 4
Joined: Tue Feb 04, 2014 3:13 pm

Re: 6.9 released!

Tue Feb 04, 2014 3:20 pm

For me. with this FW on a RB-450 routing marks stopped working.
- mark route in mangle/prerouting
- set another default route for that routing mark (this one shows blue in the list, meaning it has no effect)
- marked packets still go out on the default gw.

The same config worked flawless in 6.7

Can I have a download link for 6.7 so I can downgrade?
I have the same problem!

I mark route in mangle for prerouting, goes out the default gateway...
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: 6.9 released!

Tue Feb 04, 2014 4:11 pm

>OpenVPN server doesn't work! Clients log off immediately after connection establishing. Downgrade to 6.7.

Can confirm. Same goes for PPTP.
I can also confirm issue with VPNs:
- SSTP from MK 6.9 -> MK 6.7 (server) is working
- SSTP in other cases = not working
- OVPN = not working

Downgrade back to 6.7, everything is working.

I haven't time to do more deeper tests, but it seems that not only one network topology is having problem.
well i have the identical setup and the identical issue. thus this is bugged big time
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: 6.9 released!

Tue Feb 04, 2014 4:12 pm

For me the same problem. In ROS 6.7 I can reach my router through a pptp tunnel, in ROS 6.9 not (it freeze after some Kb of plugin transfer) maybe there's some problem with "change MSS"?
I can normally reach winbox with full MTU interface (like ether1). I try out with 3 RB with the same results...
Please fix.[/quote]

When you create a PPTP interface a mangle rule is automatically created to reduce the MTU of that interface to take into account of the axtra overhead. Using winbox open the interface and on the general tab is a MAX MTU and MAX MRU. I think the default is 1420. try dropping this to 1400[/quote]


pptp works 1 in 3 times. why should i need to adjust an mtu, when it didn't change from 6.7

everyone is having the same issue. MTU is not the problem here

sstp is broke period for windows. this is more then a coincidence
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 959
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: 6.9 released!

Tue Feb 04, 2014 4:20 pm

For those of you having issues with 6.9: after updating and also updating the firmware to 3.10, then you'll need to do a system reset-configuration and then manually apply your custom settings.
 
User avatar
Neohunter
just joined
Posts: 22
Joined: Fri Jun 10, 2011 8:54 am

Re: 6.9 released!

Tue Feb 04, 2014 5:24 pm

I update RB750G from 6.7 to 6.9 via system/package/check for updates - download & install
router reboot but not start - also all Ethernet interface led not flashed

i try repair it via netinstall - connect 1 eth on 750G to pc eth card
push rest and start router - wait so long but act not flashed !
and i can't see router in netinstall

How i can reanimate router ?
Hello,
1. try to press reset button for 3 secs and search 750G in winbox. if it wont help you then
2. press reset button for 30s and release. Device should appear in netinstall list.

ps. netinstall works only on poe-in interface (ether1?))
pps. are you sure, that netinstall prepared correctly? ie disabled firewall, set ip address

Good luck
I do it all, but router looks like brick ;(
I don't know what make update if after that router not booting and all LED not lights
Only PWR LED lightnings
 
patrickmkt
Member Candidate
Member Candidate
Posts: 157
Joined: Sat Jul 28, 2012 5:21 pm

Re: 6.9 released!

Tue Feb 04, 2014 5:45 pm

For those of you having issues with 6.9: after updating and also updating the firmware to 3.10, then you'll need to do a system reset-configuration and then manually apply your custom settings.
You mean that for every upgrade we have to completely reset the router, reprogram manually all the config (because reimporting the config will create the same issue, and a script will not work as for every version update Mikrotik made undocumented change on small syntax that creates error in scripts). That's a few hours job for each router + a few weeks of survey to debug any potential error.

It's like saying every time you have a windows update you need to reformat your hard drive and reinstall all softwares. How stupid does it sound?
 
mediana
just joined
Posts: 10
Joined: Tue Feb 04, 2014 9:03 am

Re: 6.9 released!

Tue Feb 04, 2014 6:14 pm

Model: RB450G
Upgrade from 6.7 to 6.9, IPsec (Site-to-Site) is broken.
Downgrade from 6.9 to 6.7, IPsec works as usual.
I also had this problem. When I investigated I found that the IPSEC policies had been disabled by the upgrade (they were red) I simply enabled them and IPSEC works fine on 6.9
You are right! I didn't notice that and now it works. Thanks a lot!
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 959
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: 6.9 released!

Tue Feb 04, 2014 7:22 pm

You mean that for every upgrade we have to completely reset the router, reprogram manually all the config (because reimporting the config will create the same issue, and a script will not work as for every version update Mikrotik made undocumented change on small syntax that creates error in scripts). That's a few hours job for each router + a few weeks of survey to debug any potential error.

It's like saying every time you have a windows update you need to reformat your hard drive and reinstall all softwares. How stupid does it sound?
I don't disagree with you - just offering a solution. Note that you can do an export file=MyFile and mostly copy and paste that back into a terminal window.
 
pjhb34fg
just joined
Posts: 5
Joined: Tue Feb 04, 2014 8:22 pm

Re: 6.9 released!

Tue Feb 04, 2014 8:36 pm

Dunno if right topic.

Got 951G-2HnD, bought it with l4 license and 5.25 OS version.
After upgrading to 6.7 and firmware to 3.10 got frequent internet disconnects (wan port traffic dies in statistics) during high bandwith utilization, (only reboot or 15 min of waiting helps, strange though) I've reseted config and made new manually, i ve got simple ap mode with nat and wifi.
Wan port is pure ethernet with dhcp, nothing in logs.
Upgraining to 6.9 didnt resolve my issue, reseting config and again making it manually again didnt help, l dont see anything strange in logs, traffic just stops on wan port.
Got no POE enabled, Had to downgrade to 5.26.
Anyone saw similar problems?
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: 6.9 released!

Tue Feb 04, 2014 8:40 pm

\0 ...
my rb 435G just went down with kernel failure.....
had to take power down/on and after a few tries it came up again...
ros 6.9 of 30/01/14 11:18:19 release....

anyone else had this?!
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1825
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: 6.9 released!

Tue Feb 04, 2014 9:59 pm

Model: RB450G
Upgrade from 6.7 to 6.9, IPsec (Site-to-Site) is broken.
Downgrade from 6.9 to 6.7, IPsec works as usual.
I also had this problem. When I investigated I found that the IPSEC policies had been disabled by the upgrade (they were red) I simply enabled them and IPSEC works fine on 6.9
You are right! I didn't notice that and now it works. Thanks a lot!
Mikrotik you might want to fix this for 6.10
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: 6.9 released!

Wed Feb 05, 2014 2:37 am

Hello!

I am upgrading customer devices from 6.1 to 6.9 and the provisioning script stopped working;

I want to configure an account if it doesn't already exist:

{
:local uname
:set uname [/user get [find name=someaccount] name]
:if ($uname = "someaccount") do={
/log info message="Updating account"
/user set someaccount group="full" password=$adminSecret comment="Helpdesk default access"
} else={
/log info message="Adding account"
/user add name=someaccount group="full" password=$adminSecret comment="Helpdesk default access"
}
}

When the account does not already exists, in v6.1 it was working properly. With 6.7 and 6.9 the script fails with a "no such item" error.

Is it a new behaviour or is it a bug?
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: 6.9 released!

Wed Feb 05, 2014 8:53 am

You mean that for every upgrade we have to completely reset the router, reprogram manually all the config (because reimporting the config will create the same issue, and a script will not work as for every version update Mikrotik made undocumented change on small syntax that creates error in scripts). That's a few hours job for each router + a few weeks of survey to debug any potential error.

It's like saying every time you have a windows update you need to reformat your hard drive and reinstall all softwares. How stupid does it sound?
I don't disagree with you - just offering a solution. Note that you can do an export file=MyFile and mostly copy and paste that back into a terminal window.
This was only necessary for CRS125 to prevent speed issues and behaviour of a hub.
Alternatively you can enter this command:
/interface ethernet switch port set [find] learn-restricted-unknown-sa=yes
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.9 released!

Wed Feb 05, 2014 10:58 am

For those of you having issues with 6.9: after updating and also updating the firmware to 3.10, then you'll need to do a system reset-configuration and then manually apply your custom settings.
You mean that for every upgrade we have to completely reset the router, reprogram manually all the config (because reimporting the config will create the same issue, and a script will not work as for every version update Mikrotik made undocumented change on small syntax that creates error in scripts). That's a few hours job for each router + a few weeks of survey to debug any potential error.

It's like saying every time you have a windows update you need to reformat your hard drive and reinstall all softwares. How stupid does it sound?
Like Becs says, this is not true and is not needed at all.
No answer to your question? How to write posts
 
Polky
newbie
Posts: 35
Joined: Fri Sep 17, 2010 11:19 am

Re: 6.9 released!

Wed Feb 05, 2014 11:46 am

Hi, after upgrade to 6.9 from 6.8rc1, ceased to function gateway with routing mark.
Unable to select routing mark! - Is empty.
Donwgrade back 6.8rc1 works.

THX
 
p2systems
just joined
Posts: 8
Joined: Sun Aug 28, 2011 10:27 pm

DHCP 100% on one core

Wed Feb 05, 2014 1:06 pm

x86 Server
Upgrade 6.1 to 6.9

After the upgrade, DHCP Server is using 100% CPU on one core.
If you disable IPv6 DHCP PD in PPPoE Profiles an reboot, everything is fine. But then there is no IPv6 anymore for the customers.

Ticket#2014020466000563

Update: Support is Aware of this bug. A fix will be included in 6.10
Last edited by p2systems on Wed Feb 05, 2014 3:48 pm, edited 1 time in total.
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: 6.9 released!

Wed Feb 05, 2014 1:16 pm

Dunno if right topic.

Got 951G-2HnD, bought it with l4 license and 5.25 OS version.
After upgrading to 6.7 and firmware to 3.10 got frequent internet disconnects (wan port traffic dies in statistics) during high bandwith utilization, (only reboot or 15 min of waiting helps, strange though) I've reseted config and made new manually, i ve got simple ap mode with nat and wifi.
Wan port is pure ethernet with dhcp, nothing in logs.
Upgraining to 6.9 didnt resolve my issue, reseting config and again making it manually again didnt help, l dont see anything strange in logs, traffic just stops on wan port.
Got no POE enabled, Had to downgrade to 5.26.
Anyone saw similar problems?
pjhb34fg, if your RB951G-2HnD works with RouterOS v5.26 but does not work properly with RouterOS version 6.x, please report this to MikroTik Technical Support and send supout.rif file from RouterOS v6.9.
 
User avatar
bjorncmtec
Frequent Visitor
Frequent Visitor
Posts: 98
Joined: Thu Apr 19, 2012 1:10 pm

Re: 6.9 released!

Wed Feb 05, 2014 2:37 pm

>OpenVPN server doesn't work! Clients log off immediately after connection establishing. Downgrade to 6.7.

Can confirm. Same goes for PPTP.
I can also confirm issue with VPNs:
- SSTP from MK 6.9 -> MK 6.7 (server) is working
- SSTP in other cases = not working
- OVPN = not working

Downgrade back to 6.7, everything is working.

I haven't time to do more deeper tests, but it seems that not only one network topology is having problem.
Try disabling all auth and cypher options in OVPN Setup window.

Image

Worked for me. REALLY stupid and is making me lose confidence in Mikrotik with each 6.x release
Certified

* MTCNA
* MTCRE
* MTCTCE
* MTCINE


South Africa
 
doush
Long time Member
Long time Member
Posts: 625
Joined: Thu Jun 04, 2009 3:11 pm

Re: 6.9 released!

Wed Feb 05, 2014 2:55 pm

PPPoE Auth failures shows in the logs as follows
14:52:27 pppoe,ppp,info,account [username] logged out, 1 0 0 0 0 
Sorry but what a mess this version is !
 
User avatar
bysard
Member Candidate
Member Candidate
Posts: 295
Joined: Thu Apr 22, 2010 2:53 pm

Re: 6.9 released!

Wed Feb 05, 2014 3:02 pm

PPPoE Auth failures shows in the logs as follows
14:52:27 pppoe,ppp,info,account [username] logged out, 1 0 0 0 0 
Sorry but what a mess this version is !
Big mess. I'll stay at 5.26 with all our routers except RB2xxx, which I rather put in the closed and out of production as they are not stable at all. v6.x so far is the biggest dissapointment after bloated capacitors ob RB4xxx series. I'm sure we will be disappointed even more in the future as it seems that the quality of the software is now also degrading, not only hardware.
 
mietus
Member Candidate
Member Candidate
Posts: 122
Joined: Mon Jan 30, 2006 11:14 pm
Location: Poland

Re: 6.9 released!

Wed Feb 05, 2014 4:26 pm

PPPoE Auth failures shows in the logs as follows
14:52:27 pppoe,ppp,info,account [username] logged out, 1 0 0 0 0 
Sorry but what a mess this version is !
i confirm http://forum.mikrotik.com/viewtopic.php?f=2&t=81398
it will be fixed in 6.10 (maybe).

I think that such major changes should be relased as test package for some time.
 
User avatar
koshak83
just joined
Posts: 19
Joined: Wed Feb 05, 2014 4:33 pm
Location: Russian Federation, NWFD, Saint-Petersburg Federal City

Re: 6.9 released!

Wed Feb 05, 2014 4:50 pm

Hmm: I'm install RouterOS v6.9 (hardreset-> netinstall) to my RB951G-2HnD, but dont have bootloader v3.12 firmware update...
Image
 
bryans2k
just joined
Posts: 21
Joined: Fri Apr 26, 2013 6:10 am

Re: 6.9 released!

Wed Feb 05, 2014 7:31 pm

nvm, switch related.
Last edited by bryans2k on Wed Feb 05, 2014 8:43 pm, edited 1 time in total.
 
hugleo
newbie
Posts: 32
Joined: Wed Aug 06, 2008 8:20 am

Re: 6.9 released!

Wed Feb 05, 2014 8:13 pm

Openvpn is not working in this version...
 
3bs
newbie
Posts: 48
Joined: Tue Aug 09, 2011 12:33 am
Location: Irkutsk, Russia

Re: 6.9 released!

Thu Feb 06, 2014 1:21 am

Big mess. I'll stay at 5.26 with all our routers except RB2xxx, which I rather put in the closed and out of production as they are not stable at all. v6.x so far is the biggest dissapointment after bloated capacitors ob RB4xxx series. I'm sure we will be disappointed even more in the future as it seems that the quality of the software is now also degrading, not only hardware.
+1 :(
WBR, 3bs =)
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: 6.9 released!

Thu Feb 06, 2014 1:25 am

Hello!
I did upgrade to 6.9.
Is the upgrade to 3.12 will kill my omni? Yes/no ?
FW.png
You do not have the required permissions to view the files attached to this post.
 
ndbjorne
just joined
Posts: 22
Joined: Sat Dec 15, 2012 5:06 pm
Location: Italy

Re: 6.9 released!

Thu Feb 06, 2014 1:38 am

I tried a few downgrades and then tried to upgrade at least to 6.7 but CPU usage issue remains.
Now unistalled all unused packages on RB711UA-2HnD and it works properly running 5.14:
> system package print
Flags: X - disabled
 #   NAME                    VERSION                    SCHEDULED
 0   system                  5.14
 1   routeros-mipsbe         5.14
 2   dhcp                    5.14
 3   wireless                5.14
 4   ppp                     5.14
 5   routerboard             5.14
 6   routing                 5.14
 7   advanced-tools          5.14
 8   security                5.14
> while ( true ) do={ system resource cpu print ;delay  10}
 # CPU                           LOAD         IRQ        DISK
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
 0 cpu0                            1%          0%          0%
interrupted
>  system resource print    
                   uptime: 1d14h58m48s
[...]
I'll give 6.9 another chance in a few days.

All other systems I upgraded to 6.9 (1*1200, 6*2011L, 1*2011UAS-2HnD, 3*951-2n, 1*x86 over VMWare) seem to work fine, all have simple configurations.

Bye
Andrea
 
ndbjorne
just joined
Posts: 22
Joined: Sat Dec 15, 2012 5:06 pm
Location: Italy

Re: 6.9 released!

Thu Feb 06, 2014 1:51 am

Hello!
I did upgrade to 6.9.
Is the upgrade to 3.12 will kill my omni? Yes/no ?
All my RB upgraded to 6.9 that work fine show a 3.10 firmware:
> system routerboard print 
       routerboard: yes
             model: 1200
     serial-number: [...]
  current-firmware: 3.10
  upgrade-firmware: 3.10
The only one that showed a 3.12 is the 711 with the CPU usage issue which I had to downgrade to 5.14 to solve:
>  system routerboard print 
       routerboard: yes
             model: 711UA-2HnD
     serial-number: [...]
  current-firmware: 3.10
  upgrade-firmware: 2.38
I'd wait a while.

Bye
Andrea
 
zyzelis
Member Candidate
Member Candidate
Posts: 213
Joined: Sun Apr 08, 2012 9:25 pm

Re: 6.9 released!

Thu Feb 06, 2014 9:11 am

Hello!
I did upgrade to 6.9.
Is the upgrade to 3.12 will kill my omni? Yes/no ?
FW.png
noyo,
after upgrade both ros and bootloader, my Omnitiks still works:)
and im observing better nv2 behavior and less cpu usage, when opened winbox.

So it will not kill your omni ;)
 
JanezFord
Member Candidate
Member Candidate
Posts: 264
Joined: Wed May 23, 2012 10:58 am

Re: 6.9 released!

Thu Feb 06, 2014 9:56 am

Hello!
I did upgrade to 6.9.
Is the upgrade to 3.12 will kill my omni? Yes/no ?
All my RB upgraded to 6.9 that work fine show a 3.10 firmware:
> system routerboard print 
       routerboard: yes
             model: 1200
     serial-number: [...]
  current-firmware: 3.10
  upgrade-firmware: 3.10
The only one that showed a 3.12 is the 711 with the CPU usage issue which I had to downgrade to 5.14 to solve:
>  system routerboard print 
       routerboard: yes
             model: 711UA-2HnD
     serial-number: [...]
  current-firmware: 3.10
  upgrade-firmware: 2.38
I'd wait a while.

Bye
I'm running six 711-UA-2HnD with 6.9 and firmware 3.12 ... they serve as public/private access points with multiple ssids bridged to proper vlans ... about 20 clients each, runing 5 days now, no CPU issues, cpu load is maybe a notch lower than it was with 6.7 and firmware 3.10.

JF
 
User avatar
Raf
Member Candidate
Member Candidate
Posts: 171
Joined: Thu May 07, 2009 4:26 pm
Location: Olesnica, Poland
Contact:

Re: 6.9 released!

Thu Feb 06, 2014 10:32 am

Hello!
I did upgrade to 6.9.
Is the upgrade to 3.12 will kill my omni? Yes/no ?
FW.png
No. Firmware should ALWAYS be updated. Check RouterBOOT changelog if You want.
Rafał Wójcik from AWB-NET
High Definition enthusiast
 
User avatar
Masyanich
newbie
Posts: 47
Joined: Mon Jan 21, 2013 8:19 am
Location: Russian province
Contact:

Re: 6.9 released!

Thu Feb 06, 2014 10:33 am

Am I the only one who see some port flapping on CCR once again?
Image
Image
 
User avatar
noyo
Member Candidate
Member Candidate
Posts: 114
Joined: Sat Jan 28, 2012 12:25 am
Location: Mazury - Poland
Contact:

Re: 6.9 released!

Thu Feb 06, 2014 11:32 am

Hello!
I did upgrade to 6.9.
Is the upgrade to 3.12 will kill my omni? Yes/no ?
FW.png
noyo,
after upgrade both ros and bootloader, my Omnitiks still works:)
and im observing better nv2 behavior and less cpu usage, when opened winbox.

So it will not kill your omni ;)
thanks, it works
nv2, nstream is much better, stable
 
killersoft
Member Candidate
Member Candidate
Posts: 135
Joined: Mon Apr 11, 2011 2:34 pm
Location: Victoria, Australia
Contact:

Re: 6.9 released!

Thu Feb 06, 2014 1:49 pm

v6.9 works on my Metal 2SHPn (8 Km link @ 802.11 mode ) no problem yet !!
MIT, BIT, ITIL, CERT IV Electronics.
 
User avatar
TealFrog
just joined
Posts: 23
Joined: Sun Oct 02, 2011 11:56 am

Re: 6.9 released!

Thu Feb 06, 2014 2:17 pm

The RB2011UAS-2HnD ran on 6.9 for a couple of days. Today, it lost its primary gateway connection and would not get a DHCP lease from ISP. Rebooted router and 100% CPU utilization issue occurred. I could not get the usage to drop and attempted several more reboots. I also attempted to get a support.rif file, but was unsuccessful. Downgraded from 6.9 -> 6.7 everything working again.
You do not have the required permissions to view the files attached to this post.
TealFrog
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8321
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: 6.9 released!

Thu Feb 06, 2014 2:51 pm

Please, fix vlans. I still use 6.3 becouse of it :(
VLANs are heaving a lots of problems in 6.9.
what VLAN problems are you talking about?
I am upgrading customer devices from 6.1 to 6.9 and the provisioning script stopped working;

I want to configure an account if it doesn't already exist:

{
:local uname
:set uname [/user get [find name=someaccount] name]
:if ($uname = "someaccount") do={
/log info message="Updating account"
/user set someaccount group="full" password=$adminSecret comment="Helpdesk default access"
} else={
/log info message="Adding account"
/user add name=someaccount group="full" password=$adminSecret comment="Helpdesk default access"
}
}

When the account does not already exists, in v6.1 it was working properly. With 6.7 and 6.9 the script fails with a "no such item" error.

Is it a new behaviour or is it a bug?
I think it's a new behaviour. Change
:set uname [/user get [find name=someaccount] name]
to something like
:foreach i in=[/user find name=someaccount] do={ :set $uname [/user get $i name]; }
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
chris6671980309
just joined
Posts: 21
Joined: Wed Feb 23, 2011 7:06 am
Location: Singapore

Re: 6.9 released!

Thu Feb 06, 2014 3:18 pm

In the 6.9 release, there is a "updated bootloader firmware". But I didn't see any new version then the current 3.10.
 
planetcaravan
Member Candidate
Member Candidate
Posts: 265
Joined: Tue Aug 25, 2009 5:33 pm

Re: 6.9 released!

Thu Feb 06, 2014 5:18 pm

I have RB2011 working on 6.0
The router is ~100km away from my office.
I really want to upgrade it but I don't have intensions to travel on site to do downgrade.
Is it safe to upgrade to 6.9 RB2011?
I'm using RB2011 as router for adsl, vpn, hotspot, sstp-client. Now is running 6.9 and all is working fine. I've updated from 6.7.
 
planetcaravan
Member Candidate
Member Candidate
Posts: 265
Joined: Tue Aug 25, 2009 5:33 pm

Re: 6.9 released!

Thu Feb 06, 2014 5:57 pm

Does someone noticed CCQ changes on RouterOS 6.9?
 
beamer
newbie
Posts: 35
Joined: Mon Aug 20, 2012 12:40 am

Re: 6.9 released!

Thu Feb 06, 2014 6:37 pm

pptp appears broke, trying to manage winbox while in the tunnel, different sections are blank, then winbox shows disconnected
Same problem here! The PPTP session itself stays on, as well as a RDP session. Winbox in the RDP session is also fine, but a Winbox session through the VPN tunnel (PPTP) is disconnected after a short time. :cry:

Changing the "Max MTU" and "Max MRU" from 1450 to 1400 on the PPTP server didn't help.

Sometimes there's no traffic at all passing the PPTP tunnel when connecting from Mac OS X. The PPTP session is there but zero traffic going through! This seems not to happen when connecting with Win7.
i downgraded back to 6.7, pptp and sstp back to working flawless and significantly faster
Is downgrading as easy as upgrading? Just copy the packages and reboot? Config stays?
guys fix ppp, you seem to have broken alot
+1 :(
 
tom211
just joined
Posts: 5
Joined: Sat Dec 07, 2013 12:07 am

Re: 6.9 released!

Thu Feb 06, 2014 8:01 pm

SSTP not working, slow VLANs, what's next...

I really doubt whether it was a good idea to replace all our switches and routers with MT... :cry:
 
ndbjorne
just joined
Posts: 22
Joined: Sat Dec 15, 2012 5:06 pm
Location: Italy

Re: 6.9 released!

Thu Feb 06, 2014 8:22 pm

I tried a few downgrades and then tried to upgrade at least to 6.7 but CPU usage issue remains.
Now unistalled all unused packages on RB711UA-2HnD and it works properly running 5.14
[...]
I'll give 6.9 another chance in a few days.
Had a few time: 5.14 -> 6.9 (same packages): no CPU issue
Added all packages loaded when running 6.7: no CPU issue

Only missing step is upgrade firmware to 3.12 but why if all of the other systems I upgraded to 6.9 with no issue show a 3.10 and only this one shows a 3.12?
Andrea
 
skibi82
newbie
Posts: 42
Joined: Fri Mar 22, 2013 7:09 pm

Re: 6.9 released!

Thu Feb 06, 2014 9:38 pm

I have to admit the pain in my heart that release 6.9 is the biggest disgrace.
Where to start:
1. As before predecessors wrote that the SSTP server is not running properly. I need only confirm the continuous reconect and of the initialization phase of the tunnel cpu going to head.
2 ipsec flusch sa make he router unstable (kill the router when the daily execution of the script, thanks god as a watchdog on the ip set it will then reboot, I wish that I had descended Sunday on the ends of the vpn set saved me the $ 100 on fuel)
3 For some reason no ip packing rb951g does not work after downgrade to 5.x works and answer from Mikrotik that did not observe the problem to be honest ...

My last words to Release 6.9. Was supposed to be good and work out how to always suck.
PS.
When is 6.10 with bug fixes?
Regards
Jaroslaw Skibiński
 
mspeed
just joined
Posts: 23
Joined: Fri Feb 15, 2013 9:22 pm

Re: 6.9 released!

Fri Feb 07, 2014 12:49 am

We are seeing crashes over multiple devices with CCR1036-12G-4S i'm afraid - appears to be related to VRRP.

Kernel error and reboot, then both routers attempt to act as master but are unable to pass traffic. Manually removing/readding vrrp or disabling VRRP allows traffic again, however we've then observed ongoing crashes due to kernel panic, or the watchdog timer which can no longer reach its watch address.

Have sent urgent sup outs to Mikrotik but am pretty disheartened. We upgraded on their recommendation to fix another crash in 6.8. The supouts can't even be read on mikrotik.com supout viewer.

Seems like Mikrotik may not be stable enough for our type of environment.. it's a real shame as we've now over 30 of the CCR's and really wanted to believe in the platform.

We're using CCR for a very simple deployment - BGP + VRRP + VLAN + Basic filtering + Netflow
 
sdv
just joined
Posts: 13
Joined: Tue Oct 01, 2013 9:30 am

Re: 6.9 released!

Fri Feb 07, 2014 9:22 am

Upgrade: 6.6 -> 6.9
RouterBOARD: RB 1100AHx2
Tested bugs:
а. [L2TP-Server]:
After upgrade router reboots while first l2tp-session established with watchdog exeption message on serial console.
L2tp-server (and router) crash caused by the use of MRRU (value doesn't matter) parameter in /interface l2tp-server server configuration, so multilink-PPP over single link seems to be broken.

Upgrade: 6.6 -> 6.9
RouterBOARD: RB750G
Tested bugs:
a. [L2TP-Client]:
After upgrade router not always mark as active default route learned via OSPF / Static via L2TP-tunnel.
This issue caused by the use of routing-marks (with out them all seems to be working), reboot fix this situation.
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: 6.9 released!

Fri Feb 07, 2014 9:46 am

>OpenVPN server doesn't work! Clients log off immediately after connection establishing. Downgrade to 6.7.

Can confirm. Same goes for PPTP.
I can also confirm issue with VPNs:
- SSTP from MK 6.9 -> MK 6.7 (server) is working
- SSTP in other cases = not working
- OVPN = not working

Downgrade back to 6.7, everything is working.

I haven't time to do more deeper tests, but it seems that not only one network topology is having problem.
Try disabling all auth and cypher options in OVPN Setup window.

Image

Worked for me. REALLY stupid and is making me lose confidence in Mikrotik with each 6.x release
Hello bjorncmtec,

thank you for hint, I will try it. As you have mentioned, it will be really mess-making in case that this configuration will work - no cypher option selected as allowed and it will start working :o
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: 6.9 released!

Fri Feb 07, 2014 10:09 am

6.9 still has bug same as the 6.7 version. Ip addresses are disappeared, dhcp stops working, pppoe is not working, more then a half of services is not usable and reboot is necessary. It happens on all RBs!!!! Now it's happened on CCR which is core router in my network. It's wrong when 10.000 users is left without service only because Mikrotik is not fixing reported bugs!

I can second this. Still hanging on v6.5 because of this. The way MT treats them bugreports is just ridiculous. When I email their support, replies I get makes me think that they truly believe I have to turn production router for quite a bunch of customers into ROS testbed. To be honest, it is kind of scary. One thing is if you upgrade some chain of wireless backbone or customer CPE and something goes wrong - no big damage and barely anyone cares. Now that they have introduced CCR, they also have introduced the amount of damage they can do with a single buggy version. I truly dont know how do MT tests those supout.rif files when sent over, what bugs me is this scenario:
we do a nightly upgrade CCR to newest version -> primary tests shows basic functions are OK -> morning comes, specific but critical bug hits in, customer line goes hot -> general emergency issues, we immediately downgrade -> now after the dust have settled, we make supout, detailed description of behavior and provide it to MT.
Then the fun part begins - when asked for bug to be fixed, fancy requests are being made on behalf of MT - like "ok, upgrade it again and when bug hits you, make supout and send it to us". Why ? Is this the way it is meant to be ? Is there really no way for MT to test that themselves in the lab (now that they know the problem), instead of us experimenting on our ranting customers ?
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Fri Feb 07, 2014 10:45 am

Upgrade party through the night, 433's sxt's 411's omnitiks RB1100ah CCR's all 100% no problems all upgrades smooth. well done mikrotik Nice release for me. No problems with Pptp Tunnels all working well
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: 6.9 released!

Fri Feb 07, 2014 10:48 am

Upgrade party through the night, 433's sxt's 411's omnitiks RB1100ah CCR's all 100% no problems all upgrades smooth. well done mikrotik Nice release for me. No problems with Pptp Tunnels all working well
Does your CCR have any DHCP server on any VLAN ?
 
Sander
newbie
Posts: 30
Joined: Sat Aug 18, 2012 5:50 am
Location: Shanghai

Re: 6.9 released!

Fri Feb 07, 2014 11:02 am

pptp appears broke, trying to manage winbox while in the tunnel, different sections are blank, then winbox shows disconnected
Same problem here! The PPTP session itself stays on, as well as a RDP session. Winbox in the RDP session is also fine, but a Winbox session through the VPN tunnel (PPTP) is disconnected after a short time. :cry:
Same problem. WinBox through the PPTP is disconnected within one minute after upgrade from 6.7 to 6.9 on RB2011L.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.9 released!

Fri Feb 07, 2014 12:33 pm

Upgrade from v5.26 to 6.9 - After upgrade are all packages enabled.

For example. I have in 5.26 disabled - routing, ppp, MPLS, hotspot.
After upgrade are this packages enabled. Problem is in all v6.x versions
You do not have the required permissions to view the files attached to this post.
LAN, FTTx, Wireless. ISP operator
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Fri Feb 07, 2014 1:14 pm

this is not a bug this is normal simply disable the required packages again
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Fri Feb 07, 2014 1:15 pm

Upgrade party through the night, 433's sxt's 411's omnitiks RB1100ah CCR's all 100% no problems all upgrades smooth. well done mikrotik Nice release for me. No problems with Pptp Tunnels all working well
Does your CCR have any DHCP server on any VLAN ?
No.
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.9 released!

Fri Feb 07, 2014 1:21 pm

pptp appears broke, trying to manage winbox while in the tunnel, different sections are blank, then winbox shows disconnected
Same problem here! The PPTP session itself stays on, as well as a RDP session. Winbox in the RDP session is also fine, but a Winbox session through the VPN tunnel (PPTP) is disconnected after a short time. :cry:
Same problem. WinBox through the PPTP is disconnected within one minute after upgrade from 6.7 to 6.9 on RB2011L.
I have a bunch of pptp tunnels on CCR no issues other than tweaking MTU values for max performance. Make sure keep alive packets are not being blocked by firewall rule. I had this issue after an upgrade.

Address lists may be an issue as V6.9 does not allow any duplicate entries where older versions did. I do not know what would happen if an upgrade is performed on a router with duplicate entries
 
beamer
newbie
Posts: 35
Joined: Mon Aug 20, 2012 12:40 am

Re: 6.9 released!

Fri Feb 07, 2014 2:45 pm

I opened a ticket and just got his reply but haven't tested it yet:

Should be fixed

links removed by admin
Last edited by normis on Fri Feb 07, 2014 3:35 pm, edited 1 time in total.
Reason: removed beta links
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.9 released!

Fri Feb 07, 2014 3:13 pm

this is not a bug this is normal simply disable the required packages again
This is not normal.
From 3.30 -> 4.17 packages stay disabled
from 4.17 -> 5.26 packages stay disabled
Only from 5.26 -> 6.x all packages are enabled.

It's additional work (wasted) when you migrate complete network to V6
LAN, FTTx, Wireless. ISP operator
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2298
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.9 released!

Fri Feb 07, 2014 3:32 pm

I opened a ticket and just got his reply but haven't tested it yet:
The following RouterOS development versions should be for internal testing only. Please do not distribute or publish for public in any way. You can test these versions in your own, or customer networks
LAN, FTTx, Wireless. ISP operator
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.9 released!

Fri Feb 07, 2014 3:35 pm

These beta (6.10) versions are internal FOR A REASON. They WILL contain problems, because we are not done with them. If you want to test, that's fine, but please don't confuse other forum users into thinking that this is a stable release.
No answer to your question? How to write posts
 
lavv17
Member Candidate
Member Candidate
Posts: 120
Joined: Sat Sep 01, 2007 9:01 am

Re: 6.9 released!

Fri Feb 07, 2014 6:29 pm

For some reason after upgrade from 6.7 to 6.9 bonding stopped working, interfaces don't join together.

Flags: X - disabled, R - running
0 R name="bonding1" mtu=1500 mac-address=D4:CA:6D:77:6D:34 arp=enabled
slaves=ether1,ether2 mode=802.3ad primary=none link-monitoring=mii
arp-interval=100ms arp-ip-targets="" mii-interval=100ms down-delay=0ms
up-delay=0ms lacp-rate=30secs transmit-hash-policy=layer-2-and-3

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Gi0/14(I) Gi0/15(I)
I - stand-alone

Any hints?
 
mspeed
just joined
Posts: 23
Joined: Fri Feb 15, 2013 9:22 pm

Re: 6.9 released!

Fri Feb 07, 2014 6:59 pm

Then the fun part begins - when asked for bug to be fixed, fancy requests are being made on behalf of MT - like "ok, upgrade it again and when bug hits you, make supout and send it to us". Why ? Is this the way it is meant to be ? Is there really no way for MT to test that themselves in the lab (now that they know the problem), instead of us experimenting on our ranting customers ?
Just manually generate the supout before you downgrade, takes a minute and you can retrieve it after you've restored service and send the report. Autosupout doesn't always work reliably either.

My problem is that I do this and send in the report, but it is often 3-4 days before any Mikrotik response. Sadly we're a few crashes away from moving off the MT platform alltogether.

It seems to have so much potential, but not the support to back up the product in any real customer facing/production environment that can't deal with extended downtime.
 
pmuch
just joined
Posts: 8
Joined: Fri Feb 07, 2014 6:53 pm

Re: 6.9 released!

Fri Feb 07, 2014 7:14 pm

We are seeing crashes over multiple devices with CCR1036-12G-4S i'm afraid - appears to be related to VRRP.

Kernel error and reboot, then both routers attempt to act as master but are unable to pass traffic. Manually removing/readding vrrp or disabling VRRP allows traffic again, however we've then observed ongoing crashes due to kernel panic, or the watchdog timer which can no longer reach its watch address.
The same issue on RB750GL with VRRP on 6.7.
For me the solution was to disable TCP Invalid packages filtering - with this release VRRP packages became invalid(?)
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 959
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: 6.9 released!

Fri Feb 07, 2014 7:40 pm

Sadly we're a few crashes away from moving off the MT platform alltogether ... It seems to have so much potential, but not the support to back up the product in any real customer facing/production environment that can't deal with extended downtime.
Agreed, fingers crossed MikroTik can pull out of this and create a proper internal dev/testing environment.
 
beamer
newbie
Posts: 35
Joined: Mon Aug 20, 2012 12:40 am

Re: 6.9 released!

Fri Feb 07, 2014 7:54 pm

These beta (6.10) versions are internal FOR A REASON. They WILL contain problems, because we are not done with them.
I really don't understand MikroTik's software development approach. Why does a new release (minor version) usually contains a lot of bugs that weren't present in the previous version? You should maybe limit the introduction of new features to major versions and focus on BUGS in minor versions. It seems, if you add a "feature" like "added lcd option to change the color-scheme" then essential features like VPNs or auto-negotiation are broken?

It's such a risk to update a core router, I'm really getting sick of it. The change log of 6.8/6.9 sounded like many bugs are solved (including some newly "introduced" in 6.6), but on the other side a lot of NEW BUGS are introduced again... and so on... and so on... never-ending story?

It would be much better if there's a version which is marked as STABLE/PRODUCTION, and other releases are labeled as BETA or something. In case of CCR there's not even a previous major version that could be considered stable... :-(

So if I update to the "internal" 6.10 now to make PPTP work again, to which version should I upgrade later without risking a desaster? The "final" 6.10? An even better 6.11? Or 7.0 sometime? Surely not. 7.x? When? Which version will be STABLE??
 
djdrastic
Member
Member
Posts: 305
Joined: Wed Aug 01, 2012 2:14 pm

Re: 6.9 released!

Fri Feb 07, 2014 11:29 pm

While I cannot condone the way Mikrotik goes along with their software release business do none of you test anything ? We always have some spare physical hardware and old laptop with virtualbox somewhere in the lab to test this configuration on the new version.

We always keep a good eye on the forums and probably wait roughly 2 months or so after release before we upgrade.
 
rodneygci
just joined
Posts: 2
Joined: Thu Feb 06, 2014 11:42 pm

6.9 seems to have broken my DHCP option

Fri Feb 07, 2014 11:45 pm

Hello,

We use Mikrotiks for edge devices for our IP phone deployments.

One of the requirements for these devices is that they provide a DHCP option (66) as ascii.

I upgraded a device from 6.7 to 6.9 and this option no longer works.

Here is the exact config:
/ip dhcp-server option
add code=66 name=AllworxVGW value="'192.168.2.254'"
Reverting back to 6.7 corrects the issue.

Thanks!
 
doush
Long time Member
Long time Member
Posts: 625
Joined: Thu Jun 04, 2009 3:11 pm

Re: 6.9 released!

Sat Feb 08, 2014 12:17 am

PPPoE Auth failures shows in the logs as follows
14:52:27 pppoe,ppp,info,account [username] logged out, 1 0 0 0 0 
Sorry but what a mess this version is !
I am quoting my self here but still I am having a very diffucult time to understand how come such a bug can be introduced !
Even if they did minimal testing, they could spot this stupid bug in a second.

My advice to Mikrotik:
Please, please, please STOP adding new features ! JUST STOP ! Concentrate on bug fixing + multicore enhancements and thats it ! Give us a rock solid version with no showstoppers like VPN problems, CPU problems, boot problems etc... Test it 1000 times before the release and publish.
Just one stable branch in v6.x and thats it ! We are not asking much.
 
beamer
newbie
Posts: 35
Joined: Mon Aug 20, 2012 12:40 am

Re: 6.9 released!

Sat Feb 08, 2014 2:26 am

Should be fixed
OK, I updated the CCR to "internal" 6.10 and it's NOT fixed. Winbox sessions through VPN (PPTP) are still disconnecting. Try to transfer a file with a couple 100 KB, very unlikely that it'll finish. :-x
I tested with MaxMTU/MaxMRU of PPTP server set to 1400 and 1450, same result.
 
User avatar
heislerb
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Mon Sep 16, 2013 4:41 pm

Re: 6.9 released!

Sat Feb 08, 2014 4:39 am

RB750GL upgraded ROS from 6.7 to 6.9 (firmware from 3.10 to 3.12). Script no longer works. Down grade to 6.7 and script works. I am not good at doing scripts. Can anyone quickly tell me what 6.9 found to be a problem. Note; value of > 330000 is only for testing,
PLEASE ANSWER in this thread http://forum.mikrotik.com/viewtopic.php?f=9&t=81722

:local traffic
:local nam
:local macblock
:local date
:local day
:local month
:local year
:local tim

:set date [system clock get date]
:set month [:pick $date 0 3]
:set day [:pick $date 4 6]
:set year [:pick $date 7 11]
:set tim [system clock get time]

/queue simple
:for i from=253 to=254 do={
:set traffic [get [find target="192.168.88.$i/32"] total-bytes]
:if ($traffic < 330000) do={
:set nam [get [find target="192.168.88.$i/32"] name ]

/ip dhcp-server lease
:set macblock [get [find address="192.168.88.$i/32" ] mac-address ]

/ip firewall filter add action=reject chain=forward out-interface=ether1-gateway protocol=tcp reject-with=tcp-reset src-mac-address=$macblock

/queue simple reset-counters $nam

/system scheduler add interval=1d name=$macblock on-event= test policy= ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date="$month/$day/$year" start-time=$tim

/queue simple
}
}
EDIT - support fixed the problem. I had no queue for target=192.168.88.253/32
- 6.9 has better error checking then 6.7
- this was a test script and that is the reason the queue was not present
Last edited by heislerb on Tue Feb 11, 2014 6:20 pm, edited 2 times in total.
 
Sander
newbie
Posts: 30
Joined: Sat Aug 18, 2012 5:50 am
Location: Shanghai

Re: 6.9 released!

Sat Feb 08, 2014 4:49 am

It's so weird. After I upgraded my RB2011L from 6.7 to 6.9. Routing Mark in "/ip route" doesn't work. It just like add a standby route in Main table. The color is blue in WinBox. I can't find any workaround for it, so I downgrade my RB2011L to 6.7. However, There is no problem on my RB951-2n after I upgraded RouterOS from 6.7 to 6.9. Routing Mark in "/ip route" works on RB951-2n.
 
Neilson
Member Candidate
Member Candidate
Posts: 174
Joined: Tue Nov 06, 2012 10:42 pm
Location: Auckland, New Zealand

Re: 6.9 released!

Sat Feb 08, 2014 5:07 am

@doush

For the below, I understand that this release the changes in PPP was to enable it for multicore properly (as in a clean rewrite of the deployment)

Therefore this is a multicore improvement as you ask for.

The output for an incorrect login is unusual however this is the first full production release of this so we can install it in our lab setups, find these differences, ask Mikrotik to change things if we want them to, then when we are ready we can deploy these things on our production systems.

Regards
Alexander

PPPoE Auth failures shows in the logs as follows
14:52:27 pppoe,ppp,info,account [username] logged out, 1 0 0 0 0 
Sorry but what a mess this version is !
I am quoting my self here but still I am having a very diffucult time to understand how come such a bug can be introduced !
Even if they did minimal testing, they could spot this stupid bug in a second.

My advice to Mikrotik:
Please, please, please STOP adding new features ! JUST STOP ! Concentrate on bug fixing + multicore enhancements and thats it ! Give us a rock solid version with no showstoppers like VPN problems, CPU problems, boot problems etc... Test it 1000 times before the release and publish.
Just one stable branch in v6.x and thats it ! We are not asking much.
 
ferywu
just joined
Posts: 22
Joined: Fri Feb 17, 2012 6:24 pm

Re: 6.9 released!

Sat Feb 08, 2014 12:10 pm

Just info, Using 6.9 on RB1000, running metarouter, every 5 minutes reboot itself.
With metarouter disabled, everything fine.

I have to downgrade now.
 
jackwing
just joined
Posts: 15
Joined: Tue Nov 19, 2013 12:43 pm

Re: 6.9 released!

Sat Feb 08, 2014 3:23 pm

dhcp does not work with trunk port on switch

if no vlan and trunk port , it can work

here is the Capture
You do not have the required permissions to view the files attached to this post.
 
User avatar
heislerb
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Mon Sep 16, 2013 4:41 pm

Re: 6.9 released!

Sun Feb 09, 2014 4:33 am

RB750GL upgraded from 6.7 to 6.9.

The following command works in 6.7 and not in 6.9.

6.7 on RB450G or RB750
[admin@RB450G-Main] /queue simple> get [find target="192.168.1.199"] total-bytes
[admin@RB450G-Main] /queue simple>

6.9
[admin@RB750GL-Bob] /queue simple> get [find target="192.168.88.254"] total-bytes
no such item

This is why my script is broken and at this moment in time I do not see a fix.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: 6.9 released!

Sun Feb 09, 2014 4:21 pm

Hello Folks!

A new bug was found in RoS6.9 and we had to emegreny rollback RoS6.7 all our email had stopped working for 24 hours due to it.

Mangle and Routing BUG!
We have complex mangle and routing rules for email that stopped to work fully after years flawless operation!

Mangle rules, chain: prerouting source address: scmgateway protocol: TCP source port: 25, action mark route mailnat
Mangle rules, chain: prerouting source address: scmgateway protocol: TCP destination port: 25, action mark route mailnat

Ip Route dest 0.0.0.0/0 gateway: asa5510 Routing mark: mailnat

The mikrotik router has two ISP:s as default gateway with classic mikrotik failover, but it is not default gateway for scmgateway, routing is tagged for that device out over the asa5510.

Network analysis show that traffic never leaves the mikrotik device, and telnetting to port 25 from the scmgateway hangs forever.

Rollbak to RoS6.7 solved the problem direcly.

The device is in full production for thousands of people so no supout and further analysis is possible, this is a severe incident, email incidents like this gives calls out 24 / 7 with responce time 1 hour! I will now have to sit writing a report to upper management on what have happened.
 
timberwolf
Member Candidate
Member Candidate
Posts: 274
Joined: Mon Apr 25, 2011 12:08 pm
Location: Germany

Re: 6.9 released!

Sun Feb 09, 2014 5:44 pm

The device is in full production for thousands of people so no supout and further analysis is possible, this is a severe incident, email incidents like this gives calls out 24 / 7 with responce time 1 hour! I will now have to sit writing a report to upper management on what have happened.
I really don't understand dangerfreaks like you, that put new releases directly into production without any testing. And upper management ist right in requesting a report on such unprofessional behaviour.
Also, route mangle bugs have already been reported in this thread, so by reading it you could have avoided this sitatuation even without testing. :D
 
User avatar
Bongo
newbie
Posts: 34
Joined: Thu Aug 11, 2011 4:28 am

Re: 6.9 released!

Sun Feb 09, 2014 9:44 pm

Hi
can you add in new release v7 support for pppoe dialout adsl/vdsl static ip connection L2tp


Server IP: 10.10.10.10/32

Username: Your DSL Username

Password: Your DSL Password

Authentication Type: PAP/CHAP/MSCHAP

Tunnel Authentication: Yes/No

Secret: 123456

Active as Default Route: Yes

IPSec: Yes/No
 
User avatar
bysard
Member Candidate
Member Candidate
Posts: 295
Joined: Thu Apr 22, 2010 2:53 pm

Re: 6.9 released!

Mon Feb 10, 2014 8:17 am

v6.9 and still in beta state. Good job Mikrotik, i'm really happy to announce we lost all confidence in you and your product. Downgraded all to 5.26. What a mess... AGAIN and AGAIN and AGAIN,...
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: 6.9 released!

Mon Feb 10, 2014 9:19 am

It is really a shame, but do not overestimate the big ones like Juniper and Cisco.
Most of the releases from Juniper from last year have one or more serious bugs (MX, T and SRX routers).
Cisco about the same..

BTW: I personally have no problems with 6.9
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: 6.9 released!

Mon Feb 10, 2014 9:34 am

I also don't have problem with 6.9.
Simple configuration routing mark work, OpenVPN server, PPTP server work, PPPOE server with radius work.
No problem for now, all network now running 6.9, x86, sxlite, groove, Rb433, Rb433AH, RB750, RB711.

In upgrade process lost one x86 after upgrade log is full some IPSEC error but on this machine is simple setup with static routing and OpenVPn server not use IPSEC, restart CPU go 100% and broke.
Reboot say same about unable to uncompress and don't boot, re install for iso image to 6.4 and reconfiguration upgrade to 6.9 and work again.

For now 6.9 is ok on my network.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5950
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.9 released!

Mon Feb 10, 2014 11:23 am

Hello Folks!

A new bug was found in RoS6.9 and we had to emegreny rollback RoS6.7 all our email had stopped working for 24 hours due to it.

Mangle and Routing BUG!
We have complex mangle and routing rules for email that stopped to work fully after years flawless operation!

Mangle rules, chain: prerouting source address: scmgateway protocol: TCP source port: 25, action mark route mailnat
Mangle rules, chain: prerouting source address: scmgateway protocol: TCP destination port: 25, action mark route mailnat

Ip Route dest 0.0.0.0/0 gateway: asa5510 Routing mark: mailnat

The mikrotik router has two ISP:s as default gateway with classic mikrotik failover, but it is not default gateway for scmgateway, routing is tagged for that device out over the asa5510.

Network analysis show that traffic never leaves the mikrotik device, and telnetting to port 25 from the scmgateway hangs forever.

Rollbak to RoS6.7 solved the problem direcly.

The device is in full production for thousands of people so no supout and further analysis is possible, this is a severe incident, email incidents like this gives calls out 24 / 7 with responce time 1 hour! I will now have to sit writing a report to upper management on what have happened.
Send a supout file to support.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: 6.9 released!

Mon Feb 10, 2014 1:18 pm

Hello Folks!

A new bug was found in RoS6.9 and we had to emegreny rollback RoS6.7 all our email had stopped working for 24 hours due to it.

Mangle and Routing BUG!
We have complex mangle and routing rules for email that stopped to work fully after years flawless operation!

Mangle rules, chain: prerouting source address: scmgateway protocol: TCP source port: 25, action mark route mailnat
Mangle rules, chain: prerouting source address: scmgateway protocol: TCP destination port: 25, action mark route mailnat

Ip Route dest 0.0.0.0/0 gateway: asa5510 Routing mark: mailnat

The mikrotik router has two ISP:s as default gateway with classic mikrotik failover, but it is not default gateway for scmgateway, routing is tagged for that device out over the asa5510.

Network analysis show that traffic never leaves the mikrotik device, and telnetting to port 25 from the scmgateway hangs forever.

Rollbak to RoS6.7 solved the problem direcly.

The device is in full production for thousands of people so no supout and further analysis is possible, this is a severe incident, email incidents like this gives calls out 24 / 7 with responce time 1 hour! I will now have to sit writing a report to upper management on what have happened.
Send a supout file to support.
That will be a problem, system is in production and I can not upgrade to RoS6.9 again simply for making a supout file, thay will break traffic again and cause call outs. What I will do is to clone the device to another exactly the same routerboard hardware and make a supout file from that.
But such action is more than a week away.

A further reading in this RoS6.9 thread show that many other have same problems, it is caused by tagging traffic and routing by the tag is not respected, traffic goes out the default gateway regardless the tag and routing.
 
jansat
just joined
Posts: 9
Joined: Tue Jul 09, 2013 1:33 pm
Location: Netherlands

Re: 6.9 released!

Mon Feb 10, 2014 2:21 pm

I have installed 9/2/2014 RouterOS v6.9 to my RB2011UiAS-2HnD, but dont have bootloader v3.12 firmware update,
today 10/2/2014 on a second RB2011UAS-2HnD and a rb1100ahx2 and also not the new bootloader/firmware
 
User avatar
Jetrider
newbie
Posts: 41
Joined: Tue May 12, 2009 11:31 am

Re: 6.9 released!

Mon Feb 10, 2014 3:14 pm

That will be a problem, system is in production and I can not upgrade to RoS6.9 again simply for making a supout file, thay will break traffic again and cause call outs. What I will do is to clone the device to another exactly the same routerboard hardware and make a supout file from that.
But such action is more than a week away.
Welcome to the club, man !
Now, I would gladly hear someone explain me, why exactly should Steen and Jetrider clone device (or disturb customers interwebz with yet another downtimes on current device) and fap around, if we can provide them those supouts and configs and MT can themselves replicate the situation with "another exactly the same routerboard hardware" ? Dont they have testlabs better suited for the job than our own workshops and datacenters ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.9 released!

Mon Feb 10, 2014 3:18 pm

In the 6.9 release, there is a "updated bootloader firmware". But I didn't see any new version then the current 3.10.
Only some RB models have new firmware, not all.
No answer to your question? How to write posts
 
ste
Forum Guru
Forum Guru
Posts: 1816
Joined: Sun Feb 13, 2005 11:21 pm

Re: 6.9 released!

Mon Feb 10, 2014 3:29 pm

That will be a problem, system is in production and I can not upgrade to RoS6.9 again simply for making a supout file, thay will break traffic again and cause call outs. What I will do is to clone the device to another exactly the same routerboard hardware and make a supout file from that.
But such action is more than a week away.
Welcome to the club, man !
Now, I would gladly hear someone explain me, why exactly should Steen and Jetrider clone device (or disturb customers interwebz with yet another downtimes on current device) and fap around, if we can provide them those supouts and configs and MT can themselves replicate the situation with "another exactly the same routerboard hardware" ? Dont they have testlabs better suited for the job than our own workshops and datacenters ?
Dependent on the complexity of the Installation it might be very difficult to reproduce the error condition.
The routing table is dynamic when using OSPF and depends on the whole network. So you might use the exact same
config, put it on "another exactly the same routerboard hardware" and dont see the problem.
 
beamer
newbie
Posts: 35
Joined: Mon Aug 20, 2012 12:40 am

Re: 6.9 released!

Mon Feb 10, 2014 6:12 pm

No problem for now, all network now running 6.9, x86, sxlite, groove, Rb433, Rb433AH, RB750, RB711.
I guess it's especially the PPP implementation on tile (CCR) platform that is seriously buggy since it was changed (rewritten?) to support multicore.

But watch out, some problems you'll not recognize immediately like the script malfunction "heislerb" reported. I wonder how they introduced these type of bugs...?! There's no reference in the changelog that simple queue or script functionality was even touched, yet it is broken.
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 132
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: 6.9 released!

Mon Feb 10, 2014 7:21 pm

I think there's some bug in the wireless subsystem, introduced in version 6.7.

I have two Omnitiks used to establish a link across a street. Nothing fancy, it works solid with NV2, CCR between 80-100% depending on when I open a window (both units are indoors, placed close to the windows).

Until I upgraded 6.6 to 6.7 everything was perfect. Days after upgrading to 6.7, I begun to see disconnections with a "control frame timeout" error. Restarting the unit acting as an access point cleared the error, only to be repeated again days later. Downgrading the access point from 6.7 to 6.6 corrected the issue. (I didn't downgrade the "client", it worked perfectly with 6.7 as long as the access point was 6.6.

Now I've upgraded to 6.9, and the issue seems to be present. Several days after upgrading to 6.9, I've seen a lot of packet loss (I monitor the link with Smokeping) and I have wireless disconnection and reconnection messages.

Again, rebooting the "access point" has made everything work fine.

Does it ring any bell? Seems to be some change from 6.6 to 6.[789].
 
User avatar
webpagetech
newbie
Posts: 42
Joined: Fri Mar 01, 2013 8:42 pm
Location: TX, United States
Contact:

Re: 6.9 released!

Mon Feb 10, 2014 7:33 pm

I can confirm the mangle/routing issue in test lab of 2011, 1100ah, ccr1016, and RB493.

Not going to deploy this version in our production environment as it would cause many issues with our routing and qos configs(6.9 seems to work fine on my soho config... its running fine on office routers that do not need vlans, vpn connections, and/or mangle routing techniques).

I also upgraded my crs to 6.9 and am still seeing issues with lost data. I have the standard port based vlan config running on it and even reconfigured exactly as wiki specifies seeing 6-10% packet loss consistently(can't wait for these to be stable enough for production environments. Performance is good especially at this price but not stable yet... speeds and latency are good but losing vlans randomly causing packet loss).

The main thing I need fixed it the mangle/routing marks issue.
MTCWE, MTCTCE. -- webpagetech.com
 
tom211
just joined
Posts: 5
Joined: Sat Dec 07, 2013 12:07 am

Re: 6.9 released!

Mon Feb 10, 2014 9:01 pm

OK, at least I could get some speed back in my VLANs...

I just wonder, why the way VLANs behave has been changed in a minor release. Up to 6.6, I had a masterport bridged to my VLAN, and all ports with this masterport had access to this VLAN at full-speed.

Now I have to set masterport to none and put every single port into this bridge. I think this change is a little bit strange...
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 6.9 released!

Tue Feb 11, 2014 10:31 am

I think there's some bug in the wireless subsystem, introduced in version 6.7.

I have two Omnitiks used to establish a link across a street. Nothing fancy, it works solid with NV2, CCR between 80-100% depending on when I open a window (both units are indoors, placed close to the windows).

Until I upgraded 6.6 to 6.7 everything was perfect. Days after upgrading to 6.7, I begun to see disconnections with a "control frame timeout" error. Restarting the unit acting as an access point cleared the error, only to be repeated again days later. Downgrading the access point from 6.7 to 6.6 corrected the issue. (I didn't downgrade the "client", it worked perfectly with 6.7 as long as the access point was 6.6.

Now I've upgraded to 6.9, and the issue seems to be present. Several days after upgrading to 6.9, I've seen a lot of packet loss (I monitor the link with Smokeping) and I have wireless disconnection and reconnection messages.

Again, rebooting the "access point" has made everything work fine.

Does it ring any bell? Seems to be some change from 6.6 to 6.[789].
Please make a support output file from both routers when the problem happens again and send them to support@mikrotik.com
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 132
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: 6.9 released!

Tue Feb 11, 2014 12:33 pm

Does it ring any bell? Seems to be some change from 6.6 to 6.[789].
Please make a support output file from both routers when the problem happens again and send them to support@mikrotik.com
I will. Any suggestions to get useful log information? I am collecting logs with Splunk but, so far, I can only log the usual connect/disconnect messages.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.9 released!

Tue Feb 11, 2014 12:35 pm

Does it ring any bell? Seems to be some change from 6.6 to 6.[789].
Please make a support output file from both routers when the problem happens again and send them to support@mikrotik.com
I will. Any suggestions to get useful log information? I am collecting logs with Splunk but, so far, I can only log the usual connect/disconnect messages.
Make sure to enable "wireless,debug" logs
No answer to your question? How to write posts
 
ste
Forum Guru
Forum Guru
Posts: 1816
Joined: Sun Feb 13, 2005 11:21 pm

Re: 6.9 released!

Tue Feb 11, 2014 3:08 pm

Done some testing with 6.9 to compare nv2 and nstreme. On my testlink 2km RBSXT-5HPnD to RB411AH/R52nM both nstreme and nv2 perform quite well on a 20MHz channel H+V. nstreme has lower latency with low
bandwidth usage.

Enabling HTAbove-Channel nstreme got lost control connection and disconnects/reconnects.
nv2 stays stable and get some additional bandwidth due to wider channel.

There is some (not heavy) interference.
 
FernandoSuperGG
newbie
Posts: 42
Joined: Fri Sep 06, 2013 6:51 pm

Re: 6.9 released!

Tue Feb 11, 2014 9:23 pm

There is something strange here. I can't assure if it's a RouterOS / v6.9 problem, but I have done this in 6.8 normally: Redundant Internet connection.

This happens in: RB2011UAS-RM , RB2011UiAS-RM and RB450G

I have two internet connections: One (local) through ADSL PPPoE, and a remote MikroTik also using ADSL PPPoE (192.168.0.2 - this is the secondary internet source).

When the local PPPoE is working, a default route (0.0.0.0/0 distance=1 reachable=pppoe-out1) becomes active.

If the local PPPoE goes down, my static route pointing to the other MikroTik (0.0.0.0/0 distance=2 reachable=192.168.0.2) becomes active.

Everything works very fine until here.

The problem is when my local PPPoE link comes back online. The route 1 activates normally, but there is no internet anymore. The PPPoE internet source does not work anymore. If I manually disable the PPPoE interface to force the 2nd route to become active, the Internet comes back, but pushing from my remote MikroTik.

I can ping 8.8.8.8, google,whatever inside MikroTik terminal.

To workaround this problem: I reboot the router with the 2nd route with PPPoE enabled *OR* disable the 2nd route with PPPoE enabled then just unplug/replug the Ethernet cable that goes to my switch.

What is driving me crazy is WHY just unplugging/replugging my computer bring internet back.
 
FernandoSuperGG
newbie
Posts: 42
Joined: Fri Sep 06, 2013 6:51 pm

Re: 6.9 released!

Tue Feb 11, 2014 10:50 pm

After several minutes of trial-and-error, I have detected some unknown modifications in Windows routes in these machines, maybe virus or something.

This has nothing to do with MikroTik.
 
nmaton
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Fri Feb 18, 2011 12:31 am

Re: 6.9 released!

Tue Feb 11, 2014 11:16 pm

Have updated rb1000, rb1100, rb1100ah2, rb450g, rb450,

so far so good.

This is ore first step towards ros6 in critical equipment, it feels like 6.9 is finally ready.
-----

I have tried to upgrade some elements of our network.
We have 1100ahx2 which are the core of our network and which run vrrp + BGP (full table).. this worked with 5.x but yesterday after the uprade to 6.9. The boxes became unresponsive.
CPU stayed at 100%, BGP restarted time after time..

Eventually i had to downgrade the boxes again to 5!! Now my network is stable again.

The same goes for 2 other boxes that terminate EoIP tunnels + PPTP tunnels. After the upgrade to 6.9 the tunnels became unusable so we needed to downgrade those aswell.


For me i'm staying away from the 6 train for some time!
Nicolas Maton
nicolasmaton@gmail.com

CCNA/ CCDA
MTCNA / MTCTCE

Available for Mikrotik Consulting
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8321
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: 6.9 released!

Wed Feb 12, 2014 12:04 am

I can confirm the mangle/routing issue in test lab of 2011, 1100ah, ccr1016, and RB493.
which issue? any link?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
enc
just joined
Posts: 16
Joined: Sun Feb 09, 2014 8:30 pm

Re: 6.9 released!

Wed Feb 12, 2014 3:34 pm

My issues with 6.9


1) had a no responsive router after about 2 days uptime. had to reboot to get it back running -> cannot use it in production

2) i tested 6.9 for severel days but couldnot get sstp with windows-8 Clients to work. no usefull logs. ony two lines like "LCP lower down" or so.
after downgrade to 6.7 it was running perfect.

6.7 seems stable and vpn with windows-Clients works

my router is: ccr-1016-12
fw 3.10
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8321
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: 6.9 released!

Wed Feb 12, 2014 3:45 pm

2) i tested 6.9 for severel days but couldnot get sstp with windows-8 Clients to work. no usefull logs. ony two lines like "LCP lower down" or so.
after downgrade to 6.7 it was running perfect.
probably it was fixed =) probably not
What's new in 6.10 (2014-Feb-12 13:46):

*) sstp - make it work with Windows client with AES encryption;
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: 6.9 released!

Wed Feb 12, 2014 4:15 pm

2) i tested 6.9 for severel days but couldnot get sstp with windows-8 Clients to work. no usefull logs. ony two lines like "LCP lower down" or so.
after downgrade to 6.7 it was running perfect.
probably it was fixed =) probably not
What's new in 6.10 (2014-Feb-12 13:46):

*) sstp - make it work with Windows client with AES encryption;

i think this was better

"*) ovpn - make it work again;"
 
nmaton
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Fri Feb 18, 2011 12:31 am

Re: 6.9 released!

Wed Feb 12, 2014 5:07 pm

does 6.10 fix the EoIP problems?
I've read on the forum that other people also had issues with EoIP and PPTP.
Nicolas Maton
nicolasmaton@gmail.com

CCNA/ CCDA
MTCNA / MTCTCE

Available for Mikrotik Consulting
 
karabov
just joined
Posts: 3
Joined: Wed Feb 12, 2014 6:58 pm

Re: 6.9 released!

Wed Feb 12, 2014 7:01 pm

hi!
upgrade to ROS 6.9 951Ui-2HnD (fw 3.10)
dont work usb 3g modem huawei e 1550
its worked on ROS 5.* fine
thnx
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24337
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.9 released!

Thu Feb 13, 2014 8:28 am

No problem for now, all network now running 6.9, x86, sxlite, groove, Rb433, Rb433AH, RB750, RB711.
I guess it's especially the PPP implementation on tile (CCR) platform that is seriously buggy since it was changed (rewritten?) to support multicore.

But watch out, some problems you'll not recognize immediately like the script malfunction "heislerb" reported. I wonder how they introduced these type of bugs...?! There's no reference in the changelog that simple queue or script functionality was even touched, yet it is broken.
Beamer, could you elaborate, which queue functionality is broken you mean?
No answer to your question? How to write posts
 
karabov
just joined
Posts: 3
Joined: Wed Feb 12, 2014 6:58 pm

Re: 6.9 released!

Thu Feb 13, 2014 12:04 pm

...and zte 190 dont work (((
 
Arnold2222
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Thu Jan 24, 2013 7:48 pm

Re: 6.9 released!

Thu Feb 13, 2014 11:33 pm

450G - after update to 6.9 routing mark is not working, mangle is counting packets but in routing table all wans with marked routing are blue and not active which make my LB not work
going back to 6.7
 
erkel
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Sun May 27, 2007 12:04 pm

Re: 6.9 released!

Fri Feb 14, 2014 5:04 am

I too have had issues after upgrading from 6.7 to 6.9, The PPTP server is not stable, some connections will stop passing traffic and need to disconnect and reconnect. The solution was to downgrade back to 6.7.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3427
Joined: Mon May 31, 2004 2:55 pm

Re: 6.9 released!

Fri Feb 14, 2014 11:53 am

...and zte 190 dont work (((
was it working in older RouterOS versions?
Do you see a usb port in the Port section or a lte interface under interface menu?
 
HarD
just joined
Posts: 1
Joined: Fri Feb 14, 2014 12:48 pm

Re: 6.9 released!

Fri Feb 14, 2014 12:54 pm

I have a RB750, after upgrading from 6.6 to 6.9 I can not see packets and bytes on the command /ppp active print stats
On 6.6 all be OK, all works fine.

Who is online

Users browsing this forum: No registered users and 118 guests