Community discussions

MikroTik App
 
obadaabdullah
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 71
Joined: Wed Jan 08, 2014 7:41 pm

question about hotspot

Sun Feb 16, 2014 10:31 am

how to authenticate my hotspot users by their mac address instead of username and password
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: question about hotspot

Sun Feb 16, 2014 2:38 pm

This works for me:
/ip hotspot profile
set X login-by=mac,http-chap
set X mac-auth-password="password"
set X radius-mac-format=XXXXXXXXXXXX
Then enter the mac address as the username in your database as XXXXXXXXXXXX and the password as "password", changing the XXXXXXXXXXXX to the mac address and password to the password. Don't use "password" for the password.

edit: I changed the radius-mac-format because my radius server software did not like the colons in the username. You can leave that alone if your radius server is ok with colons. Use the colons in the local database (/ip hotspot user) in the format XX:XX:XX:XX:XX:XX

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], MikeLS and 69 guests