Community discussions

MikroTik App
 
derr12
Member
Member
Topic Author
Posts: 411
Joined: Fri May 01, 2009 11:32 pm

hotspot login page works, mostly.

Thu Feb 20, 2014 12:56 am

Hey guys. Im using the hotspot to authenticate users for a hotel network. Generally it works fine, ive set my timeout values so that no matter what a user only has to log in once every 24 hours.

Ive had some odd behavior from a couple users that will simply not load the hotspot login page no matter what. When i torch the IP it shows https traffic being attempted, even tho they are simply going to google.

anyone ever come across this?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: hotspot login page works, mostly.

Thu Feb 20, 2014 1:09 am

Yes. The hotspot will not redirect port 443 requests. Google is normally a port 443 page, especially if you bookmark it or use it as a home page. Go to www.google.com and look at the address bar. Mine shows https://www.google.com/webhp?hl=en
 
nerdtron
Member Candidate
Member Candidate
Posts: 123
Joined: Sat Nov 30, 2013 7:49 am

Re: hotspot login page works, mostly.

Thu Feb 20, 2014 3:21 am

It is possible to redirect https traffic to the login page if you activate the https in the Login tab of the hotspot server profile. But you will need to have an ssl certificate installed on mikrotik.
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: hotspot login page works, mostly.

Thu Feb 20, 2014 4:46 am

The HTTP/ HTTPS problem is a trade off any way you look at it. The easiest resolution is to create instructions for the customer to go to some designated HTTP site. :D
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/

Who is online

Users browsing this forum: anav, ysha and 64 guests