Community discussions

 
hturkieh
just joined
Topic Author
Posts: 2
Joined: Sun Sep 02, 2012 11:14 pm

Whatsapp Blockage

Thu Feb 20, 2014 9:44 am

Hello,

I have tried all possible ways to block whatsapp on mikrotik, but with no luck,
If anyone has done this before please share,

Thank you,
 
PeterSullivan
newbie
Posts: 30
Joined: Wed Jul 31, 2013 3:03 pm
Contact:

Re: Whatsapp Blockage

Fri Feb 21, 2014 11:40 am

Well I have also tired that but no result found.
 
hturkieh
just joined
Topic Author
Posts: 2
Joined: Sun Sep 02, 2012 11:14 pm

Re: Whatsapp Blockage

Fri Feb 21, 2014 1:08 pm

Could it be ... Well ... I Will keep searching, and will hope that someone offers something useful ...
 
jaos
just joined
Posts: 1
Joined: Sat Jan 10, 2015 5:38 pm

Re: Whatsapp Blockage

Mon Mar 09, 2015 4:40 am

support help mikrotik for that matter... :( :?


sorry my bad english... :(
 
Znuff
Member Candidate
Member Candidate
Posts: 139
Joined: Tue Sep 26, 2006 2:42 am
Contact:

Re: Whatsapp Blockage

Mon Mar 09, 2015 10:34 am

You will need to block
c.whatsapp.net
This is currently resolving to these IPs:
# dig c.whatsapp.net

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6_6.1 <<>> c.whatsapp.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47757
;; flags: qr rd ra; QUERY: 1, ANSWER: 13, AUTHORITY: 4, ADDITIONAL: 0

;; QUESTION SECTION:
;c.whatsapp.net.                        IN      A

;; ANSWER SECTION:
c.whatsapp.net.         3118    IN      A       50.22.225.85
c.whatsapp.net.         3118    IN      A       173.192.222.182
c.whatsapp.net.         3118    IN      A       173.192.222.175
c.whatsapp.net.         3118    IN      A       50.22.225.80
c.whatsapp.net.         3118    IN      A       50.22.225.76
c.whatsapp.net.         3118    IN      A       184.173.161.168
c.whatsapp.net.         3118    IN      A       184.173.161.173
c.whatsapp.net.         3118    IN      A       50.22.225.73
c.whatsapp.net.         3118    IN      A       50.22.225.70
c.whatsapp.net.         3118    IN      A       208.43.122.151
c.whatsapp.net.         3118    IN      A       184.173.147.55
c.whatsapp.net.         3118    IN      A       208.43.122.144
c.whatsapp.net.         3118    IN      A       184.173.147.58
 
User avatar
Takv
just joined
Posts: 24
Joined: Sun Apr 19, 2015 5:37 pm

Re: Whatsapp Blockage

Sun Apr 19, 2015 5:39 pm

its in the same whatsapp page!

http://www.whatsapp.com/cidr.txt

31.13.69.240/32
31.13.70.49/32
31.13.71.49/32
31.13.73.49/32
31.13.74.49/32
31.13.76.81/32
31.13.77.49/32
50.22.75.192/27
50.22.93.192/27
50.22.198.204/30
50.22.210.32/30
50.22.210.128/27
50.22.225.64/27
50.22.235.248/30
50.22.240.160/27
50.23.90.128/27
50.97.57.128/27
75.126.39.32/27
108.168.174.0/27
108.168.176.192/26
108.168.177.0/27
108.168.180.96/27
108.168.254.65/32
108.168.255.224/32
108.168.255.227/32
158.85.0.96/27
158.85.5.192/27
158.85.46.128/27
158.85.48.224/27
158.85.58.0/25
158.85.61.192/27
158.85.224.160/27
158.85.233.32/27
158.85.249.128/27
158.85.249.224/27
158.85.254.64/27
169.53.29.128/27
169.53.250.128/26
169.54.2.160/27
169.54.210.0/27
169.54.222.128/27
173.192.162.32/27
173.192.219.128/27
173.192.222.160/27
173.192.231.32/27
173.193.205.0/27
173.193.230.96/27
173.193.230.128/27
173.193.230.192/27
173.193.239.0/27
174.36.208.128/27
174.36.210.32/27
174.36.251.192/27
174.37.199.192/27
174.37.217.64/27
174.37.231.64/27
174.37.243.64/27
174.37.251.0/27
184.173.73.176/28
184.173.136.64/27
184.173.147.32/27
184.173.161.64/32
184.173.161.160/27
184.173.173.116/32
184.173.179.32/27
184.173.195.32/27
184.173.201.32/27
184.173.204.32/27
192.155.212.192/27
198.11.193.182/31
198.11.212.0/27
198.11.217.192/27
198.11.251.32/27
198.23.80.0/27
198.23.86.224/27
198.23.87.64/27
208.43.115.192/27
208.43.117.79/32
208.43.117.136/32
208.43.122.128/27
2607:f0d0:1b01:d4::/64
2607:f0d0:3004:136::/64
2607:f0d0:3005:183::/64
2607:f0d0:3006:84::/64
2607:f0d0:3006:af::/64
 
User avatar
Takv
just joined
Posts: 24
Joined: Sun Apr 19, 2015 5:37 pm

Re: Whatsapp Blockage

Sun Apr 19, 2015 5:40 pm

Address List of CIDR its in the same whatsapp page!

http://www.whatsapp.com/cidr.txt

31.13.69.240/32
31.13.70.49/32
31.13.71.49/32
31.13.73.49/32
31.13.74.49/32
31.13.76.81/32
31.13.77.49/32
50.22.75.192/27
50.22.93.192/27
50.22.198.204/30
50.22.210.32/30
50.22.210.128/27
50.22.225.64/27
50.22.235.248/30
50.22.240.160/27
50.23.90.128/27
50.97.57.128/27
75.126.39.32/27
108.168.174.0/27
108.168.176.192/26
108.168.177.0/27
108.168.180.96/27
108.168.254.65/32
108.168.255.224/32
108.168.255.227/32
158.85.0.96/27
158.85.5.192/27
158.85.46.128/27
158.85.48.224/27
158.85.58.0/25
158.85.61.192/27
158.85.224.160/27
158.85.233.32/27
158.85.249.128/27
158.85.249.224/27
158.85.254.64/27
169.53.29.128/27
169.53.250.128/26
169.54.2.160/27
169.54.210.0/27
169.54.222.128/27
173.192.162.32/27
173.192.219.128/27
173.192.222.160/27
173.192.231.32/27
173.193.205.0/27
173.193.230.96/27
173.193.230.128/27
173.193.230.192/27
173.193.239.0/27
174.36.208.128/27
174.36.210.32/27
174.36.251.192/27
174.37.199.192/27
174.37.217.64/27
174.37.231.64/27
174.37.243.64/27
174.37.251.0/27
184.173.73.176/28
184.173.136.64/27
184.173.147.32/27
184.173.161.64/32
184.173.161.160/27
184.173.173.116/32
184.173.179.32/27
184.173.195.32/27
184.173.201.32/27
184.173.204.32/27
192.155.212.192/27
198.11.193.182/31
198.11.212.0/27
198.11.217.192/27
198.11.251.32/27
198.23.80.0/27
198.23.86.224/27
198.23.87.64/27
208.43.115.192/27
208.43.117.79/32
208.43.117.136/32
208.43.122.128/27
2607:f0d0:1b01:d4::/64
2607:f0d0:3004:136::/64
2607:f0d0:3005:183::/64
2607:f0d0:3006:84::/64
2607:f0d0:3006:af::/64
 
mianzohaib
just joined
Posts: 2
Joined: Wed Mar 04, 2015 2:14 pm
Location: Lahore
Contact:

Re: Whatsapp Blockage

Wed Jun 07, 2017 9:44 am

I want To block our network for some users how it possible
Mian Zohaib
 
User avatar
hgonzale
Member Candidate
Member Candidate
Posts: 267
Joined: Thu Nov 06, 2014 1:12 pm
Location: Fuengirola, Spain
Contact:

Re: Whatsapp Blockage

Wed Jun 07, 2017 10:01 pm

Whis this scripts that runs every X seconds

# Use DNS Entrys and add Address to the Firewall Address-list #
:foreach i in=[/ip dns cache all find where (name~"whatsapp") && (type="A") ] do={
:local tmpAddress [/ip dns cache get $i address];
delay delay-time=10ms
# prevent script from using all cpu time #
:if ( [/ip firewall address-list find where address=$tmpAddress] = "") do={
:local cacheName [/ip dns cache get $i name] ;
:log info ("added entry: $cacheName $tmpAddress");
/ip firewall address-list add address=$tmpAddress list=Whatsapp comment=$cacheName;
}
}


With this you will have a network list called whatsapp and after, you can mangle/filter/control everything with this list.

Here the script in my scheduler

add comment="Whatsapp Blocker" disabled=yes interval=2m name="Whatsapp Blocker" on-event="# Use DNS Entrys and add Address to the Firewall Address-list #\r\
\n:foreach i in=[/ip dns cache all find where (name~\"whatsapp\") && (type=\"A\") ] do={\r\
\n :local tmpAddress [/ip dns cache get \$i address];\r\
\ndelay delay-time=10ms\r\
\n# prevent script from using all cpu time #\r\
\n :if ( [/ip firewall address-list find where address=\$tmpAddress] = \"\") do={ \r\
\n :local cacheName [/ip dns cache get \$i name] ;\r\
\n :log info (\"added entry: \$cacheName \$tmpAddress\");\r\
\n /ip firewall address-list add address=\$tmpAddress list=Whatsapp comment=\$cacheName;\r\
\n}\r\
\n}" policy=ftp,read,write,policy,test,sniff,sensitive start-time=startup

Who is online

Users browsing this forum: No registered users and 59 guests