Community discussions

MikroTik App
 
Bitto
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Wed May 02, 2012 10:15 am

CRS Port mirroring help needed

Wed Mar 19, 2014 3:08 pm

Finally we have our new CRS125-24G-1S-RM in our hands, but switch menu changed there is a menu about mirroring makes none sense it seems cpu is mirroring all traffic to one port.
I couldn't find examples and manuals in wiki can any one send a configuration example of where ether2 is fully mirrored to ether3 (ingress and egress) ?
 
Bitto
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Wed May 02, 2012 10:15 am

Re: CRS Port mirroring help needed

Mon Apr 07, 2014 6:22 pm

Mikrotik Support Guys?

IS THIS PRODUCT LEFT ALONE ???
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1223
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: CRS Port mirroring help needed

Mon Apr 07, 2014 11:04 pm

This is how I understand the working of this switch (actually never tried this...):

There are 2 mirror targets, Mirror 0 and Mirror 1 (Mirror tab in switch window).
Both have a ingress and egress component and default to the cpu port as mirror port.

And each port (There is a ports list button on the right in the switch window) can be assigned a ingress and a egress mirror.

So, set your Mirror 0 to the mirror port you want (In the mirror tab, instead of cpu) and assign mirror 0 on ingress and egress for the port you like to mirror, this should do it.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
Bitto
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Wed May 02, 2012 10:15 am

Re: CRS Port mirroring help needed

Mon Apr 14, 2014 10:54 am

Yes, they updated commands on feature list but i already tried this and got no output from mirror port something is missing but what?
 
ksharabi
just joined
Posts: 6
Joined: Mon Jun 16, 2014 3:48 pm

Re: CRS Port mirroring help needed urgent!

Wed Jul 09, 2014 4:58 pm

Can you please write the port mirroring commands for CRS?

how do I assign a port to mirror0 and mirroring traffic to specific port
 
becs
MikroTik Support
MikroTik Support
Posts: 481
Joined: Thu Jul 07, 2011 8:26 am

Re: CRS Port mirroring help needed urgent!

Fri Jul 11, 2014 4:10 pm

This command sets mirroring destination port on CRS125:
/interface ethernet switch
set ingress-mirror0=ether8 egress-mirror0=ether8
This one sets mirroring source port:
/interface ethernet switch port
set ether7 ingress-mirror-to=mirror0 egress-mirror-to=mirror0
 
Bitto
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 83
Joined: Wed May 02, 2012 10:15 am

Re: CRS Port mirroring help needed

Wed Jul 22, 2015 4:59 pm

Thanks becs,

With the updated version mirror works perfectly.
 
No13TGP
just joined
Posts: 5
Joined: Tue Apr 08, 2014 10:10 am

Re: CRS Port mirroring help needed

Wed Aug 19, 2015 4:42 pm

Will the mirroring be done in the switch chip hardware? Or does the CPU do the mirroring?

When mirroring I seem to experience a high cpu load and my maximum download spead drops to ~65 mbit
/interface ethernet switch
set egress-mirror0=none,original egress-mirror1=none,original fdb-uses=\
    mirror1 ingress-mirror0=ether13 ingress-mirror1=none vlan-uses=\
    mirror1
    
/interface ethernet switch port
set 4 dscp-based-qos-dscp-to-dscp-mapping=no ingress-mirror-to=mirror0
Is my config wrong or is this to be expected? I'd like to run ntopng permanently on a mirror of my internet feed but only if the cpu load is reasonable.

Edit: My bad!! If you forget to set the master port of this monitor port the CPU will be impacted... If you however do set the master port, it will work without the high load!
 
TanmoyS
just joined
Posts: 1
Joined: Mon Aug 24, 2015 1:39 pm

Re: CRS Port mirroring help needed

Mon Aug 24, 2015 1:45 pm

Trying to do same source port 1 (Master Port) to destination port 16 (independent port).
Commands tried.

/interface ethernet switch
set ingress-mirror0=ether16 egress-mirror0=ether16
(worked)

/interface ethernet switch port
set ether1 egress-mirror-to=mirror0 ingress-mirror-to=mirror0
(Showing "no such Item")

Any insights..?? Thanks in Advance.
 
becs
MikroTik Support
MikroTik Support
Posts: 481
Joined: Thu Jul 07, 2011 8:26 am

Re: CRS Port mirroring help needed

Tue Aug 25, 2015 10:09 am

TanmoyS, you should recheck "ether1" interface name. Perhaps, it is not correct interface name you have on this switch.
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: CRS Port mirroring help needed

Tue Aug 25, 2015 12:28 pm

I have configured mirroring and it works, but only in one direction.
I need mirroing to cpu so I can mirror for 1-2minuter do a quick traffic analysys and remove the mirroring.
But all I can see is the traffic coming from the mirrored port, but not the traffic going to it. I have set both ingress and egress mirroring.
There is a checkmark for 'Mirror Tx on mirror port' but nothing happens if I check it. Also if I close my winbox session and reopen it - the checkmark is turned off.

Who is online

Users browsing this forum: Bing [Bot], brixsat, m86895 and 61 guests